Willkommen

Willkommen zu SpeedCommander

SpeedCommander hilft Ihnen bei der Verwaltung Ihrer Dateien in bewährter Zweifenstertechnik, die für jedermann einfach zu bedienen ist und dennoch auch dem erfahrenen Anwender mit ihrer Leistungsfähigkeit dient. SpeedCommander integriert Dateimanagement, Dateibetrachter, Datenkomprimierung, Verschlüsselung, das Starten von Anwendungen, Funktionen zur Festplattenverwaltung sowie den Zugriff auf Netzwerk, Internet und FTP unter einer einfachen und einheitlichen Benutzeroberfläche.

SpeedCommander 11 bietet gegenüber älteren Versionen viele nützliche Funktionen an, die Sie schon bald nicht mehr missen möchten. Neue Anwender finden im Schnelleinstieg den direkten Weg zu den einzelnen Funktionen von SpeedCommander. Und egal, was Sie schon über SpeedCommander gehört haben - SpeedCommander kann noch viel mehr.

Aktuelle Informationen und neue Versionen finden Sie auf unserer Website.

Vermissen Sie eine Funktion oder haben Sie eine Frage? Schreiben Sie Ihren Wunsch direkt an das Entwicklerteam.

Oder schauen Sie doch einfach einmal im Anwenderforum vorbei und tauschen Sie sich mit anderen Anwendern über SpeedCommander und andere Produkte aus.


Neue Funktionen

SpeedCommander
Neue Funktionen

Diese Seite listet die wesentlichen Änderungen und Erweiterungen der verschiedenen SpeedCommander-Versionen auf.

SpeedCommander 11.5

  • Unterstützung der Benutzerkontensteuerung von Windows Vista für alle Dateioperationen und Zugriffe auf die Registry (Ausnahme: Synchronisieren und Entpacken von ACE-Archiven)
  • Unterstützung der Spaltenerweiterungen von Windows Vista
  • Start von SpeedCommander nach Abschluss der Installation mit normalen Rechten, wenn das Installations-SFX ohne Adminrechte gestartet wurde
  • Anpassung der Manifeste aller ausführbaren Dateien an Windows Vista
  • Alle ausführbaren Programmdateien sind signiert
  • Dialog "Datei - Ausführen": Aufruf des Programms/Dokuments mit erhöhten Rechten, wenn der Dialog mit <Strg+Umschalt+Enter> geschlossen wird
  • Aufruf der Kommandozeile mit erhöhten Rechten, wenn zusätzlich zu <Enter> die rechte oder linke Windows-Taste gedrückt wird
  • Auf Wunsch blaues Office 2003-Design bei aktiviertem Media Center-Stil (Erweitert - Spezielles)

SpeedCommander 11.2

  • Neue Seite im Einstellungsdialog mit speziellen Einstellungen für erfahrene Anwender (Erweitert - Spezielles)
  • Option zum Mitzählen des Elternordners in der Statuszeile (Erweitert - Spezielles)
  • Option zum Kopieren der Erstellzeit von Dateien (Erweitert - Spezielles)
  • Option zum Erstellen von Archiven in das Quellverzeichnis (Erweitert - Spezielles)
  • Option zum Entpacken von Archiven in das Quellverzeichnis (Erweitert - Spezielles)
  • Option zum Übernehmen der Erstellungszeit von Dateien beim Kopieren (Erweitert - Spezielles)
  • Screenreader-kompatibler Dialog zur Feldauswahl in Listenansichten (Aussehen - Darstellung)
  • Im Dialog "Funktion unter anderer Benutzerkennung ausführen" werden die auf dem System vorhandenen Administratoraccounts aufgelistet
  • Beim Drücken eines Tastenkürzels im QuickSearch-Dialog wird der QuickSearch-Dialog geschlossen und der Tastenkürzelbefehl ausgeführt
  • Automatisches Erstellen einer Kopie der XML-Einstellungen nach erfolgreichem Laden
  • Doppelklick-Verhalten bei Registerkarten kann angepasst werden (Verhalten - Registerkarten)
  • FileSync: Zeitdifferenzen von einer Stunde ignorieren (Profileinstellung)
  • fsc: Zeitdifferenzen von einer Stunde ignorieren (/IH)
  • RAR: Anzeige von Authentizitätsinformationen
  • SpeedEdit & SpeedView: Tooltips für Registerkarten (Anzeiger der vollständige Dateinamen)
  • Ausführen von FTP-Operationen über die Zwischenablage auf Wunsch im Hintergrund

SpeedCommander 11.1

  • Spezielle Version für U3-Sticks (mehr)
  • Originalgetreuere Farben im Office 2003-Design (Deaktivierte Symbole, Hintergrund von freischwebenden Symbolleisten)
  • Anpassung des Visual Studio 2005-Designs an die endgültige Version von Visual Studio 2005
  • Einbindung von Sprachdateien möglich
  • Automatisches Entfernen von ungültigen Zeichen beim Einfügen aus der Zwischenablage in Vororteditierfelder
  • Bei aktivierter Einstellung "Ordner mit führendem Backslash kennzeichnen" wird der Backslash bei Vororteditierung herausgefiltert
  • Bei aktivierter Einstellung "Ordner in Groß- und Dateien in Kleinbuchstaben anzeigen" wird bei der Vororteditierung der unverfälschte Dateiname angezeigt
  • Kontextmenü für Archivdateien in der Baumansicht
  • Bei der Konfiguration der Anwendungsfavoriten werden die Datei/Ordner-Öffnen-Dialoge mit dem jeweiligen Dateinamen/Ordner initialisiert
  • "In einzelne Unterordner entpacken" auch beim Entpacken von einem einzelnen Archiv möglich
  • Option zur Unterdrückung der Meldung bei Datenstromverlust beim Kopieren auf nicht-NTFS-Laufwerke
  • Aktualisierung der 7z-Bibliothek auf 4.32
  • Anzeige von Dateien größer als 2GB in der Dump-Ansicht
  • Mehrfaches Umbenennen für Zweigansicht und Dateiablage
  • Unterstützung von Umgebungsvariablen bei Anwendungs- und Ordnerfavoriten, Registerkarten, Ordnergrößen und DOS-Eingabezeile
  • Umgebungsvariable %SCDIR% für das SpeedCommander-Programmverzeichnis, während SpeedCommander läuft
  • Ungültige Zeichen in Dateinamen werden beim Entpacken von Archiven automatisch durch Unterstriche ersetzt

SpeedCommander 11.0

  • Native 64-Bit-Version für Windows XP x64 (mehr)
  • Speicherung der Einstellungen als XML
  • Optimierung der Anzeige von Symbolen/Texten/Miniaturansichten in der Listenansicht
  • Unterstützung von Explorer-Erweiterungenen für Spalten (mehr)
  • Übersichtlicherer und erweiterter Konfigurationsdialog
  • Definition von eigenen Farbschemen (mehr)
  • Anzeigefilter können Schriftstil und Hintergrundfarbe enthalten (mehr)
  • Erweiterte Unterstützung für Ordner in Datei- und Anzeigefilter
  • Zweigansicht zur Auflistung aller untergeordneter Dateien in einem Ordnerfenster (mehr)
  • Stufenweises Ausblenden von versteckten Dateien (mehr)
  • Deaktivierbare Bestätigungsmeldungen beim Kopieren, Verschieben und Löschen von Dateien (mehr)
  • Fortschrittsanzeige bei der Ordnergrößenberechnung (mehr)
  • Differenzierte Ausnahmen bei der Ordnergrößenberechnung (mehr)
  • Definierbare Maximalgrenze bei der Ordnergrößenberechnung (mehr)
  • Neue Option: Bei Laufwerkswechsel immer in das Hauptverzeichnis wechseln (mehr)
  • InfoTips können für bestimmte Laufwerksgruppen (z.B. Netzwerklaufwerke) abgeschaltet werden (mehr)
  • Neue FTP-Engine mit Unterstützung für SFTP und FTP/SSL
  • Erweiterte FTP-Einstellungen mit Bandbreitenbegrenzung für Up- und Downloads (mehr)
  • Unterstützung von MODE Z (mehr)
  • Proxyserver-Unterstützung für Socks 4/4A/5 und HTTP Connect
  • FTP-Verzeichnisdaten können im Statusfenster ausgeblendet werden (mehr)
  • Automatisierung über Makros (mehr)
  • Erweiterungsmöglichkeiten durch AddIns (mehr)
  • AddIn zur Einbindung von Total Commander Dateisystem-Plugins
  • AddIn für den Zugriff auf PDAs über Active Sync
  • Kommandozeilenparameter "/xml:<Einstellungen.xml>" für die Verwendung einer alternativen Konfigurationsdatei (mehr)
  • Kommandozeilenparameter "/caption:<Fenstertitel>" für die Angabe eines eigenen Fenstertitels (mehr)
  • Kommandozeilenparameter "/layout:<Layoutname>" zum Laden eines speziellen Layouts beim Start (mehr)

SpeedCommander 10.5

  • Vollständige Unterstützung von SQX2
  • Unterstützung für NTFS-Streams (ZIP und SQX) (mehr)
  • Archivieren von NTFS-Sicherheitsattributen (ZIP und SQX) (mehr)
  • Speichern von hochauflösenden Zeitstempeln (ZIP und SQX) (mehr)
  • Automatisches Archivieren von Dateikommentaren (ZIP und SQX) (mehr)
  • Archivieren von Unicode-Dateinamen (SQX) (mehr)
  • Setzen von Ordnerzeitstempeln beim Entpacken (ZIP, SQX und 7z)
  • Eigene Icons für SFXe und Anpassung der Versionsinformation (ZIP und SQX)
  • Übertragung der ZoneID des Archivs auf alle entpackten Dateien unter XP SP2 (mehr)
  • ZIP: Vollständige Unterstützung für AES 128/256
  • TAR: Longlink-Unterstützung
  • GZIP: Unterstützung für Archive > 4GB
  • Verbesserte GNU-TAR-Unterstützung
  • CAB: Erkennung von selbstentpackenden CAB-Archiven bis zu 280kb Stubgröße
  • BZ2: Beim Erstellen von Archiven wird nun explizit die Dateiendung vor die BZ2-Erweiterung gesetzt
  • RAR: Anzeige von Archivkommentaren
  • Neue Entpackmodis (Alle, Nur neuere, Auffrischen)
  • Archivattribute können beim Entpacken gelöscht werden
  • "Auf Fenstergröße einpassen" nur noch bei Bilder, die größer sind als das aktuelle Fenster
  • WMF-Grafiken werden im richtigen Seitenverhältnis angezeigt
  • Dialog "Server ist ausgelastet" beim Drag & Drop wird nicht mehr angezeigt
  • Kopieren in ein Archiv erfolgte nun multithreaded
  • FileSync: Nach einer Synchronisation wird automatisch ein neuer Vergleich gestartet
  • FileSync: Synchronisierung von verschlüsselten nach unverschlüsselten NTFS-Verzeichnissen
  • FileSync: Wenn nicht nach Dateizeit verglichen wird, dann müssen gefundene Dateien manuell zum Abgleich ausgewählt werden
  • fsc: Kommandozeilenoptionen CT, CS und CC deaktiviert, Vergleich erfolgt nun immer nach Dateizeit

SpeedCommander 10.3

  • Erweiterte Komprimierungseinstellungen für 7z
  • Mehrere Dateien können einzeln archiviert werden
  • Unterstützung für Multimediatasten "Vorwärts", "Zurück", "Aktualisieren", "Kopieren", "Ausschneiden" und "Einfügen"
  • Definition von zusätzlichen Archivdateitypen (TweakSC)
  • Neues visuelles Design: Whidbey (mehr)
  • Kopieren von EFS-verschlüsselten Dateien auf Nicht-NTFS-Datenträger
  • Ordnertabs mit einem Basisordner, der auf einen nicht mehr vorhandenen Netzordner zeigt, konnten nicht gelöscht werden
  • Auf langsamen Laufwerken (z.B. VPN) wird aus Performancegründen kein InfoTip mehr angezeigt

SpeedCommander 10.2

  • Erkennung von 7z-SFXen
  • Registrierungsdaten können in INI-Datei abgelegt werden (mehr)
  • Unterstützung für LZW-komprimierte TIF/GIF-Dateien
  • Einstellungen zur Speicherung der Verlaufslisten im SC gelten nun auch für alle anderen Programme (Editor, Viewer, FileSearch, FileSync)
  • Beim Öffnen von SFXen innerhalb von Archiven erfolgt eine Nachfrage, ob das SFX angezeigt oder gestartet werden soll
  • Laufwerksauswahl bei Kombinationsfeld: Wechsel in das Hauptverzeichnis, wenn bei der Laufwerksauswahl "Umschalt" gedrückt wird
  • Neuer Menübefehl: Ordner | Wechseln zu | Untergeordneter Ordner

SpeedCommander 10.1

  • Unterstützung von 7-zip (Anzeige, Entpacken, Komprimieren)
  • Anzeige von administrativen und versteckten Freigaben (TweakSC)
  • Anzeige von Netzwerkdruckern (TweakSC)
  • Unterstützung von Umlaut-Domains im FTP-Client
  • "Fokusänderung bei Laufwerkswechsel" gilt nun auch für die Navigationssymbole über dem Ordnerfenster
  • Bei der Archiverstellung kann ein Archivkommentar vergeben werden
  • Archiverkennung beim Öffnen von Archiven optimiert
  • Prozess-Umgebungsvariablen werden bei Änderung aktualisiert
  • Verlaufsmenü kann per Tastatur aufgerufen werden (Strg+H / Strg+Umschalt+H) - (Tastatureinstellungen, Kategorie "Sonstige")
  • Symboleditor importiert mehr Bitmapformate sowie Icons und Cursor
  • Betrachter für Schriftarten (Schnellansicht)
  • Funktion "Ordner | Vergleichen" erweitert
  • Symbolleisten können fixiert werden (Anpassen-Dialog)
  • Verzögerter Verlauf und Speichern des Verlaufs beim Beenden (Einstellungsdialog "Grundeinstellungen")
  • Größe der Miniaturansicht und Abstand zwischen Symbolen einstellbar (TweakSC)
  • Neue Einstellung: Ordner immer nach Namen sortieren (Einstellungsdialog "Datei- und Laufwerksansicht")
  • Menüs für Ordner- und Anwendungsfavoriten können Trennzeichen (Separatoren) enthalten
  • Anzahl der eigenen QuickDrop-Symbole von 18 auf 40 erhöht
  • Kopieren/Verschieben über die Zwischenablage erfolgt nun auch im Hintergrund
  • Mögliches Löschen der Verlaufslisten vor dem Exportieren der Einstellungen
  • Menüeintrag für "Mindestanzahl Stellen" im "Mehrfach Umbenennen"-Dialog
  • FileSearch: Dateinamen können als Text in die Zwischenablage kopiert werden
  • Beim direkten Umbenennen (Vororteditierung) wird nun auch beim Einfügen aus der Zwischenablage der Text auf ungültige Zeichen überprüft
  • Archivfunktionen im Menü "Extras" werden nur noch aktiviert, wenn die jeweiligen Dateien/Archive die entsprechende Funktion unterstützen
  • Dynamic Drop für Laufwerksleiste
  • Automatische Größenanpassung für Internet wird auch beim Ordnerfenster-Wechseln beachtet
  • Interne Archivbehandlung kann nun deaktiviert werden (Einstellungsdialog "Datei- und Laufwerksansicht")
  • Zur Anzeige von Archiven innerhalb von Archiven wird automatisch eine neue Registerkarte erstellt

SpeedCommander 10.0

  • Visuelle Designs für Office 2003, Office XP, Office 2000 und Windows XP (mehr)
  • Miniaturansicht (mehr)
  • Navigationssymbole in der Titelzeile des Ordnerfensters
  • Unterstützung von Overlay-Handlern für Dateisymbole
  • Spalten in der Detailansicht für Bilder/MP3/DRM (nur XP) und für Versionsinformationen (mehr)
  • Schnellere Anzeige durch Ermittlung von Dateiinformationen im Hintergrund
  • Zeitstempel von Ordnern können beim Kopieren übernommen werden
  • Pausieren von Dateioperationen und Einstellen der Priorität
  • Zugriffe auf nicht existierende Netzwerkordner können mit 'Escape' abgebrochen werden
  • Scrollen im Textbetrachter mit <Leertaste>
  • Betrachter für ausführbare Programmdateien (exe;dll;obj;lib;dbg;sys;cpl;drv;ocx;ax;bpl;exp) (mehr)
  • Betrachter für Delphi-Formulare (dfm) (mehr)
  • Erweiterter Betrachter für Multimedia (cda;aif;aifc;aiff;asf;asx;wax;wm;wma;wmd;wmp;wmv;wmx;wpl;wvx;avi;wav; mpeg;mpg;m1v;mp2;mpa;mpe;mp2v;mpv2;mid;midi;rmi;au;snd0;mp3;vob;swf; mov;qt;rm;ram) (mehr)
  • Ordnerfenster-Eigenschaften: Bei Aktivierung in Basisordner wechseln (mehr)
  • Ordnerfensternamen können automatisch entsprechend des aktuellen Ordners umbenannt werden
  • Ordnerwechsel in gesperrten Ordnerfenstern können auf das erste freie Ordnerfenster umgelegt werden
  • Ordnergrößenanzeige für DVD-RAM, DVD+R/+RW und DVD-R/-RW
  • Registerkarten können oben angeordnet werden
  • QuickDrop-Symbole können auch mit kleinen Symbolen angezeigt werden
  • Anzeige der Ordnerhierarchie (mehr)
  • Suchprofile für FileSearch (mehr)
  • Unterstützung von Char-Sets in FileSearch und FileSync (mehr)
  • FileSync zum Sychronisieren von Ordnern (mehr)
  • FileSync Kommandozeile: Neuer Schalter -xd (Ordner ausschließen) (mehr)
  • FileSync Kommandozeile: Neuer Schalter -dd (Leere Ordner löschen) (mehr)
  • Archivoperationen im Hintergrund mit Pausieren und einstellbarer Priorität
  • LHA-, CAB-, TAR- und GZIP-Archive können auf Integrität überprüft werden (mehr)
  • Unterstützung von TAR- und BZIP-Archiven, die größer als 4GB sind
  • ZIP 6.0-Archivformat
  • Entpacken von nativen ARJ-Multivolumearchiven
  • Verwendung von Kompressionsprofilen (mehr)
  • Erstellen von nativen Multivolume-Archiven (SQX und ZIP)
  • Reparaturdaten können extern (ausserhalb des Archivs) erstellt werden
  • SQX-SFX-Dateien zeigen nun eine digitale Signatur an, wenn vorhanden
  • Normale SFX-Dateien können jetzt Systemvariablen benutzen (mehr)
  • Normale SFX-Dateien und Installations-SFX-Dateien können jetzt Parameter an aufzurufende Programme übergeben (mehr)
  • Sprachdateien für selbstentpackende Archive können mit einem normalen Texteditor angepasst bzw. übersetzt werden (mehr)
  • Verbesserte Kompression und schnellere Dekompression im SQX-Format
  • Geringerer Speicherverbrauch für alle Archiver
  • Dateien mehrfach umbenennen: Neuer Platzhalter [mi] (mehr)
  • Dateien mehrfach umbenennen: Es können mehrere Zeichenketten zum Suchen und Ersetzen auf einmal angegeben werden (mehr)
  • Kommandozeilenoption "/reg:<Einstellungen.reg> für unterwegs (mehr)
  • Kommandozeilenoption "/L:<Ordner>" und "/R:<Ordner>"
  • Reihenfolge der eigenen QuickDrop-Symbole ist änderbar (mehr)

SpeedCommander 9.2

  • Unicode-Version für Windows NT/2000/XP/2003 (mehr)
  • Ordner und Dateinamen mit Zahlen werden anhand ihres numerischen Wertes einsortiert
  • Ordnertabs sind abschließbar und können einen festen Startordner besitzen (mehr)
  • Neue Eigenschaft fuer Ordnertabs: Bei Aktivierung immer aktualisieren
  • Direkter Befehl für das Löschen des Papierkorbs
  • Neue Spalten für Besitzer, Titel, Thema, Autor und Kommentar (mehr)
  • Freie Zuordnung von Tastenkürzel für die Sortierbefehle
  • Layout-Menü via 'Strg+Alt+W'
  • Layout speichern: Alle definierten Layouts werden in einem Kombinationsfeld angezeigt
  • Umbenennen von Ordnern in der Baumansicht
  • Beim Umbenennen werden ungültige Zeichen gefiltert
  • Bei der Schnellansicht von verschlüsselten Dateien wird das Kennwort wiederverwendet, wenn die Dateien mit dem gleichen Kennwort verschlüsselt sind
  • Deaktivierung der Ordnergrößenberechnung für bestimmte Ordner (TweakSC)
  • Aus defekten Zip-Archiven können beschädigte und unbeschädigte Dateien entpackt werden
  • SQX-Format: Leicht verbesserte Kompression bei allen Dateitypen und zum Teil deutlich verbesserte Kompression bei verschiedenen Typen von ausführbaren Dateien
  • SQX-Format: Schnellere Dekompression bei verschiedenen Dateitypen
  • SQX-Format: Deutlich verringerter Speicherverbrauch im Kompressor
  • Hinweis per InfoTip, wenn aus einem gesperrten Tab gewechselt werden soll
  • Hinweis per InfoTip, wenn bei der Vororteditierung eines Dateinamens ein ungültiges Zeichen eingegeben wird
  • Nach Schließen des 'Mehrfach Umbenennen'-Dialogs wird die Dateiliste neu eingelesen
  • FTP-Kennwörter werden für Ansi/Unicode-Version transparent gespeichert

SpeedCommander 9.1

  • TweakSC für weitere Einstellungen
  • Bugfixes und kleine Optimierungen

SpeedCommander 9.0

  • Vollständige Unterstützung von Windows XP
  • Darstellung von mehreren Ordnern in einem Ordnerfenster via Registerkarten (mehr)
  • Einbindung der Dateiablage in das Zwei-Fenster-Layout (mehr)
  • Erweiterung der QuickDrop-Symbole (mehr)
  • Auswahl aller Dateien des gleichen Dateityps wie die aktuell gewählte Datei (mehr)
  • Verbesserung des NC-Auswahlmodus
  • Umfangreiche Farbanpassungsmöglichkeiten
  • Ein- und Ausblenden von Spalten in der Detailansicht per Feldauswahl (mehr)
  • Anzeige von Dateien in Gruppen (mehr)
  • Unterstützung der Kachel-Ansicht (mehr)
  • Synchronisieren von Ordnerfenstern (mehr)
  • Integriertes DOS-Ausgabefenster (mehr)
  • Unterstützung von mehreren Layouts (mehr)
  • Strg+E zum Angleichen der Fenster
  • Zugriff auf die Ordnerfavoriten durch Doppelklick auf die Titelzeile des Ordnerfensters (mehr)
  • Zugriff auf die Anwendungsfavoriten durch Doppelklick bei gedrückter Umschalt-Taste auf die Titelzeile des Ordnerfensters (mehr)
  • Ordner- und Anwendungsfavoriten können hierarchisch angeordnet werden
  • Ordnerfavoriten: Gleichzeitiges Wechseln von aktivem und inaktivem Fenster
  • Farbliche Kennzeichnung von Dateien (mehr)
  • Mehrfaches Umbenennen von Dateien und Ordnern (mehr)
  • Verwalten von Dateiverknüpfungen
  • Automatische Installation von Schriftarten beim Kopieren von Font-Dateien in den Systemordner "Schriftarten"
  • Modernes und leistungsfähiges SQX-Format
  • Erstellung von signierten Archiven
  • Vollständige Unterstützung von ZIP64 und Deflate64
  • Unterstützung für BZIP
  • Entpacken von RAR3- und ACE2-Archiven
  • Neue Volumegrößen (2 MB - 700 MB & frei einstellbar)
  • Anzeige von Archiven in der Baumansicht
  • Sichere Verschlüsselung von Archiven mit dem SQX-Format und AES
  • Komfortable Verwaltung der FTP-Standorte (mehr)
  • FTP-Schnellverbindung
  • Angabe zusätzlicher Initialisierungsbefehle bei FTP-Servern
  • Anpassung der Zeitzone für den FTP-Server
  • Einbindung des Mozilla-Browsers (mehr)
  • Unterstützung von Unicode-Dateien in der Schnellansicht
  • Einfache Konfiguration der Schnellansicht für die verschiedenen Formate (mehr)
  • FileSearch: Weitere Verbesserung der Suchgeschwindigkeit
  • FileSearch: Suche nach doppelten Dateien
  • Kommandozeilen-Tool für die Synchronisierung von Ordnern (mehr)
  • Synchronisierung mit Script-Dateien (mehr)

SpeedCommander 8.1

  • Schnellansicht automatisch vergrößern
  • Bei aktiviertem "Markieren mit rechter Maustaste" wird das Kontextmenu der Datei(en) angezeigt, wenn zusätzlich "Strg" gedrückt wird
  • Fenster angleichen mit Strg+E, aktives Fenster ist Basis
  • Ausblenden, wenn minimiert
  • Kopieren des aktuellen vollständigen Dateinamens in die Zwischenablage über Alt-Einfg
  • Kopieren des aktuellen relativen Dateinamens in die Zwischenablage über Umschalt+Alt-Einfg
  • Kopieren des aktuellen Ordnernamens in die Zwischenablage über Strg+Alt-Einfg
  • Dokumentenkartei in SpeedEdit und SpeedView

SpeedCommander 8.0

  • NC-Auswahlmodus mit eigener Farbanpassung
  • Ausblenden der Dateisymbole
  • Strg+U zum Tauschen der Fenster
  • Office XP-Menüs
  • Dateifenster können untereinander angeordnet werden
  • Erweiterung der QuickDrop-Symbole (mehr)
  • Zugriff auf die wichtigsten Systemordner (mehr)
  • Favoritenleiste mit Internetfavoriten, Ordnerfavoriten und Anwendungsfavoriten
  • Dateiablage mit mehreren voneinander unabhängigen Ablagen (mehr)
  • Anzeige der Kommentare in der Netzwerkumgebung
  • AutoComplete und AutoSuggest in vielen Eingabefeldern
  • Bis zu 50 frei definierbare Dateifilter (mehr)
  • Einschließen und Ausschließen per Maske (*.doc;*.xls;123*.*)
  • Erweiterte Auswahl beim Datum
  • Erweiterte Funktionen zum Kopieren, Verschieben und Löschen von Dateien
  • Sicheres Löschen nach Regierungsrichtlinien (mehr)
  • Automatisches Umbenennen beim Kopieren in das gleiche Verzeichnis über die Zwischenablage
  • Verwenden von Reparaturdaten (mehr)
  • Datei- und Archivkommentare (mehr)
  • Testen von Archiven (mehr)
  • Umwandeln eines Archivs in ein SFX (mehr)
  • SFX mit Listenansicht
  • Neue Volumegrößen (2 MB - 700 MB)
  • Ändern von Dateiattributen bei FTP (mehr)
  • Idle-Timer bei FTP
  • FTP-Schnellverbindung durch Eingabe der FTP-Adresse (ftp://ftp.microsoft.com) in der DOS/FTP-Eingabezeile
  • SpeedView: Viele neue Dateibetrachter für Grafikformate (mehr)
  • SpeedView: Anzeige von Word-, Excel-, Works-, WordPerfect- und Lotus 123-Dokumenten bei installiertem Microsoft Office 97/2000 (mehr)
  • SpeedView: Anzeige von Write- und RTF-Dateien
  • SpeedView: Umschalten des Betrachters für ein gerade angezeigtes Dokument (mehr)
  • SpeedEdit: Integriertes Syntaxhighlighting für: ASP, Basic, Batch, C/C++, DCL (AutoCAD), Fortran, HTML, InstallShield, Java, LISP (AutoCAD), Pascal, Perl, PHP, Python, Ressourcen, REXX, SGML, Shell Script, SIOD, SQL, TCL, TeX
  • SpeedEdit: Definition von AutoText-Einträgen
  • SpeedEdit: Lesezeichen
  • SpeedEdit: Umwandlung eines Textes in Groß- oder Kleinbuchstaben
  • SpeedEdit: Vertauschen von Groß-/Kleinbuchstaben
  • SpeedEdit: Inkrementelle Suche
  • SpeedEdit: Schreibschutzmodus
  • FileSearch: Durchsuchen von Ordnern oder mehreren Laufwerken
  • FileSearch: Suche nach Dateiinhalten (Text, Hexadezimal, Binär)
  • FileSearch: Verwendung von Suchoperatoren (UND, ODER, NICHT)
  • FileSearch: Suchen von Unicode-Text
  • FileSearch: Anzeige der gefundenen Treffer
  • FileSearch: Suchen in Archiven, in verschlüsselten Archiven und in selbstentpackenden Archiven (ACE, ARJ, CAB, GZIP, JAR, LZH, RAR, TAR, UUE, ZIP und SCB)
  • FileSearch: Übernahme der gefundenen Dateien in ein Ordnerfenster oder in die Dateiablage des SpeedCommander


Funktionsüberblick

SpeedCommander
Funktionsüberblick

Diese Seite gibt einen Überblick über die wesentlichen Funktionen im SpeedCommander.

Aufbau

  • Moderne und voll anpassungsfähige Benutzeroberfläche
  • Vollständige Unterstützung von Windows XP
  • Visuelle Designs für Office 2003, Office XP, Office 2000 und Windows XP
  • Zwei Ordnerfenster, die nebeneinander oder untereinander angeordnet werden können
  • Darstellung von mehreren Ordnern in einem Ordnerfenster via Registerkarten
  • Einblendung einer Baumansicht für jedes Ordnerfenster
  • Laufwerksfenster (Laufwerksauswahl als Kombinationsfeld, Leiste, Gemeinsame Leiste)
  • Integrierte Schnellansicht
  • DOS-Eingabezeile
  • DOS-Ausgabefenster
  • Dateiablage mit mehreren voneinander unabhängigen Ablagen
  • QuickDrop-Symbole
  • Unicode-Version für Windows NT/2000/XP/2003

Ansicht

  • Ansicht von Dateien mit großen Symbolen, kleinen Symbolen, Details, Kacheln und Miniaturbildern
  • NC-Auswahlmodus mit eigener Farbanpassung
  • Ausblenden der Dateisymbole möglich
  • Zugriff auf die wichtigsten Systemordner
  • Laufwerksstatus und Ordnerinformation
  • Synchronisieren von Ordnerfenstern
  • Unterstützung von mehreren Layouts
  • Zugriff auf das Start- und Favoriten-Menü sowie die Elemente des Desktops und des Arbeitsplatzes
  • Definition von bis zu 50 Dateifiltern zur Anzeige und für Dateioperationen
  • Ordnerfavoriten zum schnellen Wechsel in einen Ordner, in ein Archiv oder in ein FTP-Verzeichnis
  • Einbindung zusätzlicher Programme als Anwendungsfavoriten
  • AutoComplete und AutoSuggest bei vielen Eingabefeldern
  • Unterstützung von Overlay-Handlern für Dateisymbole

Dateimanagement

  • Anzeige und Sortierung von Dateien nach Name, Größe, Typ, Dateizeit und Attributen
  • Anzeige von Dateien in Gruppen
  • Ein- und Ausblenden von Spalten in der Detailansicht per Feldauswahl
  • Navigationssymbole in der Titelzeile des Ordnerfensters
  • Farbliche Kennzeichnung von Dateien
  • Kopieren von Dateien und Ordnern
  • Verschieben von Dateien und Ordnern
  • Löschen von Dateien und Ordnern
    • Normales Löschen
    • Löschen in den Papierkorb
    • Sicheres Löschen nach Regierungsrichtlinien
  • Pausieren von Dateioperationen und Einstellen der Priorität
  • Trennen von Dateien
  • Anzeige der Dateieigenschaften
  • Ermittlung von Ordnergrößen
  • Vergleichen von Ordnern
  • Ändern von Dateizeit und Dateiattributen
  • Drucken von Ordnerlisten
  • Zugriff auf die Netzwerkumgebung
  • Mehrfaches Umbenennen von Dateien und Ordnern
  • Verwalten von Dateiverknüpfungen
  • Automatische Installation von Schriftarten beim Kopieren von Font-Dateien in den Systemordner "Schriftarten"
  • Anzeige der Ordnerhierarchie

Anzeige von Dateien

  • Externer Dateibetrachter (SpeedView) und integrierte Schnellansicht
  • Grafikformate: AWD, BMI, BMP, BW, CAL, CALS, CDR, CDT, CEL, CIT, CLP, CMX, COT, CPT, CUR, CUT, DCX, DIB, FLC, FLI, GEM, GIF, HAM, HRZ, ICN, ICO, IFF, IMG, JFF, JIF, JMX, JPE, JPG, LBM, MIL, MAC, MSP, OFX, PAN, PAT, PBM, PC2, PCD, PCT, PCX, PGM, PIC, PNG, PNM, PPM, PSD, PYX, QFX, RAS, RGB, RLE, SAM, SCx, SEP, SGI, ST, STW, SUN, TGA, TIFF, UDI, WPG, ZBR, ZMF
  • Archivformate: 7Z, ACE, ARJ, BZIP, CAB, GZIP, JAR, LZH, LHA, RAR, SQX, TAR, UUE, ZIP
  • Multimedia: CDA, AIF, AIFC, AIFF, ASF, ASX, AVI, WAV, WAX, WM, WMA, WMD, WMP, WMV, WMX, WPL, WVX, MPEG, MPG, M1V, MP2, MP3, MPA, MPE, MP2V, MPV2, MID, MIDI, RMI, AU, SND0, VOB, SWF, MOV, QT, RAM, RM,
  • Dokumente: DFM, HTM, HTML, RTF, WRI, Text
  • Dokumente bei installiertem MS Office: DOC, WK1, WK3, WK4, WPS, XLS
  • Programmdateien: EXE, DLL, OBJ, LIB, DBG, SYS, CPL, DRV, OCX, AX, BPL, EXP
  • Schriftarten: FON, FNT, OTF, TTF

Bearbeiten von Dateien

  • Komfortabler Editor zur Bearbeitung von Textdateien (SpeedEdit)
  • Integriertes Syntaxhighlighting für: ASP, Basic, Batch, C/C++, DCL (AutoCAD), Fortran, HTML, InstallShield, Java, LISP (AutoCAD), Pascal, Perl, PHP, Python, Ressourcen, REXX, SGML, Shell Script, SIOD, SQL, TCL, TeX
  • Definition von AutoText-Einträgen
  • Lesezeichen
  • Umwandlung eines Textes in Groß- oder Kleinbuchstaben
  • Vertauschen von Groß-/Kleinbuchstaben
  • Inkrementelle Suche
  • Schreibschutzmodus
  • Druckvorschau

Suchen von Dateien

  • Schnelles und komfortables Suchprogramm (FileSearch)
  • Durchsuchen von Ordnern oder mehreren Laufwerken
  • Suche nach Dateiinhalten (Text, Hexadezimal, Binär)
  • Suche nach doppelten Dateien
  • Verwendung von Suchoperatoren (UND, ODER, NICHT)
  • Suchen von Unicode-Text
  • Anzeige der gefundenen Treffer
  • Suchen in Archiven und in selbstentpackenden Archive (ACE, ARJ, BZIP, CAB, GZIP, JAR, LZH, RAR, SQX, TAR, UUE, ZIP)
  • Übernahme der gefundenen Dateien in ein Ordnerfenster oder in die Dateiablage des SpeedCommander

Synchronisieren von Dateien und Ordnern

  • Komfortable Oberfläche und Kommandozeilen-Tool für die Synchronisierung von Dateien und Ordnern (FileSync)
  • Abgleich von Dateien und Ordnern nach Zeitstempel, Größe oder Inhalt
  • Übertragung der Sicherheitsbeschreibungen
  • Erstellung eines ausführlichen Protokolls
  • Synchronisierung mit Script-Dateien

Komprimierte Dateien

  • Direkte Unterstützung der Archivformate 7Z, ACE, ARJ, BZIP, CAB, GZIP, JAR, LZH, RAR, SQX, TAR, UUE, ZIP
  • Vollständige Unterstützung von ZIP64 (Keine Einschränkung hinsichtlich der Archivgröße und der Anzahl der Dateien bei ZIP)
  • Unterstützung von Deflate64
  • Komprimieren von Dateien
  • Entpacken von Archiven
  • Archivoperationen im Hintergrund mit Pausieren und einstellbarer Priorität
  • Reparaturdaten für SQX-Archive (intern und extern)
  • Archive auf Integrität prüfen
  • Unterstützung von Archiv- und Dateikommentaren
  • Erstellen von Ordnern in Archiven
  • Verschlüsselung von Archivdaten und/oder Archivverzeichnis mit AES
  • Erstellen von signierten Archiven
  • Erstellen von nativen Multivolume-Archiven (SQX und ZIP)
  • Erstellung von selbstextrahierenden Dateien
    • Normales SFX
    • SFX für Softwareinstallationen
    • SFX mit Listenansicht

Internet

  • Integration von Microsoft Internet Explorer und Mozilla
  • Automatische Vergrößerung des Ordnerfensters bei Aktivierung des Browsers
  • Eigene Start- und Suchseite

FTP

  • Transparenter Zugriff auf FTP-Server
  • Komfortable Verwaltung der FTP-Standorte
  • Angabe zusätzlicher Initialisierungsbefehle
  • Anpassung der Zeitzone für den FTP-Server
  • Download/Upload von Dateien als ASCII, Binary oder EBCDIC
  • Automatische Konvertierung der Dateinamen nach Kleinbuchstaben
  • Löschen von Dateien
  • Setzen von Dateiattributen
  • Unterstützung von Firewalls und Proxyserver
  • Automatisches Aufrechterhalten der Verbindung bei Untätigkeit
  • FTP-Kommandozeile

Datenträger

  • Formatieren von Datenträgern
  • Kopieren von Disketten
  • Umbenennen von Datenträgern
  • Verbinden und Trennen von Netzlaufwerken


Schnelleinstieg

SpeedCommander
Schnelleinstieg

Hier finden Sie einige Vorschläge zur Arbeit mit dem SpeedCommander.

Wie kann ich...

  • Dateien auswählen?
  • Dateien sortieren?
  • ein Fenster aktualisieren?
  • ein anderes Laufwerk wählen?
  • eine Datei anzeigen?
  • eine Datei bearbeiten?
  • Dateien kopieren?
  • Dateien verschieben?
  • Dateien löschen?
  • einen Ordner erstellen?
  • Zeit und Attribute einer Datei ändern?
  • einen Dateifilter einrichten?

  • Dateien komprimieren?
  • Dateien dekomprimieren?
  • ein Archiv über mehrere Disketten erstellen?
  • ein selbstextrahierendes Archiv erstellen?
  • einem Archiv Reparaturdaten hinzufügen?
  • Reparaturdaten aus einem Archiv entfernen?
  • ein Archiv auf Integrität prüfen?

  • eine Verbindung zu einem FTP-Server herstellen?
  • Dateiattribute auf einem FTP-Server ändern?
  • eine Internet-Seite anzeigen?

  • einen Datenträger formatieren?
  • eine Diskette kopieren?
  • einen Datenträger umbenennen?
  • eine Verbindung zu einem Netzlaufwerk herstellen?
  • die Verbindung zu einem Netzlaufwerk trennen?


SpeedCommander bestellen

SpeedCommander: Allgemeine Informationen
SpeedCommander bestellen

Vielen Dank für Ihr Interesse am SpeedCommander!

Telefonisch bestellen | Online bestellen
Aus Deutschland: Telefon: 04451 - 95 91 95 Telefax: 04451 - 95 91 96 Aus dem Ausland: Telefon: 0049 4451 - 95 91 95 Telefax: 0049 4451 - 95 91 96 | Bestellen Sie online unter http://shop.speedproject.de/ Online bestellen ist günstiger!

Preisliste SpeedCommander 11 (plus Versandkosten)

Artikel | Beschreibung | Preis
VC112101-25 | SpeedCommander 11 CD und Handbuch | 39,95 €
VC112121-25 | SpeedCommander 11 Freischaltcode ohne Datenträger Nur online: http://shop.speedproject.de/ | 37,95 €
VC112110-00 | SpeedCommander 11 Upgrade CD und Handbuch | 19,95 €
VC112130-00 | SpeedCommander 11 Upgrade Freischaltcode ohne Datenträger Nur online: http://shop.speedproject.de/ | 18,95 €
VC112102-20 | SpeedCommander 11 (Mehrplatzlizenz 5 Anwender) CD und Handbuch | 139,95 €
VC112103-20 | SpeedCommander 11 (Mehrplatzlizenz 10 Anwender) CD und Handbuch | 259,95 €
VC112104-20 | SpeedCommander 11 (Mehrplatzlizenz 25 Anwender) CD und Handbuch | 549,95 €

Weitere Preise erhalten Sie gerne auf Anfrage.


Lizenzbedingungen

SpeedCommander: Allgemeine Informationen
Lizenzbedingungen

Die mit dieser Lizenz erworbene Software (im folgenden als "Software" bezeichnet) ist Eigentum der Firma SWE Sven Ritter oder deren Lizenzgeber und ist durch nationale Gesetze und internationale Verträge urheberrechtlich geschützt. Mit der Annahme der Lizenzbedingungen erhalten Sie das Recht zur Benutzung der Software. Sofern nicht durch eine mit dieser Lizenz ausgelieferte Zusatzvereinbarung andere Regelungen getroffen werden, unterliegt die Nutzung der Software folgenden Bestimmungen:

Sie sind berechtigt:
  • eine Kopie der Software auf einem Einzelcomputer zu benutzen. eine Kopie der Software zu Archivierungszwecken anzufertigen oder die Software auf die Festplatte Ihres Computers zu kopieren und die Originaldisketten oder die Original-CD zu archivieren.
  • die Software in einem Netzwerk einzusetzen, vorausgesetzt, dass Sie über eine lizenzierte Kopie der Software für jeden Computer verfügen, der über das Netzwerk auf die Software zugreifen kann.
  • nach schriftlicher Benachrichtigung an SWE Sven Ritter die Software dauerhaft einem Dritten zu überlassen, vorausgesetzt, dass Sie alle Kopien der Software oder der Begleitdokumentation übergeben und der Empfänger der Software sich mit den Bestimmungen dieser Lizenzvereinbarung einverstanden erklärt.
  • als Einzelperson mehrere Installationen auf Ihren Computern vorzunehmen, vorausgesetzt, dass nur Sie als Lizenzinhaber die Software benutzen.
Sie sind NICHT berechtigt:
  • die mit der Software gelieferte Dokumentation zu kopieren.
  • die Software ganz oder teilweise zu verleihen oder zu vermieten oder Unterlizenzen zu vergeben.
  • die Software zurückzuentwickeln (reverse engineering), zu dekompilieren, zu disassemblieren oder auf andere Weise versuchen, den Quellcode der Software zugänglich zu machen, die Software zu ändern, zu übersetzen oder davon abgeleitete Produkte zu erstellen.
  • nach Erhalt einer Austausch-CD oder einer Upgrade- oder Update-Version als Ersatz für eine frühere Version die vorher erhaltene Kopie oder die frühere Version der Software zu benutzen oder zu verkaufen.
Beschränkte Garantie:

Diese Software wird geliefert wie sie ist, ohne irgendwelche ausdrückliche oder inbegriffene Garantie. Wir machen darauf aufmerksam, dass es nach dem Stand der Technik nicht möglich ist, Computersoftware zu erstellen, die in allen Anwendungen und Kombinationen fehlerfrei arbeitet. Wir haben jedoch bei der Entwicklung dieser Software größte Sorgfalt walten lassen und werden auch künftig bemüht sein, etwaige Unstimmigkeiten oder Fehler zu beseitigen. Wir haften nicht dafür, dass die Software Ihren Bedürfnissen entspricht, oder dass die Software ohne Unterbrechung und fehlerfrei arbeitet. Wir haften jedoch dafür, dass die Datenträger, auf denen die Software geliefert wird, bei normalem Gebrauch keine Material und Verarbeitungsschäden aufweisen. Diese Haftung gilt für den Zeitraum von 6 Monaten vom Datum der Auslieferung an. Jede weitere Haftung ist ausgeschlossen.


Systemvoraussetzungen

SpeedCommander: Allgemeine Informationen
Systemvoraussetzungen

Um den SpeedCommander verwenden zu können, muss Ihr System folgende Voraussetzungen erfüllen:

  • PC mit Pentium- oder kompatiblem Prozessor
  • Windows 95/NT4 mit Internet Explorer 5.0; Windows 98, ME, 2000, XP oder höher; Windows XP x64 oder höher
  • 15 MB freier Festplattenspeicher
  • CD-ROM Laufwerk für die Installation


Copyright

SpeedCommander: Allgemeine Informationen
Copyright

Copyright © 1993-2005 Sven Ritter

Einzelne Teile der Software Copyright © 1999-2005 CodeJock Software
Einzelne Teile der Software Copyright © Andrei Stcherbatchenko, Ferdinand Prantl, Sven Wiegand, Cristi Posea, Selom Ofori, Jan Patera, Stas Levin, Igor Pavlov

SpeedCommander bindet dynamisch eine DLL (7za.dll) von 7-Zip ein, diese DLL steht unter der GNU LGPL-Lizenz. Der Quellcode für 7za.dll kann von http://www.7-zip.org/ heruntergeladen werden.

Warenzeichen

Microsoft und das Microsoft Internet Explorer Logo sind eingetragene Warenzeichen der Microsoft Corporation in den USA und/oder anderen Ländern.

Acrobat® Reader, Copyright © 1987-1997 Adobe Systems Incorporated. Alle Rechte vorbehalten. Adobe und Acrobat sind Warenzeichen von Adobe Systems Incorporated.

Alle in dieser Hilfe erwähnten Marken- und Produktnamen sind Warenzeichen der jeweiligen Rechtsinhaber und werden hiermit anerkannt.


Ansi-/Unicode-Version

SpeedCommander: Allgemeine Informationen
Ansi-/Unicode-Version

Der ANSI-Zeichensatz besteht aus maximal 256 verschiedenen Zeichen (Buchstaben, Ziffern, Interpunktionszeichen und Sonderzeichen). Jedes Zeichen einer ANSI-Zeichenfolge wird durch einen 8-Bit-Wert (1 Byte) dargestellt. Um fremdländische Zeichen anzeigen zu können, muss die zur Sprache passende Codepage installiert werden. Die Zeichen in einer Unicode-Zeichenfolge sind dagegen durch einen 16-Bit-Wert (2 Bytes) kodiert. Somit können insgesamt mehr als 65000 verschiedene Zeichen kodiert werden, wodurch die Zeichen aller auf der ganzen Welt bekannten Sprachen in einem einzigen Zeichensatz verfügbar gemacht werden können.

Windows NT/2000/XP ist von Grund auf für den Einsatz von Unicode konzipiert. Alle Kernfunktionen zum Erstellen von Fenstern, Darstellen von Text, Bearbeiten von Zeichenfolgen usw. erwarten Unicode-Zeichenfolgen. Wenn irgendeiner Windows-Funktion eine ANSI-Zeichenfolge übergeben wird, wandelt das System sie zuerst in eine Unicode-Zeichenfolge um und übergibt diese dann dem Betriebssystem. Falls eine Anwendung von einer Funktion eine ANSI-Zeichenfolge als Ergebnis erwartet, wandelt das System die Unicode-Zeichenfolge um, bevor es sie an die Anwendung übergibt. All diese Umwandlungen geschehen im Verborgenen. Natürlich bringt es eine zeitliche Verzögerung mit sich, wenn das System all diese Zeichenfolgenumwandlungen durchführen muss. Die Anwendung benötigt mehr Speicher und wird obendrein auch noch langsamer ausgeführt.

SpeedCommander wird von uns daher in zwei Versionen angeboten. Die Ansi-Version läuft unter allen Windows-Systemen, während die Unicode-Version nur auf NT-Systemen (NT/2000/XP/2003) funktioniert. Wenn Sie zwischen den einzelnen Versionen wechseln möchten, so deinstallieren Sie bitte vorher die aktuelle SpeedCommander-Installation, damit das Installationsverzeichnis nicht unnötig viele Programmdateien enthält. Die Einstellungen sind untereinander kompatibel und können beibehalten werden.


64-Bit-Version für Windows XP x64

SpeedCommander: Allgemeine Informationen
64-Bit-Version für Windows XP x64

SpeedCommander wird zusätzlich auch als native Version für Windows XP x64 angeboten und bietet somit auch vollständigen Zugriff auf alle Ordner von Windows XP x64. Der Freischaltkey ist für beide Versionen gültig, für die 64-Bit-Version muss daher kein separater Freischaltkey erworben werden.

Hinweise zur 64-Bit-Version von SpeedCommander
  1. Die Anzeige und das Entpacken von ACE-Archiven ist nicht möglich, da der Hersteller noch keine 64-Bit-DLL zur Verfügung stellen konnte.
  2. Die Integration von Windows Media Player, Quicktime und RealPlayer ist nicht möglich, da diese Produkte derzeit nur als 32-Bit-Version vorliegen.
  3. 32-Bit-AddIns können in der 64-Bit-Version nicht verwendet werden.


Credits

SpeedCommander: Allgemeine Informationen
Credits

Besonderer Dank geht an folgende Personen, die uns bei der Entwicklung des SpeedCommanders direkt oder indirekt geholfen haben:

Programmierung

CodeJock Software, Stas Levin, Andrei Stcherbatchenko, Ferdinand Prantl, Sven Wiegand, Cristi Posea, Selom Ofori, Jan Patera

Grafiken

Alexandra C. Kornblum, Marc Keeley

Betatester

Alexander Möckel, André Kreitlein, Dieter Schmelich, Eric Unterberg, Gerald Mahlmeister, Hans-Josef Krey, Henrik Heimbürger, Klaus Schitteck, Martin Sperlich, Matthias Reissmann, Michael Baas, Michael Buck, Ralf Kreutzmann, Ulf Schikore, Wolfgang Rölleke


Technische Unterstützung

SpeedCommander: Allgemeine Informationen
Technische Unterstützung

Registrierung von SpeedCommander

Bitte nehmen Sie sich einen Moment Zeit, um Ihre Lizenz von SpeedCommander unter http://register.speedproject.de/ zu registrieren. Als registrierter Anwender werden Sie stets über neue Versionen informiert.

Support per Telefon oder Post

JDS-Software
Jens Driese
Postfach 1269
26302 Varel

Telefon: 0 44 51 - 95 91 95
Telefax: 0 44 51 - 95 91 96

Internet: http://www.jds-software.com/
E-Mail: bestell@jds-software.com

Bürozeiten:
Montag - Freitag von 10.00h bis 13.00h
und Montag - Donnerstag von 15.00h bis 18.00h

Support per Internet

Auf der Internet-Adresse http://www.speedproject.de/ finden Sie Informationen über weitere Produkte, Antworten auf technische Fragen und Probleme sowie aktualisierte Versionen von SpeedCommander. Anfragen per E-Mail richten Sie bitte an support@speedproject.de. Bitte geben Sie unbedingt Ihre Seriennummer an, ohne diese kann Ihre Anfrage nicht bearbeitet werden.

Anregungen und Verbesserungsvorschläge schreiben Sie bitte an feedback@speedproject.de.

Anwenderforum

Im Anwenderforum können Sie mit dem Entwickler und anderen Anwendern diskutieren.


Arbeiten mit den Fenstern

SpeedCommander: Arbeiten mit den Fenstern
Überblick

Der SpeedCommander zeigt ein Laufwerksfenster und zwei Ordnerfenster an. Sie können wählen, wie die Fenster dargestellt werden, welche Dateien in die Dateiliste aufgenommen werden und in welcher Reihenfolge sie erscheinen sollen. Diese Optionen finden Sie im Menü Ansicht.

Außerdem können Sie die Größe der Fenster ändern, indem Sie die Leiste zwischen den beiden Fenstern in die gewünschte Richtung ziehen oder eine vordefinierte Größe im Menü Ansicht | Fensterteilung wählen.

Standardmäßig werden die Ordnerfenster nebeneinander angezeigt. Möchten Sie die Ordnerfenster untereinander anzeigen, so öffnen Sie das Menü Ansicht, zeigen Sie auf Darstellung und wählen Sie den Befehl Dateifenster untereinander.

Weitere Informationen

Laufwerksfenster

Ordnerfenster

Dateiablage

Informationsfenster

DOS-Eingabezeile

DOS-Ausgabefenster

QuickDrop-Symbole

Fensterteilung

Verwenden von SmartSets

Aktualisierung von Fenstern


Laufwerksfenster

SpeedCommander: Arbeiten mit den Fenstern
Laufwerksfenster

Mit Hilfe des Laufwerksfensters wählen Sie das Laufwerk aus, für das Sie eine Dateiliste anzeigen möchten. Neben den Symbolen für die lokalen Laufwerke auf Ihrem System können zusätzlich noch drei weitere Symbole angezeigt werden. Dabei handelt es sich um virtuelle Laufwerke für die Netzwerkumgebung, das Internet und FTP. Je nach Ausstattung Ihres Systems kann es sein, dass nicht alle virtuellen Laufwerke angezeigt werden. Ist Ihr Computer beispielsweise nicht an ein Netzwerk angeschlossen, wird auch kein Symbol für die Netzwerkumgebung angezeigt.

Darstellung der Laufwerksauswahl

Der SpeedCommander bietet Ihnen die Wahl zwischen drei verschiedenen Ansichten. Die Umschaltung zwischen den Ansichten erfolgt im Menü Ansicht über das Untermenü Darstellung.

Typ | Bedeutung
Laufwerksauswahl als Kombinationsfeld | Stellt die Laufwerke in jeweils einem Kombinationsfeld über den Ordnerfenstern dar.
Laufwerksauswahl als Leiste | Stellt die Laufwerke in einer Leiste dar. Jedes Ordnerfenster bekommt eine eigene Leiste zugeordnet.
Gemeinsame Laufwerksleiste | Stellt die Laufwerke in einer Leiste dar. Die Leiste bezieht sich auf das aktive Ordnerfenster.

Ausblenden von virtuellen Laufwerken

Sie können die Symbole für die Netzwerkumgebung, das Internet oder für FTP auch ausblenden, wenn Sie die jeweilige Funktion nicht nutzen möchten. Öffnen Sie dazu den Einstellungsdialog und deaktivieren Sie im Dialogfeld Darstellung die Symbole, die Sie nicht in der Laufwerksleiste anzeigen möchten.

Weitere Informationen

Auswählen eines Laufwerks

Aktualisieren


Auswählen eines Laufwerks

SpeedCommander: Arbeiten mit den Fenstern
Auswählen eines Laufwerks

Die Auswahl eines Laufwerks kann über die Tastatur oder mit der Maus erfolgen. Um ein Laufwerk mit der Maus auszuwählen, klicken Sie einfach mit der linken Maustaste auf das gewünschte Laufwerk. Der Inhalt des Laufwerks wird dann im jeweiligen Ordnerfenster angezeigt.

Der SpeedCommander wechselt immer in das zuletzt angezeigte Verzeichnis des jeweiligen Laufwerks. Wenn z.B. im linken Ordnerfenster der Ordner "C:\Windows" angezeigt wird, dann wird bei der Auswahl des Laufwerks "C" für das rechte Ordnerfenster auch hier gleich nach "C:\Windows" gewechselt. Halten Sie beim Klicken mit der linken Maustaste einfach die Umschalt-Taste gedrückt, wenn Sie stattdessen in das Hauptverzeichnis des Laufwerks wechseln möchten.

So wählen Sie ein Laufwerk mit der Tastatur:
  1. Drücken Sie Alt+F1, um das Laufwerk für das linke Fenster auszuwählen, oder Alt+F2, um das Laufwerk für das rechte Fenster auszuwählen.
  2. Wählen Sie das gewünschte Laufwerk mit einer der folgenden Methoden aus: Drücken Sie auf der Tastatur den Buchstaben bzw. die Zahl für das gewünschte Laufwerk oder verwenden Sie den Cursor zur Auswahl des Buchstabens, und drücken Sie Eingabe.
  3. Im Ordnerfenster werden nun die Dateien des gewählten Laufwerks angezeigt.


Laufwerksfenster aktualisieren

SpeedCommander: Arbeiten mit den Fenstern
Laufwerksfenster aktualisieren

Der SpeedCommander aktualisiert das Laufwerksfenster selbständig im Hintergrund. Er beobachtet, ob in Windows neue Laufwerke an- oder abgemeldet werden oder ob sich das Symbol oder der Name eines Laufwerks geändert hat.

Sollten die Informationen jedoch einmal nicht korrekt sein, so können Sie das Laufwerksfenster auch manuell aktualisieren. Klicken Sie einfach mit der rechten Maustaste in den freien Bereich des Laufwerksfensters und wählen Sie aus dem Kontextmenü den Befehl Aktualisieren.


Ordnerfenster

SpeedCommander: Arbeiten mit den Fenstern
Ordnerfenster

Das Ordnerfenster bietet die Grundlage für viele Funktionen im SpeedCommander. Es dient zur Darstellung der Dateien und Ordner eines Laufwerks. Der SpeedCommander erlaubt unter Beibehaltung des bewährten Zwei-Fenster-Layouts das Erstellen von beliebig vielen Ordnerfenstern.

So legen Sie ein neues Ordnerfenster an:
  • Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Neues Ordnerfenster oder drücken Sie Strg+N.
So aktivieren Sie ein verdecktes Ordnerfenster:
  • Klicken Sie mit der linken Maustaste auf die Registerkarte mit dem Namen des Ordnerfensters oder
  • Drücken Sie Strg+Tab, um zum nächsten Ordnerfenster zu gelangen oder Strg+Umschalt+Tab, um zum vorherigen Ordnerfenster zu gelangen oder
  • Drücken Sie Strg+[Fensternummer].
So löschen Sie ein nicht mehr benötigtes Ordnerfenster:
  1. Aktivieren Sie das Ordnerfenster, welches Sie nicht mehr benötigen.
  2. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Ansicht schließen.
So ordnen Sie die Reihenfolge der Ordnerfenster neu:
  1. Aktivieren Sie ein Ordnerfenster.
  2. Öffnen Sie das Menü Ansicht und zeigen Sie auf Ordnerfenster.
  3. Wählen Sie den Befehl Ansicht nach rechts verschieben, um das aktive Ordnerfenster um eine Position nach rechts zu verschieben.
  4. Wählen Sie den Befehl Ansicht nach links verschieben, um das aktive Ordnerfenster um eine Position nach links zu verschieben.

Weitere Informationen

Anzeige von Dateien und Ordnern

Baumansicht

Feldauswahl

Dateien sortieren

Aktualisieren

Basisordner verwenden

Ordnerfenster synchronisieren

Ordnerhierarchie

Zweigansicht


Anzeige von Dateien und Ordnern

SpeedCommander: Arbeiten mit den Fenstern
Anzeige von Dateien und Ordnern

SpeedCommander stellt Ihnen mehrere Möglichkeiten zur Verfügung, wie Sie Dateien und Ordner anzeigen können. Die Umschaltung der verschiedenen Ansichten erfolgt über das Menü Ansicht.

Ansicht | Erklärung
Miniaturansicht | In der Miniaturansicht wird ein Ordnersymbol so angezeigt, dass sich das Symbol aus bis zu vier Bilddateien des untergeordneten Ordners zusammensetzt. Der Inhalt des Ordners kann damit rasch erkannt werden. Wenn Sie z.B. Bilder in verschiedenen Ordnern gespeichert haben, können Sie in der Miniaturansicht auf einen Blick erkennen, welcher Ordner die von Ihnen gesuchten Bilder enthält.
Kacheln | In dieser Ansicht werden die Dateien und Ordner als Symbole angezeigt. Die Informationen zur gewählten Sortierung werden unter dem Datei- oder Ordnernamen angezeigt. Wenn Sie beispielsweise Dateien nach dem Dateityp sortieren möchten, wird bei einem Microsoft Word-Dokument "Microsoft Word-Dokument" unterhalb des Dateinamens angezeigt. Diese Ansicht steht erst ab Windows XP zur Verfügung.
Symbole | In dieser Ansicht werden die Dateien und Ordner als Symbole angezeigt. Der Dateiname wird unterhalb des Symbols angezeigt; Informationen zur Sortierung werden hingegen nicht aufgeführt. In dieser Ansicht können Sie Dateien und Ordner in Gruppen anzeigen.
Liste | In dieser Ansicht wird der Inhalt eines Ordners als eine Liste aus Datei- oder Ordnernamen angezeigt, denen kleine Symbole vorangestellt sind. Diese Ansicht empfiehlt sich dann, wenn der Ordner viele Dateien enthält und Sie die Liste nach einem bestimmten Dateinamen durchsuchen möchten. Sie können die Dateien und Ordner in dieser Ansicht sortieren, Sie können die Dateien jedoch nicht in Gruppen anzeigen.
Details | In dieser Ansicht zeigt SpeedCommander den Inhalt des geöffneten Ordners in einer Liste an und stellt ausführliche Informationen zu den Dateien, einschließlich Name, Typ, Größe und Änderungsdatum bereit. Sie können die Dateien in dieser Ansicht auch in Gruppen anzeigen.
Ansicht in Gruppen

Durch das Anzeigen in Gruppen können Sie die Dateien abhängig von jedem Detail der Datei, wie Name, Größe, Typ oder Änderungsdatum, gruppieren. Wenn Sie beispielsweise nach dem Dateityp sortieren, werden Bilddateien in einer Gruppe angezeigt, während Microsoft Word-Dateien in einer anderen Gruppe und Excel-Dateien in einer dritten Gruppe angeordnet werden. Das Anzeigen in Gruppen steht in den Ansichten Kacheln, Symbole und Details zur Verfügung. Zur Anzeige der Dateien in Gruppen zeigen Sie im Menü Ansicht auf Symbole anordnen nach, und klicken Sie dann auf In Gruppen anzeigen. Beachten Sie bitte, dass diese Funktion nur ab Windows XP unterstützt wird.


Baumansicht

SpeedCommander: Arbeiten mit den Fenstern
Baumansicht

Mit Hilfe der Dateiliste wird eine Liste der Ordner und Dateien auf dem aktuellen Laufwerk angezeigt. Wenn Sie einen Ordner auswählen, sehen Sie die darin enthaltenen Unterordner und Dateien. In der Statuszeile unter dem Ordnerfenster werden Informationen zur ausgewählten Datei angezeigt.

Zusätzlich zur Dateiliste kann auch eine Baumansicht eingeblendet werden. Öffnen Sie dazu das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Baumansicht. Mit Hilfe der Baumansicht können Sie ein Baumdiagramm für das aktuelle Laufwerk anzeigen. Während Sie sich durch die Baumansicht bewegen, werden die Dateien und vorhandene Unterordner des jeweils ausgewählten Ordners in der Dateiliste angezeigt. Durch Doppelklicken können Sie in der Baumansicht Unterordner ein- oder ausblenden. Der in der Baumansicht hervorgehobene Ordner wird zum jeweils aktuellen Ordner.

Neben den Ordnern des Dateisystems zeigt SpeedCommander auf Wunsch auch Archive innerhalb der Baumansicht an. Wenn Sie dies nicht möchten, dann können Sie diese Funktion im Einstellungsdialog Dateien & Ordner deaktivieren.

Beachten Sie bitte, dass die Baumansicht nur für lokale Laufwerke sowie für die Netzwerkumgebung eingeblendet werden kann.


Feldauswahl

SpeedCommander: Arbeiten mit den Fenstern
Feldauswahl

In der Ansicht Details zeigt SpeedCommander zusätzliche Informationen zu jeder Datei an. Sie können selbst festlegen, welche Informationen Sie angezeigt haben möchten. Die angebotenen Informationen sind abhängig vom jeweiligen Betriebssystem, SpeedCommander bindet alle im System installierten Spaltenerweiterungen für den Windows Explorer ein. Ab Windows XP sind das z.B. umfangreiche Informationen zu MP3-Dateien (Titel, Interpret, Album, Dauer) und Bilddateien (Abmessungen, Aufnahmedatum und Kamera).

So ändern Sie angezeigten Details:
  1. Klicken Sie mit der rechten Maustaste auf eine Spalte im oberen Bereich des Ordnerfensters. Wählen Sie im Kontextmenü den Befehl Feldauswahl.
  2. Um eine Spalte einem Ordnerfenster hinzuzufügen, ziehen Sie die entsprechende Spalte per Drag & Drop aus dem Dialogfeld Feldauswahl an die gewünschte Position im Ordnerfenster.
  3. Wenn Sie eine Spalte entfernen möchten, dann ziehen Sie die gewünschte Spalte einfach per Drag & Drop vom Ordnerfenster in das Dialogfeld Feldauswahl.

Sie können bis auf die Spalte Name auch die Textausrichtung jeder einzelnen Spalte ändern. Dies bietet sich an, wenn Sie z.B. die Attribute einer Datei nicht links- sondern rechtsbündig angezeigt haben möchten.

So ändern Sie die Ausrichtung einer Spalte:
  1. Klicken Sie mit der rechten Maustaste auf die Spalte, deren Ausrichtung Sie ändern möchten.
  2. Zeigen Sie im Kontextmenü auf Ausrichtung und wählen Sie die gewünschte Ausrichtung.

Die folgende Tabelle zeigt alle von SpeedCommander zur Verfügung gestellten Informationen für Dateien und Ordner:

Detail | Bedeutung
Name | Name der Datei oder des Ordners
Typ | Typ der Datei
Größe | Größe der Datei
Geändert | Datum, an dem die Datei zuletzt geändert wurde
Attribute | Dateiattribute
Erweiterung | Erweiterung der Datei
Letzter Zugriff | Datum, an dem zum letzten Mal auf die Datei zugegriffen wurde
Erstellt | Datum, an dem die Datei erstellt wurde
8.3-Name | Name der Datei im 8.3-Format
Spezielle Anpassungen für einige Spaltenerweiterungen

Einige Spaltenerweiterungen werden nur in bestimmen Ordnern angezeigt, dazu gehört z.B. die Spaltenerweiterung von TortoiseCVS. Da die Initialisierung aller Spaltenerweiterungen nur beim Start von SpeedCommander erfolgt, können mit einem zusätzlichen Schalter in der Einstellungsdatei SpeedCommander.xml zusätzliche Ordner für die Initialisierung angegeben werden:

<Settings>
  <SpeedCommander>
    <Settings>
      <ColumnHandlers>
        <InitFolders Items="1" Item0="C:\\CVS-Projekt"/>
      </ColumnHandlers>
    </Settings>
  </SpeedCommander>
</Settings>

Wenn also TortoiseCVS installiert ist und sich der Ordner C:\CVS-Projekt unter Quellcodekontrolle befindet, dann muss dieser Ordner in der Sektion InitFolders eingetragen werden. Das Attribut Items legt die Anzahl der zusätzlichen Ordner fest, die Ordner werden unter den Attributen Item0 bis Item99 eingetragen. Bitte beachten Sie, dass in der Einstellungsdatei bei Pfadangaben ein doppelter Backslash (\\) erfolderlich ist.

Für jede Spaltenerweiterung, die einen speziellen Initialisierungsordner benötigt, muss immer nur ein Ordner angegeben werden. Bei TortoiseCVS reicht also die Angabe eines Ordners, der unter Quellcodekontrolle steht.


Dateien sortieren

SpeedCommander: Arbeiten mit den Fenstern
Dateien sortieren

In der Listenansicht können Sie festlegen, wie die Dateien sortiert werden sollen. Sie können u.a. nach Name, Erweiterung, Zeit, Größe oder Attribute sortiert werden. Die Standardeinstellung entspricht einer Sortierung nach Namen. Sie können die Sortierung entweder mit Menübefehlen oder mit Funktionstastenkombinationen auswählen.

So sortieren Sie Dateien mit Menübefehlen:
  1. Öffnen Sie das Menü Ansicht und zeigen Sie auf Symbole anordnen.
  2. Wählen Sie das gewünschte Sortierkriterium mit der Auswahlleiste oder mit der Maus aus.
Kriterium | Ergebnis
Name | Sortiert alphabetisch nach Dateinamen in aufsteigender Folge.
Typ | Sortiert alphabetisch nach Dateityp in aufsteigender Folge.
Geändert | Sortiert nach Datum und Zeit der letzten Änderung, die zuletzt bearbeitete Datei erscheint am Anfang der Liste.
Größe | Sortiert nach Dateigröße, die größte Datei erscheint am Anfang der Liste.
Attribute | Sortiert nach Dateiattribute.
Erweiterung | Sortiert alphabetisch nach Dateierweiterungen in aufsteigender Folge.
Einsparung | Sortiert nach Einsparung (nur bei Archiven).
Komprimierte Größe | Sortiert nach komprimierter Größe (nur bei Archiven).
CRC | Sortiert nach CRC (nur bei Archiven).
System | Sortiert nach Betriebssystem (nur bei Archiven).
Methode | Sortiert nach der Komprimiermethode (nur bei Archiven).
Ordner | Sortiert nach Ordner (nur bei Archiven).
Letzer Zugriff | Sortiert nach Datum und Zeit des letzten Zugriffs (nur im Dateisystem).
Erstellt | Sortiert nach Datum und Zeit der Erstellung (nur im Dateisystem).
Besitzer | Sortiert nach Besitzer (nur im Dateisystem).
Titel | Sortiert nach Titel (nur im Dateisystem).
Thema | Sortiert nach Thema (nur im Dateisystem).
Autor | Sortiert nach Autor (nur im Dateisystem).
Kommentar | Sortiert nach dem Kommentar (nur im Dateisystem, bei Archiven oder in der Netzwerkumgebung).
Kategorie | Sortiert nach der Kategorie, in welche die Dateien eingeordnet werden (nur im Dateisystem).
Seiten | Sortiert nach der Anzahl der Seiten im Dokument (nur im Dateisystem).
Copyright | Sortiert nach dem Copyright der Multimediadateien (nur im Dateisystem ab XP)
Interpret | Sortiert nach dem Interpret der Musikdateien (nur im Dateisystem ab XP)
Album | Sortiert nach dem Album, zu welcem die Musikdateien gehören (nur im Dateisystem ab XP)
Jahr | Sortiert nach Jahr der Aufnahme (nur im Dateisystem ab XP)
Titelnummer | Sortiert nach Titelnummer der Musikdateien (nur im Dateisystem ab XP)
Genre | Sortiert nach Genre, zu welchem die Musikdateien gehört (nur im Dateisystem ab XP)
Dauer | Sortiert nach Abspiellänge der Musik- oder Videodateien (nur im Dateisystem ab XP)
Bitrate | Sortiert nach Bitrate der Musik- oder Videodateien (nur im Dateisystem ab XP)
Geschützt | Sortiert nach DRM-Schutz der Musikdateien (nur im Dateisystem ab XP)
Kameramodell | Sortiert nach Kamera, mit der die JPEG-Bilder aufgenommen wurden (nur im Dateisystem ab XP)
Aufgenommen am | Sortiert nach Aufnahmezeitpunkt der JPEG-Bilder (nur im Dateisystem ab XP)
Abmessungen | Sortiert nach Abmessungen der Grafik- oder Videodateien (nur im Dateisystem ab XP)
Firma | Sortiert nach dem Namen der Firma, welche die Programmdateien erstellt hat (nur im Dateisystem)
Beschreibung | Sortiert nach der Beschreibung der Programmdateien (nur im Dateisystem)
Dateiversion | Sortiert nach der Versionsnummer der Programmdateien (nur im Dateisystem)
Produktname | Sortiert nach dem Namen des Produkts, zu welchem die Programmdateien gehört (nur im Dateisystem)
Produktversion | Sortiert nach der Versionsnummer des Produkts (nur im Dateisystem)
8.3-Name | Sortiert nach dem Namen der Dateien im 8.3-Format (nur im Dateisystem)
Server | Sortiert nach dem Server (nur bei FTP-Standorten)
Letzter Besuch | Sortiert nach dem letzten Besuch (nur bei FTP-Standorten)

Wenn Sie dieselbe Sortieroption zweimal wählen, wird die Reihenfolge umgekehrt. Wenn Sie also z.B. "Größe" wählen, erscheint zunächst die größte Datei am Anfang der Liste; nach erneuter Auswahl von "Größe" wird die Sortierfolge umgekehrt.

So sortieren Sie die Dateien mit den Funktionstastenkombinationen:
Um folgendes zu tun: | Drücken Sie:
Nach dem Namen sortieren | Strg+F3
Nach der Erweiterung sortieren | Strg+F4
Nach der Zeit sortieren | Strg+F5
Nach der Größe sortieren | Strg+F6
Nach den Attributen sortieren | Strg+F7


Ordnerfenster aktualisieren

SpeedCommander: Arbeiten mit den Fenstern
Ordnerfenster aktualisieren

Die Aktualisierung der Ordnerfenster erfolgt bei Änderungen im Dateisystem weitgehend automatisch. Der SpeedCommander beobachtet im Hintergrund, ob im Ordner des linken und rechten Fensters Dateien erstellt, gelöscht oder umbenannt werden, und aktualisiert gegebenenfalls die entsprechende Ansicht selbstständig.

Die automatische Aktualisierung ist jedoch nur bei lokalen Laufwerken möglich. Bei Netzlaufwerken muss die Aktualisierung manuell vorgenommen werden.

Die Hintergrundaktualisierung kann auch abgeschaltet werden. Öffnen Sie dazu im Einstellungsdialog die Seite Ordner & Laufwerke und deaktivieren Sie hier die Option Hintergrundaktualisierung. Bei deaktivierter Hintergrundaktualisierung werden die Ordnerfenster nur aktualisiert, wenn der SpeedCommander aktiviert und in den Vordergrund gebracht wird.

So aktualisieren Sie die Fenster manuell:
  • Wählen Sie aus dem Menü Ansicht den Befehl Aktualisieren. Sie können stattdessen auch das Symbol Aktualisieren in der Symbolleiste verwenden.


Basisordner verwenden

SpeedCommander: Arbeiten mit den Fenstern
Basisordner verwenden

Normalerweise zeigt der SpeedCommander beim Start in jedem Ordnerfenster den Ordner an, der beim Beenden aktiv war. Sie können jedoch einen Basisordner definieren, wenn Sie möchten, dass beim Start immer ein bestimmter Ordner angezeigt wird.

SpeedCommander bietet Ihnen auch die Möglichkeit, die Navigation in einem Ordnerfenster einzuschränken. Sie können z.B. den Laufwerkswechsel und den Wechsel in über- bzw. untergeordnete Ordner sperren.

So definieren Sie einen Basisordner:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Eigenschaften des Ordnerfensters.
  2. Aktivieren Sie das Kontrollkästchen Navigation einschränken und/oder Basisordner verwenden.
  3. Tragen Sie im Feld Basisordner den Ordner ein, den der SpeedCommander bei jedem Start in diesem Ordnerfenster anzeigen soll.
So schränken Sie die Navigation ein:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Eigenschaften des Ordnerfensters.
  2. Aktivieren Sie das Kontrollkästchen Navigation einschränken und/oder Basisordner verwenden.
  3. Tragen Sie im Feld Basisordner den Ordner ein, den der SpeedCommander bei jedem Start in diesem Ordnerfenster anzeigen soll.
  4. Aktivieren Sie das Kontrollkästchen Laufwerkswechsel sperren, wenn in diesem Ordnerfenster nur Wechsel innerhalb des gleichen Laufwerks möglich sein sollen.
  5. Aktivieren Sie das Kontrollkästchen Wechsel in untergeordnete Ordner sperren, wenn in diesem Ordnerfenster keine Wechsel in untergeordnete Ordner möglich sein sollen.
  6. Aktivieren Sie das Kontrollkästchen Wechsel in übergeordnete Ordner sperren, wenn in diesem Ordnerfenster keine Wechsel in übergeordnete Ordner möglich sein sollen.
  7. Aktivieren Sie das Kontrollkästchen Bei Aktivierung in den Basisordner wechseln, wenn bei jeder Aktivierung des Ordnerfensters in den Basisordner gewechselt werden soll.
So stellen Sie weitere Eigenschaften ein:
  1. Aktivieren Sie das Kontrollkästchen Bei Aktivierung immer aktualisieren, wenn der Inhalt des Ordnerfensters bei jeder Aktivierung neu eingelesen werden soll.
  2. Aktivieren Sie das Kontrollkästchen Name automatisch an aktuellen Ordner anpassen, wenn die Registerkarte immer den Namen des aktuellen Ordners tragen soll.


Ordnerfenster synchronisieren

SpeedCommander: Arbeiten mit den Fenstern
Ordnerfenster synchronisieren

Alle Ordnerfenster verhalten sich in der Grundeinstellung voneinander unabhängig. Wenn Sie z.B. in einem Ordnerfenster ein neues Laufwerk wählen, so bleibt der in den anderen Fenstern aktivierte Ordner immer erhalten. Mit der Funktion Ordnerfenster synchronisieren wird der in den verschiedenen Ordnerfenstern angezeigte Ordner jedoch immer abgeglichen. Dies ermöglicht es Ihnen über das ganze Dateisystem hinweg unterschiedliche Sichten auf die gleichen Daten. Dieses Verhalten ist z.B. sehr hilfreich, wenn die Dateien eines Ordners immer wieder nach verschiedenen Kriterien sortiert oder gefiltert werden müssen.

So aktivieren Sie die Synchronisation der Ordnerfenster:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Ordnerfenster synchronisieren oder drücken Sie Strg+Umschalt+E.
  2. Wählen Sie den gleichen Befehl, um die Synchronisation der Ordnerfenster zu beenden.

Bitte beachten Sie, dass im Einstellungsdialog Ordner und Laufwerke die Option Ausgewählter Filter gilt für alle Ordnerfenster gleichzeitig deaktiviert werden muss, um für die verschiedenen Ordnerfenster unterschiedliche Filter einstellen zu können.

Weitere Informationen

Sortieren von Dateien

Dateifilter

Verwenden von Layouts


Ordnerhierarchie

SpeedCommander: Arbeiten mit den Fenstern
Ordnerhierarchie

Im Ordnerhierarchie-Menü werden alle Ebenen vom aktuellen Ordner bis zum jeweiligen Hauptordner angezeigt. Damit wird der Wechsel in übergeordnete Ordner sehr vereinfacht.

So aktivieren Sie das Ordnerhierarchie-Menü:
  1. Klicken Sie in der Titelzeile des Ordnerfensters mit der linken Maustaste auf das Symbol Ordnerhierarchie.
  2. Aktivieren Sie das Menü Ordner und zeigen Sie auf Ordnerhierarchie.
  3. Drücken Sie Strg+Rücktaste.
So wechseln Sie schnell in einen Ordner:
  1. Aktivieren Sie das Ordnerhierarchie-Menü.
  2. Wählen Sie den Ordner aus, in den Sie wechseln möchten.


Zweigansicht

SpeedCommander: Arbeiten mit den Fenstern
Zweigansicht

Normalerweise werden in einem Ordnerfenster immer nur die Dateien und Unterordner eines Ordners angezeigt. Mit Hilfe der Zweigansicht kann SpeedCommander alle Dateien aus allen Unterordnern des aktuellen Ordners anzeigen. Dies ist nützlich, wenn Sie sich einen Überblick über sämtliche Dateien verschaffen möchten, die sich in bzw. unterhalb eines Ordners befinden.

Das Einlesen aller Dateien kann besonders bei größeren Ordnern etwas länger dauern, Sie sollten diese Funktion daher nicht im Hauptverzeichnis einer größeren Festplatte verwenden. Sie können das Einlesen der Dateien aber jederzeit durch Drücken von ESC abbrechen.

So aktivieren Sie die Zweigansicht:
  1. Öffnen Sie das Menü Ordner und wählen Sie den Befehl Zweigansicht oder drücken Sie Strg+T.
  2. Wählen Sie denselben Befehl, um die Zweigansicht wieder zu deaktivieren.


Dateiablage

SpeedCommander: Arbeiten mit den Fenstern
Dateiablage

Oftmals sind häufig bzw. regelmäßig benötigte Dateien über alle Laufwerke und in den verschiedensten Ordnern verstreut. Gerade wenn häufig Dateien aus tief verschachtelten Ordnern oder aus Ordnern mit sehr vielen Dateien benötigt werden ist die typische Dateiauswahl ein wenig umständlich.

Die Dateiablage des SpeedCommander ist im Prinzip ein Container, mit dem häufig oder regelmäßig benutzte Dateien verwaltet werden können. In der Dateiablage werden nicht die Dateien selbst sondern nur Verweise auf die entsprechenden Dateien gespeichert, damit nicht unnötig Festplattenplatz verschwendet und damit vor allen Dingen immer auf die aktuelle Version einer Datei zugegriffen wird.

Die Dateiablage verhält sich wie ein ganz normales Ordnerfenster, d.h. die Einträge in der Dateiablage können gefiltert, gelöscht, kopiert, komprimiert usw. werden, entsprechend universell kann die Dateiablage genutzt werden.

So aktivieren Sie eine Dateiablage:
  • Klicken Sie unterhalb des Ordnerfensters auf die Registerkarte Dateiablage.
  • Drücken Sie Strg+Umschalt+Bild nach unten bzw. Strg+Umschalt+Bild nach oben, um zwischen Ordnerfenster und Dateiablage zu wechseln.
So fügen Sie eine neue Dateiablage hinzu:
  1. Aktivieren Sie die Dateiablagen-Ansicht.
  2. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Neue Dateiablage oder drücken Sie Strg+Umschalt+N.
So entfernen Sie eine nicht mehr benötigte Dateiablage:
  1. Aktivieren Sie die Dateiablage, welche Sie nicht mehr benötigen.
  2. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Ansicht schließen.

Weitere Informationen

Hinzufügen und Entfernen von Dateien

Auswahl laden und speichern


Hinzufügen und Entfernen von Dateien

SpeedCommander: Arbeiten mit den Fenstern
Hinzufügen und Entfernen von Dateien

Bevor Sie mit der Dateiablage arbeiten können, müssen Sie die Dateiablage mit Dateien füllen. Wählen Sie dazu im Ordnerfenster die Dateien aus, die Sie in die Dateiablage übernehmen möchten und wählen Sie aus dem Menü Datei den Befehl Kopieren. Sie können die Dateien auch mit Drag & Drop in die Dateiablage ziehen. Da die Dateiablage nicht auf Dateien eines Ordners begrenzt ist, können Sie diesen Schritt auch beliebig oft wiederholen.

Wenn Sie die Dateiverknüpfungen nicht mehr benötigen, können Sie diese auch wieder aus der Dateiablage entfernen.

So entfernen Sie Dateiverknüpfungen aus der Dateiablage:
  1. Markieren Sie die Dateien, die Sie entfernen möchten.
  2. Wählen Sie im Menü Datei den Befehl Löschen.
Wichtiger Hinweis

Bitte seien Sie beim Löschen aus der Dateiablage besonders vorsichtig. Die Befehle Löschen und Löschen in den Papierkorb aus dem Menü Datei entfernen nur die Verknüpfungen aus der Dateiablage, die Dateien selbst bleiben erhalten. Mit dem Befehl Sicheres Löschen bzw. mit dem Befehl Löschen aus dem Windows-Kontextmenü einer Datei wird die Datei aber richtig gelöscht. Die Verknüpfung der Datei bleibt jedoch erhalten.


Auswahl laden und speichern

SpeedCommander: Arbeiten mit den Fenstern
Auswahl laden und speichern

Mit Hilfe der Befehle Auswahl laden und Auswahl speichern können die markierten Einträge in eine Datei speichern bzw. die Auswahl aus einer Datei wiederherstellen.

So speichern Sie eine Auswahl in eine Datei:
  1. Markieren Sie die Dateien, deren Auswahl Sie speichern möchten.
  2. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Auswahl der Dateiablage speichern.
  3. Geben Sie im Dialogfeld Auswahl speichern einen Dateinamen an, in den Sie die Auswahl speichern möchten.
So laden Sie eine Auswahl aus einer Datei:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Auswahl in Dateiablage laden.
  2. Wählen Sie im Dialogfeld Auswahl laden den Dateinamen, der die zu ladende Auswahl enthält.


Informationsfenster

SpeedCommander: Arbeiten mit den Fenstern
Informationsfenster

Neben den Ordnerfenstern zur Anzeige von Dateien und Ordnern verwendet der SpeedCommander zusätzliche Fenster zur Darstellung bestimmter Informationen. Diese Informationsfenster werden immer auf der gegenüberliegenden Seite des aktiven Ordnerfensters eingeblendet.

Das Ein- und Ausblenden der Informationsfenster erfolgt über das Untermenü Ordnerfenster des Menüs Ansicht. Aktivieren Sie einfach den jeweiligen Befehl, um das entsprechende Fenster einzublenden. Deaktivieren Sie den Befehl, wenn Sie das Informationsfenster wieder ausblenden möchten.

Weitere Informationen

Laufwerksstatus

Schnellansicht

Ordnerinformation


Laufwerksstatus

SpeedCommander: Arbeiten mit den Fenstern
Laufwerksstatus

Dieses Informationsfenster bietet Angaben zum aktuellen Laufwerk. Wählen Sie im Menü Ordnerfenster aus dem Menü Ansicht den Befehl Laufwerksstatus, um das Informationsfenster anzeigen.

Um dieses Informationsfenster wieder auszublenden, wählen Sie erneut den Befehl Laufwerksstatus aus dem Menü Ordnerfenster.

Folgende Informationen werden angezeigt:
  • Datenträgerbezeichnung
  • Seriennummer des Laufwerks
  • Typ des Dateisystems
  • Laufwerkstyp
  • Speicherkapazität des Laufwerks
  • Größe des verfügbaren Speichers auf dem Laufwerk
  • Informationen zur Anzahl der Cluster und Sektoren
  • Angaben zur Speicherung von Dateinamen mit Groß- und Kleinschreibung
  • Unterstützung von Unicode
  • Verwendung von Zugriffskontroll-Listen, Dateibasierte Kompression
  • Verschlüsselung, Disk Quotas, Sparse Streams, Reparse Points, Object Identifiers


Schnellansicht

SpeedCommander: Arbeiten mit den Fenstern
Schnellansicht

Mit der Schnellansicht können Sie den Inhalt einer Datei ansehen, ohne dazu die Anwendung starten zu müssen, mit der die Datei erstellt wurde. Zur Anzeige der Schnellansicht wählen Sie im Menü Ordnerfenster aus dem Menü Ansicht den Befehl Schnellansicht.

Um die Schnellansicht wieder auszublenden, wählen Sie erneut den Befehl Schnellansicht aus dem Menü Ordnerfenster.

Die Art der Anzeige in der Schnellansicht ist abhängig davon, ob sich unter dem Auswahlbalken eine Datei oder ein Ordner befindet. Befindet sich der Auswahlbalken auf einer Datei, so wird in der Schnellansicht der Inhalt dieser Datei angezeigt. Um die Dateien in einem Ordner nacheinander anzuzeigen, klicken Sie mit der linken Maustaste auf die gewünschte Datei oder drücken die Pfeiltasten Nach oben bzw. Nach unten.

Befindet sich der Auswahlbalken dagegen auf einem Ordner, so werden in der Schnellansicht Informationen zu diesem Ordner sowie allen ihm untergeordneten Ordner angezeigt.

Mit Hilfe einer Baumansicht zeigt der SpeedCommander den Namen des Ordners sowie die Größe aller Dateien und Ordner an, die sich unterhalb dieses Ordners befinden. Klicken Sie auf das Symbol "+" vor dem jeweiligen Ordnersymbol, um auch Informationen zu tiefergelegenen Ordnern anzuzeigen.

Weitere Informationen

Wählen des Dateibetrachters

Unterstützte Dateiformate


Ordnerinformation

SpeedCommander: Arbeiten mit den Fenstern
Ordnerinformation

Die Ordnerinformationen liefern Ihnen Angaben zu den momentan gewählten Dateien und Ordnern. Wählen Sie im Menü Ordnerfenster aus dem Menü Ansicht den Befehl Ordnerinformation, um das Informationsfenster anzeigen.

Um dieses Informationsfenster wieder auszublenden, wählen Sie erneut den Befehl Ordnerinformation aus dem Menü Ordnerfenster.

Folgende Informationen werden angezeigt:
  • Anzahl der gewählten Ordner und Dateien, einschließlich untergeordneter Ordner
  • Größe der gewählten Ordner und Dateien in Bytes
  • Effektiv belegte Größe der gewählten Ordner und Dateien (dies ist abhängig von der Clustergröße des jeweiligen Laufwerks) in Bytes

Wenn Sie einen Filter angegeben haben, erhalten Sie entsprechende Angaben zu den Dateien, die der Filtereigenschaft genügen. So können Sie z.B. einen Filter bestimmen, der *.doc-Dateien einschließt.

Die folgenden Informationen werden angezeigt:
  • Anzahl der gewählten Ordner und Dateien, die der Filtereigenschaft genügen
  • Größe der gewählten Ordner und Dateien, die der Filtereigenschaft genügen, in Bytes
  • Effektiv belegte Größe der gewählten Ordner und Dateien, die der Filtereigenschaft genügen, in Bytes

Die Angaben zu CDR's, Zip-Disketten, LS120-Disketten, 1.44 MB-Disketten und 1.20 MB-Disketten verweisen auf die Anzahl der jeweiligen Disketten/CD-ROMS, die zur Kopie der gewählten Dateien benötigt würden.


DOS-Eingabezeile

SpeedCommander: Arbeiten mit den Fenstern
DOS-Eingabezeile

Die DOS-Eingabezeile unten auf dem SpeedCommander-Bildschirm ist eine voll funktionsfähige Befehlszeile. Verwenden Sie diese genauso, wie Sie auch sonst eine Befehlszeile verwenden, wenn der SpeedCommander nicht läuft. Die DOS-Eingabezeile kann für DOS- und FTP-Befehle verwendet werden.

Sie können den Dateinamen, der gerade durch den Auswahlbalken hervorgehoben wird, in die Befehlszeile kopieren. Wechseln Sie dazu mit Strg+Umschalt+Leertaste aus dem Ordnerfenster in die DOS-Eingabezeile und drücken Sie dann Strg+Eingabe. Um den vollständigen Dateinamen in die DOS-Eingabezeile zu übernehmen, drücken Sie stattdessen Strg+Umschalt+Eingabe. Diese Funktion erleichtert Ihnen das Erstellen langer Befehlszeilen, in denen Dateinamen aus dem aktiven Ordnerfenster verwendet werden.

Mit Hilfe der DOS-Eingabezeile können Sie auch schnell in verschiedene Verzeichnisse wechseln. Geben Sie z.B. einfach den Befehl C:\Windows ein, um im aktiven Ordnerfenster in das Windows-Verzeichnis zu wechseln.

So schalten Sie die DOS-Eingabezeile ein oder aus:
  • Klicken Sie in der Symbolleiste auf die Schaltfläche DOS-Eingabezeile oder wählen Sie im Menü Ansicht aus dem Untermenü Darstellung den Befehl DOS-Eingabezeile.
So blättern Sie in der DOS-Eingabezeile:
  • Drücken Sie Strg+Umschalt+Cursor nach oben bzw. Strg+Umschalt+Cursor nach unten, um in der Befehlszeile zu blättern. Cursor nach oben bzw. Cursor nach unten ändern den aktiven Eintrag im Ordnerfenster.
So wechseln Sie aus der DOS-Eingabezeile wieder zurück:
  • Drücken Sie Strg+Umschalt+Leertaste, um wieder in das Ordnerfenster zu wechseln.


DOS-Ausgabefenster

SpeedCommander: Arbeiten mit den Fenstern
DOS-Ausgabefenster

Das DOS-Ausgabefenster zeigt die Bildschirmausgabe von DOS-Befehlen direkt im SpeedCommander an. Aufgrund der technischen Voraussetzungen steht es nur ab Windows NT/2000 und XP zur Verfügung.

So blenden Sie das DOS-Ausgabefenster ein bzw. aus:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Darstellung und wählen Sie den Befehl DOS-Ausgabefenster oder drücken Sie Strg+O.
  2. Aktivieren Sie den Befehl erneut, wenn Sie das DOS-Ausgabefenster wieder ausblenden möchten.

Wenn das DOS-Ausgabefenster aktiviert ist, wird die Ausgabe jedes in der DOS-Eingabezeile eingegebenen Befehls in diesem Fenster dargestellt.

Wichtiger Hinweis:

Das DOS-Ausgabefenster kann nur die Ausgabe der DOS-Befehle anzeigen, die reinen Text ausgeben. Anwendungen, die direkt in den Bildschirmspeicher schreiben oder grafische Symbole ausgeben, funktionieren nicht. Das DOS-Ausgabefenster ist primär dafür gedacht, die Ausgabe von Batch-Dateien zu beobachten bzw. einfache Tastaturkommandos auszuführen. Es ist kein vollwertiger DOS-Prompt. Das Abbrechen von Befehlen mittels Strg+C ist nicht möglich.


QuickDrop-Symbole

SpeedCommander: Arbeiten mit den Fenstern
QuickDrop-Symbole

Zwischen den beiden Ordnerfenstern zeigt der SpeedCommander eine Leiste mit bis zu 6 Symbolen an, die als Ziel für Dateioperationen dienen können:

  • Komprimieren
  • Entpacken
  • Betrachten
  • Editieren
  • Drucken
  • Löschen in den Papierkorb

Ziehen Sie einfach die entsprechenden Dateien aus dem Ordnerfenster per Drag & Drop auf das gewünschte QuickDrop-Symbol.

Neben den vordefinierten Symbolen können Sie auch bis zu 15 eigene Anwendungen in die QuickDrop-Leiste einbinden. Eine Anwendung kann durch Doppelklick mit der linken Maustaste oder durch Drag & Drop von einer oder mehreren Dateien auf das Symbol gestartet werden. Die Reihenfolge der QuickDrop-Symbole kann bis auf die 6 Standardsymbole beliebig angepasst werden.

So schalten Sie einzelne Symbole ein oder aus:
  1. Klicken Sie mit der rechten Maustaste auf die Leiste mit den QuickDrop-Symbolen.
  2. Aktivieren oder deaktivieren Sie im Dialogfeld QuickDrop-Symbole das QuickDrop-Symbol aus, welches Sie anzeigen oder ausschalten möchten.
So fügen Sie eine Anwendung als QuickDrop-Symbol hinzu:
  1. Klicken Sie mit der rechten Maustaste auf die Leiste mit den QuickDrop-Symbolen, das Dialogfeld QuickDrop-Symbole erscheint.
  2. Klicken Sie auf die Schaltfläche Neu und wählen Sie im Dialogfeld Öffnen, die Anwendung aus, die Sie als QuickDrop-Symbol hinzufügen möchten.
So sortieren Sie die QuickDrop-Symbole:
  1. Klicken Sie mit der rechten Maustaste auf die Leiste mit den QuickDrop-Symbolen, das Dialogfeld QuickDrop-Symbole erscheint.
  2. Wählen Sie den Eintrag, den Sie verschieben möchten.
  3. Klicken Sie auf die Schaltfläche Nach oben bzw. Nach unten, um die Position des QuickDrop-Symbols zu verändern.
So deaktivieren Sie die gesamte QuickDrop-Leiste:
  1. Öffnen Sie im Menü Ansicht das Untermenü Darstellung.
  2. Deaktivieren Sie den Befehl QuickDrop-Symbole.


Fensterteilung

SpeedCommander: Arbeiten mit den Fenstern
Fensterteilung

Sie können die beiden Ordnerfenster im SpeedCommander Ihren Anforderungen entsprechend vergrößern oder verkleinern. Das Menü Ansicht enthält ein Untermenü Fensterteilung mit den Befehlen 0%, 25%, 50%, 75% und 100%.

Befehl | Ergebnis
0 % | Verbirgt das linke Fenster.
25 % | Stellt das linke Fenster auf 25% und das rechte Fenster auf 75% der verfügbaren Fensterbreite.
50% | Stellt beide Fenster auf gleiche Größe.
75 % | Stellt das linke Fenster auf 75% und das rechte Fenster auf 25% der verfügbaren Fensterbreite.
100 % | Verbirgt das rechte Fenster.

Neben diesen festen Positionen können Sie die Fenstergröße mit der Maus auf jeden beliebigen Wert setzen. Bewegen Sie den Mauszeiger auf das Verschiebesymbol zwischen den beiden Fenstertiteln. Sobald der Mauszeiger das Aussehen eines Fadenkreuzes annimmt, können Sie die Leiste in die gewünschte Richtung ziehen.

Wenn Sie mit der linken Maustaste auf das Verschiebesymbol doppelklicken, werden die beiden Ordnerfenster wieder auf die gleiche Größe gesetzt.


Verwenden von Layouts

SpeedCommander: Arbeiten mit den Fenstern
Verwenden von Layouts

In einem Layout können Sie ihre aktuelle Arbeitsumgebung mit allen Ordnerfenstern und allen Anzeigeeinstellungen speichern, so dass Sie schnell zwischen verschiedenen häufig genutzten Einstellungen umschalten können.

So speichern Sie ein Layout:
  1. Konfigurieren Sie die Ansicht, die Sie speichern möchten.
  2. Öffnen Sie das Menü Ansicht, zeigen Sie auf Layout und wählen Sie den Befehl Speichern.
  3. Geben Sie im Dialogfeld Layout speichern einen Namen für das neue Layout ein, und klicken Sie auf OK.
So löschen Sie ein gespeichertes Layout:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Layout und wählen Sie den Befehl Löschen.
  2. Markieren Sie im Dialog Layout löschen das zu löschende Layout, und klicken Sie auf OK.
So aktivieren Sie ein Layout:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Layout und wählen Sie das Layout aus, welches Sie aktivieren möchten.
  2. Sie können auch das Symbol Layout aus der Symbolleiste verwenden oder im Einstellungsdialog Anpassen jedem Layout ein eigenes Tastenkürzel zuordnen.


Arbeiten mit Dateien und Ordnern

SpeedCommander: Arbeiten mit Dateien und Ordnern
Überblick

Im SpeedCommander ist das Sortieren und Organisieren Ihrer Dateien und Ordner eine einfache Angelegenheit. Sie können Dateien und Ordner kopieren, bewegen, komprimieren, löschen und umbenennen.

Weitere Informationen

Auswählen von Dateien

Suchen von Dateien

Ordner erstellen

Dateien anzeigen

Dateien bearbeiten

Dateien und Ordner kopieren

Dateien und Ordner verschieben

Dateien und Ordner löschen

Dateien und Ordner mehrfach umbenennen

Ordner vergleichen

Dateizeit und Attribute ändern

Ordnergrößen ermitteln

Ordnerlisten drucken


Auswählen von Dateien

SpeedCommander: Arbeiten mit Dateien und Ordnern
Auswählen von Dateien

Im SpeedCommander können Sie mit einer oder mehreren Dateien gleichzeitig arbeiten. Wählen Sie einfach die gewünschten Dateien aus, und führen Sie die erforderliche Aufgabe aus.

Folgende Aktionen sind möglich:

  • Alle Dateien auswählen/abwählen
  • Eine Gruppe zusammengehöriger Dateien auswählen/abwählen
  • Dateityp unter dem Cursor auswählen/abwählen
  • Auswahl umkehren
  • Auswahl wiederherstellen
So wählen Sie eine Gruppe zusammengehöriger Dateien aus:
  1. Aktivieren Sie das Menü Bearbeiten, zeigen Sie auf Auswählen und wählen Sie den Befehl Einige auswählen, oder drücken Sie + (Plustaste) im numerischen Tastenblock.
  2. Geben Sie im angezeigten Dialogfeld Auswahl erweitern an, welche Dateien Sie auswählen wollen. Um z.B. alle Dateien mit der Endung .EXE auszuwählen, geben Sie *.EXE ein.
  3. Drücken Sie Eingabe. Alle Dateien mit der Endung .EXE werden markiert.

Geben Sie *.* ein, um alle im Fenster angezeigten Dateien auszuwählen. Wenn Sie auch Ordner in die Auswahl mit aufnehmen möchten, aktivieren Sie im Menü Bearbeiten oder im Auswahldialog die Option Ordner in Auswahl einbeziehen. Nun werden neben den Dateien auch die Ordner mit in die Auswahl aufgenommen.

Wenn Sie eine andere Dateigruppe auswählen wollen, können Sie die Auswahl der momentan ausgewählten Gruppe rückgängig machen.

So machen Sie die Auswahl einer Gruppe zusammengehöriger Dateien rückgängig:
  1. Aktivieren Sie das Menü Bearbeiten, zeigen Sie auf Auswählen und wählen Sie den Befehl Einige abwählen, oder drücken Sie - (Minustaste) im numerischen Tastenblock.
  2. Geben Sie im angezeigten Dialogfeld Auswahl reduzieren an, für welche Dateien Sie die Auswahl aufheben wollen. Um z.B. die Auswahl für alle Dateien mit der Endung .EXE aufzuheben, geben Sie *.EXE ein.
  3. Drücken Sie Eingabe. Die Auswahl alle Dateien mit der Endung .EXE wird aufgehoben.

Vielleicht möchten Sie auch alle Dateien auswählen, welche eine bestimmte Dateierweiterung haben.

So wählen Sie alle Dateien aus, die den gleichen Dateityp wie die aktuell fokussierte Datei haben:
  1. Klicken Sie im Ordnerfenster auf eine Datei, deren Dateityp Sie auswählen möchten.
  2. Aktivieren Sie das Menü Bearbeiten, zeigen Sie auf Auswählen und wählen Sie den Befehl Dateityp unter Cursor auswählen, oder drücken Sie Alt + (Plustaste) im numerischen Tastenblock.

Sie können Ihre Auswahl auch umkehren und damit alle Dateien in einem Ordner auswählen, die nicht ausgewählt sind, und die Auswahl aller gewählten Dateien rückgängig machen.

So kehren Sie die Auswahl in einem Ordner um:
  1. Aktivieren Sie das Menü Bearbeiten, zeigen Sie auf Auswählen und wählen Sie den Befehl Auswahl umkehren, oder drücken Sie * (Multiplikationszeichen) im numerischen Tastenblock.
  2. Ihre Auswahl ist nun umgekehrt: Die Auswahl aller vorher ausgewählten Dateien ist rückgängig gemacht, und die vorher nicht ausgewählten Dateien sind ausgewählt.

Nach einer Dateioperation (z.B. Kopieren) wird die vorherige Auswahl zurückgesetzt. Sie können diese Auswahl aber schnell wiederherstellen.

So stellen Sie die Auswahl in einem Ordner wieder her:
  1. Aktivieren Sie das Menü Bearbeiten, zeigen Sie auf Auswählen und wählen Sie den Befehl Auswahl wiederherstellen, oder drücken Sie / (Divisionszeichen) im numerischen Tastenblock.
  2. Nun sind alle Dateien markiert, die vor der Dateioperation ausgewählt waren.


Suchen von Dateien

SpeedCommander: Arbeiten mit Dateien und Ordnern
Suchen von Dateien

Auf einer großen Festplatte mit zahlreichen Ordnern kommt es leicht vor, dass Sie eine Datei "verlegen". Sie haben vielleicht den Dateinamen vergessen oder Sie wissen nicht mehr, in welchem Ordner Sie die Datei abgelegt haben. Mit dem Befehl Suchen aus dem Menü Datei können Sie die Datei leicht wiederfinden und außerdem nach einer Gruppe von Dateien suchen.

Der SpeedCommander bringt mit FileSearch ein schnelles und umfangreiches Suchwerkzeug mit. Mit Hilfe von FileSearch können Sie nach Dateien suchen, die einen bestimmten Namen haben, eine bestimmte Größe haben oder innerhalb eines bestimmten Zeitraums liegen. Sie können nach Textvorkommen suchen und sich die Suchstellen anzeigen lassen. FileSearch ist auch in der Lage, Archivdateien nach bestimmten Textvorkommen zu durchsuchen.

FileSearch ist ebenfalls dazu in der Lage, doppelte Dateien zu finden. Oftmals ist es so, dass ein und dieselbe Datei an verschiedenen Orten gespeichert ist und so auf dem Datenträger viel Platz verschwendet wird. Das Auffinden von doppelten Dateien ist ohne Hilfsmittel nur sehr schwer möglich. FileSearch bietet Ihnen hier die Möglichkeit, doppelte Dateien nach verschiedenen Kriterien zu suchen:

  • Gleicher Name
  • Gleiche Größe
  • Gleicher Dateiinhalt

Weitere Informationen

FileSearch

Wählen des Suchwerkzeugs


Ordner erstellen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Ordner erstellen

Sie können an einer beliebigen Stelle auf Ihrem Laufwerk einen neuen Ordner erstellen.

So erstellen Sie einen Ordner:
  1. Wählen Sie Ordner erstellen aus dem Menü Ordner.
  2. Geben Sie im darauf erscheinenden Eingabefeld den Namen des zu erstellenden Ordners ein.
  3. Drücken Sie Eingabe.

Weitere Informationen

Auswählen eines Laufwerks


Dateien anzeigen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien anzeigen

Der SpeedCommander nutzt zur Anzeige von Dateien das Hilfsprogramm SpeedView. Mit SpeedView können Sie Dateien der gängigen Textverarbeitungs- und Grafikprogramme anzeigen, ohne die Anwendung zu starten, mit der sie erstellt wurde.

So zeigen Sie eine Datei an:
  1. Markieren Sie die Dateien, die Sie anzeigen möchten.
  2. Wählen Sie Betrachten aus dem Menü Datei, oder ziehen Sie die Datei auf das QuickDrop-Symbol Betrachten, oder klicken Sie in der Symbolleiste auf das Symbol Betrachten.
  3. Der Dateibetrachter wird gestartet und zeigt die Datei an.

Weitere Informationen

Auswählen von Dateien

Wählen des Dateibetrachters


Bearbeiten von Dateien

SpeedCommander: Arbeiten mit Dateien und Ordnern
Bearbeiten von Dateien

Sie können mit dem SpeedCommander auch Textdateien bearbeiten. Der SpeedCommander nutzt dazu das Hilfsprogramm SpeedEdit.

So bearbeiten Sie eine Datei an:
  1. Markieren Sie die Datei, die Sie bearbeiten möchten.
  2. Wählen Sie Editieren aus dem Menü Datei, oder ziehen Sie die Datei auf das QuickDrop-Symbol Editieren, oder klicken Sie in der Symbolleiste auf das Symbol Editieren.
  3. Der Dateibearbeiter wird gestartet und zeigt die Datei an.

Weitere Informationen

Auswählen von Dateien

Wählen des Dateibearbeiters


Dateien und Ordner kopieren

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien und Ordner kopieren

Mit dem SpeedCommander können Sie Dateien und Ordner an eine andere Stelle der Festplatte, des Netzwerks oder auf eine Diskette kopieren.

So kopieren Sie Dateien und Ordner:
  1. Wählen Sie die gewünschten Dateien und Order aus.
  2. Wählen Sie Kopieren aus dem Menü Datei, oder klicken Sie in der Symbolleiste auf das Symbol Kopieren.
  3. Der Ordner im anderen Fenster wird im Dialogfeld Kopieren angezeigt. Um schnell eine andere Zieladresse zu finden, können Sie auf Suchen klicken.
  4. Wenn Sie nur neuere Dateien kopieren möchten, aktivieren Sie das Kontrollkästchen Nur neuere Dateien kopieren.
  5. Existiert im Zielverzeichnis bereits eine Datei gleichen Namens, so fragt der SpeedCommander nach, ob die Datei ersetzt werden soll. Bei Aktivierung des Kontrollkästchens Dateien automatisch umbenennen wird der Dateiname ohne Nachfrage automatisch auf "Dateiname [1]" geändert.
  6. Mit Hilfe des Kontrollkästchens Dateiattribut "Schreibgeschützt" entfernen wird das Attribut "Schreibgeschützt" bei der Zieldatei entfernt. Dies ist zweckmäßig beim Kopieren von CD-ROM.
  7. Aktivieren Sie das Kontrollkästchen Sicherheitsattribute übernehmen (NTFS), wenn auch die Sicherheitsattribute der Datei kopiert werden sollen.
  8. Durch Aktivierung des Kontrollkästchens Alle Dateien ohne Nachfrage überschreiben verhindern Sie die Anzeige eines Warndialoges, falls die Zieldatei bereits existiert. Dies ist zweckmäßig, wenn Sie während des Kopiervorgangs nicht am PC sitzen.
  9. Drücken Sie Eingabe, oder wählen Sie OK.
Tips
  • Sie können den Dateinamen der zu kopierenden Dateien auch ändern. Tragen Sie z.B. im Eingabefeld Nach "D:\*.txt" ein, um die Dateien beim Kopieren gleich nach "*.txt" umzubenennen.
  • Mit Hilfe von Drag & Drop können Sie die ausgewählten Dateien und Ordner kopieren, indem Sie diese auf das andere Ordnerfenster, auf den Windows-Desktop oder in ein anderes Fenster ziehen.
  • Sie können auch einen Filter angeben. Es werden dann nur Dateien kopiert, die der Filtereigenschaft entsprechen.
  • Wenn Sie eine Schriftart-Datei in den Systemordner "Schriftarten" kopieren, dann wird die Schriftart automatisch registriert.

Weitere Informationen

Auswählen von Dateien

Einrichten eines Dateifilters


Dateien und Ordner verschieben

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien und Ordner verschieben

Mit dem SpeedCommander können Sie Dateien und Ordner an eine andere Stelle der Festplatte, des Netzwerks oder auf eine Diskette verschieben.

So verschieben Sie Dateien und Ordner:
  1. Wählen Sie die gewünschten Dateien und Order aus.
  2. Wählen Sie Verschieben aus dem Menü Datei, oder klicken Sie in der Symbolleiste auf das Symbol Verschieben.
  3. Der Ordner im anderen Fenster wird im Dialogfeld Verschieben angezeigt. Um schnell eine andere Zieladresse zu finden, können Sie auf Suchen klicken.
  4. Wenn Sie nur neuere Dateien verschieben möchten, aktivieren Sie das Kontrollkästchen Nur neuere Dateien kopieren.
  5. Existiert im Zielverzeichnis bereits eine Datei gleichen Namens, so fragt der SpeedCommander nach, ob die Datei ersetzt werden soll. Bei Aktivierung des Kontrollkästchens Dateien automatisch umbenennen wird der Dateiname ohne Nachfrage automatisch auf "Dateiname [1]" geändert.
  6. Mit Hilfe des Kontrollkästchens Dateiattribut "Schreibgeschützt" entfernen wird das Attribut "Schreibgeschützt" bei der Zieldatei entfernt.
  7. Aktivieren Sie das Kontrollkästchen Sicherheitsattribute übernehmen (NTFS), wenn auch die Sicherheitsattribute der Datei kopiert werden sollen.
  8. Durch Aktivierung des Kontrollkästchens Alle Dateien ohne Nachfrage überschreiben verhindern Sie die Anzeige eines Warndialoges, falls die Zieldatei bereits existiert. Dies ist zweckmäßig, wenn Sie während des Kopiervorgangs nicht am PC sitzen.
  9. Drücken Sie Eingabe, oder wählen Sie OK.
Tips
  • Sie können den Dateinamen der zu verschiebenden Dateien auch ändern. Tragen Sie z.B. im Eingabefeld Nach "D:\*.txt" ein, um die Dateien beim Verschieben gleich nach "*.txt" umzubenennen.
  • Mit Hilfe von Drag & Drop können Sie die ausgewählten Dateien und Ordner verschieben, indem Sie diese auf das andere Ordnerfenster, auf den Windows-Desktop oder in ein anderes Fenster ziehen und dabei die Umschalt-Taste drücken.
  • Sie können auch einen Filter angeben. Es werden dann nur Dateien verschoben, die der Filtereigenschaft entsprechen.

Weitere Informationen

Auswählen von Dateien

Einrichten eines Dateifilters


Dateien und Ordner löschen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien und Ordner löschen

Sie können Dateien und Ordner aus dem aktuellen Laufwerk löschen, in den Papierkorb verschieben oder auch sicher löschen.

So löschen Sie Dateien und Ordner:
  1. Wählen Sie die gewünschten Dateien und Ordner aus.
  2. Wählen Sie Löschen aus dem Menü Datei, oder klicken Sie in der Symbolleiste auf das Symbol Löschen.
  3. Drücken Sie Eingabe, oder wählen Sie Ja.
So löschen Sie Dateien und Ordner in den Papierkorb:
  1. Wählen Sie die gewünschten Dateien und Ordner aus.
  2. Wählen Sie Löschen in den Papierkorb aus dem Menü Datei, klicken Sie in der Symbolleiste auf das Symbol Löschen in den Papierkorb oder ziehen Sie die Dateien mit der Maus auf das QuickDrop-Symbol Löschen.
  3. Drücken Sie Eingabe, oder wählen Sie Ja.
So löschen Sie sicher nach Regierungsrichtlinien:
  1. Wählen Sie die gewünschten Dateien und Ordner aus.
  2. Wählen Sie Sicheres Löschen aus dem Menü Datei.
  3. Klicken Sie auf Schnelles Löschen, wenn die Dateien mit einem Wert überschrieben werden sollen.
  4. Klicken Sie auf Löschen nach Regierungsrichtlinien, wenn die Dateien mehrmals überschrieben werden sollen.
  5. Geben Sie an, wie oft der Löschvorgang wiederholt werden soll.
  6. Drücken Sie Eingabe, oder wählen Sie Ja.

Weitere Informationen

Auswählen von Dateien


Dateien verschlüsseln

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien verschlüsseln

Im Hinblick auf die neuen internationalen Standards haben wir die bisherige Verschlüsselung mit dem DES und Tripple-DES zugunsten des wesentlich moderneren AES bzw. Rijndael geändert.

Selbstverständlich können Sie weiterhin Ihre SCB-Dateien entschlüsseln, zum Verschlüsseln nehmen Sie aber bitte das SQX-Format und aktivieren dort die Verschlüsselung. Das neue SQX-Format bietet mindestens die gleiche Sicherheit wie die älteren SCB-Dateien, allerdings bieten SQX-Archive wesentlich mehr Komfort wie z.B. digitale Signaturen oder Reparaturdaten und können wesentlich schneller erzeugt werden.

So erstellen Sie ein neues verschlüsseltes Archiv mit dem Komprimierungs-Assistenten:
  1. Markieren Sie die Dateien und Ordner, welche Sie verschlüsseln möchten.
  2. Wählen aus dem Menü Datei den Befehl Komprimieren.
  3. Geben Sie im Dialogfeld Komprimierungs-Assistent - Name und Format einen Namen für die verschlüsselte Datei an.
  4. Wählen Sie das Format SQX und deaktivieren Sie das Kontrollkästchen Multivolume / SFX.
  5. Klicken Sie auf Weiter, um die nächste Seite anzuzeigen.
  6. Im Dialogfeld Komprimierungs-Assistent - Kompression legen Sie mögliche Komprimiereinstellungen fest.
  7. Geben Sie ein Kennwort ein, mit welchem die Dateien verschlüsselt werden sollen.
  8. Aktivieren Sie das Kontrollkästchen Archivverzeichnis, wenn auch das Archivverzeichnis verschlüsselt werden soll.
  9. Klicken Sie auf Weiter, um die nächste Seite anzuzeigen.
  10. Im Dialogfeld Komprimierungs-Assistent - Dateiauswahl können Sie weitere Dateien hinzufügen.
  11. Drücken Sie Eingabe, oder klicken Sie auf Fertig stellen.


Ordner vergleichen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Ordner vergleichen

Oft ist es sinnvoll, die Dateien in einem Ordner zu vergleichen, bevor Sie diese kopieren oder löschen. So können Sie feststellen, welche Dateien Sie behalten wollen.

So vergleichen Sie Ordner:
  1. Wechseln Sie im linken und rechten Ordnerfenster in die Ordner, die Sie vergleichen wollen.
  2. Wählen Sie Ordner vergleichen aus dem Menü Ordner, oder klicken Sie in der Symbolleiste auf das Symbol Ordner vergleichen.
  3. Wählen Sie im Dialogfeld Ordner vergleichen die Kriterien aus, nach denen verglichen werden soll.
  4. Wählen Sie aus, welche Dateien SpeedCommander nach dem Vergleich markieren soll.
  5. Drücken Sie Eingabe, oder klicken Sie auf OK.


Dateizeit und Attributeändern

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateizeit und Attribute ändern

Alle Dateien auf Ihrer Festplatte haben bestimmte Dateiattribute. Die Attribute geben an, ob eine Datei nur gelesen werden darf, ob sie versteckt ist, ob sie archiviert werden soll, oder ob sie eine Systemdatei ist. Die Dateizeit einer Datei zeigt an, wann sie erstellt oder zum letzten Mal bearbeitet wurde. Mit dem SpeedCommander können Sie diese Informationen für eine Datei, eine Gruppe von Dateien oder sogar für gesamte Ordner ändern.

So ändern Sie die Dateiattribute und die Dateizeit für Dateien und Ordner:
  1. Wählen Sie die Dateien und Ordner aus.
  2. Wählen Sie Mehr Eigenschaften aus dem Menü Datei.
  3. Stellen Sie die gewünschte Dateizeit ein. Sie können die Zeit der Erstellung, die Zeit des letzten Zugriffs oder die Zeit des letzten Schreibzugriffes setzen.
  4. Sie können für die ausgewählten Dateien und Ordner Attribute setzen oder löschen. Wählen Sie die gewünschten Attribute aus.
  5. Markieren Sie das Kontrollkästchen Dateien in Unterordnern einschließen, wenn Sie die Dateien in den ausgewählten Unterordnern ändern möchten.
  6. Drücken Sie Eingabe, oder klicken Sie auf OK.


Ordnergrößen ermitteln

SpeedCommander: Arbeiten mit Dateien und Ordnern
Ordnergrößen ermitteln

Mit diesem Befehl lässt sich der Speicherbedarf aller Ordner innerhalb des aktiven Ordners ermitteln. Die Größe der vorhandenen Ordner wird in der entsprechenden Darstellungsspalte im Ordnerfenster angezeigt. Diese Funktion ist nützlich, wenn zum Zweck eines Kopiervorgangs geprüft werden soll, wie viel Platz bestimmte Ordner auf dem Datenträger belegen. Die Anzeige der ermittelten Ordnergrößen wird wieder gelöscht, wenn auf eine über- oder untergeordnete Ordnerebene gewechselt wird.

So ermitteln Sie die Ordnergrößen:
  1. Wählen Sie aus dem Menü Ansicht den Befehl Details, um die Detailansicht für das aktive Ordnerfenster einzuschalten.
  2. Wählen Sie den Befehl Ordnergrößen ermitteln aus dem Menü Ordner, oder klicken Sie in der Symbolleiste auf das Symbol Ordnergrößen ermitteln.

SpeedCommander kann die Ordnergrößen auch automatisch im Hintergrund berechnen. Diese Funktion kann im Dialogfeld Ordnergrößen des Einstellungsdialogs aktiviert werden. Während der Berechnung der Ordnergrößen zeigt SpeedCommander ein visuelles Feedback der aktuellen Operation:

Symbol | Bedeutung
[.o|o.] | Die Ordnergrößen werden gerade berechnet.
[xxxx] | Für diesen Ordner sollen keine Ordnergrößen berechnet werden.
[----] | Die Ordnergrößen müssen noch berechnet werden.


Ordnerlisten drucken

SpeedCommander: Arbeiten mit Dateien und Ordnern
Ordnerlisten drucken

Für Archivierungszwecke ist es manchmal erforderlich, sich einen genauen Überblick über die auf einem Datenträger oder in einem Ordner befindlichen Dateien zu machen. Der SpeedCommander bietet Ihnen die Möglichkeit, eine übersichtliche und formatierte Liste mit allen Dateien eines Ordners zu erstellen und auszudrucken.

So drucken Sie eine Ordnerliste aus:
  1. Wechseln Sie in den Ordner, dessen Inhalt Sie ausdrucken möchten.
  2. Wählen Sie aus dem Menü Ordner den Befehl Ordnerliste drucken.
  3. Geben Sie im darauf erscheinenden Dialog an, ob Sie nur den aktuellen Ordner oder auch alle untergeordneten Ordner ausdrucken möchten.


Trennen und Zusammenführen von Dateien

SpeedCommander: Arbeiten mit Dateien und Ordnern
Trennen und Zusammenführen von Dateien

Sie werden oft feststellen, dass manche Dateien zu groß sind, um sie auf eine Diskette zu kopieren. Mit Hilfe der Funktion Trennen können Sie die Datei in mehrere Segmente trennen, diese dann auf Disketten kopieren und zu einem späteren Zeitpunkt wieder zusammenzuführen. Um Diskettenplatz zu sparen, wird die zu teilende Datei komprimiert. Zusätzlich können Sie die aufgeteilte Datei mit einem Kennwort schützen, das Zusammenführen ist dann nur unter Angabe dieses Kennwortes möglich.

So trennen Sie eine Datei:
  1. Wählen Sie die zu trennende Datei.
  2. Wählen Sie den Befehl Trennen aus dem Menü Datei oder klicken Sie in der Symbolleiste auf das Symbol Trennen.
  3. Geben Sie im Dialogfeld Trennen einen Namen für die getrennte Datei an.
  4. Wählen Sie das Zielsystem, unter dem Sie die Datei später wieder zusammenfügen möchten.
  5. Wählen Sie die Größe der Segmente.
  6. Drücken Sie Eingabe, oder klicken Sie auf OK.

Für das Zusammenführen von Dateien werden keinerlei Hilfsprogramme benötigt, auch der SpeedCommander ist dazu nicht erforderlich. Im ersten Segment der geteilten Datei ist ein kleines Programm enthalten, das die erforderlichen Arbeiten selbstständig durchführt.

So führen Sie getrennte Dateien zusammen:
  1. Wählen Sie das erste Segment der aufgeteilten Datei.
  2. Drücken Sie Eingabe, oder doppelklicken Sie auf den Eintrag.
  3. Die einzelnen Segmente werden nun automatisch zu einer Datei zusammengeführt.
Wichtiger Hinweis

Wenn Sie beim Trennen der Datei ein Kennwort angegeben haben, müssen Sie es zum Zusammenführen erneut eingeben. Wenn Sie das Kennwort nicht kennen, können Sie die Dateien nicht zusammenführen.


Mehrfaches Umbenennen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Mehrfaches Umbenennen

Die Funktion Mehrfaches Umbenennen ist ein leistungsfähiges Werkzeug, mit dem ganze Dateilisten in einem einzigen Arbeitsgang nach bestimmten Kriterien umbenannt werden können.

Es gibt ingesamt neun verschiedene Platzhalter, die ganz individuell zum Umbenennen von Dateien kombiniert werden können. Jeder Platzhalter außer dem Platzhalter [s] kann noch weitere Argumente enthalten, welche die Eigenschaften eines Platzhalters weiter beeinflussen. Neben den Platzhaltern gibt es weitere Optionen, mit denen die Schreibweise der Dateinamen beeinflusst werden kann.

Die Platzhalter [p], [n] und [e] stehen für einen übergeordneten Ordner, den Dateinamen und der Dateierweiterung. Jeder der vorgenannten Platzhalter kann weitere Argumente für "Index" und "Länge" enthalten. "Index" ist das Zeichen, ab dem aus dem alten Ordner, dem Dateinamen oder der Dateierweiterung die Zeichen in den neuen Namen eingefügt werden sollen. "Länge" gibt die maximale Anzahl der Zeichen an, die übernommen werden sollen.

Beispiel:
Dateiname | Platzhalter | Neuer Dateiname | Erklärung
Urlaubsbild | [n] | Urlaubsbild | Es werden alle Zeichen übernommen.
Urlaubsbild | [n,1,6] | Urlaub | Es werden die ersten sechs Zeichen übernommen.
Urlaubsbild | [n,-1,4] | bild | Es werden die letzten vier Zeichen übernommen.
Urlaubsbild | [n,-7,2] | au | Es werden zwei Zeichen ab dem siebten Zeichen (gezählt vom Ende des Namens) übernommen.

Der Platzhalter [c] steht für einen Zähler, mit dem Dateien z.B. durchnummeriert werden könnten. Dieser Platzhalter kann weitere Argumente wie Startwert, Schrittweite und Mindestbreite (in Zeichen) enthalten. Als Startwert sind 0 - 9 bzw. ein numerischer Wert, a - z und A - Z möglich. Als Schrittweite und Mindestbreite sind nur numerische Werte möglich.

Beispiel:

"Wert 1" gibt den Zählerwert für die erste Datei an, entsprechend gibt "Wert 2" den Zählerwert für die zweite Datei an. Man könnte die Liste hier beliebig weiterführen.

Dateiname | Wert 1 | Wert 2 | Erklärung
[c] | 1 | 2 | Startwert und Schrittweite sind 1, für jede Datei wird der Zähler um 1 erhöht.
[c,2,2] | 2 | 4 | Startwert und Schrittweite sind 2, für jede Datei wird der Zähler um 2 erhöht.
[c,2,2,3] | 002 | 004 | Startwert und Schrittweite sind 2, für jede Datei wird der Zähler um 2 erhöht. Da die Mindestbreite für den Zähler drei ist, wird der Wert von links mit Nullen aufgefüllt.
[c,a,1] | a | b | Startwert ist a, Schrittweite ist 1, für jede Datei wird der Zähler um 1 erhöht.
[c,a,2,3] | aaa | aac | Startwert ist a, Schrittweite ist 2, für jede Datei wird der Zähler um 2 erhöht. Da die Mindestbreite für den Zähler drei ist, wird der Wert von links mit a aufgefüllt.

Der Platzhalter [dt] steht für Datums- und Zeitangaben. Dieser Platzhalter kann mit weiteren Argumenten ganz speziellen Anforderungen angepasst werden. Je nachdem, ob die Option Aktuelle Systemzeit für [dt] benutzen aktiviert ist, wird als aktuelle Zeit entweder der Zeitstempel der jeweiligen Dateien oder die Systemzeit angenommen. Die Argumentliste für [dt] kann folgende Datums- bzw. Zeitangaben enthalten:

Platzhalter | Bedeutung
YYYY | Jahr, vierstellig
YY | Jahr, zweistellig
MMMM | Voller Monatsname, wie z.B. Januar, Februar usw.
MMM | Abgekürzter Monatsname, wie z.B. Jan, Feb usw.
MM | Monat. Monate kleiner als 10 werden mit führender 0 eingefügt
M | Monat. Monate kleiner als 10 werden ohne führende 0 eingefügt
DDDD | Voller Wochentag, wie z.B. Montag, Dienstag usw.
DDD | Abgekürzter Wochentag, wie z.B. Mon, Di usw.
DD | Tag des Monats. Tage kleiner als 10 werden mit führender 0 eingefügt
D | Tag des Monats. Tage kleiner als 10 werden ohne führende 0 eingefügt
hh | Stunde. Stunden kleiner als 10 werden mit führender 0 eingefügt
h | Stunde. Stunden kleiner als 10 werden ohne führende 0 eingefügt
mm | Minute. Minuten kleiner als 10 werden mit führender 0 eingefügt
m | Minute. Minuten kleiner als 10 werden ohne führende 0 eingefügt
ss | Sekunde. Sekunden kleiner als 10 werden mit führender 0 eingefügt
s | Sekunde. Sekunden kleiner als 10 werden ohne führende 0 eingefügt
oo | Tag des Jahres, wie z.B. 1, 2, 3 usw. Tage kleiner 10 werden mit zwei führenden Nullen erweitert, Tage kleiner als 100 werden mit einer führenden Null erweitert.
o | Tag des Jahres, wie z.B. 1, 2, 3 usw.
SS | vordefinefinierte Maske: YYYY-MM-DD-hh-mm-ss
S | vordefinefinierte Maske: YYYYMMDDhhmmss
U | vordefinefinierte Maske: MM-DD-YYYY
E | vordefinefinierte Maske: DD-MM-YYYY

Bitte beachten Sie unbedingt die Schreibweise in den einzelnen Argumenten, SS hat eine andere Bedeutung als ss. Die Argumentliste kann neben den oben aufgeführten Zeichen auch weitere Zeichen enthalten. Diese werden dann unverändert in den Dateinamen bzw. die Dateierweiterung übernommen. Wird [dt] ohne Argumente angegeben, so werden Datumsangaben als YYYY-MM-DD formatiert.

Beispiele:
Dateiname | Zeitstempel | Anweisung | Neuer Dateiname
Backup.sqx | 05.05.2002, 23:41:30 | [n]_[dt,E].[e] | Backup_05-05-2002.sqx
Urlaubsbild.bmp | 10.08.2002, 02:29:00 | [n] vom [dt,DDDD, DD.MM.YYYY].[e] | Urlaubsbild vom Samstag, 10.08.2002.bmp

Der Platzhalter [mi] steht für einen Zähler, der die Gesamtanzahl der markierten Dateien angibt. Dieser Platzhalter kann als weiteres Argument die Mindestbreite (in Zeichen) enthalten. Wären z.B. die Dateien text1.txt, text2.txt, text3.txt und text4.txt markiert, dann würde der Platzhalter [mi] beim Umbenennen durch 4 ersetzt werden, weil vier Dateien markiert sind.

Beispiele:
Dateiname | Anweisung | Neuer Dateiname
Bild1.bmp | Bild, Teil [c] von [mi].[e] | Bild, Teil 1 von 4.bmp
Bild2.bmp |  | Bild, Teil 2 von 4.bmp
Bild3.bmp |  | Bild, Teil 3 von 4.bmp
Bild4.bmp |  | Bild, Teil 4von 4.bmp

Der Platzhalter [u] ist im Prinzip eine Anweisung, um die Schreibweise des Dateinamens ab der aktuellen Position zu beeinflussen. Enthält der Platzhalter [u] keine weiteren Argumente, so wird ab der aktuellen Position der gesamte Dateiname in Großbuchstaben umgewandelt. Die Schreibweise in Großbuchstaben gilt solange, bis der Platzhalter [u] vom Platzhalter [k] oder Platzhalter [s] ersetzt bzw. aufgehoben wird oder für die Anzahl der Zeichen, die dem Platzhalter [u] als Argument übergeben worden ist.

Beispiele:
Dateiname | Platzhalter | Neuer Dateiname | Erklärung
Urlaubsbild | [u][n] | URLAUBSBILD | Es werden alle Zeichen übernommen und in Großbuchstaben umgewandelt.
Urlaubsbild | [u,7][n] | URLAUBSbild | Es werden alle Zeichen übernommen. Die ersten sieben Zeichen werden in Großbuchstaben umgewandelt.
Urlaubsbild | [n,1,6][u][n,7] | UrlaubSBILD | Es werden die ersten sechs Zeichen unverändert übernommen. Der Rest der Zeichen wird in Großbuchstaben umgewandelt.
Urlaubsbild | [u][n,-1,4] | BILD | Es werden die letzten vier Zeichen übernommen, alle Zeichen werden in Großbuchstaben umgewandelt.

Der Platzhalter [k] ist ebenfalls eine Anweisung, um die Schreibweise des Dateinamens ab der aktuellen Position zu beeinflussen. Enthält der Platzhalter [k] keine weiteren Argumente, so wird ab der aktuellen Position der gesamte Dateiname in Kleinbuchstaben umgewandelt. Die Schreibweise in Kleinbuchstaben gilt solange, bis der Platzhalter [k] vom Platzhalter [u] oder Platzhalter [s] ersetzt bzw. aufgehoben wird oder für die Anzahl der Zeichen, die dem Platzhalter [k] als Argument übergeben worden ist.

Beispiele:
Dateiname | Platzhalter | Neuer Dateiname | Erklärung
URLAUBSBILD | [k][n] | urlaubsbild | Es werden alle Zeichen übernommen und in Kleinbuchstaben umgewandelt.
URLAUBSBILD | [k,7][n] | urlaubsBILD | Es werden alle Zeichen übernommen. Die ersten sieben Zeichen werden in Kleinbuchstaben umgewandelt.
URLAUBSBILD | [n,1,6][k][n,7] | URLAUBsbild | Es werden die ersten sechs Zeichen unverändert übernommen. Der Rest der Zeichen wird in Kleinbuchstaben umgewandelt.
URLAUBSBILD | [k][n,-1,4] | bild | Es werden die letzten vier Zeichen übernommen, alle Zeichen werden in Kleinbuchstaben umgewandelt.

Der Platzhalter [s] hebt den Platzhalter [u] bzw. den Platzhalter [k] ab der aktuellen Position auf.

Mit Suchen und Ersetzen können verschiedene Teile der Dateinamen ausgetauscht bzw. entfernt werden. Die Zeichenkette, nach der gesucht werden soll, darf die Wildcards * und ? enthalten. Es können mehrere Zeichenketten zum Suchen und Ersetzen auf einmal angegeben werden. Die Zeichenketten müssen jeweils durch das Pipe-Zeichen (|) voneinander getrennt werden.

Beispiele:
Dateiname | Suchen nach | Ersetzen durch | Neuer Dateiname
Urlaubsbild | bild |  | Urlaubs
Urlaubsbild | bi* |  | Urlaubs
Urlaubsbild | bi?? |  | Urlaubs
Urlaubsbild | bild | photo | Urlaubsphoto
Urlaubsbild | bi* | reise | Urlaubsreise

Mit der Option Groß-/Kleinschreibung kann die Schreibweise der Dateinamen beeinflusst werden.
Beispiele:
Dateiname | Option | Neuer Dateiname
Urlaubsbild.bmp | Keine Änderung | Urlaubsbild.bmp
Urlaubsbild.bmp | Alles gross | URLAUBSBILD.BMP
Urlaubsbild.bmp | Alles klein | urlaubsbild.bmp
Das ist ein Text.txt | Wortanfang gross | Das Ist Ein Text.Txt
urlaubsbild.bmp | Erster Buchstabe gross | Urlaubsbild.bmp
Das ist ein Text.txt | Erstes Wort gross | Das ist ein text.Txt

Da im Prinzip alle Platzhalter in eckigen Klammern [] stehen, müssen eckige Klammern selbst in eckigen Klammern stehen, wenn sie den Dateinamen hinzugefügt werden sollen.
Beispiele:
Dateiname | Platzhalter | Neuer Dateiname | Hinweis
Mein Buch | [n], [Auflage 1] | Fehler! | Die Kombination der Platzhalter und Zeichen ist fehlerhaft!
Mein Buch | [n], [[]Auflage 1[]] | Mein Buch, [Auflage 1] |

Die neuen Dateinamen werden nach den folgenden Regeln zusammengesetzt: Zuerst werden die neuen Dateinamen aus den Platzhaltern [p], [n], [e], [c], [dt], [u], [k] und [s] gebildet. Danach wird überprüft, ob entsprechend der Parameter "Suchen nach" und "Ersetzen durch" Teile der Dateinamen ersetzt werden müssen. Ganz zum Schluß wird entsprechend der Option "Groß-/Kleinschreibung" die Schreibweise (unabhängig von den Platzhaltern [u] und [k]) angepasst.

So benennen Sie Dateien mehrfach um:
  1. Wählen Sie die gewünschten Dateien und Ordner aus.
  2. Wählen Sie Mehrfaches Umbenennen aus dem Menü Datei, der Dialog Mehrfaches Umbenennen erscheint.
  3. Setzen Sie mit Hilfe der Platzhalter die neuen Dateinamen zusammen.
  4. Drücken Sie Eingabe, oder wählen Sie Umbenennen.
  5. Wenn Sie die zuletzt durchgeführte Umbenenn-Aktion wieder rückgängig machen möchten, dann wählen Sie Rückgängig.

Weitere Informationen

Auswählen von Dateien


Komprimierte Dateien

SpeedCommander: Komprimierte Dateien
Überblick

Der SpeedCommander macht die Arbeit mit komprimierten Dateien einfach, da er sie wie Ordner behandelt. Er bietet direkte Unterstützung für eine Vielzahl von Archivformaten, so dass Sie die wichtigsten Formate im SpeedCommander ohne externe Programme verarbeiten können.

So arbeiten Sie mit einer komprimierten Datei:
  1. Wählen Sie die komprimierte Datei aus.
  2. Doppelklicken Sie auf die Datei, oder drücken Sie Eingabe.
  3. Eine Liste der in der komprimierten Datei enthaltenen Dateien und Ordner wird angezeigt. Die Liste können Sie genauso wie ein anderes Ordnerfenster verwenden.
  4. Wenn Sie aus dem Inhalt einer komprimierten Datei eine Datei auswählen und kopieren, wird sie vor dem Kopieren automatisch dekomprimiert.

Weitere Informationen

Archive erstellen

Archive entpacken

Komprimieren über mehrere Disketten

Verwendung von Reparaturdaten

Kompressionsprofile

Integrität eines Archivs prüfen

Verwendung von Archiv- und Dateikommentaren

Selbstextrahierende Archive

Wahl des richtigen Archivformats


Erstellen eines Archivs

SpeedCommander: Komprimierte Dateien
Erstellen eines Archivs

Komprimierte Dateien sparen Festplattenspeicher, da sie sehr viel weniger Platz einnehmen als nicht komprimierte Dateien. Wenn Sie mit den Dateien wieder arbeiten wollen, dekomprimieren Sie diese einfach wieder.

So erstellen Sie ein neues Archiv mit dem Komprimierungs-Assistenten:
  1. Markieren Sie die Dateien und Ordner, welche Sie komprimieren möchten.
  2. Wählen aus dem Menü Datei den Befehl Komprimieren.
  3. Geben Sie im Dialogfeld Komprimierungs-Assistent - Name und Format einen Namen für die komprimierte Datei an.
  4. Wählen Sie das gewünschte Format und wählen Sie im Kombinationsfeld Typ die Einstellung Normales Archiv.
  5. Klicken Sie auf Weiter, um die nächste Seite anzuzeigen.
  6. Im Dialogfeld Komprimierungs-Assistent - Kompression legen Sie die Komprimiereinstellungen fest.
  7. Klicken Sie auf Weiter, um die nächste Seite anzuzeigen.
  8. Im Dialogfeld Komprimierungs-Assistent - Dateiauswahl können Sie weitere Dateien hinzufügen.
  9. Drücken Sie Eingabe, oder klicken Sie auf Fertig stellen.
So fügen Sie einer komprimierten Datei weitere Dateien hinzu:
  1. Öffnen Sie die komprimierte Datei, indem Sie darauf doppelklicken oder indem Sie diese hervorheben und Eingabe drücken. Die darin enthaltenen Dateien werden aufgelistet.
  2. Wählen Sie im anderen Ordnerfenster die Dateien aus, die Sie der komprimierten Datei hinzufügen wollen.
  3. Sie können die Dateien in das Ordnerfenster mit der komprimierten Datei kopieren, indem Sie den Befehl Kopieren aus dem Menü Datei wählen.
Erweiterte Möglichkeiten für ZIP und SQX

Mit Hilfe von Sicherheitsattributen wird im NTFS-Dateisystem festgelegt, wer Zugriff auf eine Datei erhalten darf und wer nicht. Diese Informationen gehen beim Erstellen eines Archivs in der Regel verloren. Wählen Sie im Komprimierungs-Assistenten die Option Sicherheitsattribute erhalten, wenn SpeedCommander die Sicherheitsattribute in das Archiv übernehmen soll.

Eine weitere Eigenschaft vom NTFS-Dateisystem ist die Möglichkeit, Informationen zu einer Datei in einem alternativen Datenstrom zu speichern. Die meisten Archivformate komprimieren nur den Dateiinhalt, die erweiterten Informationen gehen verloren. Wählen Sie im Komprimierungs-Assistenten die Option Alternative Datenströme erhalten, wenn SpeedCommander die alternativen Datenströme in das Archiv übernehmen soll.

Im Dateisystem NTFS ist es auch möglich, Dateien mit Kommentaren zu versehen. Diese Kommentare werden ebenfalls in einem alternativen Datenstrom gespeichert. Bei den Archivformaten SQX und ZIP ist es möglich, diese Kommentare auszulesen und automatisch als Dateikommentare für die jeweiligen Dateien in das Archiv zu übernehmen. Wählen Sie im Komprimierungs-Assistenten die Option OLE/NTFS-Kommentare automatisch übernehmen, wenn SpeedCommander diese Kommentare automatisch in Archivkommentare umwandeln soll.

Unmittelbar nach dem Komprimieren kann das Archiv automatisch mit einem besonderen Testverfahren geprüft werden. Das Archiv wird auf Integrität geprüft und die Dateiinhalte im Archiv werden mit den Dateiinhalten auf der Festplatte verglichen. Der Test gilt dann als bestanden, wenn sich das Archiv ohne Fehler testen lässt und die Dateiinhalte des Archives mit den Dateiinhalten der Festplatte übereinstimmen. Wählen Sie im Komprimierungs-Assistenten die Option Erweitertes Testen nach dem Archivieren, wenn SpeedCommander diesen Vergleich automatisch durchführen soll.

Es ist auch möglich, Dateinamen in Unicode abzuspeichern. Dies ist dann sinnvoll, wenn im Dateinamen Zeichen vorkommen, die in üblichen Zeichensätzen nicht vorhanden sind (z.B. osteuropäische und asiatische Sprachen). Wählen Sie im Komprimierungs-Assistenten die Option Unicode-Dateinamen speichern, wenn SpeedCommander zusätzlich Unicode-Dateinamen abspeichern soll. Unicode-Dateinamen können nur mit dem SQX-Format abgespeichert werden.

Wichtiger Hinweis

Sie können für das Komprimieren von Dateien ein Kennwort festlegen. Vor dem Dekomprimieren dieser Dateien werden Sie aufgefordert, das Kennwort anzugeben. Wenn Sie das Kennwort vergessen, können Sie die Dateien nicht mehr dekomprimieren.


Entpacken von Archiven

SpeedCommander: Komprimierte Dateien
Entpacken von Archiven

Beim Entpacken wird eine Datei in ihren unkomprimierten Zustand wiederhergestellt und in einem von Ihnen angegebenen Ordner gespeichert, so dass Sie mit der Datei arbeiten können. Sie werden feststellen, dass das Dekomprimieren einer oder mehrerer Dateien aus einem Archiv eine der häufigsten Tätigkeiten beim Umgang mit Archivdateien ist. Sie können mit SpeedCommander eine Datei, eine Auswahl von Dateien oder sämtliche Dateien eines Archivs dekomprimieren.

So entpacken Sie Dateien aus einer Archivdatei:
  1. Öffnen Sie das Archiv, das die zu dekomprimierende Datei enthält.
  2. Um eine oder mehrere Dateien zu dekomprimieren, wählen Sie die Dateien aus der Liste im aktiven Ordnerfenster aus.
  3. Wählen Sie aus dem Menü Datei den Befehl Entpacken. Das Dialogfeld Entpacken wird angezeigt.
  4. Geben Sie im Feld Entpacken nach den Ordner ein, in dem die dekomprimierten Dateien gespeichert werden sollen. Sie können auch im Feld Ordner auf den gewünschten Ordner klicken.
  5. Um nicht nur einzelne Dateien, sondern alle Dateien zu dekomprimieren, wählen Sie im Abschnitt Dateien die Option Alle Dateien.
  6. Wählen Sie Ordnerstruktur wiederherstellen, um auf Ihrer Festplatte die ursprüngliche Ordnerstruktur wiederherzustellen und die Dateien aus dem Archiv in Ordnern abzulegen, die den gleichen Namen haben wie die Ordner im Archiv.
  7. Wählen Sie Nachfrage vor dem Überschreiben, wenn SpeedCommander Sie vor dem Überschreiben einer bereits existierenden Datei um Erlaubnis fragen soll.
  8. Wählen Sie Beschädigte Dateien nicht löschen, wenn fehlerhaft entpackte Dateien nach dem Entpacken nicht gelöscht werden sollen.
  9. Drücken Sie Eingabe, oder wählen Sie OK.

Mit Hilfe von Sicherheitsattributen wird im NTFS-Dateisystem festgelegt, wer Zugriff auf eine Datei erhalten darf und wer nicht. Diese Informationen gehen beim Erstellen eines Archivs in der Regel verloren. SpeedCommander kann jedoch bei SQX- und ZIP-Archiven die Sicherheitsattribute mit in das Archiv übernehmen. Wählen Sie im Dialog Entpacken die Option Sicherheitsattribute wiederherstellen, wenn SpeedCommander die gespeicherten Sicherheitsattribute nach dem Entpacken wiederherstellen soll.

Eine weitere Eigenschaft vom NTFS-Dateisystem ist die Möglichkeit, Informationen zu einer Datei in einem alternativen Datenstrom zu speichern. Die meisten Archivformate komprimieren nur den Dateiinhalt, die erweiterten Informationen gehen verloren. Mit dem SQX- und dem ZIP-Format ist es aber möglich, auch diese zusätzlichen Informationen mit in das Archiv aufzunehmen. Wählen Sie im Dialog Entpacken die Option Alternative Datenströme wiederherstellen, wenn SpeedCommander die alternativen Datenströme beim Entpacken wiederherstellen soll.

Im Dateisystem NTFS ist es auch möglich, Dateien mit Kommentaren zu versehen. Diese Kommentare werden ebenfalls in einem alternativen Datenstrom gespeichert. Bei den Archivformaten SQX und ZIP ist es möglich, diese Kommentare auszulesen und automatisch als Dateikommentare für die jeweiligen Dateien in das Archiv zu übernehmen. Wählen Sie im Dialog Entpacken die Option OLE/NTFS-Kommentare wiederherstellen, wenn SpeedCommander Archivkommentare automatisch auf die entpackten Dateien übertragen soll.

Beim Download von Archivdateien in Windows XP (SP2) und höher wird in einem alternativen Datenstrom vermerkt, dass die Datei aus dem Internet stammt. Beim Ausführen einer solchen Datei zeigt der Windows-Explorer einen Warnhinweis an. Wählen Sie im Dialog Entpacken die Option Zone ID auf entpackte Dateien übertragen, wenn SpeedCommander auch alle entpackten Dateien entsprechend markieren soll. Diese Funktion erfordert das Dateisystem NTFS.

Wichtiger Hinweis

Wenn Sie beim Komprimieren der Dateien ein Kennwort angegeben haben, müssen Sie es zum Entpacken erneut eingeben. Wenn Sie das Kennwort nicht kennen, können Sie die Dateien nicht entpacken.


Komprimierenüber mehrere Disketten

SpeedCommander: Komprimierte Dateien
Komprimieren über mehrere Disketten

Bei Datensicherungen kann es passieren, dass das zu erstellende Archiv größer als eine Diskette oder eine bestimmte Datenträgergröße ist. Der SpeedCommander bietet Ihnen die Möglichkeit, ein Archiv über mehrere Disketten oder Datenträger zu erstellen.

So komprimieren Sie mit dem Komprimierungs-Assistenten über mehrere Disketten:
  1. Wählen Sie den Ordner oder die Dateien aus, die Sie komprimieren möchten.
  2. Wählen Sie Komprimieren aus dem Menü Datei, oder ziehen Sie die Datei auf das QuickDrop-Symbol Komprimieren, oder klicken Sie in der Symbolleiste auf das Symbol Komprimieren.
  3. Geben Sie im Dialogfeld Komprimierungs-Assistent - Name und Format einen Namen für die komprimierte Datei an.
  4. Wählen Sie das gewünschte Format und aktivieren Sie im Kombinationsfeld Typ die Einstellung Multivolume-Archiv.
  5. Klicken Sie auf Weiter, um die nächste Seite anzuzeigen.
  6. Im Dialogfeld Komprimierungs-Assistent - Dateiauswahl können Sie weitere Dateien hinzufügen.
  7. Klicken Sie auf Weiter, das Dialogfeld Komprimierungs-Assistent - Zielsystem und Größe wird angezeigt.
  8. Wählen Sie hier die Datenträgergröße, auf die das Archiv aufgeteilt werden soll.
  9. Drücken Sie Eingabe, oder klicken Sie auf Fertig stellen.

Wenn für das spätere Dekomprimieren von Archiven über mehrere Disketten keinerlei Hilfsprogramme benötigt werden sollen, so können Sie auch ein selbstentpackendes Archiv erstellen. Im ersten Segment des Archivs ist ein kleines Programm enthalten, das die erforderlichen Arbeiten selbstständig durchführt.

So erstellen Sie ein selbstentpackendes Archiv über mehrere Disketten:
  1. Wählen Sie den Ordner oder die Dateien aus, die Sie komprimieren möchten.
  2. Wählen Sie Komprimieren aus dem Menü Datei, oder ziehen Sie die Datei auf das QuickDrop-Symbol Komprimieren, oder klicken Sie in der Symbolleiste auf das Symbol Komprimieren.
  3. Geben Sie im Dialogfeld Komprimierungs-Assistent - Name und Format einen Namen für die komprimierte Datei an.
  4. Wählen Sie das gewünschte Format und aktivieren Sie im Kombinationsfeld Typ die Einstellung Selbstentpackend.
  5. Klicken Sie auf Weiter, um die nächste Seite anzuzeigen.
  6. Im Dialogfeld Komprimierungs-Assistent - Dateiauswahl können Sie weitere Dateien hinzufügen.
  7. Klicken Sie auf Weiter, um die nächste Seite anzuzeigen.
  8. Wählen Sie im Dialogfeld Komprimierungs-Assistent - SFX-Typ und Sprache die Einstellung Normales SFX.
  9. Klicken Sie auf Weiter, bis Sie das Dialogfeld Komprimierungs-Assistent - Zielsystem und Größe erreichen.
  10. Wählen Sie hier das gewünschte Zielsystem und die Datenträgergröße, auf die das Archiv aufgeteilt werden soll.
  11. Drücken Sie Eingabe, oder klicken Sie auf Fertig stellen.

Verwandte Themen

Selbstextrahierende Archive


Verwendung von Reparaturdaten

SpeedCommander: Komprimierte Dateien
Verwendung von Reparaturdaten

Mit dem SpeedCommander ist es möglich, SQX-Archiven sogenannte Reparaturdaten hinzuzufügen. Diese Reparaturdaten dienen als zusätzlicher Schutz gegen Beschädigungen von Archiven, da diese wesentlich empfindlicher auf Beschädigungen reagieren, als "normale" Dateien. Wird z.B. in einem Word-Dokument ein einziges Byte verändert, so hat man unter Umständen einen falschen Buchstaben oder eine falsche Formatierung an einer Stelle des Dokumentes. Ein Archiv kann in der Regel schon nicht mehr korrekt dekomprimiert werden, wenn ein einziges Byte (oder Zeichen) verändert wurde, da ein falsches Byte das gesamte Archiv beeinflussen kann.

Funktionsweise von Reparaturdaten

Sämtliche Daten auf bzw. in einem PC werden in der Regel blockweise zwischen der Hard- und Software ausgetauscht, und genau hierbei kann es zu Problemen kommen, wenn z.B. ein Datenträger (Festplatte, Diskette, CD) beschädigt ist. Kann ein bestimmter Sektor auf einem Datenträger nicht gelesen werden, dann werden letztendlich falsche bzw. ungültige Daten übertragen. Die Datei behält zwar an sich die gleiche Größe, enthält aber trotzdem falsche Daten. Genau hier setzt der SpeedCommander an und erzeugt mit einem speziellen Verfahren Prüf- und Reparaturblöcke, mit denen beschädigte Blöcke wieder korrekt hergestellt werden können. Hierbei wird jede Datei in einem Archiv einzeln für sich geschützt. Es können selbstverständliche auch verschlüsselten bzw. mit einem Kennwort geschützten SQX-Archiven Reparaturdaten hinzugefügt werden. Die Prüf- und Reparaturblöcke lassen keine Rückschlüsse auf die unverschlüsselten Daten zu.

Der SpeedCommander kann einem SQX-Archiv ein Prozent bis fünf Prozent Reparaturdaten hinzufügen und könnte entsprechend SQX-Archive mit einem bis zu fünf Prozent Beschädigungen (bezogen auf die Archivgröße) wiederherstellen. Enthält z.B. ein SQX-Archiv mit der Größe von einem MB fünf Prozent Reparaturdaten, so könnten bis zu ca. 50KB eines Archivs beschädigt sein und der SpeedCommander könnte das Archiv immer noch reparieren. Immerhin entsprechen 50KB rund 100 Sektoren einer Diskette bzw. bis zu sechs Clustern einer Festplatte.

In der Praxis haben sich zwei Prozent Reparaturdaten bewährt, sie fallen bezogen auf die Archivgröße kaum auf und bieten schon einen deutlichen Schutz gegenüber Beschädigungen. Aber trotzdem sollten Sie mit Ihren Daten niemals leichtsinnig umgehen. Ist ein Archiv inklusive der Reparaturdaten beschädigt, kann der SpeedCommander auch nicht mehr helfen. Sie sollten stets darauf achten, dass Ihre Datenträger wie Disketten, CD's etc. in Ordnung sind, um jedes Risiko zu minimieren.

Reparaturdaten hinzufügen

Sie können den SpeedCommander veranlassen, gleich bei der Erstellung eines Archivs Reparaturdaten in das Archiv einzubauen. Aktivieren Sie dazu im Komprimierungs-Assistenten auf der Seite Kompressionsrate für die Einstellung Reparaturdaten die gewünschte Dichte der Reparaturdaten. Je höher der Prozentsatz von Reparaturdaten ist, desto größer können die Beschädigungen an einem Archiv sein, das der SpeedCommander wiederherstellen kann.

Der SpeedCommander kann einem Archiv aber auch nachträglich Reparaturdaten hinzufügen. So müssen bestehende Archive nicht erst dekomprimiert und dann wieder neu erstellt werden. Markieren Sie dazu im Ordnerfenster einfach das entsprechende Archiv, aktivieren Sie das Menü Extras, zeigen Sie auf Archiv und wählen Sie den Befehl Reparaturdaten hinzufügen.

Reparaturdaten entfernen

Der SpeedCommander bietet Ihnen auch die Möglichkeit, vorhandene Reparaturdaten aus einem Archiv zu entfernen. Markieren Sie dazu im Ordnerfenster das entsprechende Archiv, aktivieren Sie das Menü Extras, zeigen Sie auf Archiv und wählen Sie den Befehl Reparaturdaten entfernen.

Archive reparieren

Mit Hilfe des Befehls Defektes Archiv reparieren aus dem Untermenü Archiv des Menüs Extras können beschädigte Archive mit SpeedCommander/Squeez-Reparaturdaten ganz oder teilweise wiederhergestellt werden. Der Grad der möglichen Wiederherstellung hängt hier von der Art und dem Umfang der Beschädigung des Archivs ab. Beim Reparieren des Archivs wird zusammen mit dem reparierten Archiv eine Logdatei im Textformat erzeugt, in der aufgeführt wird, welche Dateien gerettet werden konnten und welche Dateien nicht wiederherstellbar sind.


Kompressionsprofile

SpeedCommander: Komprimierte Dateien
Kompressionsprofile

In einem Kompressionsprofil werden alle Einstellungen für die Erstellung eines Archivs gespeichert. Wenn Sie z.B. immer ZIP-Archive als eMail-Anhang verschicken und zur Archivierung Ihrer Daten das SQX-Format verwenden, so können Sie für beide Einsatzzwecke ein eigenes Profil definieren. Auf der ersten Seite des Komprimierungs-Assistenten kann schnell zwischen den Profilen umgeschaltet werden und die Archive werden mit wenigen Mausklicks erstellt.

So erstellen Sie ein neues Kompressionsprofil:
  1. Öffnen Sie den Komprimierungs-Assistenten.
  2. Klicken Sie im Abschnitt Profile auf die Schaltfläche Definieren, der Einstellungsdialog Profile erscheint.
  3. Klicken Sie auf die Schaltfläche Neu, um ein neues Profil zu erstellen.
  4. Aktivieren Sie die gewünschten Komprimiereinstellungen und schließen Sie das Dialogfeld mit Ok.
So wählen Sie ein Kompressionsprofil:
  1. Öffnen Sie den Komprimierungs-Assistenten.
  2. Wählen Sie im Kombinationsfeld Profil das gewünschte Kompressionsprofil.
  3. Klicken Sie auf Fertig stellen, um das Archiv zu erzeugen.
So löschen Sie ein Kompressionsprofil:
  1. Öffnen Sie den Komprimierungs-Assistenten.
  2. Klicken Sie im Abschnitt Profile auf die Schaltfläche Definieren, der Einstellungsdialog Profile erscheint.
  3. Wählen Sie im Listenfeld Profile das Profil, welches Sie löschen möchten.
  4. Klicken Sie auf die Schaltfläche Löschen, um das Profil zu löschen.


Archiv testen

SpeedCommander: Komprimierte Dateien
Archiv testen

Mit Hilfe dieser Funktion können Sie die Integrität eines Archivs testen, d.h. die Vollständigkeit der im Archiv enthaltenen Daten überprüfen. Der SpeedCommander simuliert dazu einen Dekomprimierungsvorgang, schreibt dabei aber keinerlei Daten auf die Festplatte. Für den Test eines Archivs ist somit kein zusätzlicher Speicherplatz erforderlich. Wenn beim Testvorgang Probleme auftreten, zeigt der SpeedCommander Ihnen nach dem Prüfvorgang eine Fehlermeldung bzw. bestätigt die Integrität des Archivs.

So überprüfen Sie die Integrität eines Archivs:
  1. Markieren Sie die Archivdatei, deren Integrität Sie testen möchten.
  2. Aktivieren Sie das Menü Extras, zeigen Sie auf Archiv und wählen Sie den Befehl Auf Integrität prüfen.


Archiv- und Dateikommentare

SpeedCommander: Komprimierte Dateien
Archiv- und Dateikommentare

Kommentare sind im Prinzip Notizen zum Archiv bzw. zu den Dateien, die sich im Archiv befinden. Im Gegensatz zum normalen Dateisystem können Sie sich so bestimmte Bemerkungen zu den Archiven oder sogar zu einzelnen Dateien im Archiv machen. Die Kommentare werden im Archiv abgespeichert und vom SpeedCommander automatisch angezeigt.

Mit dem SpeedCommander ist es auch möglich, in einem Arbeitsschritt mehreren Dateien im Archiv den gleichen Kommentar zuzuweisen. Die Archiv- oder Dateikommentare können geändert oder gelöscht werden.

So vergeben Sie einen Archivkommentar:
  1. Öffnen Sie die Archivdatei, der Sie einen Kommentar hinzufügen möchten.
  2. Aktivieren Sie das Menü Extras, zeigen Sie auf Archiv und wählen Sie den Befehl Hauptkommentar setzen.
  3. Tragen Sie im Dialogfeld Hauptkommentar ändern Ihren neuen Archivkommentar ein und klicken Sie auf OK.
So vergeben Sie einen Dateikommentar:
  1. Öffnen Sie die Archivdatei, der Sie einen Dateikommentar hinzufügen möchten.
  2. Aktivieren Sie das Menü Extras, zeigen Sie auf Archiv und wählen Sie den Befehl Dateikommentar setzen.
  3. Tragen Sie im Dialogfeld Eigenschaften im Feld Kommentar Ihren Dateikommentar ein und klicken Sie auf OK.


Selbstextrahierende Archive

SpeedCommander: Komprimierte Dateien
Selbstextrahierende Archive

SpeedCommander kann normale Archive und selbstextrahierende Archive (SFX) erzeugen. Normale Archive können in der Regel nur von SpeedCommander bzw. von dem entsprechenden Dateikomprimierer gelesen, bearbeitet oder dekomprimiert werden. Ohne zusätzliche Hilfsprogramme ist der Zugriff auf ein normales Archiv daher nicht möglich.

Sogenannte selbstextrahierende Archive dekomprimieren sich selbstständig: Ein Doppelklick unter Windows 9x/ME/2000/XP & NT startet das Archiv und dieses Archiv dekomprimiert sich dann selbst, ohne dass ein entsprechender Dateikomprimierer benötigt wird. SpeedCommander kann selbstextrahierende Archive erzeugen, die sich unter DOS und Windows 9x/ME/2000/XP & NT ausführen lassen. Somit sind selbstextrahierende Archive optimal für die Weitergabe von Software an Computerneulinge, die mit dem Konzept der Archive noch nicht so vertraut sind.

Mit SpeedCommander lassen sich 3 verschiedene Arten von selbstextrahierenden Archiven erzeugen:

  • Normales SFX
  • SFX für Softwareinstallationen
  • SFX mit Listenansicht

Der Text, der von den selbstextrahierenden Archiven zur Laufzeit angezeigt wird, kann mit einem Texteditor (z.B. SpeedEdit) angepasst bzw. übersetzt werden. Hierfür sind keine Programmierkenntnisse notwendig. Weitere Hinweise hierzu finden Sie im Thema Sprachdateien.

Normalerweise teilen Sie SpeedCommander gleich bei der Erstellung eines Archivs mit, dass Sie ein selbstextrahierendes Archiv erzeugen möchten. Wenn Sie jedoch ein bereits existierendes Archiv in ein selbstextrahierendes Archiv umwandeln möchten, gehen Sie folgendermaßen vor:

  1. Markieren Sie die Archivdatei, die Sie in ein selbstextrahierendes Archiv umwandeln möchten.
  2. Wählen Sie im Menü Extras aus dem Untermenü Archiv den Befehl EXE-Datei erzeugen.
  3. Der SpeedCommander startet den Komprimierungs-Assistenten, der Sie Schritt für Schritt durch die Erstellung des selbstextrahierendes Archivs führt.


Normales SFX

SpeedCommander: Komprimierte Dateien
Normales SFX

Ein normales SFX ist einfach zu erstellen und optimal zur Weitergabe von Dokumenten, Grafiken und anderen Dateien an Mitarbeiter und andere Personen geeignet. Es ist auch möglich, ein normales SFX für einfache Softwareinstallationen zu verwenden. Ein normales SFX kann für die Betriebssysteme DOS und Windows 9x/ME/2000/XP & NT erstellt werden.

Ein normales SFX enthält eine optionale Begrüßungsmeldung. Es kann bei der Erstellung ein Ordner festgelegt werden, in dem die Dateien auf dem Zielsystem dekomprimiert werden. Bei der Angabe des Ordners können folgende Systemvariablen angegeben werden, die zur Laufzeit auf dem Zielsystem aufgelöst werden:

Systemvariable | Beschreibung
%Programs% | Wird durch den Ordner "Programme" ersetzt
%CommonFiles% | Wird durch den Ordner "Gemeinsame Dateien" ersetzt
%AppData% | Wird durch den Ordner "Anwendungsdaten" des jeweiligen Benutzers ersetzt
%LocalAppData% | Wird durch den Ordner "Lokale Einstellungen\Anwendungsdaten" des jeweiligen Benutzers ersetzt
%Documents% | Wird durch den Ordner "Eigene Dateien" des jeweiligen Benutzers ersetzt
%Windows% | Wird durch den Ordner "Windows" ersetzt
%System% | Wird durch den Ordner "Windows\System" ersetzt
%Temp% | Wird durch den Ordner "Temp" des jeweiligen Benutzers ersetzt
Mit der Option Überschreiben ohne Nachfrage werden vorhandene Dateien ohne Nachfrage überschrieben. Zusätzlich kann ein Programm direkt nach dem Dekomprimieren aufgerufen werden. Dem aufzurufenden Programm können weitere Parameter beim Start übergeben werden. Die Parameter müssen mit dem Pipe-Zeichen (|) vom Programmnamen getrennt werden. Zum Beispiel würde Backup.exe|/as /t /i das SFX anweisen, nach dem Entpacken das Programm Backup.exe zu starten und die Parameter /as /t /i an Backup.exe zu übergeben.

Erstellen eines normalen SFX

Die Erstellung eines normalen SFX geschieht mit dem Komprimierungs-Assistenten vom SpeedCommander. Im Unterschied zur Erstellung eines normalen Archivs muss auf der ersten Seite des Komprimierungs-Assistenten im Kombinationsfeld Typ die Einstellung Selbstentpackend gewählt werden.

Auf der Seite SFX-Typ und Sprache aktivieren Sie das Kontrollkästchen Normales SFX. Zusätzlich zur Art des SFX können Sie hier auch die Sprache festlegen, in der die Texte im Dialogfenster des selbstextrahierenden Archivs erscheinen.

Auf der Seite Normales SFX können Sie einen Ordner festlegen, der als Vorgabe für das Dekomprimieren erscheinen soll. Weiterhin kann ein Befehl festgelegt werden, der nach dem Dekomprimieren des Archivs automatisch aufgerufen werden soll. Das Kontrollkästchen Dateien ohne Nachfrage überschreiben bestimmt, ob das gleichnamige Kontrollkästchen im SFX beim Start aktiviert ist. Mit Hilfe des Kontrollkästchens Automatisches Dekomprimieren bestimmen Sie, ob das SFX nach dem Start ohne Rückfrage dekomprimiert wird. Verwenden Sie diese Option äußerst vorsichtig, da der Empfänger des selbstextrahierenden Archivs keinerlei Meldungen auf dem Bildschirm erhält.

Die Seite Hinweisdialog legt fest, ob nach dem Start des SFX ein Hinweisdialog angezeigt wird. Geben Sie hier den Dialogtext sowie den Titel des Dialoges ein. Sie können auch wählen, welche Schaltflächenkombination verwendet werden soll. Wenn Sie keinen Hinweisdialog anzeigen möchten, lassen Sie einfach die Textfelder leer.

Jedes selbstextrahierende Archiv enthält einen Informationsdialog, der Programminformationen, Versionsnummer und Copyright anzeigt. Auf der Seite Informationsdialog können Sie einen Text eingeben, der zusätzlich angezeigt wird.

Auf der letzten Seite Zielsystem und Größe wählen Sie das Betriebssystem aus, für welches das SFX erzeugt werden soll. Wenn Sie das selbstextrahierende Archiv auf mehrere Datenträger aufteilen möchten, können Sie hier auch die Größe des verwendeten Datenträgers angeben.

Klicken Sie nun auf Fertig stellen, um das selbstextrahierende Archiv anzulegen.

Verwandte Themen

SFX für Softwareinstallationen

SFX mit Listenansicht


SFX für Softwareinstallationen

SpeedCommander: Komprimierte Dateien
SFX für Softwareinstallationen

Ein SFX für Softwareinstallationen ist zwar etwas schwieriger zu erstellen, es bietet dafür jedoch ein professioneller aussehendes Erscheinungsbild. Der Text, der im Dialogfeld erscheint, kann nach Ihren eigenen Vorstellungen angepasst werden.

Das selbstextrahierende Archiv erstellt beim Aufruf einen temporären Ordner, dekomprimiert die im Archiv enthaltenen Dateien, startet Ihr Installationsprogramm und wartet, bis dieses beendet ist. Danach werden alle Dateien im temporären Ordner und der Ordner selbst wieder entfernt.

Dem Setup-Programm können weitere Parameter beim Start übergeben werden. Die Parameter müssen mit dem Pipe-Zeichen (|) vom Programmnamen getrennt werden. Zum Beispiel würde Setup.exe|/as /t /i das SFX anweisen, nach dem Entpacken das Programm Setup.exe zu starten und die Parameter /as /t /i an Setup.exe zu übergeben.

Erstellen eines SFX für Softwareinstallationen

Die Erstellung eines SFX für Softwareinstallationen geschieht mit dem Komprimierungs-Assistenten vom SpeedCommander. Im Unterschied zur Erstellung eines normalen Archivs muss auf der ersten Seite des Komprimierungs-Assistenten im Kombinationsfeld Typ die Einstellung Selbstentpackend gewählt werden.

Auf der Seite SFX-Typ und Sprache aktivieren Sie das Kontrollkästchen SFX für Softwareinstallationen. Zusätzlich zur Art des SFX können Sie hier auch die Sprache festlegen, in der die Texte im Dialogfenster des selbstextrahierenden Archivs erscheinen.

Auf der Seite SFX für Softwareinstallationen geben Sie den Text an, der im Dialogfeld erscheinen soll, sowie das nach dem Dekomprimieren auszuführende Installationsprogramm. Beide Angaben sind zwingend erforderlich. Das dritte Eingabefeld wird nur verwendet, wenn das Installationsprogramm gleich nach dem Start ein weiteres Programm ausführt und sich sofort wieder beendet. In diesem Fall wird hier der Name des zweiten Programms eingetragen. Bitte beachten Sie, dass der Name des SFX sich von den Namen des Installationsprogramms unterscheiden muss. Anderenfalls ist es möglich, dass beim Start des SFX unter Windows NT nicht eindeutig festgestellt werden kann, ob das Installationsprogramm noch aktiv ist.

Die Seite Hinweisdialog legt fest, ob nach dem Start des SFX ein Hinweisdialog angezeigt wird. Geben Sie hier den Dialogtext sowie den Titel des Dialoges ein. Sie können auch wählen, welche Schaltflächenkombination verwendet werden soll. Wenn Sie keinen Hinweisdialog anzeigen möchten, lassen Sie einfach die Textfelder leer.

Jedes selbstextrahierende Archiv enthält einen Informationsdialog, der Programminformationen, Versionsnummer und Copyright anzeigt. Auf der Seite Informationsdialog können Sie einen Text eingeben, der zusätzlich angezeigt wird.

Auf der letzten Seite Zielsystem und Größe wählen Sie das Betriebssystem aus, für welches das SFX erzeugt werden soll. Wenn Sie das selbstextrahierende Archiv auf mehrere Datenträger aufteilen möchten, können Sie hier auch die Größe des verwendeten Datenträgers angeben.

Klicken Sie nun auf Fertig stellen, um das selbstextrahierende Archiv anzulegen.

Verwandte Themen

Normales SFX

SFX mit Listenansicht


SFX mit Listenansicht

SpeedCommander: Komprimierte Dateien
SFX mit Listenansicht

Ein SFX mit Listenansicht ist genauso einfach zu erstellen wie ein normales SFX. Im Unterschied zum normalen SFX wird nach dem Aufruf des selbstextrahierenden Archivs ein Fenster mit einer Listenansicht gezeigt, das alle Dateien im Archiv anzeigt. Die Dateien können einzeln oder zusammen per Drag & Drop oder per Menübefehl entpackt werden.

Erstellen eines SFX mit Listenansicht

Die Erstellung von selbstextrahierenden Archiven geschieht mit dem Komprimierungs-Assistenten vom SpeedCommander. Im Unterschied zur Erstellung eines normalen Archivs muss auf der ersten Seite des Komprimierungs-Assistenten im Kombinationsfeld Typ die Einstellung Selbstentpackend gewählt werden.

Die Erstellung eines SFX mit Listenansicht erfordert weitaus weniger Eingaben als die Erstellung eines normalen SFX oder eines SFX für Softwareinstallationen.

Auf der Seite SFX-Typ und Sprache aktivieren Sie das Kontrollkästchen SFX mit Listenansicht. Ein SFX mit Listenansicht ist grundsätzlich zweisprachig (Deutsch und Englisch) aufgebaut. Das System, worauf das SFX gestartet wird, entscheidet darüber, welche Sprache verwendet wird.

Auf der letzten Seite Zielsystem und Größe wählen Sie das Betriebssystem aus, für welches das SFX erzeugt werden soll. Wenn Sie das selbstextrahierende Archiv auf mehrere Datenträger aufteilen möchten, können Sie hier auch die Größe des verwendeten Datenträgers angeben.

Klicken Sie nun auf Fertig stellen, um das selbstextrahierende Archiv anzulegen.

Verwandte Themen

Normales SFX

SFX für Softwareinstallationen


Anpassen von Sprachdateien

SpeedCommander: Komprimierte Dateien
Anpassen von Sprachdateien

Bei der Erstellung von selbstentpackenden Archiven werden für die Texte in den Dialogfeldern der Archive Sprachdateien verwendet. Diese Sprachdateien können sehr leicht mit einem einfachen Texteditor an die persönlichen Bedürfnisse angepasst werden. Die Sprachdateien finden Sie im Programmverzeichnis von SpeedCommander im Unterordner 'sfx'.

Beschreibung

Der Eintrag in der Sektion [description] wird dazu benutzt, die Sprache bzw. den Zweck einer bestimmten Sprachdatei festzulegen. Der Eintrag in dieser Sektion sollte immer in nativer Sprache gemacht werden. Eine deutsche Sprachdatei sollte z.B. den Eintrag in dieser Sektion in deutsch haben, eine englische Sprachdatei sollte den Eintrag in englischer Sprache haben.

Wert | Beschreibung
0 = Deutsch | für eine deutsche Sprachdatei
0 = Englisch | für eine englische Sprachdatei
0 = Nederlands | für eine niederländische Sprachdatei

Es ist durchaus möglich, mehrere Sprachdateien mit der gleichen Sprache zu nutzen. Der Eintrag in der Sektion [description] sollte allerdings immer eindeutig sein, damit diese zur Laufzeit auch auseinander gehalten werden können, wie z.B.

0 = Deutsch

oder

0 = Deutsch, geschäftlich

oder

0 = Deutsch, privat

Wenn eine neue Sprachdatei erzeugt werden soll, dann ist es wohl am sinnvollsten, eine Kopie einer vorhandenen Sprachdatei zu erzeugen, und dann entsprechend den Text Nummer für Nummer zu übersetzen bzw. anzupassen. Sprachdateien müssen immer die Erweiterung .lng haben (also z.B. sfx_lang_deu.lng, privat.lng), damit sie vom SpeedCommander genutzt werden können.

Texte

Der gesamte Text in der Sektion [data] ist von Interesse, wenn eine Sprachdatei übersetzt bzw. angepasst werden soll. Jede Zeile, die übersetzt oder angepasst werden kann, beginnt mit einer eindeutigen Nummer. Diese Nummern dürfen auf *keinen Fall* geändert werden, es muss lediglich jeweils der Text nach dem Gleichheitszeichen übersetzt oder angepasst werden.

Einige Textzeilen enthalten Platzhalter, die besonders beachtet werden müssen. Z.B. weist der Platzhalter \n die Software an, einen Zeilenumbruch an einer ganz bestimmten Stelle zu erzwingen.

Die Zeile

Klicken Sie bitte auf die Schaltfläche 'Entpacken',\num alle Dateien dieses Archivs zu extrahieren.

würde zur Laufzeit so aussehen:

Klicken Sie bitte auf die Schaltfläche 'Entpacken',
um alle Dateien dieses Archivs zu extrahieren.

Diese Vorgehensweise ist notwendig, weil einige Bildschirmelemente nur eine begrenzte Breite haben.

Der %u Platzhalter wird zur Laufzeit durch eine Nummer ersetzt, der %s Platzhalter und der %1 Platzhalter werden zur Laufzeit durch weiteren Text ersetzt. Der Text

Dieser Ordner enthält bereits eine Datei namens '%1'.

könnte zur Laufzeit so expandiert werden zu

Dieser Ordner enthält bereits eine Datei namens 'Winword.exe'.

Bitte achten Sie beim Übersetzen und Anpassen von Textzeilen mit den Platzhaltern %u, %1 und %s darauf, dass der ursprüngliche Sinn erhalten bleibt, d.h. die Reihenfolge der Platzhalter muss erhalten bleiben. Ein gutes Beispiel hierfür ist die Zeile mit der Nummer 34.


Wahl des richtigen Archivtyps

SpeedCommander: Komprimierte Dateien
Wahl des richtigen Archivtyps

Die Packer ARJ, LZH, RAR 1.5, und ZIP gehören zu den ältesten Vertretern Ihrer Gattung und bieten eine fast identische Leistung. Die Packer bzw. Archiver GZIP und Unix-TAR sind in erster Linie auf Unix-Rechnern zu Hause bzw. auf fast allen Universitäts-Internetservern anzutreffen.

Die Archiver UUE/UUX haben eine besondere Berechtigung: Beim Transport von Dateien durch das Internet bzw. die verschiedenen Onlinedienste müssen oftmals völlig verschiedene Rechnersysteme miteinander kommunizieren. PC's z.B. kennen ein Alphabet mit 256 Zeichen, verschiedene Großrechnersysteme (Mainframes) kennen nur erheblich kleinere Zeichensätze. UUE/UUX-Archiver transformieren sozusagen Archive oder Dateien mit einem großen Alphabet in Archive oder Dateien mit einem genormten kleineren Alphabet.

Die Packer MS-CAB bzw. MS-LZX wurden von Microsoft entwickelt. Microsoft setzt zum Packen bzw. Archivieren oftmals diese Packer ein. In der Regel sind auch die Dateien auf den Installations-CD's von Microsoft-Programmen mit diesen Komprimierern gepackt. Die Packleistung dieser Packer entspricht in etwa der Packleistung des ZIP, jedoch sind diese Packer langsamer als der ZIP.

Der Packer SQX nimmt eine Sonderstellung unter allen vorgenannten Packern ein: Die Kompressionstechnologie ist in jeder Hinsicht wesentlich moderner und leistungsfähiger. Der SQX-Archiver kann sogenannte 'Solid Archive' erzeugen. Dieses besondere Kompressionsverfahren berücksichtigt beim Komprimieren die Statistiken aller komprimierter Dateien und kann so den Wirkungsgrad der internen Kompressoren extrem verbessern. Weiterhin sind in den SQX besondere Kompressionsverfahren zum Packen von ausführbaren Dateien (EXE, DLL etc.), Multimediadateien (Bilddateien etc.) und WAV-Dateien integriert. Diese speziellen Kompressionsverfahren können die Kompressionsrate beim Packen der entsprechenden Dateien deutlich verbessern. SQX-Archive können mit dem internationalen Verschlüsselungsstandard AES verschlüsselt werden. Außerdem können optional die Archivverzeichnisse verschlüsselt werden (solche Archive können ohne dem richtigen Kennwort nicht geöffnet werden).

Faustregel Nummer 1

Wenn eine sehr hohe Ausführungsgeschwindigkeit beim Packen wichtig ist oder Programme und Dateien komprimiert werden sollen, die relativ häufig auf dem heimischen Rechner benötigt oder geändert werden, so ist unbedingt das SQX- oder das ZIP-Format zu bevorzugen.
Für das SQX-Format sollten folgende Einstellungen vorgenommen werden: Die Kontrollkästchen EXE-Kompression, Solid-Archiv erstellen und Multimedia-Kompression sollten deaktiviert sein. Als Speichergröße sollte 32 KBytes und als Kompressionsrate entweder Normal (sehr schnell) oder Maximal (schnell, bessere Kompression) eingestellt werden.
Für das ZIP-Format sollten folgende Einstellungen vorgenommen werden: Als Speichergröße sollte 32 KBytes und als Kompressionsrate entweder Normal (sehr schnell) oder Maximal (schnell, bessere Kompression) eingestellt werden.

Faustregel Nummer 2

Sollen die zu erzeugenden Archive möglichst klein sein, weil diese z.B. für eine Onlinedistribution bestimmt sind oder auf möglichst wenige Disketten passen sollen, so ist unbedingt das SQX-Format zu bevorzugen. Beim Erzeugen der Archive ist darauf zu achten, dass die Kontrollkästchen EXE-Kompression, Solid-Archiv erstellen und Multimedia-Kompression aktiviert sind. Weiterhin sollte als Speichergröße möglichst 4096 KBytes sowie als Kompressionsrate Maximal gewählt werden. Wenn diese Optionen gesetzt sind, ist der SQX zwar langsamer als ZIP, jedoch wird Sie SQX mit sehr kleinen Archiven überraschen.

Faustregel Nummer 3

Sollen Multimediadateien (z.B. WAV-Dateien) komprimiert werden, so ist unbedingt das SQX-Format zu bevorzugen. Beim Erzeugen der Archive ist darauf zu achten, dass das Kontrollkästchen Multimedia-Kompression aktiviert ist. Die intelligente Kompressionstechnologie des SQX sorgt stets dafür, dass das optimale Kompressionsverfahren genutzt wird.

Faustregel Nummer 4

Wenn sehr sensible Daten archiviert und verschlüsselt werden sollen, dann ist ebenfalls das SQX-Format zu bevorzugen. Geben Sie im Eingabefeld Kennwort das Kennwort für das Archiv ein und aktivieren Sie das Kontrollkästchen Archivverzeichnis, wenn Sie möchten, dass das Archiv nur mit dem richtigen Kennwort geöffnet werden kann.
Wichtiger Hinweis: SQX-Archive werden mit einem sehr aufwendigen und als sehr sicher eingestuftem Verfahren (128/256-Bit AES) verschlüsselt. Die Kennwörter werden weder im Archiv noch irgendwo anders gespeichert, auch gibt es keine sogenannten Hintertürchen im SQX. Der Verlust eines Kennwortes führt unweigerlich zum Verlust von Daten.

Faustregel Nummer 5

Ist ein Archiv für einen Unix-Rechner bestimmt bzw. soll es auf einen Universitäts-Internetserver aufgeladen werden, so sollten die entsprechenden Dateien mit dem TAR/BZIP oder TAR/GZIP archiviert werden. Der SpeedCommander kann TGZ- (tar.gz) und TBZ- (tar.bz) Archive in einem einzigen Arbeitsgang erzeugen, ohne dass hierzu temporärer Speicher benötigt wird.

Um ein TGZ (tar.gz) bzw. TBZ (tar.bz) Archiv zu erzeugen, wählen Sie im Komprimierungs-Assistenten als Format bitte TAR und als Version wählen Sie entsprechend TGZ bzw. TBZ.

Die folgende Tabelle listet die Eigenschaften der im SpeedCommander enthaltenen Archiver auf:

Eigenschaft | SQX | ZIP | ARJ | LZH/LHA | MS-CAB | GZIP | TAR | RAR 1.x | RAR 2.x | ACE 1.x | UUE/UUX | BZIP | 7zip
Maximale Archiv- oder Volumegröße | Unbeschränkt | Unbeschränkt | 2 GB | 2 GB | 2 GB | Unbeschränkt | Unbeschränkt | 2 GB | 2 GB | 2 GB | 2 GB | Unbeschränkt | Unbeschränkt
Maximale Anzahl der Dateien in einem Archiv | Unbeschränkt | Unbeschränkt | Unbeschränkt | Unbeschränkt | Unbeschränkt | 1 Datei* | Unbeschränkt | Unbeschränkt | Unbeschränkt | Unbeschränkt | 1 Datei** | 1 Datei* | Unbeschränkt
Spezielle Kompression für ausführbare Dateien | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Ja
Spezielle Kompression für Multimedia-Dateien | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Ja | Nein | Nein | Nein | Nein
Spezielle Kompression für Sound-Dateien (WAV) | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein
Mögliche Dictionary-Größen beim Komprimieren | 32 KB - 4096 KB | 32 KB - 64 KB | 16 KB | 8 KB | 32 KB - 2048 KB | 32 KB | Keine* | 64 KB | 64 KB - 1024 KB | 64 KB - 1024 KB | Keine** | 1024 KB | 32 KB - 128 MB
Solid-Archive | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Ja | Ja | Nein | Nein | Ja
Verschlüsselung der Dateien | Ja (128-Bit AES) | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Ja | Nein | Nein | Nein | Ja
Verschlüsselung der Archivverzeichnisse | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Ja
Archive können digital signiert werden | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein
Archivieren/Komprimieren von Dateien | Ja | Ja | Ja | Ja | Ja | 1 Datei* | Ja | Ja | Ja | Ja | 1 Datei** | 1 Datei* | Ja
Archivieren/Komprimieren von leeren Ordnern | Ja | Ja | Ja | Nein | Nein | Nein | Nein | Nein | Ja | Ja | Nein | Nein | Ja
Multivolume-Archive | Ja | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein
Reparaturdaten für Archive | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein
Selbstextrahierende Archive (DOS & Win32) | Ja | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein
Selbstextrahierende Multivolume-Archive (DOS & Win32) | Ja | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein
Selbstextrahierende Archive mit Listenansicht (Win32) | Ja | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein
Selbstextrahierende Archive für Softwareinstallationen (Win32) | Ja | Ja | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein | Nein

* Auf Unix-Systemen werden meistens mehrere Dateien mit dem TAR archiviert und dann mit dem GZIP oder BZIP komprimiert

** UUE/UUX Archive dienen zum Transport zwischen verschiedenen Rechnersystemen


Dateifilter

SpeedCommander: Dateifilter
Überblick

Mit den Dateifiltern im SpeedCommander können Sie bestimmen, welche Dateien Sie anzeigen möchten. Dateifilter können auch verwendet werden, um Dateien, die Sie nicht sehen wollen, auszublenden oder um bestimmte Dateien beim Kopieren auszulassen. Mit Hilfe der Dateifilter ist es auch möglich, bestimmten Dateien verschiedene Farben zuzuordnen.

Weitere Informationen

Dateifilter bei der Anzeige

Farben zuordnen

Dateifilter bei Dateioperationen

Einrichten eines Dateifilters


Dateifilter bei der Anzeige

SpeedCommander: Dateifilter
Dateifilter bei der Anzeige

Sie können in jedem Fenster einen anderen Filter verwenden, oder für alle Fenster den gleichen Filter aktivieren. Um auf die Filter zuzugreifen, öffnen Sie das Menü Ordner und zeigen Sie auf Filter.

So aktivieren Sie einen Filter:
  1. Öffnen Sie das Menü Ordner und zeigen Sie auf Filter.
  2. Wählen Sie den Filter aus, den Sie verwenden möchten oder wählen Sie den Befehl Filter auswählen.
  3. Wählen Sie im Dialogfeld Filter auswählen den gewünschten Filter aus.
  4. Möchten Sie schnell Dateien mit bestimmten Erweiterungen filtern, wählen Sie Einschließen und tragen die entsprechende Maske im daneben liegenden Eingabefeld ein. Wenn Sie z.B. nur Dateien mit der Erweiterung "EXE" und "DLL" anzeigen möchten, tragen Sie "*.EXE;*.DLL" ein.
  5. Drücken Sie Eingabe, oder klicken Sie auf OK.
So schalten Sie einen Filter aus:
  1. Öffnen Sie das Menü Ordner und zeigen Sie auf Filter.
  2. Wählen Sie den Befehl Alle Dateien.
Wichtige Hinweise
  • Sie können auch mit der rechten Maustaste auf die Titelzeile des linken oder rechten Ordnerfensters klicken, um einen anderen Filter auszuwählen.
  • Wenn Sie für jedes Fenster einen unterschiedlichen Filter verwenden möchten, so deaktivieren Sie im Einstellungsdialog Ordner und Laufwerke das Kontrollkästchen Ausgewählter Filter gilt für alle Ordnerfenster gleichzeitig.


Farben zuordnen

SpeedCommander: Dateifilter
Farben zuordnen

Neben der Filterung von Dateien bei der Anzeige können Dateifilter noch benutzt werden, um bestimmte Dateien im Ordnerfenster farblich hervorzuheben. So ist es z.B. möglich, alle Dateien, die am heutigen Tag geändert wurden, in rot darzustellen. So fallen diese Dateien in großen Dateilisten schneller auf.

So ordnen Sie einem Filter eine Farbe und/oder einen Schriftstil zu:
  1. Öffnen Sie das Menü Extras und wählen Sie den Befehl Einstellungen.
  2. Aktivieren Sie das Dialogfeld Farben aus der Kategorie Darstellung.
  3. Wählen Sie im Kombinationsfeld Filter den Filter aus, dem Sie eine Farbe zuweisen möchten.
  4. Klicken Sie auf die Farbauswahl-Schaltflächen unter dem Kombinationsfeld und wählen Sie eine Farbe für den Text und/oder für den Hintergrund aus.
  5. Wählen Sie einen Schriftstil, wenn Sie den Text z.B. kursiv oder fett anzeigen möchten.
  6. Drücken Sie Eingabe, oder klicken Sie auf OK.
So entfernen Sie die Farb- und Schriftstilzuordnung für einen Filter:
  1. Öffnen Sie das Menü Extras und wählen Sie den Befehl Einstellungen.
  2. Aktivieren Sie das Dialogfeld Farben aus der Kategorie Darstellung.
  3. Wählen Sie im Kombinationsfeld Filter den Filter aus, dessen Farbzuordnung Sie entfernen möchten.
  4. Klicken Sie auf die Farbauswahl-Schaltflächen unter dem Kombinationsfeld und wählen Sie Automatisch.
  5. Setzen Sie den Schriftstil auf Standard.
  6. Drücken Sie Eingabe, oder klicken Sie auf OK.


Dateifilter bei Dateioperationen

SpeedCommander: Dateifilter
Dateifilter bei Dateioperationen

Sie können Dateifilter auch dazu verwenden, um bestimmte Dateien beim Kopieren/Verschieben ein- oder auszuschließen. Der SpeedCommander prüft dann vor dem Kopieren/Verschieben einer Datei, ob diese Datei den Filtereigenschaften genügt. Entspricht sie den Eigenschaften nicht, so wird sie beim Kopieren/Verschieben übersprungen.

So benutzen Sie einen Dateifilter beim Kopieren:
  1. Wählen Sie die Dateien aus, die Sie kopieren möchten.
  2. Wählen Sie Kopieren aus dem Menü Datei, oder klicken Sie in der Symbolleiste auf das Symbol Kopieren.
  3. Wählen Sie im Eingabefeld Filter den Filter aus, den Sie verwenden möchten, oder klicken Sie auf die Schaltfläche Filter, um einen neuen Dateifilter zu erstellen oder einen bestehenden Dateifilter anzupassen.
  4. Drücken Sie Eingabe, oder wählen Sie OK.


Einrichten eines Dateifilters

SpeedCommander: Dateifilter
Einrichten eines Dateifilters

Die Verwaltung der Dateifilter erfolgt im Dialogfeld Filter konfigurieren. Hier können Sie bis zu 50 angepasste Dateifilter erstellen. Das Dialogfeld Filter konfigurieren erreichen Sie über die Dialoge

  • Filter auswählen
  • Auswahl erweitern und Auswahl reduzieren
  • Listenansicht

Zur Definition eines Dateifilters können Sie folgende Dateieigenschaften verwenden:

  • Dateiname
  • Dateiattribute
  • Datum
  • Größe
Dateiname

Mit der Kategorie Dateiname können Sie Dateien aufgrund Ihres Namens filtern. Sie können Dateien einschließen oder auch von der Ansicht ausschließen.

  • Tragen Sie im Eingabefeld Einschließen die Dateimasken ein, die Sie anzeigen möchten.
  • Tragen Sie im Eingabefeld Ausschließen die Dateimasken ein, die Sie von der Anzeige ausschließen möchten.
Dateiattribute

Mit der Kategorie Dateiattribute können Sie Dateien aufgrund Ihrer Dateiattribute filtern. Wenn Sie mehrere Kontrollkästchen aktivieren, werden Dateien nur berücksichtigt, wenn für diese Dateien alle markierten Attribute gesetzt oder gelöscht sind.

  • Aktivieren Sie ein Kontrollkästchen, um Dateien anzuzeigen, die das entsprechende Attribut besitzen.
  • Deaktivieren Sie ein Kontrollkästchen, um Dateien anzuzeigen, die das entsprechende Attribut nicht besitzen.
  • Stellen Sie das Kontrollkästchen auf Grau, wenn das entsprechende Attribut nicht beachtet werden soll.
Datum

Mit der Kategorie Datum können Sie Dateien aufgrund des Datums, zu der sie erstellt, zuletzt geändert oder zuletzt geöffnet wurden, filtern. Sie können entweder eine Zeitspanne vom aktuellen Zeitpunkt hergesehen angeben (Stunden, Minuten, Tage, Wochen, Monate, Jahre) oder einen Zeitraum mit Anfangs- und Enddatum festlegen.

Größe

Mit der Kategorie Größe können Sie Dateien aufgrund ihrer Größe (in Bytes) filtern. Aktivieren Sie die Kontrollkästchen Größer als und/oder Kleiner als, um die Dateigröße festlegen zu können. Wenn Sie eine bestimmte Größe nur als obere bzw. untere Grenze festlegen möchten, deaktivieren Sie das eine oder andere Kontrollkästchen.


Internet

SpeedCommander: Internet
Überblick

Mit dem Laufwerkssymbol Internet erhalten Sie Zugriff auf das Internet, ohne dabei den SpeedCommander verlassen zu müssen. Der SpeedCommander integriert dazu den Microsoft Internet Explorer oder Mozilla.

Sie können die Option Internetansicht vergrößern nutzen, um bei Aktivierung des Internet das jeweilige Ordnerfenster auf eine bestimmte Größe zu vergrößern. Nach dem Verlassen des Internet schaltet der SpeedCommander das Ordnerfenster automatisch auf die vorherige Größe zurück. Die Option Internetansicht vergrößern finden Sie im Einstellungsdialog Darstellung.

Weitere Themen

Webseiten anzeigen

Startseite festlegen

Suchseite festlegen

Mozilla integrieren


Webseiten anzeigen

SpeedCommander: Internet
Webseiten anzeigen

SpeedCommander bietet Ihnen mehrere Möglichkeiten, einzelne Webseiten anzuzeigen.

So wechseln Sie zu einer Seite, deren Adresse Sie wissen:
  • Geben Sie in der Adressleiste über dem Dateifenster die komplette Adresse ein.
So wechseln Sie zu einer Seite, die bereits in Ihrer Favoritenliste abgespeichert ist:
  1. Klicken Sie in der Symbolleiste auf die Schaltfläche Favoriten.
  2. Wählen Sie die gewünschte Seite aus.
So gelangen Sie zu Webseiten, die Sie vor kurzem besucht haben:
  • Um zu der zuletzt angezeigten Seite zu wechseln, klicken Sie auf die Schaltfläche Zurück.
  • Um eine Seite anzuzeigen, die Sie vor dem Klicken auf Zurück besucht haben, klicken Sie auf die Schaltfläche Vorwärts.
  • Um eine Liste der zuletzt besuchten Seiten anzuzeigen, klicken Sie auf die kleinen, abwärts gerichteten Pfeile neben den Schaltflächen Zurück oder Vorwärts.


Startseite festlegen

SpeedCommander: Internet
Startseite festlegen

Die Startseite ist die Seite, die bei jeder Aktivierung des Internet im SpeedCommander angezeigt wird. Sie können jederzeit zur Startseite zurückkehren, indem Sie in der Symbolleiste auf die Schaltfläche Internet Startseite klicken.

So ändern Sie die Startseite:
  1. Öffnen Sie mit dem Befehl Einstellungen aus dem Menü Extras den Einstellungsdialog.
  2. Wählen Sie die Seite Anwendungen und Internet.
  3. Geben Sie im Eingabefeld Startseite Ihre gewünschte Startseite ein.

Verwandte Themen

Suchseite festlegen


Suchseite festlegen

SpeedCommander: Internet
Suchseite festlegen

Die Suchseite ist die Seite, die Sie verwenden, um im Internet nach Informationen zu suchen. Sie können die Suchseite jederzeit aktivieren, indem Sie in der Symbolleiste auf die Schaltfläche Internet Suchen klicken.

So ändern Sie die Suchseite:
  1. Öffnen Sie mit dem Befehl Einstellungen aus dem Menü Extras den Einstellungsdialog.
  2. Wählen Sie die Seite Anwendungen und Internet.
  3. Geben Sie im Eingabefeld Suchseite Ihre gewünschte Suchseite ein.

Verwandte Themen

Startseite festlegen


Mozilla integrieren

SpeedCommander: Internet
Mozilla integrieren

Neben dem Microsoft Internet Explorer kann der SpeedCommander auch Mozilla als integrierten Browser verwenden. Voraussetzung dafür ist die Installation der aktuellen Version des Mozilla-ActiveX-Controls.

So verwenden Sie Mozilla als integrierten Browser:
  1. Laden Sie sich die aktuelle Version des Mozilla-ActiveX-Controls herunter.
  2. Wechseln Sie in das Programmverzeichnis von Mozilla.
  3. Geben Sie in der DOS-Eingabezeile den Befehl "regsvr32 mozctlx.dll" ein.
  4. Öffnen Sie mit dem Befehl Einstellungen aus dem Menü Extras den Einstellungsdialog.
  5. Wählen Sie die Einstellungsseite Anwendungen und Internet.
  6. Aktivieren Sie das Kontrollkästchen Mozilla ActiveX-Control verwenden.


FTP

SpeedCommander: FTP
Überblick

Sie können mit Hilfe des SpeedCommander einfach auf FTP-Server zugreifen. Das Kopieren, Verschieben und Löschen von Dateien erfolgt dabei so, wie Sie es vom Arbeiten mit lokalen Laufwerken kennen. Die Voraussetzung für das Arbeiten mit einem FTP-Server ist eine aktive TCP/IP-Verbindung über die Winsock-Schnittstelle. Sollten Sie nicht ständig mit dem Internet verbunden sein, müssen Sie sich vor dem Zugriff auf einen FTP-Server mit dem Internet über das DFÜ-Netzwerk verbinden.

Unterstützung von Firewalls und Proxyserver

Neben der direkten Verbindung zu einem FTP-Server unterstützt der SpeedCommander auch Verbindungen über Firewalls und Proxyserver.

Automatisches Aufrechterhalten der Verbindung

Viele FTP-Server beenden die Verbindung, wenn in einer bestimmten Zeit kein Datenfluß auftritt. Die Verbindung muss dann vor einem Einlesen eines Ordners oder dem Übertragen einer Datei neu aufgebaut werden. Der SpeedCommander hält die Verbindung im Hintergrund aufrecht, so dass kein neuer Verbindungsaufbau notwendig ist.

Weitere Themen

Standorte definieren

Verbindung herstellen

Dateien kopieren

Dateien löschen

Dateiattribute ändern


Standorte definieren

SpeedCommander: FTP
Standorte definieren

Mit Hilfe der Standortansicht können Sie eine Liste mit FTP-Servern verwalten, zu denen Sie im SpeedCommander eine Verbindung aufnehmen möchten. Wählen Sie im Laufwerksfenster das Symbol FTP, um die Standortansicht anzuzeigen.

So fügen Sie einen neuen Standort hinzu:
  1. Klicken Sie mit der rechten Maustaste in die Standortansicht und wählen Sie den Befehl Neue Verbindung. Der Dialog Neuen FTP-Standort erstellen erscheint.
  2. Tragen Sie einen Namen und optional eine Beschreibung für den Standort ein.
  3. Geben Sie im Eingabefeld Server die Adresse des FTP-Servers ein. Eine gültige Adresse ist z.B. "ftp.microsoft.com"
  4. Tragen Sie im Eingabefeld Benutzername Ihren Benutzernamen und im Eingabefeld Kennwort das dazugehörige Kennwort ein. Wenn Sie die Verbindung anonym herstellen wollen, so können Sie beide Eingabefelder leer lassen.
  5. Füllen Sie wenn nötig auch noch die anderen Felder aus.
So löschen Sie einen Standort:
  1. Markieren Sie in der Standortansicht den Standort, den Sie löschen möchten.
  2. Wählen Sie im Menü Datei den Befehl Löschen.


Verbindung herstellen

SpeedCommander: FTP
Verbindung herstellen

Um die Verbindung mit einem FTP-Server herzustellen, wählen Sie in der Standortansicht den Server aus, zu dem Sie eine Verbindung aufnehmen möchten. Doppelklicken Sie auf den Eintrag oder wählen Sie im Menü Datenträger den Befehl FTP-Verbindung herstellen.

Unterhalb der Dateiliste wird ein Statusfenster angezeigt. In diesem Fenster werden alle Befehle, die an den FTP-Server geschickt werden, sowie die Reaktionen des FTP-Servers dargestellt. Sie können die Größe des Statusfensters ändern, indem Sie mit der linken Maustaste auf die Trennlinie zwischen Ordnerfenster und Statusfenster klicken, und diese verschieben.

Über den Befehl FTP-Verbindung trennen aus dem Menü Datenträger kann die Verbindung wieder getrennt werden. Beachten Sie bitte, dass Sie die Internet-Verbindung über das DFÜ-Netzwerk wieder trennen.

Sie können auch schnell eine Verbindung aufbauen, indem Sie in der DOS-Kommandozeile einfach die FTP-Adresse (ftp://ftp.microsoft.com) eingeben.

Weitere Informationen

Standorte definieren


Dateien kopieren

SpeedCommander: FTP
Dateien kopieren

Mit dem SpeedCommander können Sie Dateien von einem FTP-Server auf ein lokales Laufwerk oder ein Netzlaufwerk kopieren. Der SpeedCommander kann auch abgebrochene Downloads wieder aufnehmen, wenn der FTP-Server dies unterstützt.

Natürlich können Sie auch Dateien von einem lokalen Laufwerk oder einem Netzlaufwerk auf einen FTP-Server kopieren.

So kopieren Sie Dateien von einem FTP-Server:
  1. Stellen Sie eine Verbindung zu einem FTP-Server her und wechseln Sie in den Ordner, in dem sich die zu übertragenen Dateien befinden.
  2. Markieren Sie die Dateien, die Sie kopieren möchten.
  3. Wählen Sie aus dem Menü Datei den Befehl Kopieren.
  4. Geben Sie im Dialogfeld Kopieren das Ziel des Kopiervorgangs an.
  5. Wählen Sie im Feld Modus den Übertragungsmodus. In der Regel sollten Sie hier Automatisch angeben.
  6. Aktivieren Sie das Kontrollkästchen Dateizeit vom FTP-Server übernehmen, wenn die Dateizeit für eine Datei vom FTP-Server übernommen werden soll.
  7. Drücken Sie Eingabe, oder klicken Sie auf OK.
So kopieren Sie Dateien auf einen FTP-Server:
  1. Stellen Sie eine Verbindung zu einem FTP-Server her und wechseln Sie in den Ordner, in dem die Dateien abgelegt werden sollen.
  2. Markieren Sie im anderen Ordnerfenster die Dateien und Ordner, die Sie auf den FTP-Server kopieren möchten.
  3. Wählen Sie aus dem Menü Datei den Befehl Kopieren.
  4. Wählen Sie im Dialogfeld Kopieren im Feld Modus den Übertragungsmodus. In der Regel sollten Sie hier Automatisch angeben.
  5. Aktivieren Sie das Kontrollkästchen Automatische Konvertierung nach Klein, wenn die Dateinamen beim Kopieren automatisch in Kleinbuchstaben umgewandelt werden sollen.
  6. Drücken Sie Eingabe, oder klicken Sie auf OK.


Dateien löschen

SpeedCommander: FTP
Dateien löschen

Sie können Dateien und Ordner auf einem FTP-Server löschen.

So löschen Sie Dateien auf einem FTP-Server:
  1. Stellen Sie eine Verbindung zu einem FTP-Server her und wechseln Sie in den Ordner, in dem sich die zu löschenden Dateien befinden.
  2. Markieren Sie Dateien, die Sie löschen möchten.
  3. Wählen Sie aus dem Menü Datei den Befehl Löschen.
  4. Drücken Sie Eingabe, oder klicken Sie auf Ja, um die Dateien zu löschen.


Dateiattributeändern

SpeedCommander: FTP
Dateiattribute ändern

Alle Dateien auf einem FTP-Server haben bestimmte Dateiattribute. Die Attribute geben an, ob und von wem eine Datei gelesen, ausgeführt oder beschrieben werden darf. Mit dem SpeedCommander können Sie diese Informationen für eine Datei, eine Gruppe von Dateien oder sogar für gesamte Ordner ändern.

So ändern Sie die Dateiattribute für Dateien und Ordner:
  1. Wählen Sie die Dateien und Ordner aus.
  2. Wählen Sie Eigenschaften aus dem Menü Datei, oder klicken Sie in der Symbolleiste auf das Symbol Eigenschaften.
  3. Sie können für die ausgewählten Dateien und Ordner Berechtigungen setzen oder löschen. Wählen Sie die gewünschten Attribute aus.
  4. Drücken Sie Eingabe, oder klicken Sie auf OK.


Datenträger verwalten

SpeedCommander: Datenträger verwalten
Überblick

Dieser Abschnitt erläutert, wie Sie Daten von einer Diskette auf eine andere kopieren, Datenträger formatieren und benennen sowie Netzlaufwerke verbinden und trennen.

Weitere Informationen

Formatieren von Datenträgern

Kopieren von Disketten

Datenträger umbenennen

Netzlaufwerk verbinden

Netzlaufwerk trennen


Formatieren von Datenträgern

SpeedCommander: Datenträger verwalten
Formatieren von Datenträgern

Bevor Sie eine Diskette oder eine Festplatte zur Speicherung von Dateien verwenden können, muss diese formatiert werden. Der SpeedCommander enthält ein schnelles und leistungsfähiges Hilfsprogramm zur Formatierung von Datenträgern.

So formatieren Sie einen Datenträger:
  1. Wählen Sie Datenträger formatieren aus dem Menü Datenträger.
  2. Wählen Sie das Laufwerk zur Formatierung aus. Klicken Sie auf OK. Das Dialogfeld Datenträger formatieren wird angezeigt.
  3. Wählen Sie Starten, um den Formatiervorgang zu beginnen.


Kopieren von Disketten

SpeedCommander: Datenträger verwalten
Kopieren von Disketten

Mit dem Befehl Datenträger kopieren können Sie Daten von einer Diskette auf eine andere kopieren. Sie können direkt von Diskette zu Diskette kopieren, ohne die Daten dazu vorher auf Ihre Festplatte kopieren zu müssen.

So kopieren Sie eine Diskette:
  1. Wählen Sie Datenträger kopieren aus dem Menü Datenträger. Das Dialogfeld Diskette kopieren erscheint.
  2. Wählen Sie die Quelldiskette und die Zieldiskette aus.
  3. Klicken Sie auf Starten, um den Kopiervorgang zu starten.


Datenträger umbenennen

SpeedCommander: Datenträger verwalten
Datenträger umbenennen

Sie können für jeden Datenträger Ihres Computers eine Bezeichnung festlegen.

So benennen Sie einen Datenträger:
  1. Klicken Sie in der Laufwerksleiste mit der rechten Maustaste auf den Datenträger, den Sie umbenennen möchten.
  2. Wählen Sie aus dem Kontextmenü den Befehl Eigenschaften.
  3. Geben Sie im Dialogfeld Eigenschaften in das Eingabefeld Bezeichnung den neuen Namen ein.
  4. Drücken Sie Eingabe, oder klicken Sie auf OK.


Netzlaufwerk verbinden

SpeedCommander: Datenträger verwalten
Netzlaufwerk verbinden

Wenn Sie regelmäßig auf einen bestimmten Ordner auf einem Netzwerkserver zugreifen und dabei Zeit sparen möchten, können Sie diesem Ordner einen Laufwerksbuchstaben zuweisen.

So stellen Sie eine Verbindung zu einem Netzlaufwerk her:
  1. Wählen Sie den Befehl Netzlaufwerk verbinden aus dem Menü Datenträger. Das Dialogfeld Netzlaufwerk verbinden wird angezeigt.
  2. Wählen Sie den Laufwerksbuchstaben, den Sie zuordnen wollen, aus dem Kombinationsfeld Laufwerk aus. Alle bereits zugeordneten Laufwerke werden hier aufgeführt.
  3. Wählen Sie den Pfad für die Laufwerkszuordnung aus dem Kombinationsfeld Pfad aus. Wenn der gewünschte Pfad noch nicht in der Liste vorhanden ist, müssen Sie ihn manuell eingeben.
  4. Klicken Sie auf Verbindung beim Start wiederherstellen, wenn die Verbindung beim nächsten Start von Windows automatisch wiederhergestellt werden soll.
  5. Klicken Sie auf OK. Das ausgewählte Laufwerk ist nun dem gewünschten Ordner auf dem Netzwerkserver zugeordnet.

Verwandte Themen

Netzlaufwerk trennen


Netzlaufwerk trennen

SpeedCommander: Datenträger verwalten
Netzlaufwerk trennen

Greifen Sie nicht mehr regelmäßig auf ein verbundenes Netzlaufwerk zu, können Sie die Verbindung trennen.

So trennen Sie die Verbindung zu einem Netzlaufwerk:
  1. Wählen Sie den Befehl Netzlaufwerk trennen aus dem Menü Datenträger. Das Dialogfeld Netzlaufwerk trennen wird angezeigt. Es enthält eine Liste der Laufwerke, deren Zuordnung aufgehoben werden kann.
  2. Wählen Sie das Laufwerk aus, dessen Verbindung getrennt werden soll.
  3. Drücken Sie Eingabe, oder klicken Sie auf OK.

Verwandte Themen

Netzlaufwerk verbinden


Weitere Möglichkeiten

SpeedCommander: Weitere Möglichkeiten
Überblick

Dieses Kapitel beschreibt Möglichkeiten, wie Sie den SpeedCommander noch besser und effizienter zur täglichen Arbeit am Computer einsetzen können. Sie erfahren hier, wie Sie unter anderem auf die Historyliste und die verschiedenen Favoritenmenüs zugreifen sowie eigene Programme in den SpeedCommander einbinden können.

Weitere Informationen

Historyliste

Zugriff auf Systemordner

Ordnerfavoriten

Anwendungsfavoriten

Internetfavoriten-Menü

Startmenü

Desktop-Menü

Arbeitsplatz-Menü


Historyliste

SpeedCommander: Weitere Möglichkeiten
Historyliste

Die Historyliste ist eine Zusammenstellung der Ordner, die Sie während der aktuellen Sitzung mit dem SpeedCommander aktiviert gehabt haben. Sie können so schnell auf vorher aktivierte Ordner zugreifen, ohne sich mühselig durch die Ordnerstrukturen zu kämpfen.

So greifen Sie auf die Historyliste zu:
  • Klicken Sie in der Symbolleiste auf die Schaltflächen Zurück oder Vorwärts, um den zuletzt aktivierten Ordner anzuzeigen.
  • Klicken Sie in der Symbolleiste auf die Pfeile neben den Schaltflächen Vorwärts oder Rückwärts, um eine Liste mit den zuletzt angezeigten Ordnern anzuzeigen.
So wechseln Sie schnell zum vorherigen Ordner:
  • Aktivieren Sie das Menü Ordner, zeigen Sie auf Wechseln zu und wählen Sie den Befehl Zurück; klicken Sie in der Symbolleiste auf die Schaltfläche Zurück; oder drücken Sie Alt+Cursor nach links.
So wechseln Sie schnell zum nächsten Ordner:
  • Aktivieren Sie das Menü Ordner, zeigen Sie auf Wechseln zu und wählen Sie den Befehl Vorwärts; klicken Sie in der Symbolleiste auf die Schaltfläche Vorwärts; oder drücken Sie Alt+Cursor nach rechts.

Wenn die Schaltflächen Zurück und Vorwärts nicht in der Symbolleiste zu finden sind, müssen Sie diese Schaltflächen in die Symbolleiste einfügen. Informationen dazu erhalten Sie unter Symbolleisten und Menü anpassen.


Systemordner

SpeedCommander: Weitere Möglichkeiten
Systemordner

Mit dem Systemordner-Menü gelangen Sie schnell in alle wichtigen Systemordner. Der SpeedCommander unterstützt die folgenden Ordner:

  • Desktop
  • Favoriten
  • Startmenü
  • Programmordner
  • Ordner mit den gemeinsamen Dateien
  • Senden An
  • Anwendungsdaten
  • Lokale Anwendungsdaten
  • Eigene Dateien
  • Eigene Bilder
  • Schriftarten
  • Verlauf
  • Cookies
  • Temporäre Internetdateien
  • Windows-Verzeichnis
  • System-Verzeichnis
So aktivieren Sie einen Systemordner:
  1. Aktivieren Sie das Menü Ordner und zeigen Sie auf Systemordner oder klicken Sie in der Symbolleiste auf die Schaltfläche Systemordner.
  2. Wählen Sie den Systemordner aus, den Sie aktivieren möchten.

Wenn die Schaltfläche Systemordner nicht in der Symbolleiste zu finden ist, müssen Sie diese Schaltfläche in die Symbolleiste einfügen. Informationen dazu erhalten Sie unter Symbolleisten und Menü anpassen.


Ordnerfavoriten

SpeedCommander: Weitere Möglichkeiten
Ordnerfavoriten

Ordnerfavoriten sind Ordner, die Sie oft benutzen und die Sie schnell aktivieren möchten. Wenn Sie einen Ordnerfavoriten auswählen, wechselt der SpeedCommander im aktiven Ordnerfenster in den entsprechenden Ordner. Zusätzlich können Sie auch gleich noch einen Ordner festlegen, der gleichzeitig im inaktiven Fenster dargestellt wird.

So aktivieren Sie das Ordnerfavoriten-Menü:
  1. Klicken Sie mit der linken Maustaste doppelt auf den Bereich über dem Ordnerfenster, in dem der Name des Ordners angezeigt wird.
  2. Aktivieren Sie das Menü Ordner und zeigen Sie auf Ordnerfavoriten.
  3. Drücken Sie Strg+W.
So fügen Sie einen Ordner den Ordnerfavoriten hinzu:
  1. Aktivieren Sie das Ordnerfavoriten-Menü.
  2. Wählen Sie im Ordnerfavoriten-Menü den Befehl Aktuellen Ordner hinzufügen.
So wechseln Sie schnell in einen Ordner:
  1. Aktivieren Sie das Ordnerfavoriten-Menü.
  2. Wählen Sie den Ordner aus, in den Sie wechseln möchten.
So verwalten Sie die Ordnerfavoriten:
  1. Wählen Sie im Ordnerfavoriten-Menü den Befehl Konfigurieren, das Dialogfeld Ordnerfavoriten konfigurieren erscheint.
  2. Klicken Sie mit der linken Maustaste einmal auf den Ordnerfavoriten, um dessen Eigenschaften zu ändern.
  3. Das Eingabefeld Aktives Fenster gibt den Ordner an, in welchen im aktiven Ordnerfenster gewechselt wird.
  4. Das Eingabefeld Inaktives Fenster gibt den Ordner an, in welchen im inaktiven Ordnerfenster gewechselt wird.
  5. Die Schaltfläche Neu erstellt unterhalb des gerade gewählten Eintrags einen neuen Ordnerfavoriten.
  6. Die Schaltfläche Untermenü erstellt unterhalb des gerade gewählten Eintrags ein neues Untermenü. Dies eröffnet Ihnen die Möglichkeit, die Ordnerfavoriten hierarchisch zu organisieren.
  7. Die Schaltfläche Löschen entfernt den gewählten Eintrag. Wenn Sie ein Untermenü löschen, wird nur das Menü gelöscht, die Einträge selbst bleiben erhalten.
  8. Zum Verschieben von Menüeinträgen klicken Sie mit der linken Maustaste auf den Eintrag, den Sie verschieben möchten und ziehen diesen per Drag & Drop an die gewünschte Position.


Anwendungsfavoriten

SpeedCommander: Weitere Möglichkeiten
Anwendungsfavoriten

Viele Funktionen, die für die tägliche Arbeit am Computer benötigt werden, sind bereits im SpeedCommander enthalten. Der SpeedCommander ermöglicht es Ihnen jedoch auch, eigene Programme einzubinden, die per Menü oder Symbolleiste gestartet werden können. Sie können einem Anwendungsfavoriten beim Start auch Parameter übergeben. Diese Parameter werden dem Programm per Kommandozeile übermittelt.

So aktivieren Sie das Anwendungsfavoriten-Menü:
  1. Klicken Sie mit der linken Maustaste bei gedrückter Umschalt-Taste doppelt auf den Bereich über dem Ordnerfenster, in dem der Name des Ordners angezeigt wird.
  2. Aktivieren Sie das Menü Extras und zeigen Sie auf Anwendungsfavoriten.
  3. Drücken Sie Strg+Umschalt+W.
So verwalten Sie die Anwendungsfavoriten:
  1. Aktivieren Sie das Anwendungsfavoriten-Menü und wählen Sie den Befehl Konfigurieren, das Dialogfeld Anwendungsfavoriten konfigurieren erscheint.
  2. Klicken Sie auf die Schaltfläche Neu, um einen neuen Eintrag zu erstellen, und vergeben Sie eine Bezeichnung für diesen Eintrag.
  3. Tragen Sie im Eingabefeld Anwendung den vollständigen Pfadnamen zum Programm ein.
  4. Wenn Sie möchten, dass ein bestimmter Ordner als Startordner festgelegt wird, so tragen Sie diesen im Eingabefeld Ordner ein.
  5. Im Eingabefeld Argumente können Sie der Anwendung Parameter übergeben.
  6. Legen Sie im Kombinationsfeld Modus den Startmodus der Anwendung fest.
  7. Aktivieren Sie das Kontrollkästchen Dateinamen in 8.3-Notation, wenn die Anwendung eine DOS-Anwendung ist.
  8. Die Schaltfläche Untermenü erstellt unterhalb des gerade gewählten Eintrags ein neues Untermenü. Dies eröffnet Ihnen die Möglichkeit, die Ordnerfavoriten hierarchisch zu organisieren.
  9. Zum Verschieben von Menüeinträgen klicken Sie mit der linken Maustaste auf den Eintrag, den Sie verschieben möchten und ziehen diesen per Drag & Drop an die gewünschte Position.
So aktivieren Sie einen Anwendungsfavoriten:
  1. Aktivieren Sie das Anwendungsfavoriten-Menü.
  2. Wählen Sie das Programm aus, welches Sie starten möchten.


Internetfavoriten-Menü

SpeedCommander: Weitere Möglichkeiten
Internetfavoriten-Menü

Das Internetfavoriten-Menü dient ähnlich den Ordnerfavoriten zur schnellen Aktivierung von favorisierten Ordnern oder Internetadressen. Im Gegensatz zu den Ordnerfavoriten ist das Internetfavoriten-Menü jedoch systemweit abrufbar und wird ebenso vom Internet Explorer verwendet.

So fügen Sie einen Ordner oder eine Webseite zum Internetfavoriten-Menü hinzu:
  1. Aktivieren Sie in einem Ordnerfenster den Ordner oder die Webseite, die Sie dem Internetfavoriten-Menü hinzufügen möchten.
  2. Aktivieren Sie das Menü Extras, zeigen Sie auf Internetfavoriten und wählen Sie den Befehl Zu Favoriten hinzufügen.
  3. Geben Sie im Dialogfeld Zu Favoriten hinzufügen einen Namen an, unter dem der Favorit gespeichert werden soll.
  4. Drücken Sie Eingabe, oder klicken Sie auf OK.
So wählen Sie einen Eintrag aus dem Internetfavoriten-Menü aus:
  1. Aktivieren Sie das Menü Extras, zeigen Sie auf Internetfavoriten oder klicken Sie in der Symbolleiste auf die Schaltfläche Internetfavoriten.
  2. Wählen Sie aus dem darauf erscheinenden Menü den Favoriten aus, den Sie aktivieren möchten.

Wenn die Schaltfläche Internetfavoriten nicht in der Symbolleiste zu finden ist, müssen Sie diese Schaltfläche in die Symbolleiste einfügen. Informationen dazu erhalten Sie unter Symbolleisten und Menü anpassen.


Startmenü

SpeedCommander: Weitere Möglichkeiten
Startmenü

Mit dem Startmenü können Sie sehr schnell auf alle Programme im Startmenü von Windows zugreifen, ohne den SpeedCommander verlassen zu müssen.

So greifen Sie auf das Startmenü zu:
  1. Aktivieren Sie das Menü Extras und zeigen Sie auf Startmenü oder klicken Sie in der Symbolleiste auf die Schaltfläche Startmenü.
  2. Wählen Sie aus dem darauf erscheinenden Menü das Programm aus, das Sie starten möchten.

Wenn die Schaltfläche Startmenü nicht in der Symbolleiste zu finden ist, müssen Sie diese Schaltfläche in die Symbolleiste einfügen. Informationen dazu erhalten Sie unter Symbolleisten und Menü anpassen.


Desktop-Menü

SpeedCommander: Weitere Möglichkeiten
Desktop-Menü

Mit dem Desktop-Menü können Sie sehr schnell auf alle Symbole des Desktops von Windows zugreifen, ohne alle Anwendungen davor minimieren zu müssen.

So greifen Sie auf die Symbole des Desktops zu:
  1. Aktivieren Sie das Menü Extras und zeigen Sie Desktop oder klicken Sie in der Symbolleiste auf die Schaltfläche Desktop.
  2. Wählen Sie aus dem darauf erscheinenden Menü das Symbol aus, das Sie aktivieren möchten. Stellt das Symbol eine Verknüpfung zu einem Programm dar, wird dieses Programm gestartet. Ist das Symbol dagegen eine Verknüpfung zu einem Ordner, wird der Order im aktiven Ordnerfenster angezeigt.

Wenn die Schaltfläche Desktop nicht in der Symbolleiste zu finden ist, müssen Sie diese Schaltfläche in die Symbolleiste einfügen. Informationen dazu erhalten Sie unter Symbolleisten und Menü anpassen.


Arbeitsplatz-Menü

SpeedCommander: Weitere Möglichkeiten
Arbeitsplatz-Menü

Mit dem Arbeitsplatz-Menü können Sie sehr schnell auf alle Komponenten des Arbeitsplatzes zugreifen, ohne den SpeedCommander zu verlassen. Sie haben z.B. so Zugriff auf alle Komponenten der Systemsteuerung und auf das DFÜ-Netzwerk.

So greifen Sie auf Komponenten des Arbeitsplatzes zu:
  1. Aktivieren Sie das Menü Extras und zeigen Sie auf Arbeitsplatz oder klicken Sie in der Symbolleiste auf die Schaltfläche Arbeitsplatz.
  2. Wählen Sie aus dem darauf erscheinenden Menü die gewünschte Komponente aus.

Wenn die Schaltfläche Arbeitsplatz nicht in der Symbolleiste zu finden ist, müssen Sie diese Schaltfläche in die Symbolleiste einfügen. Informationen dazu erhalten Sie unter Symbolleisten und Menü anpassen.


Konfiguration

SpeedCommander: Konfiguration
Überblick

Dieses Kapitel beschreibt, wie Sie den SpeedCommander konfigurieren und so an Ihre persönliche Arbeitsweise anpassen können. Sie können die Anzeige auf dem Bildschirm, den Inhalt der Fenster und die Schriftarten und Farben ändern sowie auswählen, welchen Editor Sie aus dem SpeedCommander heraus aufrufen möchten.

Sie können die Symbolleisten und das Menü frei gestalten sowie vielen Befehlen im SpeedCommander eigene Tastenkürzel zuordnen.

Weitere Informationen

Dialogfeld "Einstellungen"

Dialogfeld "Anpassen"

Schriftart anpassen

Einstellungen sichern

SpeedCommander im mobilen Einsatz


Einstellungen

SpeedCommander: Konfiguration
Einstellungen

Im Einstellungsdialog nehmen Sie Grundeinstellungen für den SpeedCommander vor. Sie können das Aussehen der Ordner- und Laufwerksfenster anpassen und die externen Programme zum Betrachten und Editieren von Dateien ändern. Zur Anzeige des Dialogfeldes wählen Sie den Befehl Einstellungen aus dem Menü Extras.

Aussehen
  • Darstellung
  • Farben
  • Dateien & Ordner
  • Netzwerk und Sortieren
  • Details
Verhalten
  • Programmstart
  • Ordner & Laufwerke
  • NC-Kompatibilität
  • Registerkarten
  • Ordnergrößen
  • Details
Erweitert
  • Anwendungen & Internet
  • FTP-Client
  • Schnellansicht
  • Kompression
  • Dateiverknüpfungen


Darstellung

SpeedCommander: Konfiguration
Darstellung

Mit dem Dialogfeld Darstellung legen Sie fest, ob SpeedCommander eine textorientierte Menüleiste verwenden soll und welche zusätzlichen Symbole in der Laufwerksanzeige eingeblendet werden sollen.

Allgemein
Sprache | Ermöglicht es Ihnen, die Sprache zu wechseln, die von SpeedCommander für Menüs und Dialogfelder verwendet wird. Wählen Sie Ihre gewünschte Sprache und starten Sie SpeedCommander neu.
Screenreader-kompatible Menüs verwenden | Bei Aktivierung ist die oben in SpeedCommander angezeigte Menüleiste textorientiert und Screenreader-kompatibel, die von blinden Benutzern oder Benutzern mit Sehschwächen verwendet werden. Diese eher traditionelle Menüleiste kann nicht benutzerdefiniert angepasst werden.
Screenreader-kompatiblen Dialog zur Feldauswahl benutzen | Legt fest, dass für die Feldauswahl in den verschiedenen Listenansichten ein Screenreader-kompatibler Dialog angezeigt werden soll.
Zusätzliche Symbole für Laufwerksanzeige
Netzwerkumgebung | Legt fest, ob die Netzwerkumgebung als virtuelles Laufwerk angezeigt werden soll.
Internet | Legt fest, ob das Internet als virtuelles Laufwerk angezeigt werden soll.
FTP | Legt fest, ob FTP als virtuelles Laufwerk angezeigt werden soll.
AddIns | Legt fest, ob die AddIns als virtuelles Laufwerk angezeigt werden sollen.
Darstellung
Automatische Auswahl | Die Auswahl von Dateien und Verzeichnissen erfolgt automatisch durch Berühren mit der Maus.
Trennlinien in der Detailansicht | Die einzelnen Zeilen und Spalten in der Detailansicht werden durch Linien getrennt.
Ganze Zeile markieren | In der Detailansicht wird bei Auswahl eines Eintrages die gesamte Zeile hervorgehoben.
Fenster automatisch verbreitern
Schnellansicht auf | Aktivieren Sie diese Option, wenn das Ordnerfenster nach Aktivierung der Schnellansicht automatisch verkleinert werden soll und tragen Sie den Wert ein, auf den die Schnellansicht vergrößert werden soll. Die Angabe des Wertes erfolgt in Prozent.
Internetansicht auf | Aktivieren Sie diese Option, wenn das Ordnerfenster nach Aktivierung des Internet automatisch vergrößert werden soll und tragen Sie den Wert ein, auf den das Ordnerfenster vergrößert werden soll. Die Angabe des Wertes erfolgt in Prozent.


Farben

SpeedCommander: Konfiguration
Farben

Mit dem Dialogfeld Farben definieren Sie Ihr persönliches Farbschema.

Darstellung
Schema | Listet die Farbschemas auf, die verfügbar sind. Klicken Sie auf das Farbschema, das Sie verwenden möchten.
Element | Zeigt eine Liste der Bildschirmelemente an, deren Farben Sie ändern können.
Text | Listet die Farben auf, die in der ausgewählten Fensterkomponente für Text verwendet werden können.
Hintergrund | Listet die Hintergrundfarben auf, die Sie für das ausgewählte Fensterelement verwenden können. Ist diese Option nicht verfügbar, können Sie die Farbe des ausgewählten Elements nicht ändern.
Filter | Zeigt eine Liste mit allen selbstdefinierten Filtern.


Dateien & Ordner

SpeedCommander: Konfiguration
Dateien & Ordner

Das Dialogfeld Dateien & Ordner enthält Einstellungsmöglichkeiten zur Anpassung der Dateiliste und zur Arbeit mit Archiven.

Dateien
Dateisymbole anzeigen | Legt fest, dass zu jedem Dateinamen ein Symbol angezeigt wird. Deaktivieren Sie diese Option, wenn Sie keine Symbole angezeigt haben möchten und das Anzeigen eines Ordners beschleunigen möchten.
Dateierweiterungen immer anzeigen | Blendet die Dateinamenserweiterungen für alle Dateien ein. Klicken Sie auf diese Option, wenn Sie für alle Dateien den vollständigen Dateinamen anzeigen möchten.
Versteckte Dateien und Ordner anzeigen

Legt fest, ob versteckte Dateien und Ordner angezeigt werden sollen. Versteckte Dateien sind Programm- oder Systemdateien, die nicht geändert oder gelöscht werden sollten.

Nicht markiert: Versteckte Dateien und Ordner werden ausgeblendet.
Grau: Versteckte Dateien werden angezeigt, aber geschützte Systemdateien werden ausgeblendet.
Markiert: Alle Dateien und Ordner werden angezeigt.
Versteckte Dateien und Ordner etwas blasser anzeigen | Ordner und Dateien, die das Dateiattribut System oder Versteckt besitzen, werden besonders gekennzeichnet.
Darstellung durchgehend großgeschriebener Dateinamen beibehalten | Gibt an, dass Ihr Computer einen Dateinamen in Großbuchstaben anzeigen soll (z.B. DATEINAME.TXT), wenn der Dateiname ursprünglich so eingegeben wurde. Ist diese Option nicht aktiviert, werden Dateinamen unabhängig von ihrer ursprünglichen Eingabe in Groß-/Kleinschreibung geändert (z.B. Dateinamen.txt).
Dateigröße in | Legt fest, wie in der Detailansicht die Dateigröße angezeigt wird. Wählen Sie Bytes, wenn die Dateigröße immer in Bytes angezeigt werden soll; wählen Sie KB/Bytes, wenn die Dateigröße für Dateien größer 1MB in KB angezeigt werden soll, oder wählen Sie MB/KB/Bytes, wenn die Dateigröße jeweils in MB, KB oder Bytes angezeigt werden soll.
Ordner
Ordner mit führendem Backslash (\) kennzeichnen | Aktivieren Sie dieses Kontrollkästchen, wenn in der Listenansicht jedem Ordnernamen ein Backslash vorangestellt werden soll. Dies ist sinnvoll, wenn Sie keine Symbole eingeblendet haben.
Leere Ordner etwas blasser anzeigen | Leere Ordner werden besonders gekennzeichnet. Die Aktivierung dieser Einstellung verlangsamt das Einlesen der Ordnerfenster, da SpeedCommander bei jedem Unterordner prüft, ob dieser Dateien oder Unterverzeichnisse enthält.
Ordner bei Baumansicht ausblenden | Legt fest, ob bei einer kombinierten Baum-/Listenansicht die Ordner in der Listenansicht ausgeblendet werden sollen.
Archive
Archive wie Ordner behandeln | Legt fest, dass Archive beim Doppelklick oder bei Enter wie Ordner behandelt werden sollen.
Archive im Baum anzeigen | Legt fest, ob auch neben Ordnern auch Archive in der Baumansicht angezeigt werden sollen.
Ausführbare Archive als Ordner anzeigen | Legt fest, ob SpeedCommander beim Doppelklick auf eine ausführbare Datei prüfen soll, ob diese ein selbstentpackendes Archiv ist.
Zusätzliche Archivtypen | Geben Sie hier zusätzliche Dateitypen an, die SpeedCommander als Archive betrachten soll. Die Dateierweiterungen werden durch ein Semikolon getrennt (z.B. xpi;sxw).


Netzwerk & Sortieren

SpeedCommander: Konfiguration
Netzwerk & Sortieren

Mit dem Dialogfeld Netzwerk & Sortieren passen Sie die Anzeige der Netzwerkumgebung an und legen die Sortiereinstellungen fest.

Netzwerk
Administrative und versteckte Freigaben anzeigen (z.B. C$) | Aktivieren Sie dieses Kontrollkästchen, wenn SpeedCommander in der Netzwerkumgebung auch administrative und versteckte Freigaben anzeigen soll.
Freigegebene Drucker anzeigen | Aktivieren Sie dieses Kontrollkästchen, wenn SpeedCommander in der Netzwerkumgebung freigegebene Drucker anzeigen soll.
Bei Aktivierung der Netzwerkumgebung immer die oberste Ebene anzeigen | Legt fest, ob die zuletzt angezeigte Position in der Netzwerkumgebung wieder hergestellt werden soll. Deaktivieren Sie dieses Kontrollkästchen, wenn Sie bei jeder Aktivierung der Netzwerkumgebung immer im Hauptordner starten möchten.
Sortieren
Dateinamen mit Zahlen nach numerischem Wert sortieren | Legt fest, dass Ordner und Dateinamen mit Ziffern nach ihrem numerischen Wert sortiert werden (z.B. 2, 3, 10 anstatt 10, 2, 3).
Ordner unabhängig von Sortierung immer nach Namen ordnen | Legt fest, dass Ordner unabhängig von der eingestellten Sortierung immer nach dem Namen sortiert werden sollen.
Dateien und Ordner ausblenden
Konfigurieren Öffnet ein Dialogfeld, in dem Sie Dateinamen eintragen können, die SpeedCommander automatisch von der Ansicht ausschließen soll.


Details

SpeedCommander: Konfiguration
Details

Mit dem Dialogfeld Details legen Sie erweiterte Einstellungen für SpeedCommander fest.

Erweitert
Benutzername in Titelzeile anzeigen | Aktivieren Sie dieses Kontrollkästchen, wenn in der Titelzeile von SpeedCommander zusätzlich der aktuelle Benutzername angezeigt werden soll.
Hochauflösende Symbole | Legt fest, dass SpeedCommander die Symbolleisten und die QuickDrop-Symbole in hoher Auflösung anzeigen soll.
Basecap-Icon benutzen | Aktivieren Sie diese Option, wenn Sie anstatt des SpeedCommander-Programmsymbols das bekannte SpeedCommander-Basecap als Programmsymbol für die Titelzeile und die Task-Leiste festlegen möchten. Eine Änderung des Icons erfolgt erst nach einem Neustart von SpeedCommander.
In Infobereich minimieren | Aktivieren Sie diese Option, wenn SpeedCommander beim Minimieren anstatt als Symbol in der Taskleiste im Infobereich der Taskleiste (neben der Uhr) angezeigt werden soll.
Startbildschirm
Startbildschirm anzeigen | Legt fest, dass beim Programmstart ein Startbildschirm angezeigt wird.
Einblendeffekt | Legt den Effekt für das Einblenden des Startbildschirmes und die Zeit fest, die für Einblendeffekt verwendet werden soll.
Ausblendeffekt | Legt den Effekt für das Ausblenden des Startbildschirmes und die Zeit fest, die für Ausblendeffekt verwendet werden soll.
Miniaturansicht
Größe | Geben Sie hier die Größe der Miniaturansicht an.
Abstand (X) | Legt den horizontalen Abstand zwischen zwei Symbolen fest (X-Achse).
Abstand (Y) | Legt den vertikalen Abstand zwischen zwei Symbolen fest (Y-Achse).


Programmstart

SpeedCommander: Konfiguration
Programmstart

Im Dialogfeld Programmstart finden Sie Konfigurationsoptionen zu allgemeinen Dingen und zum Ausschalten von Bestätigungen.

Programmstart und -ende
Ordner- und Layout-Einstellungen beim Beenden speichern | Beim Beenden von SpeedCommander werden die aktuellen Einstellungen (Typ der Ordnerfenster, aktueller Ordner, Sortierung, Sortierrichtung, Anzeige in der Listenansicht, Spalten in der Detailansicht, Filter) gespeichert.
Nur eine Programminstanz von SpeedCommander gleichzeitig erlaubt | Aktivieren Sie diese Option, wenn beim Start von SpeedCommander geprüft werden soll, ob bereits ein SpeedCommander aktiv ist. In diesem Fall wird der bereits aktive SpeedCommander in den Vordergrund gebracht.
Speicherung der letzten Einträge in Eingabefeldern | Aktivieren Sie diese Option, wenn sich SpeedCommander die zuletzt getätigten Eingaben in den Dialogfeldern merken soll und geben Sie die Anzahl der Einträge an, die sich SpeedCommander merken soll.
Bestätigungen beim
Kopieren von Dateien und Ordnern | Das Kopieren von Dateien und Ordnern muss bestätigt werden. SpeedCommander zeigt den Dialog Kopieren, in dem Sie ein anderes Ziel angeben oder die Aktion abbrechen können.
Verschieben von Dateien und Ordnern | Das Verschieben von Dateien und Ordnern muss bestätigt werden. SpeedCommander zeigt den Dialog Verschieben, in dem Sie ein anderes Ziel angeben oder die Aktion abbrechen können.
Löschen von Systemdateien | Das Löschen von Systemdateien muss bestätigt werden.
Löschen von schreibgeschützten Dateien | Das Löschen von schreibgeschützten Dateien muss bestätigt werden.
Ordnerverlauf
Ordnerverlauf beim Beenden speichern | Aktivieren Sie diese Option, wenn der Ordnerverlauf beim Beenden gespeichert werden soll.
Ordner verzögert in Verlauf aufnehmen nach | Aktivieren Sie diese Option, wenn ein Ordner dem Verlauf erst hinzugefügt werden soll, wenn Sie sich eine bestimmte Zeit in dem Ordner aufgehalten haben.


Ordner & Laufwerke

SpeedCommander: Konfiguration
Ordner & Laufwerke

Mit dem Dialogfeld Ordner & Laufwerke legen Sie das Verhalten von Ordnern und Laufwerken fest und passen die Einstellungen zur Aktualisierung an.

Verhalten von Ordnern
Ausgewählter Filter gilt für alle Ordnerfenster gleichzeitig | Legt fest, ob die Auswahl eines Filters gleichzeitig für alle Fenster gelten soll. Deaktivieren Sie diese Option, wenn Sie für jedes Ordnerfenster einen eigenen Filter verwenden möchten.
Spalten zwischen Ordnerfenstern bei Änderungen synchronisieren | Aktualisiert bei einer Änderung der Spaltengröße oder der Reihenfolge der einzelnen Spalten in der Detailansicht gleichzeitig die Spalten im gegenüberliegenden Fenster. Eine Aktualisierung kann nur erfolgen, wenn in beiden Fenstern der gleiche Ordnertyp angezeigt wird (z.B. C:\Windows und D:\). Es erfolgt keine Aktualisierung, wenn auf einer Seite ein lokaler Ordner und auf der anderen Seite ein Archiv angezeigt wird.
Bei Wechsel in übergeordnetes Verzeichnis aktuellen Ordner markieren | Legt fest, ob nach einem Wechsel in das Elternverzeichnis der zuvor angezeigte Ordner markiert werden soll. Deaktivieren Sie diese Einstellung, wenn der Ordner nur fokussiert aber nicht markiert werden soll.
Laufwerksauswahl
Bei Laufwerksauswahl zugehöriges Ordnerfenster aktivieren | Legt fest, dass nach der Auswahl des Laufwerksbuchstabens das entsprechende Fenster auch aktiviert wird.
Bei Laufwerksauswahl immer in dessen Hauptverzeichnis wechseln | Legt fest, dass SpeedCommander bei der Aktivierung eines Laufwerks immer in das Hauptverzeichnis wechseln soll.
Aktualisierung
Wechseldatenträger nach dem Einlegen automatisch einlesen | Legt fest, dass der Inhalt eines Ordnerfensters nach dem Einlegen eines Wechseldatenträgers automatisch aktualisiert wird.
Nach automatischer Aktualisierung sortieren | SpeedCommander aktualisiert seine Ordnerfenster selbständig, sofern dies möglich ist. Die neuen Dateien werden wie im Explorer an das Ende der Dateiliste angefügt. Aktivieren Sie diese Option, wenn SpeedCommander die Ordnerfenster nach einer Änderung im Dateisystem automatisch sortieren soll.
Aktualisierung der Dateifenster bei Aktivierung von SpeedCommander | Legt fest, dass der Inhalt der Ordnerfenster aktualisiert werden soll, wenn SpeedCommander aktiviert wird. Diese Einstellung ist nur wählbar, wenn die automatische Hintergrundaktualisierung deaktiviert ist.
Hintergrundaktualisierung | Legt fest, dass SpeedCommander seine Dateifenster automatisch aktualisieren soll, wenn im angezeigten Ordner Änderungen erfolgen. Geben Sie hier die Zeit in Millisekunden an, die SpeedCommander wartet, um nach einer Änderung im Dateisystem die Anzeige des aktuellen Ordners zu aktualisieren. Die Aktualisierung erfolgt jedoch erst, wenn innerhalb der angegebenen Zeit keine weitere Änderung im aktuellen Ordner erfolgt.


NC-Kompatibilität

SpeedCommander: Konfiguration
NC-Kompatibilität

Mit dem Dialogfeld NC-Kompatibilität können Sie den NC-Kompatibilitätsmodus aktivieren und anpassen.

Anzeige
NC-Auswahlmodus aktivieren | Aktiviert den NC-Auswahlmodus.
Erweiterte Auswahl mit den Steuerungstasten 'Umschalt' und 'Strg' | Aktiviert die erweiterte Auswahl mit 'Umschalt' und 'Strg' für den NC-Auswahlmodus.
Markieren mit rechter Maustaste | Legt fest, dass die Markierung von Dateien mit der rechten Maustaste erfolgt. In der Detailansicht erfolgt die Markierung durch Klicken auf den Dateinamen.
Ordner in Groß- und Dateien in Kleinbuchstaben anzeigen | Legt fest, dass alle Ordner in Großbuchstaben und alle Dateien in Kleinbuchstaben dargestellt werden.
Dateierweiterung im Namen unterdrücken | Legt fest, dass die Dateinamen ohne Dateierweiterungen angezeigt werden.
Erweitert
Hauptmenü mit F9 anzeigen | Aktivieren Sie dieses Kontrollkästchen, wenn Sie das Menü mit 'F9' aktivieren möchten.
SpeedCommander mit F10 schließen | Aktivieren Sie dieses Kontrollkästchen, wenn Sie SpeedCommander neben 'Alt-F4' auch mit 'F10' beenden möchten.


Registerkarten

SpeedCommander: Konfiguration
Registerkarten

Mit dem Dialogfeld Registerkarten legen Sie Einstellungen für die Registerkarten sowie deren Anordnung fest.

Allgemein
Bei Ordnerwechsel in gesperrten Registerkarten in freies Fenster wechseln | SpeedCommander zeigt einen Hinweis an, wenn Sie in einem Ordnerfenster, dessen Navigation eingeschränkt ist, in einen Ordner wechseln möchten. Aktivieren Sie dieses Kontrollkästchen, wenn SpeedCommander stattdessen in das erste freie Ordnerfenster wechseln und dort den neuen Ordner anzeigen soll.
Registername automatisch an aktuellen Ordner anpassen | Aktivieren Sie dieses Kontrollkästchen, wenn SpeedCommander den Namen von neu erstellten Ordnerfenstern automatisch an den angezeigten Ordner anpassen soll.
Ordnerfenster für temporäre Archive automatisch schließen | Legt fest, dass SpeedCommander temporär erzeugte Tabs zur Anzeige von Archiven in Archiven automatisch schließen soll, wenn das temporär entpackte Archiv verlassen wird.
Anordnung
Hauptregister | Wählen Sie hier, an welcher Position die Hauptregisterkarten (Ordner, Dateiablage) angezeigt werden sollen.
Unterregister | Wählen Sie hier, an welcher Position die Unterregisterkarten (Ordnerfenster) angezeigt werden sollen.


Ordnergrößen

SpeedCommander: Konfiguration
Ordnergrößen

Mit dem Dialogfeld Ordnergrößen legen Sie Einstellungen zur automatischen Ordnergrößenberechnung fest.

Allgemein
Dateigröße bei Ordnern automatisch berechnen | Aktivieren Sie dieses Kontrollkästchen, wenn SpeedCommander neben der Größe der einzelnen Dateien auch die Größe eines Ordners in der Detailansicht anzeigen soll.
Berechnete Ordnergrößen automatisch im Hintergrund aktualisieren | Aktivieren Sie dieses Kontrollkästchen, wenn bei aktivierter Ordnergrößenberechnung die angezeigten Ordnergrößen automatisch aktualisiert werden, wenn sich in den Unterordnern etwas ändert.
Ordnergrößen automatisch berechnen bis maximal | Legt fest, dass die automatische Berechnung von Ordnergrößen nur bis zu einem bestimmten Limit erfolgen soll. Die Berechnung wird abgebrochen, wenn die Ordnergröße das Limit überschreitet.
Ordnergrößenberechnung deaktivieren
Konfigurieren Öffnet ein Dialogfeld, in dem Sie Ordner eintragen können, für welche die automatische Ordnergrößenberechnung deaktiviert werden soll.


Details

SpeedCommander: Konfiguration
Details

Mit dem Dialogfeld Details legen Sie erweiterte Einstellungen von SpeedCommander fest.

Erweitert
Dateien und Ordner durch einfachen Klick öffnen | Die Aktivierung eines Eintrages kann statt eines Doppelklicks auch durch einen einfachen Klick erfolgen. Aktivieren Sie diese Option, wenn Sie z.B. einen Ordner mit einem einfachen Mausklick öffnen möchten.
Favoriten-Menü immer an Mausposition anzeigen | Normalerweise werden die Menüs mit den Ordner- und Anwendungsfavoriten immer unterhalb der Titelzeile des aktiven Ordnerfensters angezeigt. Aktivieren Sie dieses Kontrollkästchen, wenn die Menüs stattdessen an der Mauszeigerposition angezeigt werden sollen.
DOS-Eingabefenster nach Befehlsverarbeitung automatisch schließen | Legt fest, ob das DOS-Fenster, das durch den Aufruf von Befehlen über die integrierte DOS-Befehlszeile geöffnet wird, automatisch wieder geschlossen wird. Deaktivieren Sie diese Option, wenn Sie die Statusmeldungen der Befehle sehen möchten.
Dateiinformation als InfoTip anzeigen für | Legt fest, ob beim Zeigen auf einen Eintrag in der Listenansicht ein Infofenster mit den wichtigsten Dateieigenschaften erscheinen soll und gibt die Laufwerke an, für welche ein Infofenster angezeigt werden soll.
Drag & Drop
Verschieben bei rechter Maustaste | Beim Drag & Drop von Dateien und Ordnern mit der rechten Maustaste wird ein Kontextmenü angezeigt, aus dem Sie eine mögliche Operation auswählen (Kopieren / Verschieben / Verknüpfung erstellen) oder den Vorgang abbrechen können. Aktivieren Sie diese Option, wenn Sie die Dateien und Ordner ohne Anzeige eines Menüs gleich verschieben wollen.
Dynamic Drop | Aktivieren Sie diese Option, wenn beim Drag & Drop auf einen Ordner dieser automatisch geöffnet und angezeigt werden soll.
Schnellsuche
Schnellsuche im aktuellen Ordner Legt fest, ob bei der Schnellsuche ein kleines Dialogfeld angezeigt und wie es aktiviert wird.


Anwendungen & Internet

SpeedCommander: Konfiguration
Anwendungen & Internet

Mit dem Dialogfeld Anwendungen und Internet legen Sie fest, welche Zusatzprogramme SpeedCommander verwenden soll. Lassen Sie die Eingabefelder DiskFormat, DiskCopy und Dateisuche leer, wenn SpeedCommander die von Windows bereitgestellten Module nutzen soll.

Sie können hier auch festlegen, dass SpeedCommander anstatt des Internet Explorer Mozilla als integrierten Browser verwenden soll. Weitere Informationen zur Integration von Mozilla erhalten Sie unter Mozilla integrieren.

Anwendungen
Editor | Zeigt den Namen der Anwendung an, die SpeedCommander zum Editieren von Dateien verwenden soll.
Betrachter | Zeigt den Namen der Anwendung an, die SpeedCommander zum Betrachten von Dateien verwenden soll.
DiskFormat | Zeigt den Namen der Anwendung an, die SpeedCommander zum Formatieren von Datenträgern verwenden soll.
DiskCopy | Zeigt den Namen der Anwendung an, die SpeedCommander zum Kopieren von Datenträgern verwenden soll.
Dateisuche | Zeigt den Namen der Anwendung an, die SpeedCommander zum Suchen von Dateien und/oder Dateiinhalten verwenden soll.
Internet
Startseite | Legt die Startseite für das Internet fest, die nach der Aktivierung des integrierten Browsers angezeigt wird.
Suchseite | Legt die Suchseite für das Internet fest, die zum Suchen von Informationen im Internet angezeigt wird.
Mozilla ActiveX-Control verwenden | Legt fest, dass SpeedCommander Mozilla als integrierten Browser verwenden soll.
DFÜ-Verbindung trennen | Legt fest, dass SpeedCommander Sie beim Schließen des FTP- oder Internetfensters an das Trennen der DFÜ-Verbindung erinnern soll.
Erweitert | Öffnet den Einstellungsdialog vom Internet Explorer.


FTP-Client

SpeedCommander: Konfiguration
FTP-Client

Mit Hilfe des Dialogfeldes FTP-Client passen Sie die grundlegenden FTP-Einstellungen an. Sie können den Transfermodus festlegen, Angaben zum Timeout machen sowie einen Proxy-Server festlegen, der für alle FTP-Verbindungen gelten soll.

Transfermodus
Transfermodus | Legt den Transfermodus fest. Wählen Sie Automatisch, wenn die unten angegebenen Dateierweiterungen als ASCII und alle anderen Dateien als Binär übertragen werden sollen.
Erweiterungen | Geben Sie hier die Dateierweiterungen ein, für welche der Transfermodus ASCII verwendet werden soll.
Timeout & Wiederholung
Verbindungsfehler, wenn keine Antwort nach xx Sekunden | Legt die Zeit in Sekunden fest, in der auf eine Antwort vom FTP-Server gewartet wird.
Wiederholungen, wenn ein FTP-Server besetzt ist | Geben Sie hier die Anzahl der Wiederholungen ein, falls der FTP-Server besetzt ist.
Sekunden Pause zwischen den Versuchen | Legt die Pause in Sekunden fest, die zwischen zwei Versuchen gewartet wird.
Sonstiges
Verzeichnisdaten im Statusfenster anzeigen | Legt fest, dass im Statusfenster beim Auflisten von Ordnern die vollständigen Daten angezeigt werden, die der Server übermittelt.
Ausführliche Logdatei für jede Verbindung erstellen | Aktivieren Sie dieses Kontrollkästchen, wenn im Anwendungsdaten-Ordner eine detaillierte Ausgabe der Kommunikation mit dem FTP-Server erfolgen soll.
Kompression (MODE Z) bei Dateitransfers | Legt fest, dass Datentransfers nach Möglichkeit komprimiert werden sollen. Tragen Sie eine 0 ein, um die Kompression zu deaktivieren.

Erweiterte Einstellungen

Proxy-Server
Typ | Legt den Typ des Proxy-Servers fest. Nähere Informationen erhalten Sie bei Ihrem Netzwerkadministrator.
Server | Legt den Namen oder die IP-Adresse des Proxyservers fest.
Port | Legt den Port fest, unter welchem eine Verbindung zum Proxyserver aufgenommen werden soll.
Benutzername | Legt den Benutzernamen fest, unter dem die Verbindung zum Proxyserver aufgenommen werden soll.
Kennwort | Legt das Kennwort fest, unter dem die Verbindung zum Proxyserver aufgenommen werden soll.
Geschwindigkeitsbeschränkung
Upload beschränken auf | Legt fest, dass Uploads mit begrenzter Geschwindigkeit ausgeführt werden sollen. Tragen Sie 0 ein, um die Geschwindigkeitsbegrenzung zu deaktivieren.
Download beschränken auf | Legt fest, dass Downloads mit begrenzter Geschwindigkeit ausgeführt werden sollen. Tragen Sie 0 ein, um die Geschwindigkeitsbegrenzung zu deaktivieren.


Schnellansicht

SpeedCommander: Konfiguration
Schnellansicht

Im Dialogfeld Schnellansicht legen Sie fest, welchen Dateibetrachter SpeedCommander in der Schnellansicht für einen bestimmten Dateityp verwenden soll. Sie können eine neue Zuordnung erstellen sowie eine Zuordnung bearbeiten und löschen.

Registrierte Dateierweiterungen
Dateierweiterungen | Zeigt eine Liste mit den aktuell zugeordneten Dateierweiterungen.
Neu | Ordnet einer noch nicht registrierten Dateierweiterung einen Betrachter zu.
Bearbeiten | Ändert den Betrachter einer bereits registrierten Dateierweiterung.
Löschen | Hebt die Zuordnung einer Dateierweiterung zu einem Betrachter auf.
Standardbetrachter | Legt den Betrachter fest, der bei allen nicht registrierten Dateierweiterungen verwendet wird.

Wichtiger Hinweis: Bei Anzeige von HTML-Dateien werden auch entsprechend der eingestellten Sicherheitsstufe für Lokales Intranet Skripte ausgeführt. Wenn Sie dies nicht wünschen, müssen Sie die Anzeige für HTML-Dateien deaktivieren, indem Sie die Zuordnung für die Dateierweiterungen html, htm, ihtml und shtml löschen.


Kompression

SpeedCommander: Konfiguration
Kompression

Mit Hilfe des Dialogfeldes Kompression können Sie die Komprimierungseinstellungen für die einzelnen Formate festlegen.

Allgemein
Archivformat | Wählen Sie hier das gewünschte Archivformat, für das Sie die Voreinstellungen festlegen möchten.
Kompressionsrate | Wählen Sie hier die Kompressionsrate, mit der die Dateien komprimiert werden sollen.
Speichergröße | Wählen Sie hier die Speichergröße, die zur Komprimierung verwendet wird.
Reparaturdaten | Legt fest, dass dem Archiv Reparaturdaten hinzugefügt werden sollen. Ein Archiv, das Reparaturdaten enthält, kann mit hoher Wahrscheinlichkeit wieder repariert werden, wenn es beschädigt wurde.
Details | Öffnet ein Dialogfeld für erweiterte Einstellungen bei bestimmten Formaten.
Erweitert
Multimedia-Kompression | Verwendet bei der Kompression spezielle Algorithmen, die besonders bei Multimediadateien die Kompressionsrate verbessern.
EXE-Kompression | Verwendet bei der Kompression spezielle Algorithmen, die besonders bei ausführbaren Dateien die Kompressionsrate verbessern.
Solid-Archiv erstellen | Erstellt Solid-Archive, die gegenüber normalen Archiven meist wesentlich kleiner sind.
AV-Signatur erzeugen | Aktivieren Sie diese Option, wenn Sie das Archiv digital signieren möchten.
Sonstiges
Originaldateien nach dem Archivieren löschen | Legt fest, dass die Originale der zu komprimierenden Dateien nach dem Komprimieren gelöscht werden sollen.
Immer den Ordnernamen als Archivnamen vorschlagen | Legt fest, dass der vorgeschlagene Dateiname im Komprimierungsdialog immer aus dem übergeordneten Ordnernamen abgeleitet wird.

Erweiterte Einstellungen für SQX 2.0

Die erweiterten Einstellungen für SQX 2.0 ermöglichen eine feinere Abstimmung des SQX-Archivers für verschiedene Einsatzfälle.

Transformatoren
Multimedia | Aktiviert, deaktiviert oder erzwingt den Multimedia-Transformator. Der Multimedia-Transformator kann die Kompression bei Dateien mit multimedialen Elementen deutlich verbessern (Bilder, Ressourcen).
EXE | Aktiviert, deaktiviert oder erzwingt den EXE-Transformator. Der EXE-Transformator kann die Kompression bei ausführbaren Dateien, dynamischen Programmbibliotheken und Gerätetreibern deutlich verbessern.
RGB | Aktiviert, deaktiviert oder erzwingt den RGB-Transformator. Der RGB-Transformator kann die Kompression bei unkomprimierten RGB-Bilddateien deutlich verbessern (BMP, TGA, TIFF, PSD).
Kompressoren
Audio | Aktiviert, deaktiviert oder erzwingt den Audio-Kompressor. Der Audio-Kompressor kann die Kompressionsrate und Geschwindigkeit bei Audiodateien deutlich verbessern (WAV, PCM).
Kanäle | Legt die Anzahl der Kanäle fest, in welche die Audiodateien aufgeteilt werden sollen. Wenn der Audiokompressor die Anzahl der Kanäle automatisch ermitteln soll, so muss die Einstellung des Audiokompressors auf Automatisch gesetzt werden.
Kanalbreite | Legt die Kanalbreite fest, die der Kompressor für die Audiodateien benutzen soll. Wenn der Audiokompressor die Kanalbreite automatisch ermitteln soll, so muss die Einstellung des Audiokompressors auf Automatisch gesetzt werden.
Text | Aktiviert, deaktiviert oder erzwingt den Text-Kompressor. Der Text-Kompressor kann die Kompressionsrate und Geschwindigkeit bei textartigen Dateien deutlich verbessern (TXT, HTML, RTF, CPP, PAS).
Speicher | Legt die Größe des Speichers für den Text-Kompressor fest. Je größer der Speicher ist, desto größer ist auch die Kompressionsrate.
Ordnung | Legt die Ordnung für den Text-Kompressor fest. Je höher die Ordnung, desto besser ist auch die Kompression und desto mehr Speicher sollte dem Kompressor zur Verfügung stehen. Ein guter Mittelwert ist hier 6-8.
Ultrakompression
Ultrakompression Legt die feinere Abstimmung für den Kompressor fest, wenn als Kompressionsrate Ultra gewählt ist. Der Wert Schneller ist die beste Synthese aus Kompressionsrate und Geschwindigkeit. Der Wert Besser erreicht in der Regel die maximale Kompression, der Kompressor wird dabei aber deutlich langsamer. Mit den einzelnen Zwischenstufen lässt sich dieses variieren.

Erweiterte Einstellungen für 7z

Die erweiterten Einstellungen für 7z ermöglichen eine feinere Abstimmung des 7z-Archivers für verschiedene Einsatzfälle.

Kompressor
Methode Legt die zu verwendende Kompressionsmethode fest. Die LZMA-Methode ist eine universelle Kompressionsmethode und für alle Dateien geeignet. Die PPMD-Methode ist am besten für Textdateien geeignet.
LZMA
Modus | Legt den Kompressionsmodus für den LZMA-Kompressor fest.
Matchfinder | Legt den zu verwendenden Matchfinder fest. Binary Tree ist die beste Synthese aus Kompressionsrate und Geschwindigkeit. Patricia Tree ist etwas schneller als Binary Tree, braucht aber deutlich mehr Speicher. Hash Chain ist hinsichtlich des Speicherverbrauchs am sparsamsten und am schnellsten bei fast allen Dateitypen, bietet aber dafür die schlechteste Kompression aller drei Varianten.
Fast Bytes | Legt die maximale Länge der Matches fest, deren Qualität verglichen werden soll. Je höher der Wert, desto besser (und langsamer) ist die Kompression.
Literal Context Bits | Legt die Ordnung des Literal-Kompressors fest.
Position Bits | Legt die Anzahl der Bits fest, die von den absoluten Distanzwerten komprimiert werden sollen.
Literal Position Bits | Legt die Anzahl der Extra-Bits für die Literale fest.
PPMD
Speicher | Legt die Ordnung für den PPMD-Kompressor fest. Je höher die Ordnung, desto besser ist auch die Kompression und desto mehr Speicher sollte dem Kompressor zur Verfügung stehen. Ein guter Mittelwert ist hier 6-8.
Ordnung | Legt die Ordnung für den PPMD-Kompressor fest. Je höher die Ordnung, desto besser ist auch die Kompression und desto mehr Speicher sollte dem Kompressor zur Verfügung stehen. Ein guter Mittelwert ist hier 6-8.


Dateiverknüpfungen

SpeedCommander: Konfiguration
Dateiverknüpfungens

Im Dialogfeld Dateiverknüpfungen legen Sie fest, für welche Archivformate SpeedCommander als Bearbeitungsprogramm eingetragen werden soll.

Verknüpfungen
Dateierweiterungen | Zeigt eine Liste mit den unterstützten Dateierweiterungen.
Alle | Markiert alle Dateierweiterungen.
Keine | Hebt die Auswahl für alle Dateierweiterungen auf.


Anpassen

SpeedCommander: Konfiguration
Anpassen

Mit dem Dialogfeld Anpassen können Sie die Symbolleiste frei gestalten und Tastenkürzel zuordnen. Zur Anzeige des Dialogfeldes wählen Sie den Befehl Anpassen aus dem Menü Extras.

Weitere Informationen

Symbolleisten und Menü anpassen

Tastenkürzel definieren

Visuelles Design ändern


Symbolleisten und Menü

SpeedCommander: Konfiguration
Symbolleisten und Menü

Mit Hilfe der Registerkarten Befehle, Symbolleisten und Menü können Sie die Symbolleiste und das Menü nach Ihren Wünschen gestalten. So können einzelne Symbolleisten ein- und ausgeblendet werden, eigene Symbolleisten erstellt, umbenannt und wieder gelöscht werden. Sie können sogar einzelne Menüeinträge ausblenden.

So fügen Sie einer Symbolleiste eine Schaltfläche hinzu:
  1. Aktivieren Sie die Registerkarte Befehle.
  2. Wählen Sie im Listenfeld Kategorien das Menü, das den entsprechenden Befehl enthält.
  3. Ziehen Sie die entsprechende Schaltfläche aus dem Listenfeld Befehle an die gewünschte Stelle in der Symbolleiste.
So entfernen Sie eine Schaltfläche aus einer Symbolleiste:
  1. Klicken Sie mit der linken Maustaste auf die Schaltfläche, die Sie entfernen möchten, und ziehen Sie die Schaltfläche aus der Symbolleiste heraus.
  2. Lassen Sie die linke Maustaste los.
So erstellen Sie eine neue Symbolleiste:
  1. Aktivieren Sie die Registerkarte Symbolleisten.
  2. Klicken Sie auf die Schaltfläche Neu.
  3. Geben Sie im Dialog Name der Symbolleiste einen Namen ein.
  4. Drücken Sie Eingabe oder klicken Sie auf OK.
So fügen Sie zwischen zwei Symbolen ein Trennzeichen ein:
  1. Klicken Sie in der Symbolleiste mit der rechten Maustaste auf das Symbol, vor dem Sie ein Trennzeichen einfügen möchten.
  2. Wählen Sie aus dem Kontextmenü den Befehl Gruppierung beginnen.
So passen Sie ein Symbol an:
  1. Klicken Sie in der Symbolleiste mit der rechten Maustaste auf das Symbol, das Sie anpassen möchten.
  2. Wählen Sie aus dem Kontextmenü den Befehl Schaltflächensymbol bearbeiten, der Dialog Symboleditor erscheint.
  3. Im Dialogfeld Symboleditor können Sie das Symbol anpassen.


Tastenkürzel

SpeedCommander: Konfiguration
Tastenkürzel

Die Registerkarte Tastatur ermöglicht es Ihnen, jedem Befehl im SpeedCommander ein eigenes Tastenkürzel zuzuordnen. Sie können das Tastaturschema auch auf eine Windows-kompatible Vorlage zurücksetzen.

So ordnen Sie einem Befehl ein Tastenkürzel zu:
  1. Wählen Sie im Kombinationsfeld Kategorie das Menü, das den gewünschten Befehl enthält. Klicken Sie dann im Listenfeld auf diesen Befehl.
  2. Geben Sie im Feld Neue Tastenkombination das Tastenkürzel ein, welches Sie verwenden möchten, und klicken Sie auf Zuweisen.
  3. Das Tastenkürzel erscheint im Listenfeld Aktuelle Tastenkürzel.
So entfernen Sie ein zugeordnetes Tastenkürzel:
  1. Wählen Sie im Kombinationsfeld Kategorie das Menü, das den gewünschten Befehl enthält. Klicken Sie dann im Listenfeld auf diesen Befehl.
  2. Wählen Sie im Listenfeld Aktuelle Tastenkürzel das Tastenkürzel aus, welches Sie entfernen möchten, und klicken Sie auf Entfernen.
So setzen Sie alle Tastenkürzel zurück:
  1. Klicken Sie auf die Schaltfläche Zurücksetzen.
  2. Wählen Sie die gewünschte Tastenkürzelvorlage und klicken Sie auf OK.

Fest eingebaute Tastenkürzel

SpeedCommander enthält zusätzlich fest eingebaute Tastenkürzel, die nicht angepasst werden können.

Ordnerfenster
Enter | Wechseln in Ordner oder Ausführen einer Datei
Backspace | Wechsel in übergeordneten Ordner
Strg+BildAuf | Wechsel in übergeordneten Ordner
Alt+F1 | Auswahl des linken Laufwerks
Alt+F2 | Auswahl des rechten Laufwerks
Tab | Wechsel zwischen den beiden Ordnerfenstern
Strg+Tab | Wechsel zwischen den Registerkarten eines Ordnerfensters
Umschalt+Tab | Wechsel zwischen Baum- und Listenansicht
Strg+<#> | Aktivierung des/der #. Ordnerfensters/Dateiablage
Strg+Umschalt+1 | Aktivierung der Ordnerfenster-Ansicht
Strg+Umschalt+2 | Aktivierung der Dateiablagen-Ansicht
Listenansicht
Leertaste | Auswählen einer Datei
Strg+Leertaste | Auswahl einer Datei aufheben
Cursortasten | Bewegung des Auswahlbalkens
Strg+Cursortasten | Bewegung des Auswahlbalkens ohne Änderung der Auswahl
Umschalt+Cursortasten | Auswählen einer zusammenhängenden Gruppe
Strg+Umschalt+ZehnerPlus | Optimale Spaltenbreite
Listenansicht NC-Auswahlmodus
Leertaste | Datei auswählen / Auswahl einer Datei aufheben
Einfg | Datei auswählen / Auswahl einer Datei aufheben und Auswahlbalken auf die nächste Datei setzen
Cursortasten | Bewegung des Auswahlbalkens
Pos1 | Auswahlbalken auf ersten Eintrag
Ende | Auswahlbalken auf letzten Eintrag
BildAb | Auswahlbalken seitenweise nach unten
BildAuf | Auswahlbalken seitenweise nach oben
Umschalt+Positionstasten | Zusammenhängende Dateien seitenweise auswählen
Umschalt+Cursortasten | Zusammenhängende Dateien einzeln auswählen
Listenansicht NC-Auswahlmodus mit "Markieren mit rechter Maustaste"
Rechte Maustaste | Datei auswählen / Auswahl einer Datei aufheben
Strg+Kontextmenu | Kontextmenü für ausgewählte Dateien
Baumansicht
Cursor-nach-unten | Nächster Eintrag auf gleicher Ebene
Cursor-nach-oben | Vorheriger Eintrag auf gleicher Ebene
Cursor-nach-rechts | Eintrag aufklappen oder bei aufgeklappten Eintrag in nächste Ebene
Cursor-nach-links | Eintrag zuklappen oder bei zugeklappten Eintrag in vorherige Ebene
Umschalt+ZehnerPlus | Eintrag aufklappen
Umschalt+ZehnerMinus | Eintrag zuklappen
Umschalt+ZehnerStern | Eintrag vollständig aufklappen
Eingabezeile
Strg+Umschalt+Leertaste | Wechsel zwischen aktivem Fenster und Eingabezeile
Tab | Wechsel zwischen den Ordnerfenstern
Enter | Befehl ausführen
Strg+Enter | Dateinamen einfügen
Strg+Umschalt+Enter | Vollständigen Dateinamen einfügen
Cursortasten | Änderung des Auswahlbalkens in der Listenansicht
Strg+Cursortasten | Nächstes / Vorheriges Wort
Umschalt+Cursortasten | Text markieren


Visuelle Designs

SpeedCommander: Konfiguration
Visuelle Designs

Die Programmoberfläche vom SpeedCommander kann in verschiedenen visuellen Designs dargestellt werden. Mit Hilfe der Registerkarte Erweitert können Sie leicht zwischen den verschiedenen visuellen Designs umschalten.

So ändern Sie das visuelle Design:
  1. Wählen Sie im Kombinationsfeld Design das visuelle Design, welches der SpeedCommander verwenden soll.


Schriftart einstellen

SpeedCommander: Konfiguration
Schriftart einstellen

Mit dem Dialogfeld Schriftart können Sie die in den Fenstern vom SpeedCommander verwendete Schriftart und -größe ändern.

So ändern Sie die Schriftart:
  1. Aktivieren Sie aus dem Menü Extras den Befehl Schriftart.
  2. Wählen Sie im Dialogfeld Schriftart die Schriftart und -größe, die der SpeedCommander verwenden soll.


Einstellungen sichern

SpeedCommander: Konfiguration
Einstellungen sichern

SpeedCommander speichert seine Einstellungen in einer XML-Datei. Die angepassten Menüs und Symbolleisten werden aufgrund ihrer Größe in externen Dateien abgelegt. Unter Windows 9x/ME befinden sich diese Dateien im Programmverzeichnis von SpeedCommander, unter Windows NT/2000/XP werden diese Dateien unter 'Dokumente und Einstellungen\<Nutzername>\Anwendungsdaten\SpeedProject\SpeedCommander 11' gespeichert.

So sichern Sie Ihre Einstellungen:
  1. Wechseln Sie in das Programmverzeichnis (Windows 9x/ME) bzw. in das Anwendungsdatenverzeichnis (Windows NT/2000/XP).
  2. Kopieren Sie alle Dateien an einen sicheren Ort.
So stellen Sie Ihre Einstellungen wieder her:
  1. Schließen Sie SpeedCommander sowie alle in SpeedCommander enthaltenen Anwendungen.
  2. Kopieren Sie die gesicherten Dateien in das Programmverzeichnis (Windows 9x/ME) bzw. in das Anwendungsdatenverzeichnis (Windows NT/2000/XP).
  3. Starten Sie SpeedCommander.


Kommandozeilenparameter

SpeedCommander: Konfiguration
Kommandozeilenparameter

Beim Aufruf von SpeedCommander können einige Optionen über Kommandozeilenparameter gewählt werden. Sie können auf diese Weise die Ordner festlegen, die nach dem Start angezeigt werden. Durch Vorgabe einer Einstellungsdatei können Sie SpeedCommander auch mit verschiedenen Konfigurationen betreiben.

Befehl | Bedeutung
/l:<Ordner> | Pfad für das linke Ordnerfenster, in welchen nach dem Start gewechselt wird
/r:<Ordner> | Pfad für das rechte Ordnerfenster, in welchen nach dem Start gewechselt wird
/xml:<Einstellungen.xml> | Vorgabe einer speziellen Einstellungsdatei (z.B. SpeedCommander.exe /xml:C:\Test\SpeedCommander.xml)
/caption:<Fenstertitel> | Vorgabe eines Fenstertitels für das Hauptfenster
/layout:<Layoutname> | Laden eines vordefinierten Layouts beim Start
/register | Registrierung von Dateiverknüpfungen (keine Zuordnung) und Typenbibliothek
/unregister | Registrierung von Dateiverknüpfungen und Typenbibliothek entfernen
/noaddins | Programmstart ohne AddIns


Mobiler Einsatz

SpeedCommander: Konfiguration
Mobiler Einsatz

SpeedCommander verwendet für seine Einstellungen eine XML-Datei und ist daher nicht auf die Registrationsdatenbank angewiesen. Daher ist es besonders einfach, SpeedCommander auf einen USB-Stick zu kopieren und überall einzusetzen.

Einrichtung auf einem USB-Stick

Kopieren Sie einfach das Programmverzeichnis von SpeedCommander und die Einstellungsdateien auf Ihren USB-Stick. Unter Windows 9x/ME befinden sich diese Dateien im Programmverzeichnis von SpeedCommander, unter Windows NT/2000/XP werden diese Dateien unter 'Dokumente und Einstellungen\<Nutzername>\Anwendungsdaten\SpeedProject\SpeedCommander 11' gespeichert. Wenn SpeedCommander beim Start erkennt, dass sich im Programmverzeichnis auch die Einstellungsdatei SpeedCommander.xml befindet, dann sucht SpeedCommander alle Einstellungsdateien im Programmverzeichnis.

Freischaltcode verwenden

Damit SpeedCommander als Vollversion startet, erstellen Sie einfach im Verzeichnis auf dem USB-Stick eine Textdatei register.ini mit folgendem Inhalt:

[register]
RegOwner=<Ihr Name>
KeyCode=<Ihr Freischaltcode>

Verschlüsselten Freischaltcode verwenden

Sie können Ihren Freischaltcode auch mit einem Kennwort verschlüsselt ablegen, SpeedCommander fragt dann beim Start nach dem Kennwort. Ohne das richtige Kennwort startet SpeedCommander lediglich als Testversion. Zur Verschlüsselung benutzen Sie bitte das Programm EncryptKeyCode.exe aus dem SpeedCommander-Programmverzeichnis. Tragen Sie den verschlüsselten Freischaltcode anschließend wie folgt in der register.ini ein:

[register]
RegOwner=<Ihr Name>
KeyCode2=<Ihr verschlüsselter Freischaltcode>

Ordner für zusätzliche Anwendungen

Um die Zusatzprogramme SpeedEdit, SpeedView und FileSearch auf dem USB-Stick nutzen zu können, müssen Sie im Einstellungsdialog auf der Seite Anwendungen & Internet noch den Pfad zu den Programmen anpassen. Da der Pfad bzw. der Laufwerksbuchstaben für den USB-Stick von System zu System verschieden ist, sollte hier einfach nur den Namen der Programmdatei angegeben werden (z.B. SpeedView.exe). SpeedCommander sucht das Programm dann in seinem Programmverzeichnis.

Alternativ können Sie hier auch die Umgebungsvariable %SCDIR% verwenden. Diese Umgebungsvariable wird beim Start von SpeedCommander gesetzt und zeigt immer auf das jeweilige Programmverzeichnis. Der Eintrag für SpeedView sähe dann wie folgt aus: %SCDIR%\SpeedView.exe

Anpassen der AddIn-Einstellungen

AddIns müssen im System registriert sein, bevor SpeedCommander sie verwenden kann. Im mobilen Einsatz kann SpeedCommander AddIns automatisch beim Programmstart registrieren und beim Programmende wieder aus der Registrationsdatenbank austragen. Dazu muss in der register.ini eine Sektion AddIns erstellt werden, in der alle AddIns mit ihrem relativen Pfad in Bezug zur register.ini eingetragen werden. Der Wert Items gibt die Anzahl an, die AddIns werden unter den Werten Item0 ... Item99 aufgeführt:

[AddIns]
Items=2
Item0=AddIns\WfxWrapper.dll
Item1=AddIns\WinCeFS.dll

Einrichtung auf einem U3-fähigen USB-Stick

U3 ist ein offener Standard, um portable Anwendungen auf USB-Sticks zu betreiben. Ein U3-fähiger USB-Stick enthält ein Launch Pad, das beim Einstecken des USB-Sticks geladen wird. Über den Infobereich der Taskleiste kann dann auf das Launch Pad zugegriffen werden.

Installation

Für die Installation auf einem U3-fähigen USB-Stick wird ein spezielles Installationsarchiv nötig, welches im Downloadbereich heruntergeladen werden kann. Die Installation erfolgt anschließend über das U3-Launch Pad. Nach der Installation können die Einstellungsdateien auf den USB-Stick in das Verzeichnis K:\System\Apps\6A20B3E0-A4F1-11D8-ACBB-000C6E33EB97\Data kopiert werden. Beachten Sie bitte, dass sich der Laufwerksbuchstabe von System zu System unterscheidet.

Freischaltcode verwenden

Auch bei der U3-Version wird der verschlüsselte bzw. unverschlüsselte Freischaltcode in der register.ini abgelegt. Kopieren Sie diese Datei ebenfalls nach K:\System\Apps\6A20B3E0-A4F1-11D8-ACBB-000C6E33EB97\Data.

Anpassen der AddIn-Einstellungen

Für die Verwendung von AddIns legen Sie im Verzeichnis K:\System\Apps\6A20B3E0-A4F1-11D8-ACBB-000C6E33EB97\Exec einen Ordner AddIns an. Anschließend kopieren Sie den Inhalt des AddIns-Ordners aus dem SpeedCommander-Programmverzeichnis in den neu angelegten Ordner. Legen Sie nun im Ordner K:\System\Apps\6A20B3E0-A4F1-11D8-ACBB-000C6E33EB97\Exec eine Datei register.ini an und tragen Sie hier die zu registrierenden AddIns ein, wie es weiter oben beschrieben wurde.

Zusätzliche Umgebungsvariablen

Beim Start von SpeedCommander über das U3-Launch Pad werden zusätzliche Umgebungsvariablen definiert, die in SpeedCommander verwendet werden können.

Umgebungsvariable | Wert | Beispiel
U3_DEVICE_SERIAL | Seriennummer des USB-Sticks | 0A81A950E0B34904
U3_DEVICE_PATH | Laufwerksbuchstabe des USB-Sticks | K:
U3_DEVICE_DOCUMENT_PATH | Dokumentenverzeichnis auf dem USB-Stick | K:\Documents
U3_APP_DATA_PATH | Verzeichnis der Anwendungsdaten auf dem USB-Stick | K:\System\Apps\6A20B3E0-A4F1-11D8-ACBB-000C6E33EB97\Data
U3_HOST_EXEC_PATH | Verzeichnis der ausführbaren Dateien auf dem Host | %APPDATA%\U3\0A81A950E0B34904\6A20B3E0-A4F1-11D8-ACBB-000C6E33EB97\Exec
U3_DEVICE_EXEC_PATH | Verzeichnis der ausführbaren Dateien auf dem USB-Stick | K:\System\Apps\6A20B3E0-A4F1-11D8-ACBB-000C6E33EB97\Exec


FileSearch
Überblick

FileSearch ist ein schnelles und komfortables Suchprogramm. Sie können mit FileSearch Ordner oder ganze Laufwerke nach Dateien durchsuchen. FileSearch bietet Ihnen folgende Möglichkeiten:

  • Suche nach Dateiinhalten (Text, Hexadezimal, Binär)
  • Verwendung von Suchoperatoren (UND, ODER, NICHT)
  • Suchen von Unicode-Text
  • Suchen von doppelten Dateien
  • Anzeige der gefundenen Treffer
  • Suchen in Archiven und in selbstentpackenden Archiven (ACE, ARJ, BZIP, CAB, GZIP, JAR, LZH, RAR, SQX, TAR, UUE, ZIP)
  • Übernahme der gefundenen Dateien in ein Ordnerfenster oder in die Dateiablage des SpeedCommander
  • Speichern von Sucheinstellungen in einem Suchprofil

Weitere Informationen

Suchen von Dateien

Verwendung von Suchoperatoren

Suchergebnisse bearbeiten

Suchprofile verwenden


Suchen von Dateien

FileSearch
Suchen von Dateien

Mit FileSearch können Sie einfach nach Dateien auf lokalen Datenträgern, im Netzwerk oder sogar in Archiven suchen.

Beim Verwenden von FileSearch können Sie verschiedene Suchkriterien festlegen. Sie können z.B. bei der Suche nach Dateien deren Namen, Datum und Größe angeben. Sie können auch nach Dateien suchen, die einen bestimmten Text enthalten.

Die einzelnen Suchkriterien werden auf drei Registerkarten definiert.

Name und Ort
Kriterium | Beschreibung
Ordner | Legt den Ordner fest, der durchsucht werden soll.
Laufwerke | Ermöglicht die Suche über mehrere Laufwerke.
Einschließen und/oder Ausschließen von Dateien | Bietet die Möglichkeit, nur nach bestimmten Dateimasken zu suchen oder von der Suche auszuschließen. Die Dateimasken können auch Stellvertreterzeichen enthalten. Gültige Stellvertreterzeichen sind das Sternchen (*) für eine unbestimmte Anzahl von unbestimmten Zeichen und das Fragezeichen (?) für ein unbestimmtes Zeichen. Neben den Stellvertreterzeichen werden auch Char-Sets unterstützt. Weitere Informationen zu Char-Sets finden Sie hier.
Ordner suchen | Zeigt in der Ergebnisliste auch Ordner an.
Archive durchsuchen | Durchsucht auch Archive und verschlüsselte Archive. Unterstützt werden die Formate ACE, ARJ, BZIP, CAB, GZIP, JAR, LZH, RAR, SQX, TAR, UUE, ZIP und SCB.
Datum, Größe und Attribute
Kriterium | Beschreibung
Datum | Legt fest, ob Dateien gesucht werden sollen, die an einem bestimmten Datum oder in einem bestimmten Zeitraum erstellt, geändert oder bearbeitet wurden.
Größe | Legt fest, dass nach Dateien mit einer bestimmten Größe gesucht werden soll.
Dateiattribute

Legt fest, dass nach Dateien mit einem oder mehreren bestimmten Attributen gesucht werden soll.

Aktivieren Sie ein Kontrollkästchen, um Dateien zu suchen, die das entsprechende Attribut besitzen.

Deaktivieren Sie ein Kontrollkästchen, um Dateien zu suchen, die das entsprechende Attribut nicht besitzen.

Stellen Sie das Kontrollkästchen auf Grau, wenn das entsprechende Attribut nicht beachtet werden soll.
Erweitert - Suche nach enthaltenem Text
Kriterium | Beschreibung
Text / Hex | Legt fest, ob nach einem angegebenen Suchtext oder einem Hexadezimalwert/Binärwert gesucht werden soll.
Groß-/Kleinschreibung beachten | Bei Aktivierung wird nach Textzeichenfolgen gesucht, die der Groß-/Kleinschreibung des Suchtextes genau entsprechen. Andernfalls wird die Groß-/Kleinschreibung des Suchtextes ignoriert.
Nur ganze Wörter | Bei Aktivierung wird nach Textzeichenfolgen gesucht, die dem angegebenen Suchtext entsprechen, und denen ein Leerzeichen, ein Tab oder ein Worttrennzeichen nach- bzw. vorangestellt ist, oder die sich am Anfang oder am Ende einer Zeile befinden. Andernfalls werden durch die Suche alle entsprechenden Zeichenfolgen ermittelt, unabhängig davon, ob es sich um Teile einer längeren Zeichenfolge handelt oder nicht. Gültige Worttrennzeichen sind: .!?,;:-_()[]{}=*"+§$'#%\^/~<>|@\n\r\t
Alle Vorkommen ermitteln | Bei Aktivierung werden alle Vorkommen des angegebene Suchtextes ermittelt. Andernfalls wird nach dem ersten Auffinden des angegebenen Suchtextes die Suche abgebrochen. Dieses Kriterium ist nur wichtig, wenn die genaue Anzahl der Fundstellen benötigt wird.
ASCII | Bei Aktivierung wird der angegebene Suchtext vor der Suche in den IBM-ASCII-Zeichensatz umgewandelt. Dieses Kriterium ist dann wichtig, wenn Dateien durchsucht werden sollen, die mit DOS-Programmen erzeugt worden sind.
Unicode | Bei Aktivierung wird der angegebene Suchtext vor der Suche in den Unicode-Zeichensatz umgewandelt. Dieses Kriterium ist dann wichtig, wenn Dateien durchsucht werden sollen, die Unicode-Text enthalten.
Erweitert - Suche nach doppelten Dateien
Kriterium | Beschreibung
Gleicher Name | Legt fest, dass Dateien mit gleichem Namen gesucht werden sollen.
Gleiche Größe | Legt fest, dass Dateien mit gleicher Größe gesucht werden sollen.
Gleicher Inhalt | Legt fest, dass Dateien mit gleichem Inhalt gesucht werden sollen. Diese Einstellung impliziert automatisch die Einstellung Gleiche Größe. Die gefundenen Dateien sind dann 100% identisch, können aber unterschiedliche Dateinamen haben.


Verwenden von Suchoperatoren

FileSearch
Verwenden von Suchoperatoren

FileSearch kennt grundsätzlich zwei verschiedene Suchmodi: Das Suchen nach reinem Text wie z.B. Schiff oder Hafen und die Suche nach Hexadezimalzeichen bzw. binären Bitmustern.

Suchen nach Text

Die einzelnen Worte, nach denen gesucht werden soll, können mit den booleschen Operatoren ODER bzw. OR, UND bzw. AND und NICHT bzw. NOT verknüpft werden. Zusätzlich können Teile des Suchausdruckes (auch mehrfach) in Klammern gesetzt werden, um die eigentliche Rangfolge der booleschen Operatoren zu übergehen. Suchworte können Joker (*) für eine unbestimmte Anzahl von unbestimmten Zeichen und Wildcards (?) für ein unbestimmtes Zeichen enthalten. Die Suche nach Str*e würde z.B. Strasse und Straße finden, die Suche nach M*er würde Maier, Meier, Meyer, Müller, Möller usw. finden, die Suche nach M?ller würde Müller, Möller und Miller usw. finden.

Hexadezimal-Suche bzw. das Suchen nach binären Bitmustern

Bei der Hexadezimal-Suche werden die Suchworte in hexadezimaler Notation angegeben (z.B. F0FAFE), entsprechend werden die Suchworte bei der Suche nach binären Bitmustern in binärer Notation angegeben (z.B. 11101101). Mit der Hexadezimal-Suche bzw. mit der Suche nach binären Bitmustern könnte man z.B. ausführbare Dateien (EXE-Dateien) nach ganz bestimmtem Codeteilen wie virulentem Code durchsuchen.

Rangfolge der Booleschen Operatoren

Die Rangfolge der booleschen Operatoren lautet: NICHT UND ODER (die höchste Rangfolge von links nach rechts). Ein geklammerter Ausdruck (runde Klammern ()) übergeht die natürliche Rangfolge.

  • Schiff ODER Hafen UND Hamburg findet alle Dokumente, in denen Hafen und Hamburg oder Schiff vorkommt.
  • (Schiff ODER Hafen) UND Hamburg findet alle Dokumente, in denen Schiff oder Hafen und Hamburg vorkommt.

Suchausdrücke können nahezu beliebig miteinander verknüpft werden und es können beliebig viele Klammerebenen gesetzt werden, z.B. ((Schiff ODER Hafen) UND Hamburg) UND Fracht. Suchworten dürfen sogenannte Selbstoperatoren zugewiesen werden (obwohl es nicht notwendig ist), zwischen Klammerpaaren hingegen darf jeweils nur ein Operator vorhanden sein.

Der Suchausdruck Schiff UND NICHT Hafen z.B. ist korrekt, es würden alle Dokumente gefunden werden, die Schiff und nicht Hafen enthalten. Der Suchausdruck (Schiff UND Hafen) UND NICHT (Fracht ODER Hamburg) würde mit einem Syntax-Fehler quittiert werden, weil zwischen den Klammerpaaren die beiden Operatoren UND und NICHT stehen. Die korrekte Schreibweise für den vorgenannten Ausdruck wäre (Schiff UND Hafen) NICHT (Fracht ODER Hamburg).

Reservierte Worte und Zeichen

Aufgrund der booleschen Ausdrücke als Abfragesprache sowie der erweiterten Joker- und Wildcardsuche sind einige Worte und Zeichen für den internen Gebrauch von FileSearch reserviert. Die Worte ODER, UND, NICHT, OR, AND, NOT sowie die Zeichen | (für ODER), + (für UND), - (für NICHT),(,),*,? und " können nur in Suchausdrücken verwendet werden, wenn sie durch hochgestellte Anführungszeichen eingeschlossen werden.

"UND" ODER "NICHT" würde z.B. alle Dokumente finden, die UND oder NICHT enthalten. Ohne die Anführungszeichen würde der Suchausdruck nicht ausgewertet werden können.

Müller"?" würde alle Dokumente finden, die Müller? enthalten. Ohne die Anführungszeichen würde Müllers usw. gefunden werden.

Die Schreibweise der booleschen Operatoren ist nicht weiter von Belang, UND erfüllt dieselbe Aufgabe wie und, Und, uNd usw.


Verwendung von Char-Sets

FileSearch
Verwendung von Char-Sets

Char-Sets sind im Prinzip eine Erweiterung der Wildcards, die beim Suchen mit FileSearch oder beim Synchronisieren mit FileSync bzw. FileSync Kommandozeile genutzt werden können. Typisch für Wildcards sind die Zeichen * und ?, wobei * für eine beliebige Anzahl von beliebigen Zeichen und ? für ein beliebiges Zeichen steht.

Ein Char-Set steht immer für ein mögliches Zeichen, funktioniert im Prinzip wie ein ?, allerdings lassen sich die jeweils gültigen Zeichen präzise festlegen. Char-Sets werden einfach in eckigen Klammern angegeben, wie z.B.

Char-Set | Beschreibung
[abc] | an dieser Stelle sind a,b, oder c gültig
[^abc] | an dieser Stelle sind a,b, oder c *nicht* gültig
[a-z] | an dieser Stelle sind a bis z gültig
[^a-z] | an dieser Stelle sind a bis z *nicht* gültig
Beispiele
Char-Set | Ergebnis
[-]abc | findet -abc
[-abc]? | findet *nicht* dd
[a-c][a-c][a-c] | findet abc
[abc]??[def] | findet *nicht* abca
ab[a-z]?a*b | findet *nicht* abCdaxxxxb
ab[a-z]?a*b | findet abcdab
?[f]* | affe, affe.txt
?[^f]* | findet *nicht* affe, affe.txt
Hinweis

Da die eckigen Klammern [] einen Char-Set beschreiben, müssen Suchmasken, mit denen nach eckigen Klammern gesucht werden sollen, gesondert angegeben werden.

Wenn z.B. nach allen Dateien gesucht werden soll, die die Zeichenfolge [1].txt enthalten (wie z.B. Unbenannt[1].txt, Hinweis[1].txt, Kopie[1].txt), dann wäre hierfür die korrekte Suchmaske *[[1]].* und *nicht* *[1].*. Letztere Suchmaske würde Dateien wie Unbenannt1.txt oder Hinweis1.txt finden.


Suchergebnisse bearbeiten

FileSearch
Suchergebnisse bearbeiten

Alle gefundenen Dateien werden in einem Listenfeld angezeigt. Sie können

  • die Suchergebnisse anzeigen
  • eine Datei öffnen
  • eine Datei im SpeedCommander anzeigen
  • Datei(en) zur Dateiablage im SpeedCommander hinzufügen
  • Datei(en) löschen

Suchergebnisse anzeigen

Wenn Sie erfahren möchten, wo genau sich in der Datei der Suchtext befindet, können Sie sich von FileSearch die Fundstellen anzeigen lassen.

So zeigen Sie die Fundstellen an:
  1. Markieren Sie im Listenfeld die Datei, deren Fundstellen Sie sich anzeigen lassen möchten.
  2. Wählen Sie aus dem Menü Datei den Befehl Anzeigen.
  3. FileSearch öffnet ein Fenster und zeigt die Fundstellen an.
  4. Sie können mit Nächster Treffer und Vorheriger Treffer zur nächsten/vorherigen Fundstelle wechseln.

Datei öffnen

Mit Hilfe des Befehls Öffnen können Sie eine gefundene Datei öffnen. Die Anwendung, mit der die Datei verknüpft ist, wird gestartet und zeigt die Datei an.

So öffnen Sie eine Datei:
  1. Markieren Sie im Listenfeld die Datei, die Sie öffnen möchten.
  2. Wählen Sie aus dem Menü Datei den Befehl Öffnen.
  3. FileSearch startet die Anwendung, mit der die Datei verknüpft ist.

Datei im SpeedCommander anzeigen

Mit Hilfe des Befehls Anzeigen im SC können Sie im SpeedCommander zu einer gefundenen Datei wechseln. Der SpeedCommander wechselt dazu im aktiven Ordnerfenster in den Ordner, in dem sich die Datei befindet und setzt den Auswahlbalken auf die Datei.

Hinweis: Für diesen Befehl muss der SpeedCommander geöffnet sein.

So zeigen Sie eine Datei im SpeedCommander an:
  1. Markieren Sie im Listenfeld die Datei, zu der Sie im SpeedCommander wechseln möchten.
  2. Wählen Sie aus dem Menü Datei den Befehl Anzeigen im SC.
  3. Der SpeedCommander wird aktiviert und setzt den Auswahlbalken auf die Datei.

Datei(en) zur Dateiablage im SpeedCommander hinzufügen

Mit Hilfe des Befehls Zur Dateiablage im SC hinzufügen können Sie eine oder mehrere Dateien der aktiven Dateiablage im SpeedCommander hinzufügen. Dies ermöglicht es Ihnen zum Beispiel, alle gefundenen Dateien zu komprimieren.

Hinweis: Für diesen Befehl muss der SpeedCommander geöffnet sein.

So fügen Sie eine oder mehrere Dateien der Dateiablage im SpeedCommander hinzu:
  1. Markieren Sie im Listenfeld die Datei(en), die Sie der Dateiablage hinzufügen möchten.
  2. Wählen Sie aus dem Menü Datei den Befehl Zur Dateiablage im SC hinzufügen, wenn Sie die Dateien der aktiven Dateiablage hinzufügen möchten. Wählen Sie den Befehl Zur Dateiablage im SC hinzufügen (Neu), wenn der SpeedCommander für die gewählten Dateien eine neue Dateiablage erstellen soll.
  3. Der SpeedCommander wird aktiviert und die Datei(en) werden der aktiven Dateiablage hinzugefügt.

Datei(en) löschen

Sie können gefundene Dateien löschen oder in den Papierkorb verschieben. Sie können so zum Beispiel alle überflüssigen Dateien (*.tmp; *.bak) schnell von Ihrer Festplatte entfernen.

So löschen Sie eine oder mehrere Datei(en):
  1. Markieren Sie im Listenfeld die Datei(en), die Sie löschen möchten.
  2. Wählen Sie aus dem Menü Datei den Befehl Löschen, wenn Sie die Datei löschen möchten; oder den Befehl Löschen in den Papierkorb, wenn Sie die Datei(en) in den Papierkorb verschieben möchten.


Suchprofile verwenden

FileSearch
Suchprofile verwenden

In einem Suchprofil können Sie Ihre aktuellen Sucheinstellungen speichern, so dass Sie schnell zwischen verschiedenen häufig genutzten Einstellungen umschalten können.

So speichern Sie ein Profil:
  1. Konfigurieren Sie die Einstellungen, die Sie speichern möchten.
  2. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie den Befehl Speichern.
  3. Geben Sie im Dialogfeld Profil speichern einen Namen für das neue Profil ein, und klicken Sie auf OK.
So löschen Sie ein gespeichertes Profil:
  1. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie den Befehl Löschen.
  2. Markieren Sie im Dialog Profil löschen das zu löschende Profil, und klicken Sie auf OK.
So aktivieren Sie ein Profil:
  1. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie das Profil aus, welches Sie aktivieren möchten.
  2. Sie können auch das Symbol Profile aus der Symbolleiste verwenden oder im Einstellungsdialog Anpassen jedem Profil ein eigenes Tastenkürzel zuordnen.


Einstellungen

FileSearch
Einstellungen

Die Grundeinstellungen von FileSearch werden im Menü Extras festgelegt. Öffnen Sie das Menü Extras und wählen Sie die Einstellung, die Sie ändern möchten.

SFX'e durchsuchen

Aktivieren Sie diese Einstellung, wenn Sie auch selbstextrahierende Archive durchsuchen möchten.

Verschlüsselte Archive überspringen

Aktivieren Sie diese Einstellung, wenn bei der Suche verschlüsselte Archive übersprungen werden sollen.

Nur eine Instanz erlauben

Aktivieren Sie diese Einstellung, wenn nur eine Programmkopie von FileSearch gestartet werden soll.

FileSearch bei Anzeige im SC schließen

Legt fest, dass FileSearch beendet werden soll, wenn eine Datei im SpeedCommander angezeigt wird.

Aktion bei Doppelklick

Hier legen Sie fest, welche Aktion ausgeführt werden soll, wenn Sie in der Ergebnisliste auf einen gefundenen Eintrag doppelklicken:

Aktion | Beschreibung
Öffnen | Die Datei wird mit dem Programm ausgeführt, mit dem sie verknüpft ist.
Anzeigen | FileSearch zeigt die Datei mit den gefundenen Treffern an.
Anzeigen im SC | Die Datei wird im aktiven Ordnerfenster des SpeedCommander markiert. Der SpeedCommander muß dazu geöffnet sein.
Alle History-Listen löschen

Bei Aktivierung dieses Befehls werden alle in FileSearch gespeicherten Eingaben gelöscht.


SpeedEdit
Überblick

SpeedEdit ist ein komfortabler Editor zur Bearbeitung von Textdateien und bietet zusätzlich folgende Funktionen:

  • Integriertes Syntaxhighlighting für: ASP, Basic, Batch, C/C++, DCL (AutoCAD), Fortran, HTML, InstallShield, Java, LISP (AutoCAD), Pascal, Perl, PHP, Python, Ressourcen, REXX, SGML, Shell Script, SIOD, SQL, TCL, TeX
  • Definition von AutoText-Einträgen
  • Einsatz von Lesezeichen
  • Umwandlung eines Textes in Groß- oder Kleinbuchstaben
  • Vertauschen von Groß-/Kleinbuchstaben
  • Inkrementelle Suche
  • Schreibschutzmodus
  • Druckvorschau

Weitere Informationen

Erstellen, Öffnen und Speichern eines Dokumentes

Kopieren, Einfügen, Ausschneiden und Löschen von Text

Suchen und Ersetzen

Lesezeichen verwenden

AutoText-Einträge verwenden

Einstellungen


Erstellen,Öffnen und Speichern eines Dokumentes

SpeedEdit
Erstellen, Öffnen und Speichern eines Dokumentes

Sie können mit SpeedEdit ein neues Dokument erstellen, ein bereits vorhandenes Dokument öffnen und die vorgenommen Änderungen speichern.

So erstellen Sie ein neues Dokument:
  1. Wählen Sie im Menü Datei den Befehl Neu oder klicken Sie in der Symbolleiste auf die Schaltfläche Neu.
  2. SpeedEdit erzeugt ein neues Fenster und Sie können mit der Eingabe des Textes beginnen.
So öffnen Sie ein bereits vorhandenes Dokument:
  1. Wählen Sie im Menü Datei den Befehl Öffnen oder klicken Sie in der Symbolleiste auf die Schaltfläche Öffnen.
  2. Das Dialogfeld Öffnen erscheint.
  3. Klicken Sie im Feld Suchen in auf das Laufwerk, auf dem das zu öffnende Dokument gespeichert ist.
  4. Aktivieren Sie das Kontrollkästchen Schreibgeschützt öffnen, wenn Sie am Dokument nur anzeigen, aber keine Änderungen vornehmen möchten.
  5. Geben Sie im Kombinationsfeld Textformat das Format an, mit dem die Datei erstellt wurde. Dies ist nur nötig, wenn die Datei von einem DOS-Programm oder unter einem anderen Betriebssystem erzeugt worden ist.
  6. Wechseln Sie zum gewünschten Dokument, klicken Sie auf den Namen des Dokuments, und klicken Sie auf Öffnen.

Tipp: Ein Dokument, das Sie vor kurzem geöffnet hatten, können Sie öffnen, indem Sie im Menü Datei auf seinen Dateinamen klicken.

So speichern Sie Ihre Änderungen:
  1. Wählen Sie im Menü Datei den Befehl Speichern.
  2. Um das Dokument unter einem anderen Namen zu speichern, wählen Sie im Menü Datei den Befehl Speichern unter, geben im Eingabefeld Dateiname den gewünschten Namen ein und klicken dann auf Speichern.


Suchen und Ersetzen

SpeedEdit
Suchen und Ersetzen

Sie können das Dokument nach Wörtern oder Zeichen durchsuchen. Darüber hinaus können Sie Wörter und Zeichen durch einen bestimmten Text ersetzen lassen.

So suchen Sie nach einem Text:
  1. Wählen Sie aus dem Menü Bearbeiten den Befehl Suchen.
  2. Das Dialogfeld Suchen erscheint.
  3. Geben Sie im Feld Suchen nach den Suchtext (Zeichen oder Wörter) ein, und klicken Sie anschließend auf Weitersuchen.
  4. Um eine weitere Stelle zu finden, an welcher der Text vorkommt, klicken Sie noch einmal auf Weitersuchen. Wenn Sie das Dialogfeld Suchen bereits geschlossen haben, können Sie die Suche nach dem Text mit der Taste F3 fortsetzen.
So ersetzen Sie einen Text durch einen anderen:
  1. Wählen Sie aus dem Menü Bearbeiten den Befehl Ersetzen.
  2. Das Dialogfeld Ersetzen erscheint.
  3. Geben Sie im Feld Suchen nach die zu suchenden Zeichen oder Wörter ein. Geben Sie im Feld Ersetzen durch den Text ein, durch den der Suchtext ersetzt werden soll.

  4. Klicken Sie auf Weitersuchen und dann auf Ersetzen. Wenn Sie alle Textstellen auf einmal ersetzen möchten, klicken Sie auf Alles ersetzen.


Kopieren, Einfügen, Ausschneiden und Löschen von Text

SpeedEdit
Kopieren, Einfügen, Ausschneiden und Löschen von Text

So können Sie Text ausschneiden, kopieren, einfügen und löschen.

So kopieren Sie einen Text in die Zwischenablage:
  1. Markieren Sie den Text, den Sie kopieren möchten.
  2. Wählen Sie im Menü Bearbeiten den Befehl Kopieren, oder klicken Sie in der Symbolleiste auf die Schaltfläche Kopieren.
So fügen Sie einen Text aus der Zwischenablage ein:
  1. Platzieren Sie die Einfügemarke an die Stelle, an der Sie den Text einfügen möchten.
  2. Wählen Sie im Menü Bearbeiten den Befehl Einfügen, oder klicken Sie in der Symbolleiste auf die Schaltfläche Einfügen.
So schneiden Sie einen Text aus:
  1. Markieren Sie den Text, den Sie ausschneiden möchten.
  2. Wählen Sie im Menü Bearbeiten den Befehl Ausschneiden, oder klicken Sie in der Symbolleiste auf die Schaltfläche Ausschneiden.
So löschen Sie einen Text:
  1. Markieren Sie den Text, den Sie löschen möchten.
  2. Wählen Sie im Menü Bearbeiten den Befehl Löschen, oder klicken Sie in der Symbolleiste auf die Schaltfläche Löschen.


Lesezeichen verwenden

SpeedEdit
Lesezeichen verwenden

Bei größeren Textdokumenten empfiehlt sich der Einsatz von Lesezeichen, um schneller im Text navigieren zu können. SpeedEdit kann bis zu 10 benannte und beliebig viele unbenannte Lesezeichen erstellen. Der Vorteil bei einem benannten Lesezeichen ist, dass das Lesezeichen direkt angesprungen werden kann.

So erstellen Sie ein benanntes Lesezeichen:
  1. Wechseln Sie in die Zeile, für die Sie ein Lesezeichen erstellen möchten.
  2. Drücken Sie Strg+1, um das Lesezeichen 1 zu erstellen. Sie können auch die Ziffern 2-0 verwenden, um die Lesezeichen 2-10 zu erstellen.
  3. Ein erneutes Drücken von Strg+1 (bzw. Strg+2 ... Strg+0) schaltet das Lesezeichen wieder aus.
So aktivieren Sie ein benanntes Lesezeichen:
  1. Drücken Sie Alt+1, um das Lesezeichen 1 zu aktivieren. Sie können auch die Ziffern 2-0 verwenden, um die Lesezeichen 2-10 zu aktivieren.
  2. Die entsprechende Zeile im Textdokument wird angezeigt.

Unbenannte Lesezeichen können nicht direkt angesprungen werden, man kann nur direkt zwischen ihnen hin- und herwechseln. Ein unbenanntes Lesezeichen wird mit Strg+F2 erstellt. Drücken Sie F2 oder Umschalt+F2, um zwischen den Lesezeichen zu wechseln.


AutoText-Einträge verwenden

SpeedEdit
AutoText-Einträge verwenden

Mit SpeedEdit können Sie AutoText-Einträge definieren. SpeedEdit ersetzt dann das eingegebene Kürzel durch den ihm zugeordneten Eintrag. Wenn Sie z.B. dem Kürzel "mfg" den Eintrag "Mit freundlichen Grüßen" zuordnen, wird bei der Eingabe "mfg" durch "Mit freundlichen Grüßen" ersetzt.

So definieren Sie einen AutoText-Eintrag:
  1. Wählen Sie aus dem Menü Extras den Befehl Einstellungen.
  2. Aktivieren Sie die Registerkarte AutoText.
  3. Tragen Sie in das Eingabefeld Kürzel den Begriff ein, den SpeedEdit bei der Eingabe ersetzen soll.
  4. Tragen Sie in das Eingabefeld Text den Text ein, den SpeedEdit anstelle des Begriffs oder der Abkürzung im Eingabefeld Kürzel einfügen soll.
  5. Klicken Sie auf Hinzufügen.
So verwenden Sie einen AutoText-Eintrag:
  1. Geben Sie im Textdokument das entsprechende Kürzel ein.
  2. Wählen Sie aus dem Menü Bearbeiten den Befehl Automatisch ersetzen; oder drücken Sie Strg+Enter, um das Kürzel durch den zugeordneten Text zu ersetzen.


Einstellungen

SpeedEdit
Einstellungen

Im Einstellungsdialog nehmen Sie Grundeinstellungen für SpeedEdit vor. Zur Anzeige des Dialogfeldes wählen Sie den Befehl Einstellungen aus dem Menü Extras.

Das Dialogfeld besteht aus mehreren Registerkarten:

  • Allgemein
  • Editor
  • Format
  • AutoText

Registerkarte "Allgemein"

Hier definieren Sie allgemeine Einstellungen von SpeedEdit.

Einstellung | Beschreibung
Neues Dokument erstellen | Niemals: Beim Start von SpeedEdit wird niemals ein leeres Dokumentenfenster erzeugt. Immer: Beim Start von SpeedEdit wird immer ein leeres Dokumentenfenster erzeugt. Wenn zuletzt keins aktiv: Beim Start von SpeedEdit wird nur ein leeres Dokumentenfenster erzeugt, wenn beim Beenden der letzten SpeedEdit-Sitzung kein Dokument angezeigt war.
Hauptfenster beim Start maximieren | Aktivieren Sie dieses Kontrollkästchen, wenn das Hauptfenster von SpeedEdit beim Start maximiert werden soll.
MDI-Fenster beim Start maximieren | Aktivieren Sie dieses Kontrollkästchen, wenn beim Start von SpeedEdit alle Dokumentenfenster maximiert werden sollen.
Textbearbeitung mit Drag & Drop | Aktivieren Sie dieses Kontrollkästchen, um die Textbearbeitung mit Drag & Drop zu aktivieren. Dadurch können Sie markierten Text mit der Maus verschieben oder kopieren.
Neuladen von Dateien beim Start | Aktivieren Sie dieses Kontrollkästchen, wenn SpeedEdit beim Start alle Dokumente laden soll, die beim Beenden der letzten SpeedEdit-Sitzung angezeigt wurden.
Erkennung von veränderten Dateien | Aktivieren Sie dieses Kontrollkästchen, wenn SpeedEdit darauf achten soll, ob die gerade geöffneten Dokumente von anderen Anwendungen verändert werden.
Extern geänderte Dateien automatisch neu laden | Aktivieren Sie dieses Kontrollkästchen, damit SpeedEdit extern geänderte Dateien, die vom Editor geladen (jedoch noch nicht geändert) wurden, automatisch erneut lädt.
Einstellungen beim Beenden speichern | Aktivieren Sie dieses Kontrollkästchen, wenn SpeedEdit beim Beenden seine Einstellungen automatisch speichern soll.
Alle Dokumente beim Beenden speichern | Aktivieren Sie dieses Kontrollkästchen, wenn beim Beenden von SpeedEdit alle offenen Dokumente automatisch gespeichert werden sollen.
Position der Einfügemarke speichern | Aktivieren Sie dieses Kontrollkästchen, wenn sich SpeedEdit die Position der Einfügemarke für eine Datei speichern soll.
SpeedEdit mit <ESC> beenden | Aktivieren Sie dieses Kontrollkästchen, wenn Sie SpeedEdit auch mit ESC beenden möchten.

Registerkarte "Editor"

Hier legen Sie fest, wie einzelne Textdokumente angezeigt werden sollen. Wählen Sie die Formate aus, deren Einstellungen Sie ändern möchten.

Einstellung | Beschreibung
Tabulatoren einfügen | Aktivieren Sie dieses Kontrollkästchen, wenn beim Drücken der Tabulatortaste ein Tabulartorzeichen eingefügt werden soll.
Leerzeichen einfügen | Aktivieren Sie dieses Kontrollkästchen, wenn beim Drücken der Tabulatortaste statt eines Tabulartorzeichens die im Eingabefeld Tab-Länge definierte Anzahl von Leerzeichen eingefügt werden soll.
Tab-Länge | In diesem Feld können Sie die Anzahl von Leerzeichen angeben, die einem Tabulatorzeichen entsprechen.
Tabulatoren anzeigen | Aktivieren Sie dieses Kontrollkästchen, wenn die Tabulatoren oder Leerzeichen besonders gekennzeichnet werden sollen.
Einzug bei Klammern | Keiner: Es erfolgt kein Einzug bei Klammern. ANSI Stil: Der Einzug bei Klammern erfolgt im ANSI-Stil. GNU Stil: Der Einzug bei Klammern erfolgt im GNU-Stil.
Automatischer Einzug | Aktivieren Sie dieses Kontrollkästchen, wenn der Text einer neuen Zeile automatisch so eingezogen werden soll wie der der vorherigen Zeile.
Zeilenende | Auto: SpeedEdit versucht, das Zeilenendezeichen automatisch zu erkennen. DOS: Das Zeilenende wird durch die Zeichen \r\n dargestellt. UNIX: Das Zeilenende wird durch das Zeichen \n dargestellt. MAC: Das Zeilenende wird durch das Zeichen \n dargestellt.
Zeilenumbruch | Aktivieren Sie dieses Kontrollkästchen, wenn der Text am rechten Rand automatisch umgebrochen werden soll.
Markierungsleiste anzeigen | Aktivieren Sie dieses Kontrollkästchen, um links neben den einzelnen Textzeilen einen Rand anzeigen zu lassen. Sie können diesen Rand verwenden, um Text zu markieren und um Lesezeichen anzuzeigen.
Rücktaste am Zeilenanfang | Aktivieren Sie dieses Kontrollkästchen, wenn ein Zusammenführen von einzelnen Zeilen nach Verwenden der RÜCKTASTE verhindert werden soll.
Leerzeichen vor öffnender Klammer einfügen | Aktivieren Sie dieses Kontrollkästchen, wenn beim Schreiben einer öffnenden Klammer automatisch ein Leerzeichen vor dieser Klammer eingefügt werden soll.
Dateierweiterungen | Geben Sie hier die Dateierweiterungen ein, für welche diese Einstellungen gelten sollen.
Textformat | Wählen Sie hier das Textformat aus, mit dem die Dateien abgespeichert sind. Dies ist nur nötig, wenn die Dateien von einem DOS-Programm oder unter einem anderen Betriebssystem erzeugt worden sind.

Registerkarte "Format"

Hier können Sie die Farben für einzelne Textelemente festlegen.

Einstellung | Beschreibung
Schriftart | Listet die verfügbaren Schriftarten auf. Markieren Sie den gewünschten Namen in der Dropdown-Liste.
Grad | Listet die verfügbaren Schriftgrade auf. Markieren Sie den gewünschten Schriftgrad in der Dropdown-Liste.
Farben | Listet die Fensterelemente auf, für die Sie eine Vordergrund- bzw. eine Hintergrundfarbe angeben können.
Vordergrund | Zeigt die Vordergrundfarbe für das ausgewählte Element in der Liste Farben an. Klicken Sie auf den Pfeil, um die Standardfarben anzeigen zu lassen und wählen Sie die gewünschte Farbe aus.
Hintergrund | Zeigt die Hintergrundfarbe für das ausgewählte Element in der Liste Farben an. Klicken Sie auf den Pfeil, um die Standardfarben anzeigen zu lassen und wählen Sie die gewünschte Farbe aus.
Fett | Aktivieren Sie dieses Kontrollkästchen, wenn das ausgewählte Element in der Liste Farben fett dargestellt werden soll.
Kursiv | Aktivieren Sie dieses Kontrollkästchen, wenn das ausgewählte Element in der Liste Farben kursiv dargestellt werden soll.

Registerkarte "AutoText"

Hier legen Sie fest, welche Begriffe bei der Eingabe durch andere ersetzt werden sollen.

Einstellung | Beschreibung
Kürzel | Geben Sie den Begriff ein, den SpeedEdit bei der Eingabe ersetzen soll.
Text | Geben Sie den Text ein, den SpeedEdit anstelle des Begriffs oder der Abkürzung im Feld Kürzel einfügen soll.
Hinzufügen | Erstellt einen neuen Eintrag und fügt ihn dem Listenfeld hinzu.
Löschen | Löscht den gewählten Eintrag aus dem Listenfeld.


SpeedView
Überblick

SpeedView ist ein externes Programm zur Anzeige von Dateien. SpeedView kann aus dem SpeedCommander heraus aufgerufen werden, Sie können das Programm aber auch separat starten.

SpeedView zeigt folgende Dokumente an:

  • Grafikformate: AWD, BMI, BMP, BW, CAL, CALS, CDR, CDT, CEL, CIT, CLP, CMX, COT, CPT, CUR, CUT, DCX, DIB, FLC, FLI, GEM, GIF, HAM, HRZ, ICN, ICO, IFF, IMG, JFF, JIF, JMX, JPE, JPG, LBM, MIL, MAC, MSP, OFX, PAN, PAT, PBM, PC2, PCD, PCT, PCX, PGM, PIC, PNG, PNM, PPM, PSD, PYX, QFX, RAS, RGB, RLE, SAM, SCx, SEP, SGI, ST, STW, SUN, TGA, TIFF, UDI, WPG, ZBR, ZMF
  • Archivformate: 7Z, ACE, ARJ, CAB, GZIP, JAR, LZH, LHA, RAR, SQX, TAR, UUE, ZIP
  • Multimedia: AVI, MID, MP3, MPG, MPEG, RMI, WAV
  • Dokumente: HTM, HTML, RTF, WRI, Text
  • Dokumente bei installiertem MS Office: DOC, WK1, WK3, WK4, WPS, XLS
  • Schriftarten: FON, FNT, OTF, TTF

Weitere Informationen

Anzeigen einer Datei

Unterstützte Dateiformate

Konfiguration der Dateibetrachter

Umschalten des Dateibetrachters

Textkonverter installieren


Anzeigen einer Datei

SpeedView
Anzeigen einer Datei

SpeedView ist ein externes Programm zur Anzeige von Dateien. SpeedView kann aus dem SpeedCommander heraus aufgerufen werden, Sie können das Programm aber auch separat starten.

So zeigen Sie eine Datei an:
  1. Starten Sie das Programm SpeedView.
  2. Aktivieren Sie aus dem Menü Datei den Befehl Öffnen.
  3. Wählen Sie im Dateiauswahldialog die Datei(en) aus, die Sie anzeigen möchten.


Unterstützte Dateiformate

SpeedView
Unterstützte Dateiformate

SpeedView und SpeedCommander zeigen folgende Dateiformate an:

Grafik

  • AWD - Microsoft At Work Document fax format
  • BMI - Zoner Bitmap
  • BMP - MS Windows Bitmap, including compressed and HiColor
  • BMP - OS/2 Bitmap
  • BW - Black-and-White images in SGI Image file format
  • CAL - CALS Raster Type I, G4 fax compression
  • CALS - CALS Raster Type I, G4 fax compression
  • CDR - CorelDraw! 2.0 - 9.0, preview and imported bitmaps only
  • CDT - CorelDraw! 2.0 - 9.0 Template, preview and imported bitmaps only
  • CEL - Autodesk Animator Pro animation
  • CEL - Autodesk Animator still picture
  • CIT - Intergraph Group 4 Raster
  • CLP - MS Windows Clipboard file
  • CMX - Corel Metafile Exchange 5.0 - 9.0, preview and imported bitmaps only
  • COT - Intergraph Raster images, 8-bit or TrueColor
  • CPT - Corel PhotoPaint 6.0
  • CUR - MS Windows cursors
  • CUT - Dr. Halo/Dr.Genius Clipboard Format
  • DCX - Intel's multipage fax-format
  • DIB - MS Windows Device Independent Bitmap, including compressed
  • EMF - Windows Meta File
  • FLC - Autodesk Animator Pro Animation
  • FLI - Autodesk Animator Animation
  • GEM - GEM IMG
  • GIF - Compuserve Interchange File Format, including animated GIFs
  • HAM - Amiga Interchange File Format in hardware modes (HAM)
  • HRZ - Slow scan televison
  • ICN - Images from RIPTerm program
  • ICO - MS Windows Icons, including HiColor and TrueColor
  • ICO - OS/2 Icons
  • IFF - Amiga Interchange File Format
  • IMG - GEM IMG
  • IMG - IMG Software Set
  • IMG - Vivid Raytracer
  • JFF - JPEG File Format, including Progressive Mode
  • JIF - JPEG File Interchange Format, including Progressive Mode
  • JMX - Images from a Tetris game
  • JPEG - JPEG, including Progressive Mode
  • JPG - JPEG, including Progressive Mode
  • LBM - Amiga Interchange File Format, Interleaved Bitmap
  • MAC - MacPaint
  • MIL - CALS Raster Type I, G4 fax compression
  • MSP - Microsoft Paint
  • OFX - OLIFAX fax package
  • PAN - SmoothMove Pan Viewer, preview only
  • PAT - CorelDraw! 6.0 - 9.0 patterns, preview only
  • PBM - Portable Bitmap
  • PC2 - Degas Elite Medium Resolution
  • PCD - Kodak PhotoCD - Base/16, Base/4 and Base only
  • PCT - MacIntosh PICT
  • PCX - PC PaintBrush
  • PGM - Portable GrayMap
  • PIC - PC Paint/Pictor, including HiColor
  • PIC - Dr. Halo/Dr. Genius
  • PNG - Portable Network Graphics
  • PNM - Portable Any Bitmap
  • PPM - Portable PixelMap
  • PSD - Adobe Photoshop 2,5 - 4.0, including CMYK
  • PYX - Old Epson scanner format
  • QFX - Quick Link II Fax file format
  • RAS - Raster SunMicrosystems
  • RGB - TrueColor (RGB) Images in SGI File Format
  • RLE - Compressed MS Windows BMP
  • RLE - Compressed Images in SGI File Format
  • RLE - Compressed Intergraph Raster images, bilevel only
  • RLE - Utah RunLength Encoded
  • SAM - Images in Text Documents from AmiPro
  • SCx - ColorRIX SEP - CMYK Separated Images in TIFF 6.0 File Format
  • SEP - CMYK Separated Images in TIFF 6.0 File Format
  • SGI - SGI Image File Format
  • ST - NeoPaint for DOS thumbnails
  • STW - NeoPaint for Windows thumbnails
  • SUN - Raster SunMicrosystems
  • TGA - TrueVision Targa
  • TIFF - Tagged Interchange File Format
  • WMF - Windows Meta File
  • WPG - WordPerfect Graphics
  • ZBR - Zoner Zebra for Windows 1.0 - 1.5, preview only
  • ZMF Zoner Callisto Metafile, preview only, uncompressed only

Multimedia

  • AIF - Audio Interchange File Format
  • AIFC - Audio Interchange File Format
  • AIFF - Audio Interchange File Format
  • ASF - Windows Media-Audio-/Videodatei
  • ASX - Windows Media-Wiedergabeliste für Audio-/Videodateien
  • AU - AU-Audioformat
  • AVI - Videoclip
  • CDA - CD-Audiospur
  • MID - MIDI-Sequenz
  • MIDI - MIDI-Sequenz
  • M1V - Motion Picture Experts Group Video-/Audiodatei
  • MP2 - Motion Picture Experts Group Video-/Audiodatei
  • MP2V - Motion Picture Experts Group Video-/Audiodatei (bei installiertem DVD-Player)
  • MP3 - Motion Picture Experts Group Video-/Audiodatei
  • MPA - Motion Picture Experts Group Video-/Audiodatei
  • MPE - Motion Picture Experts Group Video-/Audiodatei
  • MPEG - Motion Picture Experts Group Video-/Audiodatei
  • MPG - Motion Picture Experts Group Video-/Audiodatei
  • QT - QuickTime-Film (bei installiertem QuickTime)
  • MOV - QuickTime-File (bei installiertem QuickTime)
  • RAM - RealPlayer-Film (bei installiertem RealPlayer)
  • RM - RealPlayer-Film (bei installiertem RealPlayer)
  • RMI - MIDI-Sequenz
  • SND0 - AU-Audioformat
  • SWF - Macromedia Flash (bei installiertem Flash-Player)
  • VOB - DVD-Video (bei installiertem DVD-Player)
  • WAV - Wave Sound
  • WAX - Windows Media-Audio- und Videodatei
  • WM - Windows Media-Audio- und Videodatei
  • WMA - Windows Media-Audio- und Videodatei
  • WMD - Windows Media-Audio- und Videodatei
  • WMP - Windows Media-Audio- und Videodatei
  • WMV - Windows Media-Audio- und Videodatei
  • WMX - Windows Media-Audio- und Videodatei
  • WPL - Windows Media-Audio- und Videodatei
  • WVX - Windows Media-Audio- und Videodatei

Archive

  • 7Z - Igor Pavlovs 7z
  • ACE - Marcel Lembkes ACE
  • ARJ - Robert Jungs ARJ
  • BZIP - Julian Sewards BZIP
  • CAB - Microsoft CAB
  • GZ - Unix GZip
  • GZIP - Unix GZip
  • JAR - JavaSoft Archiv
  • LZH - Yoshi's LHA, LHARC
  • LHA - Yoshi's LHA, LHARC (Amiga)
  • SQX - SpeedProjects SQX
  • RAR - Eugene Roshals RAR
  • TAR - Unix TAR
  • UUE - Unix UUE/UUX
  • ZIP - PKWARE Pkzip

Dokumente

  • DFM - Delphi-Formulare
  • DOC - Word für Windows (bei installiertem MS Office)
  • DOC - WordPerfect 5.x / 6.x (bei installiertem MS Office)
  • HTM - Internet World Wide Web
  • HTML - Internet World Wide Web
  • RTF - Rich Text Format
  • WK1 - Lotus 1-2-3 (bei installiertem MS Office)
  • WK3 - Lotus 1-2-3 (bei installiertem MS Office)
  • WK4 - Lotus 1-2-3 (bei installiertem MS Office)
  • WPS - Works 3.x / 4.x (bei installiertem MS Office)
  • WRI - Write
  • XLS - Excel (bei installiertem MS Office)
  • Textdateien

Programmdateien

  • AX - Audio-Codec
  • BPL - Borland Runtime Bibliothek
  • CPL - Systemsteuerungsoption
  • DBG - Debuginformation
  • DLL - Programmbibliothek
  • DRV - Gerätetreiber
  • EXE - Anwendung
  • EXP - Exports Library File
  • LIB - Bibliotheksdatei
  • OBJ - Objektdatei
  • OCX - ActiveX-Steuerelement
  • SYS - Gerätetreiber

Schriftarten

  • FON - Windows 3.1 Schriftart

  • FNT - Windows 3.1 Schriftart
  • OTF - OpenType-Schriftart
  • TTF - TrueType-Schriftart


Konfiguration der Dateibetrachter

SpeedView
Konfiguration der Dateibetrachter

SpeedCommander und SpeedView bringen für die Anzeige von Dateien eigene Betrachter für die wichtigsten Grafikformate, Multimediadateien und Textdateien mit. Dieser Abschnitt beschreibt, wie Sie die Zuordnung von Dateibetrachtern steuern können.

Öffnen Sie im SpeedCommander den Einstellungsdialog und aktivieren Sie die Seite Schnellansicht.

So weisen Sie einer Dateierweiterung einen Betrachter zu:
  1. Klicken Sie auf die Schaltfläche Neu.
  2. Tragen Sie im Eingabefeld Dateierweiterung die Dateierweiterung ein, der Sie einen Betrachter zuordnen möchten.
  3. Wählen Sie im Auswahlfeld Betrachter den entsprechenden Betrachter aus.
So ändern Sie die Zuweisung für eine Dateierweiterung:
  1. Wählen Sie in der Auswahlliste Registrierte Dateierweiterungen die Dateierweiterung aus, deren Zuordnung Sie ändern möchten.
  2. Klicken Sie auf die Schaltfläche Bearbeiten.
  3. Wählen Sie im Auswahlfeld Betrachter den entsprechenden Betrachter aus.
So löschen Sie die Zuweisung eines Betrachters zu einer Dateierweiterung:
  1. Wählen Sie in der Auswahlliste Registrierte Dateierweiterungen die Dateierweiterung aus, deren Zuordnung Sie löschen möchten.
  2. Klicken Sie auf die Schaltfläche Löschen.
  3. Beantworten Sie die Sicherheitsabfrage mit Ja.
So ändern Sie den Standardbetrachter:
  1. Wählen Sie im Auswahlfeld Standardbetrachter den Betrachter aus, der für nichtregistrierte Dateierweiterungen verwendet werden soll.

Wichtiger Hinweis: Bei Anzeige von HTML-Dateien werden auch entsprechend der eingestellten Sicherheitsstufe für "Lokales Intranet" Skripte ausgeführt. Wenn Sie dies nicht wünschen, müssen Sie die Anzeige für HTML-Dateien deaktivieren, indem Sie die Zuordnung für die Dateierweiterungen html, htm, ihtml und shtml löschen.


Umschalten des Dateibetrachters

SpeedView
Umschalten des Dateibetrachters

In einigen Fällen kann es vorkommen, dass Sie eine Datei mit einem anderen Betrachter anzeigen möchten. Dies ist z.B. nötig, wenn Sie den binären Aufbau einer Datei analysieren möchten.

So schalten Sie den Dateibetrachter um:
  1. Wählen Sie die Datei aus, die Sie betrachten möchten.
  2. Klicken Sie in der Symbolleiste über der angezeigten Datei auf das Symbol Betrachter ändern .
  3. Wählen Sie aus dem darauf erscheinenden Menü den Betrachter aus, mit dem Sie die Datei anzeigen möchten.


Textkonverter installieren

SpeedView
Textkonverter installieren

Für die Anzeige von Word-, Excel-, Works-, WordPerfect- und Lotus 123-Dokumenten greift SpeedView auf Textkonverter zurück, die mit Microsoft Office installiert werden.

So installieren Sie die Textkonverter von Office 97:
  1. Starten Sie das Setup-Programm von Office 97.
  2. Öffnen Sie den Bereich Konverter und Grafikfilter.
  3. Markieren Sie Konvertierungsprogramme und klicken Sie auf Option ändern.
  4. Aktivieren Sie folgende Kontrollkästchen:
    • Word für Windows 2.0-Konverter
    • Word 6.0/95 für Windows/Macintosh
    • Word 97 für Windows/Macintosh
    • Word für Macintosh 4.0-5.1-Konverter
    • Microsoft Excel-Konverter
    • WordPerfect 5.x-Konverter
    • WordPerfect 6.x-Konverter
    • Lotus 123-Konverter
    • Works für Windows 3.0-Konverter
    • Works für Windows 4.0-Konverter
  5. Schließen Sie die Installation ab.
So installieren Sie die Textkonverter von Office 2000/XP:
  1. Starten Sie das Setup-Programm von Office 2000/XP.
  2. Öffnen Sie den Bereich Konverter und Grafikfilter.
  3. Öffnen Sie den Bereich Textkonverter.
  4. Aktivieren Sie für folgende Textkonverter die Installationsart Vom Arbeitsplatz starten:
    • Word für Windows 2.0-Konverter
    • Word 6.0/95 für Windows/Macintosh
    • Word 97 für Windows/Macintosh
    • Word für Macintosh 4.0-5.1-Konverter
    • WordPerfect 5.x-Konverter
    • Microsoft Excel-Konverter
    • WordPerfect 6.x-Konverter
    • Lotus 123-Konverter
    • Works für Windows 4.0-Konverter
  5. Schließen Sie die Installation ab.
So installieren Sie die Textkonverter von Office 2003:
  1. Starten Sie das Setup-Programm von Office 2003.
  2. Öffnen Sie unter Gemeinsam genutzte Office-Features den Bereich Konverter und Filter.
  3. Öffnen Sie den Bereich Textkonverter.
  4. Aktivieren Sie für folgende Textkonverter die Installationsart Vom Arbeitsplatz starten:
    • WordPerfect 6.x-Konverter
    • WordPerfect 5.x-Konverter
    • Word 97-2003 & 6.0/95 RTF-Konverter
    • Word 97 für Windows/Word 98 für Macintosh
    • Works für Windows 7.0
  5. Schließen Sie die Installation ab.


FileSync
Überblick

FileSync ist ein Synchronisationsprogramm, mit dem sich der Inhalt zweier Ordner schnell abgleichen lässt. FileSync bietet Ihnen folgende Möglichkeiten:

  • Inhaltsvergleich zweier Ordner in drei verschiedene Richtungen
  • Einbeziehen von Unterordnern
  • Ein- und Ausschließen von bestimmten Dateien
  • Löschen verwaister Dateien und Ordner
  • Übernahme von Sicherheitsattributen (NTFS)
  • Speichern von Synchronisationseinstellungen in einem Profil

Weitere Informationen

Vergleichen und Synchronisieren

Synchronisationsprofile verwenden


Vergleichen und Synchronisieren

FileSync
Vergleichen und Synchronisieren

Das Abgleichen von Ordnern geschieht in drei Schritten:

  1. Festlegen der Einstellungen
  2. Vergleichen
  3. Synchronisieren

Sofern nach einem Vergleich ein Vergleichskriterium geändert wird, ist vor dem Synchronisieren ein neuer Vergleich notwendig.

Festlegen der Einstellungen

FileSync synchronisiert immer zwei Ordner miteinander. Die Ordner werden mit den Befehlen Quellordner auswählen und Zielordner auswählen aus dem Menü Extras festgelegt. Für die Synchronisierung gibt es drei verschiedene Methoden, die ebenfalls im Menü Extras aktiviert werden:

Methode | Beschreibung | Wann anwenden?
Quelle -> Ziel | Der Zielordner wird auf den Stand des Quellordners gebracht. | Änderungen im Zielordner
Quelle <- Ziel | Der Quellordner wird auf den Stand des Zielordners gebracht. | Änderungen im Quellordner
Quelle <-> Ziel | Der Abgleich erfolgt in beide Richtungen. | Änderungen in Ziel- und Quellordner

Mit Hilfe des Dialogfelds Profileinstellungen werden weitere Einstellungen festgelegt:

Einstellung | Beschreibung
Zeitstempel beachten | Beim Vergleich wird der Zeitstempel der Dateien beachtet.
Dateigröße beachten | Beim Vergleich wird die Dateigröße beachtet.
Dateiinhalt beachten | Beim Vergleich wird der Dateiinhalt beachtet.
Unterordner einbeziehen | FileSync vergleicht auch alle Unterordner von Quell- und Zielordner.
Auf gerade Sekunden aufrunden | Vor dem Vergleich wird der Zeitstempel aller Dateien auf gerade Sekunden aufgerundet. Dies ist wichtig, wenn zwischen FAT/FAT32 und NTFS synchronisiert wird. Der Zeitstempel bei FAT/FAT32 kann nur gerade Sekunden speichern, während NTFS auch ungerade Sekunden speichert.
Zeitdifferenz von 1h ignorieren | Legt fest, dass beim Vergleichen Zeitdifferenzen von genau einer Stunde ignoriert werden sollen (Sommer-/Winterzeit).
Sicherheitsattribute für Dateien | Die Zieldatei erhält nach dem Synchronisieren die Sicherheitsattribute der Quelldatei (nur NTFS).
Sicherheitsattribute für Ordner | Der Zielordner erhält nach dem Synchronisieren die Sicherheitsattribute des Quellordners (nur NTFS).
Verwaiste Dateien löschen | Im Normalfall wird von Quellordner nach Zielordner synchronisiert, d.h. im Zielordner werden gegebenenfalls Dateien ersetzt. Aktivieren Sie diese Option, wenn Sie zusätzlich alle Dateien im Zielordner löschen möchten, die im Quellordner nicht vorhanden sind. Diese Einstellung wird automatisch deaktiviert, wenn in beide Richtungen synchronisiert wird.
Verwaiste Ordner löschen | Im Normalfall wird von Quellordner nach Zielordner synchronisiert, d.h. im Zielordner werden gegebenenfalls Dateien ersetzt. Aktivieren Sie diese Option, wenn Sie zusätzlich alle leeren Ordner im Zielordner löschen möchten, die im Quellordner nicht vorhanden sind. Diese Einstellung wird automatisch deaktiviert, wenn in beide Richtungen synchronisiert wird oder wenn das Kontrollkästchen 'Verwaiste Dateien löschen' deaktiviert ist.

Mit Hilfe des Kombinationsfeldes Dateimaske wird festgelegt, welche Dateien in den Vergleich eingeschlossen werden bzw. welche Dateien FileSync ignorieren soll. Das Kombinationsfeld befindet sich zwischen Quell- und Zielordner. Einzelne Dateimasken werden durch ein Semikolon voneinander getrennt, die Trennung zwischen Ein- und Ausschließen-Maske erfolgt durch einen Bindestrich (z.B. ' *.*-*.tmp;*.~tm').

Vergleichen

Nachdem alle Einstellungen vorgenommen wurden, kann der Vergleich mit dem Befehl Vergleichen aus dem Menü Datei gestartet werden. FileSync vergleicht nun anhand der oben vorgenommen Einstellungen die beiden Ordner und stellt anschließend alle Dateien in einer Übersicht dar. Alle zu kopierenden Dateien können durch ein Kontrollkästchen für den Abgleich markiert oder demarkiert werden. Eine Datei ohne Kontrollkästchen entspricht nicht den Vergleichskriterien und wird daher vom Abgleich ausgeschlossen.

Synchronisieren

Nach dem Vergleich wird mit dem Befehl Synchronisieren aus dem Menü Datei die Synchronisation gestartet. FileSync kopiert die Dateien in die entsprechenden Ordner und löscht (sofern angegeben) verwaiste Dateien und Ordner. Der Verlauf der Synchronisation wird in der Statuszeile angezeigt.


Synchronisationsprofile verwenden

FileSync
Synchronisationsprofile verwenden

In einem Synchronisationsprofil können Sie Ihre aktuellen Einstellungen speichern, so dass Sie schnell zwischen verschiedenen häufig genutzten Einstellungen umschalten können.

So speichern Sie ein Profil:
  1. Konfigurieren Sie die Einstellungen, die Sie speichern möchten.
  2. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie den Befehl Speichern.
  3. Geben Sie im Dialogfeld Profil speichern einen Namen für das neue Profil ein, und klicken Sie auf OK.
So löschen Sie ein gespeichertes Profil:
  1. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie den Befehl Löschen.
  2. Markieren Sie im Dialog Profil löschen das zu löschende Profil, und klicken Sie auf OK.
So aktivieren Sie ein Profil:
  1. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie das Profil aus, welches Sie aktivieren möchten.
  2. Sie können auch das Symbol Profile aus der Symbolleiste verwenden oder im Einstellungsdialog Anpassen jedem Profil ein eigenes Tastenkürzel zuordnen.


FileSync Kommandozeile
Überblick

FileSync Kommandozeile (FSC) ist die Kommandozeilenversion von FileSync. Beide Programme dienen dazu, Ordner bzw. Dateien miteinander abzugleichen. Gerade bei den heute üblichen Daten- bzw. Dateimengen kann der Abgleich von Ordnern (z.B. von Laptop und stationärem Rechner) sehr zeitaufwendig sein.

FileSync kann diese Aufgabe für Sie automatisiert durchführen und Ordner bzw. Dateien nach verschiedenen Kriterien abgleichen. FileSync Kommandozeile unterstützt außerdem einfache Skriptdateien, die mit einem üblichen Texteditor (z.B. dem Windows-Editor oder SpeedEdit) angelegt und bearbeitet werden können. Es sind keinerlei Programmierkenntnisse notwendig, um diese Skriptdateien zu erstellen.

Weitere Themen

Kommandoschalter

Skriptdateien


Kommandoschalter

FileSync Kommandozeile
Kommandoschalter

FileSync Kommandozeile nutzt eine ganze Reihe von Kommandoschaltern, um den Ablauf von Sicherungsaufgaben usw. zu steuern. Soweit nicht anders vermerkt, spielt die Schreibweise (groß/klein) der Kommandoschalter keine Rolle: fsc -r erzeugt das gleiche Ergebnis wie fsc -R.

FileSync Kommandozeile muss wie folgt aufgerufen werden:

fsc -sd Quellordner -td Zielordner [-Schalter...] [Dateien...] [@Scriptdatei]

oder

fsc @Skriptdatei

Mit [Dateien...] werden alle diejenigen Dateien angegeben, die beim Synchronisieren eingeschlossen werden sollen. Erlaubt sind hier neben Dateinamen auch Dateimasken, die Wildcards oder Char-Sets enthalten. Wildcards sind die Zeichen * und ?, wobei * für eine beliebige Anzahl von beliebigen Zeichen und ? für ein beliebiges Zeichen steht.

Die Dateimaske *.doc würde z.B. alle Dateien mit der Dateierweiterung 'doc' finden, wie z.B. Brief.doc oder Beschwerde.doc. Die Dateimaske M?ller.doc würde Dateien wie Müller.doc, Möller.doc oder Miller.doc finden.

Char-Sets funktionieren im Prinzip wie ?, allerdings lassen sich mit Char-Sets die jeweils gültigen Zeichen präzise festlegen. Char-Sets werden einfach in eckigen Klammern angegeben, wie z.B. [üö]. Die Dateimaske M[üö]ller.doc würde Dateien wie Müller.doc oder Möller.doc finden, nicht aber Miller.doc. Weitere Informationen zu Char-Sets finden Sie hier.

Verschiedene Schalter benötigen ein weiteres Argument. Diese Schalter werden wie folgt in der Kommandozeile angegeben

-Schalter Argument

Zwischen dem Schalter und dem Argument befindet sich ein Leerzeichen. In Skriptdateien werden solche Schalter in zwei Zeilen angegeben. Argumente, die Leerzeichen enthalten, müssen in der Kommandozeile als auch in Skriptdateien in Anführungszeichen angegeben werden, z.B.:

fsc -sd C:\Dokumente -td "D:\Gesicherte Dokumente"

Grundsätzlich können die Kommandoschalter untereinander kombiniert werden. Es müssen jedoch immer die Kommandoschalter für den Quellordner (-sd) und für den Zielordner (-td) mit den entsprechenden Argumenten angegeben werden.

FileSync Kommandozeile durchsucht im Normalfall in [Quellordner] nach Dateien, die auf die in der Kommandozeile angegebene Dateiliste passen. Danach wird [Zielordner] auf die gleiche Art durchsucht und die Dateien werden entsprechend der Vorgaben miteinander verglichen und ersetzt.

-af
Sicherheitsbeschreibungen der Dateien mitkopieren (nur für NTFS-Laufwerke).

-ad
Sicherheitsbeschreibungen der Ordner mitkopieren (nur für NTFS-Laufwerke).

-am Attribute

Nur Dateien mit bestimmten Attributen in die Dateiliste(n) einschließen. Attribute ist eine Zeichenkette mit den Abkürzungen für die Attribute, die Abkürzungen sind wie folgt:

A | Archivattribut
H | Attribut für versteckte Dateien
R | Schreibschutz-Attribut
S | Attribut für System-Dateien
E | Attribut für vom System verschlüsselte Dateien (nur NTFS)
C | Attribut für vom System komprimierte Dateien (nur NTFS)

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -am AR

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, die das Archivattribut und das Schreibschutzattribut gesetzt haben.

-as

Nur Dateien mit gesetztem Dateiattribut "Archiv" in die Dateiliste(n) einschließen.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -as

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, die das Archivattribut gesetzt haben.

-d

Dieser Schalter legt fest, dass "verwaiste" Dateien gelöscht werden sollen. Sind z.B. in [Zielordner] Dateien vorhanden, die nicht in [Quellordner] enthalten sind, so werden die entsprechenden Dateien aus [Zielordner] gelöscht.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -s -d

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. FileSync durchsucht C:\Dokumente nach Dateien, die auf die in der Kommandozeile angegebene Dateiliste passen (hier *.doc). Danach wird D:\Dokumente auf die gleiche Art durchsucht und die Dateien werden entsprechend der Vorgaben miteinander verglichen und ersetzt.

Hier wurden keine weiteren Vorgaben für den Vergleich bzw. das Ersetzen der Dateien gemacht, also ersetzt FileSync in D:\Dokumente alle Dateien, die einen älteren Zeitstempel als die entsprechenden Dateien in C:\Dokumente haben. Da der Schalter -d angegeben ist, würde FileSync Kommandozeile aus D:\Dokumente alle Dateien löschen, die nicht in C:\Dokumente enthalten sind.

-dd

Leere Ordner löschen. Dieser Schalter wird automatisch deaktiviert, wenn der Schalter -d (Verwaiste Dateien löschen) *nicht* gesetzt ist oder wenn in beide Richtungen synchronisiert wird.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -s -d -dd

-fb Dateigröße

Nur Dateien größer als Dateigröße in die Dateiliste(n) einschließen.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -fb 100000

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, die größer als 100000 Bytes sind.

-fs Dateigröße

Nur Dateien kleiner als Dateigröße in die Dateiliste(n) einschließen.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -fs 100000

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, die kleiner als 100000 Bytes sind.

-it

Sekundenanteil der Dateizeitstempel auf gerade Sekunden abrunden. Verschiedene Dateisysteme wie z.B. FAT und FAT32 haben eine maximale Auflösung von zwei Sekunden, Dateisysteme wie z.B. NTFS (Windows NT, Windows 2000, Windows XP) haben eine wesentlich höhere Auflösung. Werden nur Dateizeitstempel von Dateien auf gleichen Dateisystemen verglichen (z.B. FAT32 <-> FAT32, oder NTFS <->NTFS), so ist der Vergleich der Zeitstempel immer eindeutig.

Werden aber Dateizeitstempel von Dateien auf verschiedenen Dateisystemen (z.B. FAT32 <-> NTFS) verglichen, so könnte ein Vergleich im schlechtesten Fall fehlschlagen. Der Schalter -it sorgt im Prinzip für gleiche Auflösungen unter den verschiedenen Dateisystemen.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -it

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. Vor dem Vergleichen der Dateilisten bzw. Ersetzen der Dateien werden die Sekundenanteile der Zeitstempel auf gerade Sekunden abgerundet.

-ih

Zeitdifferenzen von exakt einer Stunde ignorieren. Durch die Zeitverschiebung zwischen Sommerzeit und Winterzeit entstehen unter Umständen Zeitunterschiede von genau einer Stunde.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -it -ih

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. Vor dem Vergleichen der Dateilisten bzw. Ersetzen der Dateien werden die Sekundenanteile der Zeitstempel auf gerade Sekunden abgerundet. Dateien, die genau eine Stunde jünger oder älter sind, werden als gleich betrachtet.

-log[n]

Automatisches Protokoll aktivieren bzw. deaktivieren. Der Wert n wird direkt an den Schalter -log angefügt. Möglich sind

-log0 | Automatisches Protokoll deaktivieren.
-log1 | Automatisches Protokoll aktivieren. Es werden nur jeweils die Uhrzeit und der Statuscode für jede Aktion protokolliert.
-log2 | Automatisches Protokoll aktivieren. Es werden jeweils die komplette Kommandozeile mit allen Parametern sowie die Uhrzeit und der Statuscode für jede Aktion protokolliert.
-log3 | Automatisches Protokoll aktivieren. Es werden jeweils die komplette Kommandozeile mit allen Parametern sowie die Uhrzeit und der Statuscode für jede Aktion protokolliert. Außerdem werden für jede Aktion alle Dateien mitprotokolliert, die kopiert oder gelöscht wurden.

Sämtliche Meldungen, Statuscodes usw. werden per Voreinstellung in die Datei fsc_log.txt geschrieben, die sich im gleichen Ordner wie fsc.exe befindet.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -log3

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. In die Protokolldatei werden sämtliche Meldungen, Statuscodes sowie die Namen aller kopierten bzw. gelöschten Dateien geschrieben.

-loge Dateiname

Dateiname ist der Name der Datei, in die alle Meldungen, Statuscodes usw. geschrieben werden sollen.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -log3 -loge D:\Protokoll.txt

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. In die Protokolldatei D:\Protokoll.txt werden sämtliche Meldungen, Statuscodes sowie die Namen aller kopierten bzw. gelöschten Dateien geschrieben.

-q

Alle Bildschirmausgaben unterdrücken.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -q

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. Es werden aber nicht die normalerweise üblichen Statusmeldungen am Bildschirm ausgegeben.

-r

Dateien aus Unterordnern in die Dateiliste einschließen.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -r

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente sowie deren Unterordner einbezogen. Würde der Schalter -r weggelassen werden, so würden alle Dateien aus C:\Dokumente einbezogen werden, nicht aber die Dateien aus C:\Dokumente\Briefe.

-s

Dieser Schalter legt die "Zielrichtung" des Vergleiches bzw. den Zielordner der zu ersetzenden oder zu löschenden Dateien fest. Dieser Schalter wird automatisch von FileSync gesetzt und legt fest, dass die Dateien von [Quellordner] nach [Zielordner] kopiert werden bzw. in [Zielordner] gelöscht werden.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -s

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. FileSync durchsucht C:\Dokumente nach Dateien, die auf die in der Kommandozeile angegebene Dateiliste passen (hier *.doc). Danach wird D:\Dokumente auf die gleiche Art durchsucht und die Dateien werden entsprechend der Vorgaben miteinander verglichen und ersetzt.

Hier wurden keine weiteren Vorgaben für den Vergleich bzw. das Ersetzen der Dateien gemacht, also ersetzt FileSync in D:\Dokumente alle Dateien, die einen älteren Zeitstempel als die entsprechenden Dateien in C:\Dokumente haben. Wäre noch der Schalter -d angegeben, so würde FileSync aus D:\Dokumente alle Dateien löschen, die nicht in C:\Dokumente enthalten sind.

-sb

Dieser Schalter legt ebenfalls die "Zielrichtung" des Vergleiches bzw. den Zielordner der zu ersetzenden oder zu löschenden Dateien fest. Dieser Schalter legt fest, dass zuerst die entsprechenden Dateien von [Quellordner] nach [Zielordner] kopiert werden, danach werden die entsprechenden Dateien von [Zielordner] nach [Quellordner] kopiert. Es werden also beide Ordner auf einmal miteinander synchronisiert.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -sb

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. FileSync durchsucht C:\Dokumente nach Dateien, die auf die in der Kommandozeile angegebene Dateiliste passen (hier *.doc). Danach wird D:\Dokumente auf die gleiche Art durchsucht und die Dateien werden entsprechend der Vorgaben miteinander verglichen und ersetzt.

Hier wurden keine weiteren Vorgaben für den Vergleich bzw. das Ersetzen der Dateien gemacht, also ersetzt FileSync in D:\Dokumente alle Dateien, die einen älteren Zeitstempel als die entsprechenden Dateien in C:\Dokumente haben. Danach werden in C:\Dokumente alle Dateien ersetzt, die einen älteren Zeitstempel als die entsprechenden Dateien in D:\Dokumente haben

Hinweis: Der Schalter -d wird ignoriert, wenn der Schalter -sb angegeben wurde.

-sd Quellordner

Dieser Schalter legt den Quellordner fest.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc

Der Ordner C:\Dokumente wird als Quellordner festgelegt.

-st

Dieser Schalter legt die "Zielrichtung" des Vergleiches bzw. den Zielordner der zu ersetzenden oder zu löschenden Dateien fest. Dieser Schalter legt fest, dass die Dateien von [Zielordner] nach [Quellordner] kopiert werden bzw. in [Quellordner] gelöscht werden.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -st

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. FileSync durchsucht C:\Dokumente nach Dateien, die auf die in der Kommandozeile angegebene Dateiliste passen (hier *.doc). Danach wird D:\Dokumente auf die gleiche Art durchsucht und die Dateien werden entsprechend der Vorgaben miteinander verglichen und ersetzt.

Hier wurden keine weiteren Vorgaben für den Vergleich bzw. das Ersetzen der Dateien gemacht, also ersetzt FileSync in C:\Dokumente alle Dateien, die einen älteren Zeitstempel als die entsprechenden Dateien in D:\Dokumente haben. Wäre noch der Schalter -d angegeben, so würde FileSync aus C:\Dokumente alle Dateien löschen, die nicht in D:\Dokumente enthalten sind.

-ta DatumZeit

Nur Dateien jünger als DatumZeit in die Dateiliste(n) einschließen. Die Angabe von DatumZeit muss immer in der Form yyyymmddhhmmss erfolgen. Die einzelnen Formatzeichen haben folgende Bedeutungen:

yyyy | Jahr, vierstellig
mm | Monat (1 - 12)
dd | Tag im Monat (1 - 31)
hh | Stunde
mm | Minute
ss | Sekunde

Formatzeichen am Ende der Formatangabe können ausgelassen werden.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -ta 200010

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, die nach dem 1.10.2000 erzeugt oder geändert wurden.

Hinweis: Der besseren Übersichtlichkeit halber kann die Formatangabe auch in der Form yyyy-mm-ddhh-mm-ss oder in der Form yyyy:mm:dd:hh:mm:ss erfolgen.

-tb DatumZeit

Nur Dateien älter als DatumZeit in die Dateiliste(n) einschließen. Die Angabe von DatumZeit muss immer in der der Form yyyymmddhhmmss erfolgen. Die einzelnen Formatzeichen haben folgende Bedeutungen:

yyyy | Jahr, vierstellig
mm | Monat (1 - 12)
dd | Tag im Monat (1 - 31)
hh | Stunde
mm | Minute
ss | Sekunde

Formatzeichen am Ende der Formatangabe können ausgelassen werden.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -tb 200010

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, die vor dem 1.10.2000 erzeugt oder geändert wurden.

Hinweis: Der besseren Übersichtlichkeit halber kann die Formatangabe auch in der Form yyyy-mm-dd hh-mm-ss oder in der Form yyyy:mm:dd:hh:mm:ss erfolgen.

-td Zielordner

Dieser Schalter legt den Zielordner fest.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc

Der Ordner D:\Dokumente wird als Zielordner festgelegt.

-x Dateimaske

Dateien, die Dateimaske entsprechen, nicht in die Dateiliste(n) einschließen.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.* -x *.bak

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente *außer* BAK-Dateien einbezogen.

Hinweis: Dieser Schalter kann mehrfach in der Kommandozeile oder in Script-Dateien angegeben werden.

-xd Ordnername

Ordner, die Ordnername entsprechen, nicht in die Dateiliste(n) einschließen.

Mit dem Schalter -xd Ordnername können Ordner beim Synchronisieren ausgeschlossen werden. Ordnername kann Wildcards oder Char-Sets enthalten. Genauso wie der Schalter -x muß -xd einmal für jeden Ordner angegeben werden.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.* -xd *\System* -xd *\Temp

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente *außer* Dateien in den Ordnern 'Temp' und 'System' einbezogen.

Hinweis: Dieser Schalter kann mehrfach in der Kommandozeile oder in Script-Dateien angegeben werden.

-y

Bei Nachfragen automatisch immer mit Ja antworten.

Beispiel: fsc -sd C:\Dokumente -td D:\Dokumente *.doc -y

Es werden in den Vergleich alle DOC-Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, alle eventuellen Nachfragen werden automatisch mit Ja beantwortet.


Skriptdateien

FileSync Kommandozeile
Skriptdateien

FSC unterstützt einfache Skriptdateien, die mit einem üblichen Texteditor (z.B. dem Windows-Editor oder SpeedEdit) angelegt und bearbeitet werden können. Es sind keinerlei Programmierkenntnisse notwendig, um diese Skriptdateien zu erstellen.

Jede Zeile in einer Skriptdatei darf ein Kommando, einen Kommandoschalter oder ein Argument enthalten. Um das Skript abzuarbeiten, müsste FSC wie folgt aufgerufen werden:

fsc.exe @NameDerSriptDatei

NameDerSriptDatei ist der vollständige Dateiname der Datei, in der Sie das Skript gespeichert haben. Ist der Name z.B. D:\Sicherung.job, so würde der korrekte Aufruf

fsc.exe @D:\Sicherung.job

lauten. Bitte beachten Sie das führende @-Zeichen am Anfang. Dieses Zeichen muss beim Aufruf dem eigentlichen Dateinamen direkt vorangestellt werden, damit FileSync erkennen kann, dass diese Datei als Skript abgearbeitet werden soll.

Skriptdateien dürfen Kommentare enthalten, die der C-Notation folgen. Die Zeichenfolge // wird als Einleitung eines Kommentars interpretiert. So können komplexe Skriptdateien auch dokumentiert werden.

Beispiel für eine Skriptdatei:
-sd | //- Quellordner festlegen
C:\Dokumente | //- Argument für Quellordner
-td | //- Zielordner festlegen
D:\Dokumente | //- Argument für Zielordner
*.doc | //- DOC-Dateien in den Vergleich einbeziehen
*.xls | //- XLS-Dateien in den Vergleich einbeziehen


Automatisierung von Aufgaben

SpeedCommander: Automatisierung
Automatisierung von Aufgaben

Im SpeedCommander führen Sie viele Aufgaben manuell durch. Sie verwenden beispielsweise Menübefehle, um Dateien auszuwählen, zu kopieren und umzubenennen. Wenn es sich um Routine-Aufgaben handelt oder solche, die sich wiederholen, dann ist es von Vorteil, diese zu automatisieren. Durch die Automatisierung können Sie die für diese Aufgaben verwendete Zeit reduzieren und Fehler vermeiden, die häufig durch die manuelle Durchführung von Aufgaben entstehen.

Automatisierung bedeutet, dass Sie Aufgaben programmtechnisch durchführen, indem Sie VBScript-Makros oder AddIns schreiben. AddIns sind prozessintegrierte ActiveX-Komponenten (DLLs), die Sie in jeder gebräuchlichen Programmiersprache (C++, Delphi, Visual Basic.NET) entwickeln können.

Mit Makros oder AddIns führen Sie Aufgaben durch, indem Sie die SpeedCommander-Umgebung und die zugehörigen Komponenten als Objekte verwenden. Mit dieser Vorgehensweise markieren Sie z.B. Dateien, erstellen neue Fenster oder führen bestimmte Aktionen mit Dateien aus.

Ein Objekt stellt eine Komponente der SpeedCommander-Umgebung oder eine Auflistung von verwandten Komponenten dar. Ein FolderFavorite-Objekt repräsentiert z.B. einen Ordnerfavoriten, während das Objekt FolderFavorites alle Ordnerfavoriten darstellt. Entsprechend repräsentiert ein UserTool-Objekt einen Anwendungsfavoriten, während das Objekt UserTools alle Anwendungsfavoriten darstellt. Die Objekte FolderFavorites und UserTools werden als Auflistungsobjekte bezeichnet, da sie Auflistungen von verwandten Objekten enthalten.

Sie verarbeiten Objekte, indem Sie die mit den Objekten verbundene Methoden, Eigenschaften und Ereignisse verwenden. Methoden stellen Aktionen dar, die Sie an den Objekten durchführen. Eigenschaften stellen Merkmale der Objekte dar, wie beispielsweise deren Typ oder Größe. Ereignisse stellen Bedingungen dar, unter denen Aktionen an den Objekten durchgeführt werden.

Wenn Sie beispielsweise durch einfaches Klicken auf eine Schaltfläche alle png- und jpg-Dateien in einem Ordnerfenster markieren möchten, schreiben Sie zunächst ein Makro, das die Dateien markiert:

  Set Workspace = Application.GetObject(scObjectWorkspace)
  Set FolderWindow = Workspace.ActiveWindow.FolderWindows.Active

  FolderWindow.Selection.Select("*.png")
  FolderWindow.Selection.Select("*.jpg")

Dieses Makro führt die folgenden Aktionen durch:

  • Die erste Zeile ruft das Objekt für den Arbeitsbereich ab, die zweite Zeile das Objekt für das aktive Ordnerfenster.
  • In der dritten und vierten Zeile wird die Methode Select vom Selection-Objekt des Ordnerfensters aufgerufen, mit welcher die gewünschten Dateien markiert werden.

Nachdem Sie das Makro geschrieben haben, können Sie es einer Symbolleistenschaltfläche oder einem Tastenkürzel zuweisen. Führen Sie anschließend das Makro aus, indem Sie auf die Schaltfläche klicken oder das Tastenkürzel aktivieren.

Weitere Informationen zu Objekten, welche in SpeedCommander zur Durchführung von Aufgaben verwendet werden können, finden Sie in der Objektreferenz. Informationen zur Erstellung von AddIns finden Sie iim Kapitel Erweiterung durch AddIns.


Arbeiten mit Makros

Arbeiten mit Makros

Ein Makro ist ein Satz von VBScript-Anweisungen, der in einer Datei gespeichert ist und zu einem späteren Zeitpunkt ausgeführt werden kann. Sie können Makros verwenden, um sich die Arbeit in SpeedCommander zu erleichtern. Mit Hilfe eines Makros können z.B. mehrere Befehle zusammengefasst werden, welche die Bearbeitung von Routinen beschleunigen oder eine komplexe Abfolge von Aufgaben automatisieren.

Weiterführende Themen

Arbeiten mit dem Makroeditor

Ausführen von Makros

Externe Objekte einbinden

Zuweisen von Makros zu Symbolleisten und Tastenkürzeln

Exportieren und Importieren von Makros

Unterschiede zwischen Makros und AddIns


Arbeiten mit dem Makroeditor

Arbeiten mit dem Makroeditor

Mit Hilfe des Makroeditors können Sie Makros schreiben, ausführen und testen. Öffnen Sie das Menü Extras, zeigen Sie auf Makros und wählen Sie den Befehl Makroeditor, um den Makroeditor anzuzeigen.

So erstellen Sie ein neues Makro:
  1. Wählen Sie im Menü Datei den Befehl Neu.
  2. Tragen Sie im Dialogfeld Neues Makro einen Namen für das Makro ein.
  3. Geben Sie im Makroeditor den Programmtext ein.
  4. Wählen Sie im Menü Datei den Befehl Speichern, um das neue Makro zu speichern.
So benennen Sie ein Makro um:
  1. Wählen Sie im Makroeditor das Makro, welches Sie umbenennen möchten.
  2. Wählen Sie im Menü Datei den Befehl Umbenennen.
  3. Tragen Sie im Dialogfeld Makro umbenennen einen neuen Namen für das Makro ein.
So löschen Sie ein Makro:
  1. Wählen Sie im Makroeditor das Makro, welches Sie löschen möchten.
  2. Wählen Sie im Menü Datei den Befehl Löschen.


Ausführen von Makros

Ausführen von Makros

SpeedCommander zeigt alle Makros im Menü Makros an, welches über das Menü Extras aktiviert werden kann. Zum Ausführen eines Makros öffnen Sie einfach dieses Menü und wählen dann das gewünschte Makro aus. Alternativ können Sie ein Makro auch über eine Schaltfläche in einer Symbolleiste oder über ein Tastenkürzel ausführen.

So führen Sie ein Makro über das Menü aus:
  1. Öffnen Sie das Menü Extras und zeigen Sie auf Makros.
  2. Wählen Sie das Makro aus, welches Sie ausführen möchten.


Externe Objekte einbinden

Externe Objekte einbinden

In einem Makro kann nicht nur auf das Objektmodell von SpeedCommander zugegriffen werden, auch die Einbindung aller skriptfähigen COM-Module ist möglich. Wenn Sie bestimmte Objekte häufiger benötigen, dann können diese automatisch für alle Makros verwendet werden. Zusätzlich kann der Makroeditor auch IntelliSense-Informationen zu den einzelnen Funktionen der Objekte anzeigen.

So binden Sie ein externes Objekt ein:
  1. Öffnen Sie den Makroeditor.
  2. Wählen Sie im Menü Extras den Befehl Externe Objekte.
  3. Tragen Sie im Eingabefeld Name den Namen ein, den Sie für das Objekt verwenden möchten.
  4. Geben Sie im Eingabefeld CLSID oder ProgID die CLSID oder ProgID des Objekts ein.
  5. Klicken Sie auf die Schaltfläche Hinzufügen.
So entfernen Sie ein externes Objekt:
  1. Öffnen Sie den Makroeditor.
  2. Wählen Sie im Menü Extras den Befehl Externe Objekte.
  3. Wählen Sie im Listenfeld das Objekt, welches Sie entfernen möchten und klicken Sie auf Entfernen.

Die folgende Tabelle enthält die wichtigsten externen Objekte, die viele nützliche Funktionen anbieten. Der Name der Objekte ist frei wählbar.

Name | CLSID oder ProgID | Beschreibung
fso | Scripting.FileSystemObject | Zugriff auf Dateien, Ordner und Laufwerke
net | WScript.Network | Zugriff auf Anmeldeinformationen, Freigaben und Netzwerkdrucker
shell | WScript.Shell | Zugriff auf Registry, Ausführung externer Programme, Senden von Tastatureingaben
shellapp | Shell.Application | Steuerung von Startmenü, Desktop und Explorer-Ansichten


Zuweisen von Makros zu Symbolleisten und Tastenkürzeln

Zuweisen von Makros zu Symbolleisten und Tastenkürzeln

Sie können ein Makro auch einer Symbolleistenschaltfläche oder einem Tastenkürzel zuweisen, damit Sie es schneller ausführen können.

So weisen Sie ein Makro einer Symbolleistenschaltfläche zu:
  1. Wählen Sie im Menü Extras den Befehl Anpassen.
  2. Aktivieren Sie die Registerkarte Befehle.
  3. Wählen Sie im Listenfeld Kategorien den Eintrag Makros.
  4. Ziehen Sie das entsprechende Makro aus dem Listenfeld Befehle an die gewünschte Stelle in der Symbolleiste.
So ordnen Sie einem Makro ein Tastenkürzel zu:
  1. Wählen Sie im Menü Extras den Befehl Anpassen.
  2. Aktivieren Sie die Registerkarte Tastatur.
  3. Wählen Sie im Kombinationsfeld Kategorie den Eintrag Makros.
  4. Klicken Sie im Listenfeld Befehle auf das gewünschte Makro.
  5. Geben Sie im Feld Neue Tastenkombination das Tastenkürzel ein, welches Sie verwenden möchten, und klicken Sie auf Zuweisen.
  6. Das Tastenkürzel erscheint im Listenfeld Aktuelle Tastenkürzel.


Exportieren und Importieren von Makros

Exportieren und Importieren von Makros

SpeedCommander speichert alle Makros in der Datei Macros.spm. Unter Windows 9x/ME befindet sich diese Datei im Programmverzeichnis von SpeedCommander, unter Windows NT/2000/XP in den Anwendungsdaten. Um ein Makro mit anderen Anwendern auszutauschen, müssen sie das Makro exportieren bzw. importieren.

So exportieren Sie ein Makro:
  1. Öffnen Sie den Makroeditor und wählen Sie das Makro aus, welches Sie exportieren möchten.
  2. Wählen Sie im Menü Datei den Befehl Exportieren.
  3. Geben Sie einen Namen für die Textdatei ein, in welche das Makro gespeichert werden soll.
So importieren Sie ein Makro:
  1. Öffnen Sie den Makroeditor.
  2. Erstellen Sie mit dem Befehl Neu aus dem Menü Datei ein neues Makro.
  3. Wählen Sie im Menü Datei den Befehl Importieren.
  4. Wählen Sie die Textdatei mit dem Makro aus, welches Sie importieren möchten.


Unterschiede zwischen Makros und AddIns

Unterschiede zwischen Makros und AddIns

Zwischen VBScript-Makros und AddIns gibt es eine Reihe von Unterschieden. Der Hauptunterschied besteht darin, dass Makros Prozeduren sind, die in VBScript geschrieben werden; während AddIns prozessintegrierte COM-Module sind, die in C++, Visual Basic.NET oder Delphi geschrieben werden.

Makros können schneller und einfacher erstellt werden als AddIns. Zum Erstellen und Ausführen von Makros können Sie den eingebauten Makroeditor von SpeedCommander verwenden. Nach dem ausführlichen Test kann das Makro dann in ein Menü oder in eine Symbolleiste eingebunden werden. Ein AddIn wird normalerweise in einer Entwicklungsumgebung erstellt, kompiliert und dann in SpeedCommander eingebunden.

Makros sind nicht so vielseitig wie AddIns. Makros können nur in VBScript geschrieben werden und können nur auf das Objektmodell von SpeedCommander sowie auf alle skriptfähigen COM-Objekte zugreifen. In AddIns können Sie dagegen eine beliebige Sprache verwenden und auf alle Ressourcen des Computersystems zugreifen.

Die folgende Tabelle zeigt die Unterschiede zwischen VBScript-Makros und AddIns:

VBScript-Makros | AddIns
Werden interpretiert. | Werden kompiliert.
Leichter zu erstellen. | Schwieriger zu erstellen.
Können nur in VBScript geschrieben werden. | Können in verschiedenen Sprachen geschrieben werden (z.B. C++, VB.NET, Delphi).
Können auf das Objektmodell von SpeedCommander und auf alle skriptfähigen COM-Objekte zugreifen. | Können auf das Objektmodell von SpeedCommander und auf alle lokalen Computerressourcen zugreifen.
Können nur Dialogfelder verwenden, die mit den VBScript-Befehlen InputBox und MsgBox erstellt werden. | Können beliebige modale Dialogfelder verwenden.
Können nicht auf die Win32-API zugreifen. | Können auf die Win32-API zugreifen.
Können keine frühe Bindung verwenden. | Können eine frühe Bindung für eine höhere Laufzeitleistung verwenden.


Erweiterung mit AddIns

Erweiterung mit AddIns

SpeedCommander lässt sich mit AddIns beliebig erweitern. Ein AddIn ist ein Inprozess-COM-Server und kann mit jeder Programmiersprache erstellt werden, die COM-Komponenten erzeugen kann. Dazu gehören u.a. Visual C++, Delphi, Visual Basic und Visual Studio.NET. Das AddIn kann über das Objektmodell auf viele Elemente innerhalb von SpeedCommander zugreifen.

SpeedCommander und das AddIn kommunizieren über festgelegte Schnittstellen miteinander. Eine Schnittstelle, deren Name mit IDT beginnt (z.B. IDTCommandTarget), wird vom AddIn implementiert. Alle anderen Schnittstellen (z.B. IFileOpProgress) werden von SpeedCommander implementiert.

Folgende Schnittstellen können vom AddIn implementiert werden:

Schnittstelle | Beschreibung
IDTExtensibility2 | Basisschnittstelle, die von jedem AddIn implementiert werden muss.
IDTCommandTarget | Auswahl eines Menübefehls oder Klick auf eine Schaltfläche in der Symbolleiste.
IDTFileSystem | Abfrage der verfügbaren Dateisystemobjekte.
IDTFileSystemSite | Schnittstelle für Dateisystemobjekte, die im Fenster Dateisystem-AddIns angezeigt werden.
IDTFileSystemItem | Datei oder Ordner innerhalb eines Dateisystemobjektes.
IDTContextMenu | Erweiterung des Kontextmenüs für Dateisystemobjekte.
IDTConfigDialog | Einstellungsdialog für das AddIn.

Registrierung eines AddIns

Das AddIn muss als COM-Objekt registriert werden, bevor es verwendet werden kann. Die Registrierung kann entweder in der Funktion DllRegisterServer erfolgen, die beim Hinzufügen des AddIns über den Einstellungsdialog Anpassen aufgerufen wird oder (falls das AddIn die Funktion DllRegisterServer nicht exportiert) manuell durch eine vom Hersteller des AddIns erstellte REG-Datei.

Zusätzlich zur COM-Registrierung muss das AddIn sich auch als Erweiterungskomponente für SpeedCommander registrieren. Dies erfolgt durch einen Schlüssel, wobei {CLSID_ADDIN} stellvertretend für die CLSID des AddIns steht:

[HKEY_CLASSES_ROOT\CLSID\{CLSID_ADDIN}\Implemented Categories\{C9B33781-A4F1-11D8-ACBB-000C6E33EB97}].

Weiterhin sollte das AddIn im Schlüssel {CLSID_ADDIN} folgende Werte definieren:

Wert | Beschreibung
FriendlyName | Benutzerfreundliche Bezeichnung für das AddIn.
Description | Beschreibung für das AddIn.

AddIn installieren

Ein AddIn muss installiert und aktiviert werden, bevor es von SpeedCommander verwendet werden kann. Die Verwaltung der AddIns erfolgt über die Registerkarte AddIns des Einstellungsdialogs Anpassen.

So installieren Sie ein AddIn:
  1. Öffnen Sie den Einstellungsdialog Anpassen und wechseln Sie auf die Registerkarte AddIns.
  2. Wählen Sie Hinzufügen, um ein neues AddIn zu installieren und wählen Sie das AddIn aus.
  3. SpeedCommander versucht nun, das AddIn zu registrieren. Wenn er die dafür nötigen Funktionen nicht findet, wird eine Fehlermeldung ausgegeben.

AddIn deinstallieren

Wenn Sie ein AddIn nicht mehr einsetzen möchten, dann können Sie es ganz einfach deinstallieren.

So deinstallieren Sie ein AddIn:
  1. Öffnen Sie den Einstellungsdialog Anpassen und wechseln Sie auf die Registerkarte AddIns.
  2. Wählen Sie das AddIn, welches Sie deinstallieren möchten.
  3. Klicken Sie auf die Schaltfläche Entfernen.

Weitere Informationen

IDTExtensibility2, IDTCommandTarget, IDTFileSystem, IDTFileSystemSite, IDTFileSystemItem


IDTExtensibility2

IDTExtensibility2

Die Schnittstelle IDTExtensibility2 ist die Basisschnittstelle, die ein AddIn anbieten muss. Wenn ein AddIn geladen wird, sucht SpeedCommander nach IDTExtensibility2. Schlägt die Suche fehl, dann wird das AddIn wieder entladen. Bei erfolgreicher Suche kommuniziert SpeedCommander über diese Schnittstelle mit dem AddIn.

Methoden

OnConnection | Wird aufgerufen, wenn das AddIn mit SpeedCommander verbunden wird.
OnDisconnection | Wird aufgerufen, bevor die Verbindung zu SpeedCommander getrennt wird.
OnStartupComplete | Wird aufgerufen, wenn der Startvorgang von SpeedCommander abgeschlossen wurde.
OnBeginShutdown | Wird aufgerufen, bevor SpeedCommander beendet wird.
OnAddInsUpdate | Wird aufgerufen, wenn ein AddIn geladen oder entladen wurde.

Siehe auch

IDTExtensibility2, IDTCommandTarget


IDTCommandTarget

IDTCommandTarget

Mit IDTCommandTarget kann das AddIn auf den Aufruf eigener Befehle reagieren, die es über das AddInCommands-Objekt erstellt hat. IDTCommandTarget wird vom AddIn zusätzlich zu IDTExtensibility2 implementiert.

Methoden

Exec | Führt den angegebenen Befehl aus.
QueryStatus | Gibt den aktuellen Status für den angegebenen Befehl zurück.

IDTExtensibility2


IDTConfigDialog

IDTConfigDialog

Mit IDTConfigDialog kann das AddIn einen eigenen Einstellungsdialog anzeigen. IDTConfigDialog wird vom AddIn zusätzlich zu IDTExtensibility2 implementiert.

Methoden

ShowConfigDialog Ruft den Konfigurationsdialog auf.

IDTExtensibility2


IDTContextMenu

IDTContextMenu

Mit IDTContextMenu kann ein AddIn dem Kontextmenü für Dateisystemerweiterungen eigene Befehle hinzufügen.

Methoden

QueryContextMenu | Erweitert das Kontextmenü um eigene Befehle.
InvokeCommand | Führt den ausgewählten Befehl aus.

IDTFileSystemSite


IDTFileSystem

IDTFileSystem

Mit IDTFileSystem kann ein AddIn eigene Dateisysteme implementieren. IDTFileSystem wird vom AddIn zusätzlich zu IDTExtensibility2 implementiert.

Ein Dateisystemobjekt besteht aus einer IDTFileSystemSite-Schnittstelle, die vom AddIn implementiert werden muss. SpeedCommander zeigt alle Dateisystemobjekte im Fenster Dateisystem-AddIns an. Dazu wird jedes AddIn gefragt, ob es die IDTFileSystem-Schnittstelle unterstützt. Wenn ja, ruft SpeedCommander die Funktion IDTFileSystem::GetFileSystemSites auf, in der alle vom AddIn angebotenen IDTFileSystemSite-Objekte in eine Liste eingetragen werden.

Nach erfolgreicher Abfrage erfolgt dann die Kommunikation zwischen SpeedCommander und den Dateisystemobjekten über die IDTFileSystemSite-Schnittstelle. Das Dateisystemobjekt kann auch eigene Spalten für die Listenansicht definieren sowie vordefinierte Spalten ausblenden.

Methoden

GetFileSystemSites Wird aufgerufen, um die vom AddIn angebotenen Dateisystemobjekte abzufragen.

IDTExtensibility2, IDTFileSystemSite


IDTFileSystemSite

IDTFileSystemSite

Mit Hilfe der IDTFileSystemSite-Schnittstelle kann ein AddIn ein virtuelles Dateisystem anbieten. Alle Objekte, die IDTFileSystemSite implementieren, werden im Dateisystem-AddIns-Fenster angezeigt. Die Navigation in SpeedCommander innerhalb der AddIns erfolgt durch eine URL in der Form AddIn://HostName/Ordner1/Datei. Der HostName wird durch das AddIn festgelegt und sollte möglichst eindeutig sein. Alle Pfadangaben werden in der Form \Ordner1\Datei an IDTFileSystemSite übergeben.

Jedes Dateisystem kann eigene zusätzliche Spalten für die Detailansicht implementieren. SpeedCommander speichert die jeweilige Spaltenanordnung selbständig, das AddIn muss nur Informationen über die angebotenen Spalten liefern.

Es ist auch möglich, für verschiedene Ordner unterschiedliche Spalten anzuzeigen, z.B. getrennt für den Hauptordner und für alle anderen Unterordner. Als Unterscheidung wird hier die Spalten-ID verwendet, die über GetColumnID abgefragt wird. Die Spaltenanordnung wird unter GUID:ColumnID gespeichert und bei jedem Wechsel in einen Ordner entsprechend der letzten Konfiguration wiederhergestellt.

Eigenschaften

Capabilities | Legt die Fähigkeiten des AddIns fest.
Comment | Gibt einen Kommentar für das Dateisystem-Objekt zurück. Der Kommentar wird in der Dateisystem-AddIn-Ansicht angezeigt.
Guid | Gibt eine eindeutige Kennzeichnung für das Dateisystem-Objekt zurück (GUID).
HostName | Gibt den Namen für das Dateisystem-Objekt zurück.
Image | Gibt das Symbol zurück, welches SpeedCommander für das Dateisystem-Objekt anzeigen soll.

Methoden

CreateDirectory | Erstellt einen Ordner.
DeleteFile | Löscht eine Datei.
DownloadFile | Kopiert eine Datei vom AddIn-Dateisystem in das lokale Dateisystem oder in einen UNC-Pfad.
EnumObjects | Listet alle Elemente auf, die sich in einem Ordner befinden.
ExecCommand | Führt einen Befehl aus der Kommandozeile aus.
FileOpStatusInfo | Wird aufgerufen, wenn eine Dateioperation gestartet oder beendet wird.
GetColumnID | Legt die Spalten-ID für einen Ordner fest.
GetColumnInfo | Zählt die Spalten auf, die SpeedCommander für einen Ordner anzeigen soll.
GetCurrentDirectory | Gibt den aktuellen Ordner zurück.
GetDefaultColumns | Gibt an, welche Spalten bei der ersten Initialisierung einer Ansicht aktiviert werden sollen.
GetTargetFileName | Gibt den Zieldateinamen vor einer Dateioperation (UploadFile/DownloadFile) zurück.
GetUIObjectOf | Erstellt ein UI-Objekt für die angegebenen Dateien und Ordner.
GetVolumeInformation | Gibt Informationen zum Laufwerksstatus zurück.
MoveFile | Verschiebt eine Datei oder einen Ordner bzw. nennt eine Datei oder einen Ordner um.
RemoveDirectory | Entfernt einen Ordner.
SetCurrentDirectory | Setzt den aktuellen Ordner.
SetFileAttributes | Setzt die Attribute für eine Datei oder einen Ordner.
SetFileTime | Setzt Datum und Uhrzeit für eine Datei oder einen Ordner.
UploadFile | Kopiert eine Datei vom lokalen Dateisystem oder einem UNC-Pfad in das AddIn-Dateisystem.

IDTFileSystemItem


IDTFileSystemItem

IDTFileSystemItem

Ein IDTFileSystemItem liefert alle Informationen über einen Eintrag im Dateisystem des AddIns.

Eigenschaften

Name | Gibt den Namen der Datei oder des Ordners zurück.
Attributes | Gibt die Dateiattribute zurück.
DateCreated | Gibt den Zeitpunkt der Erstellung zurück.
DateLastAccessed | Gibt den Zeitpunkt des letzten Zugriffs zurück.
DateLastModified | Gibt den Zeitpunkt der letzten Änderung zurück.
Size | Gibt die Größe der Datei zurück.
Image | Gibt den Index des Symbols in der Systemimageliste zurück.

Methoden

GetItemData Liefert erweiterte Informationen für zusätzliche Spalten.

IDTFileSystemSite


Objektreferenz

Objektreferenz

Jedes SpeedCommander-Objekt implementiert eine duale Schnittstelle, über die Sie das Objekt bearbeiten können. Die duale Schnittstelle besteht aus einer IDispatch-Schnittstelle für die Automatisierung und einer COM-Schnittstelle für den direkten Zugriff auf die Objektelemente (Eigenschaften, Methoden und Ereignisse).

Makros nutzen die IDispatch-Schnittstelle, während AddIns unter Verwendung der COM-Schnittstelle eine frühe Bindung eingegen können. Frühes Binden beschleunigt zur Laufzeit alle Aufrufe in Schnittstellenelemente.

Übersicht über die Objekte von SpeedCommander

AddIn | Einzelnes AddIn.
AddInCommand | Einzelner Befehl eines AddIns.
AddInCommands | Auflistung aller AddIn-Befehle.
AddIns | Auflistung aller AddIns.
AddInSettings | Laden und Speichern von Einstellungen für AddIns.
AppFolder | Ordner innerhalb eines Ordnerfensters.
Application | SpeedCommander-Anwendung.
CommandBar | Einzelne Symbolleiste.
CommandBarControl | Einzelnes Symbol oder Menübefehl.
CommandBarControls | Auflistung aller Symbole oder Menübefehle in einer Symbolleiste.
CommandBars | Auflistung des Menüs und aller anderen Symbolleisten.
FileContainer | Einzelne Dateiablage.
FileContainers | Auflistung aller Dateiablagen im rechten oder linken Teil des Arbeitsbereiches.
FolderFavorite | Einzelner Ordnerfavorit.
FolderFavorites | Auflistung aller Ordnerfavoriten.
FolderWindow | Einzelnes Ordnerfenster.
FolderWindows | Auflistung aller Ordnerfenster im rechten oder linken Teil des Arbeitsbereiches.
ListItem | Einzelner Eintrag in einem Ordnerfenster oder in einer Dateiablage.
ListItems | Auflistung aller Einträge in einem Ordnerfenster oder in einer Dateiablage.
ListSelection | Auswahl in einem Ordnerfenster oder in einer Dateiablage.
MainWindow | Hauptfenster von SpeedCommander.
MultiRename | Umbenennen von mehreren Dateien.
TabWindow | Linkes oder rechtes Fenster in der Zweifenster-Ansicht.
UserTool | Einzelner Anwendungsfavoriten.
UserTools | Auflistung aller Anwendungsfavoriten.
Workspace | Arbeitsbereich, welcher die Zweifenster-Ansicht, die Laufwerkssymbole und die QuickDrop-Symbole einschließt.

Die Objekthierarchie von SpeedCommander für die Automatisierung

Um SpeedCommander-Objekte zu bearbeiten, müssen Sie die Beziehungen zwischen den Objekten kennen. Das Application-Objekt ist das höchstrangige Objekt, dem alle anderen Objekte untergeordnet sind. Dies ermöglicht es, durch Verwendung der Eigenschaften und Methoden des Objekts Application direkt auf Objekte zuzugreifen, die dem Application-Objekt untergeordnet sind.

Jedes Objekt hat zudem die Eigenschaft Parent, welche stets auf das übergeordnete Objekt verweist, und die Eigenschaft Application, die immer auf das Application-Objekt zurückführt.

Die Beziehungen zwischen den Objekten ist nachfolgend dargestellt.

Application
  MainWindow
  CommandBars
    CommandBar
      CommandBarControls
        CommandBarControl
  Workspace
    TabWindow
      FolderWindows
        FolderWindow
          ListSelection
          ListItems
            ListItem
      FileContainers
        FileContainer
          ListSelection
          ListItems
            ListItem
  AddIns
    AddIn
    AddInSettings
  UserTools
    UserTool
  FolderFavorites
    FolderFavorite
  MultiRename


AddIn-Objekt

AddIn-Objekt

Das AddIn-Objekt enthält alle Informationen über ein AddIn und ermöglicht so anderen AddIns, mit ihm zu kommunizieren. Über die Eigenschaft Connect kann das AddIn aktiviert oder deaktiviert werden.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das AddIns-Objekt.
Connect | Gibt den Aktivierungszustand des AddIns an oder legt ihn fest.
Description | Gibt eine Beschreibung für das AddIn zurück.
Guid | Gibt die Guid (Klassenbezeichnung) des AddIns zurück.
ProgID | Gibt die ProgID des AddIns zurück.
Extensibility2 | Gibt einen Verweis auf die Basisschnittstelle des AddIns zurück.

AddIns-Objekt


AddInCommand-Objekt

AddInCommand-Objekt

Das AddInCommand-Objekt repräsentiert einen von einem AddIn erstellten Befehl. Die verfügbaren AddIn-Befehle werden im Einstellungsdialog Anpassen verwaltet, sie können von dort aus in Symbolleisten oder Menüs integriert werden.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das AddInCommands-Objekt.
CommandID | Gibt die Befehls-ID zurück.
Description | Gibt die Beschreibung des Befehls zurück oder legt sie fest.
ImageLarge | Legt das große Symbol (24x24) für diesen Befehl fest, welches in der Symbolleiste angezeigt wird.
ImageSmall | Legt das kleine Symbol (16x16) für diesen Befehl fest, welches in der Symbolleiste oder im Menü angezeigt wird.
Name | Gibt den Namen des Befehls zurück.
ProgID | Gibt die ProgID des AddIns zurück, welches das AddInCommand-Objekt erstellt hat.

AddInCommands-Objekt


AddInCommands-Objekt

AddInCommands-Objekt

Das AddInCommands-Objekt enthält eine Liste der Befehle, die von den AddIns zur Verfügung gestellt werden. Mit seiner Hilfe können neue Befehle hinzugefügt oder nicht mehr benötigte Befehle gelöscht werden.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das AddIns-Objekt.
Count | Gibt die Anzahl der verfügbaren Befehle zurück.

Methoden

Add | Erstellt einen neuen Befehl.
Item | Gibt eine bestimmtes Objekt (AddInCommand-Objekt) innerhalb der Auflistung zurück.
Remove | Löscht einen Befehl.

AddIns-Objekt, AddInCommand-Objekt


AddIns-Objekt

AddIns-Objekt

Das AddIns-Objekt enthält eine Liste der installierten AddIns. Ein AddIn kann so überprüfen, ob andere AddIns installiert sind oder mit anderen AddIns kommunizieren.

Eigenschaften

Application | Gibt einen Verweis auf das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
Commands | Gibt ein AddInCommands-Objekt zurück, welches die Befehle der AddIns enthält.
Count | Gibt die Anzahl der installierten AddIns zurück.
Settings | Gibt ein AddInSettings-Objekt zurück, welches zum Speichern von Einstellungen genutzt werden kann.

Methoden

Item | Gibt eine bestimmtes Objekt (AddIn-Objekt) innerhalb der Auflistung zurück.
Update | Aktualisiert die AddIn-Liste.

Siehe auch

AddIn-Objekt, AddInCommands-Objekt, AddInSettings-Objekt, Application-Objekt


AddInSettings-Objekt

AddInSettings-Objekt

Das AddInSettings-Objekt wird von einem AddIn zum Laden und Speichern von Einstellungen genutzt. Alle Einstellungen werden in der XML-Datei von SpeedCommander abgelegt.

Eigenschaften

Application | Gibt einen Verweis auf das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das AddIns-Objekt.

Methoden

EmptySection | Löscht eine Sektion.
Read | Liest eine AddIn-Einstellung.
SaveSettings | Schreibt alle gespeicherten Einstellungen in die XML-Datei.
Write | Speichert eine AddIn-Einstellung.

AddIns-Objekt


AppFolder-Objekt

AppFolder-Objekt

Das AppFolder-Objekt ermöglicht die Abfrage und das Setzen des aktuellen Ordners in einem Ordnerfenster.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
DisplayName | Gibt den Anzeigenamen des Ordners zurück.
Folder | Gibt den vollständigen Ordnernamen zurück oder setzt ihn.
FolderType | Gibt den Typ des Ordners zurück.
IsAddInSite | Gibt an, ob der Ordner die oberste Ebene in der AddIn-Dateisystemansicht ist.
IsArchive | Gibt an, ob der Ordner ein Archiv ist.
IsFtpSite | Gibt an, ob der Ordner die FTP-Standortansicht ist.
IsRoot | Gibt an, ob der Ordner ein Hauptverzeichnis ist.
LocalOrUncFolder | Gibt den vollständigen Ordnernamen zurück, wenn der Ordner ein lokaler Ordner oder ein Netzwerkordner ist.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das FolderWindow-Objekt.
UrlHostName | Gibt den Namen des Servers zurück, wenn der Ordner eine Internet- oder AddIn-Adresse ist.
UrlPath | Gibt den Pfadanteil zurück, wenn der Ordner eine Internet- oder AddIn-Adresse ist.

Methoden

FolderWindow-Objekt


Application-Objekt

Application-Objekt
Das Application-Objekt ist das oberste Objekt im SpeedCommander-Objektmodell. Ausgehend vom Application-Objekt können Sie auf alle anderen Objekte zugreifen.

Eigenschaften

AppDataFolder | Gibt den Pfad zurück, in dem die Einstellungen gespeichert werden.
FullName | Gibt den vollständigen Dateinamen der Anwendung zurück.
LocaleID | Gibt die Sprache der Benutzeroberfläche zurück.
Name | Gibt den Namen der Anwendung zurück.
Path | Gibt den Pfad zurück, in dem die Anwendung installiert ist.
Version | Gibt die Versionsnummer vom SpeedCommander zurück.

Methoden

AddImage | Fügt das angegebene Symbol zur Systemimageliste hinzu.
ExecuteCommand | Führt den angegebenen Befehl aus.
GetEvents | Ermöglicht den Zugriff auf alle Ereignisse des Erweiterungsmodells.
GetObject | Gibt ein bestimmtes Objekt zurück.
Help | Zeigt die Onlinehilfe an.
Quit | Beendet die Anwendung.

Siehe auch

AddIns-Objekt, Workspace-Objekt, FolderFavorites-Objekt, MainWindow-Objekt, UserTools-Objekt


CommandBar-Objekt

CommandBar-Objekt

Das CommandBar-Objekt stellt eine Symbolleiste in SpeedCommander dar.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das CommandBars-Objekt.
BarID | Gibt die eindeutige ID der Symbolleiste zurück.
BarType | Gibt den Typ der Symbolleiste zurück.
BuiltIn | Gibt an, ob die Symbolleiste eine fest eingebaute Symbolleiste ist.
Controls | Gibt eine Auflistung von Elementen (CommandBarControls-Objekt) in der Symbolleiste zurück.
Position | Setzt die Position der Symbolleiste oder gibt diese zurück.
Title | Setzt den Titel der Symbolleiste oder gibt diesen zurück.
Visible | Setzt die Sichtbarkeit der Symbolleiste oder gibt diese zurück.
Width | Setzt die Breite der Symbolleiste oder gibt diese zurück.

Methoden

Delete | Löscht eine Symbolleiste.
EnableDocking | Legt fest, ob und wie eine Symbolleiste angedockt werden kann.
FindControl | Sucht ein Element (CommandBarControl-Objekt) in der Symbolleiste.

Siehe auch

CommandBar-Objekt, CommandBarControl-Objekt, CommandBarControls-Objekt


CommandBarControl-Objekt

CommandBarControl-Objekt

Das CommandBarControl-Objekt stellt ein Element in einer Symbolleiste dar.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das CommandBar-Objekt.
BeginGroup | Gibt an, ob das Element der Beginn einer neuen Gruppe ist.
Caption | Setzt den Text für das Element oder gibt ihn zurück.
Checked | Gibt an, ob das Element gewählt ist.
CmdId | Gibt die Befehls-ID des Elements zurück.
CommandBar | Gibt das CommandBar-Objekt für untergeordnete Elemente zurück.
Controls | Gibt ein CommandBarControls-Objekt zurück, welches die benachbarten Elemente enthält.
ControlType | Gibt den Typ des Elements zurück.
DefaultItem | Gibt an, ob das Element das Standardelement im Menü ist.
Description | Setzt den Beschreibungstext für das Element oder gibt ihn zurück.
Enabled | Gibt an, ob das Element aktiv oder deaktiviert ist.
IconId | Gibt die ID des Icons zurück, welches für das Element gezeichnet werden soll, oder legt sie fest.
Index | Gibt den Index des Elements in der CommandBarControls-Auflistung zurück.
Tooltip | Setzt den Text für ein anzuzeigendes InfoTip-Fenster oder gibt ihn zurück.
Visible | Gibt an oder legt fest, ob das Element sichtbar ist.

Methoden

Delete Löscht das Element.

CommandBar-Objekt, CommandBarControls-Objekt


CommandBarControls-Objekt

CommandBarControls-Objekt

Das CommandBarControls-Objekt stellt eine Auflistung dar, die alle CommandBarControl-Objekte innerhalb einer Symbolleiste enthält.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das CommandBar-Objekt.
Count | Gibt die Anzahl der Elemente zurück.

Methoden

Add | Erstellt ein neues Objekt und fügt es in die Symbolleiste ein.
FindControl | Sucht ein Element (CommandBarControl-Objekt) in der Auflistung.
Item | Gibt ein bestimmtes Objekt (CommandBarControl-Objekt) innerhalb der Auflistung zurück.

CommandBarControl-Objekt, CommandBar-Objekt


CommandBars-Objekt

CommandBars-Objekt

Das CommandBars-Objekt enthält alle CommandBar-Objekte innerhalb von SpeedCommander, von denen jedes eine Symbolleiste darstellt.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
Count | Gibt die Anzahl der Symbolleisten zurück.

Methoden

Add | Erstellt eine neue Symbolleiste.
Item | Gibt eine bestimmte Symbolleiste (CommandBar-Objekt) innerhalb der Auflistung zurück.

Siehe auch

CommandBar-Objekt, CommandBarControl-Objekt, CommandBarControls-Objekt


FileContainer-Objekt

FileContainer-Objekt

Das FileContainer-Objekt ermöglicht den Zugriff auf eine Dateiablage.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das FileContainers-Objekt.
FocusedItem | Gibt den fokussierten Eintrag zurück oder legt ihn fest.
Index | Gibt den Index des Objekts innerhalb der FileContainers-Auflistung zurück.
IsVisible | Gibt an, ob die Dateiablage sichtbar ist.
Items | Gibt die Objekte einer Dateiablage in einer ListItems-Aufzählung zurück.
Name | Setzt den Namen der Dateiablage oder gibt ihn zurück.
SelectedItems | Gibt die ausgewählten Objekte einer Dateiablage in einer ListItems-Aufzählung zurück.
Selection | Gibt ein ListSelection-Objekt zum Auswählen von Objekten in der Dateiablage zurück.

Methoden

Close | Schließt die Dateiablage.
MoveLeft | Verschiebt die Dateiablage in der FileContainers-Auflistung um eine Position nach links.
MoveRight | Verschiebt die Dateiablage in der FileContainers-Auflistung um eine Position nach rechts.

FileContainers-Objekt, ListSelection-Objekt


FileContainers-Objekt

FileContainers-Objekt

Das FileContainers-Objekt ermöglicht den Zugriff auf einzelne Dateiablagen des linken oder rechten Fensters.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das TabWindow-Objekt.
Active | Gibt ein FileContainer-Objekt für die aktive Dateiablage zurück.
Count | Gibt die Anzahl der Dateiablagen zurück.
IsVisible | Gibt an, ob die Dateiablagen sichtbar sind.

Methoden

Activate | Aktiviert die Dateiablagen.
Add | Erstellt eine neue Dateiablage.
CloseAll | Entfernt alle Dateiablagen bis auf die aktive Dateiablage.
Item | Gibt eine bestimmte Dateiablage (FileContainer-Objekt) innerhalb der Auflistung zurück.

TabWindow-Objekt, FileContainer-Objekt


FolderFavorite-Objekt

FolderFavorite-Objekt

Das FolderFavorite-Objekt stellt einen einzelnen Ordnerfavoriten dar.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das FolderFavorites-Objekt.
CmdId | Gibt die Befehls-ID des Ordnerfavoriten zurück.
Folder | Setzt den Namen des Ordners, in den im aktiven Fenster gewechselt werden soll, oder gibt ihn zurück.
Folder2 | Setzt den Namen des Ordners, in den im inaktiven Fenster gewechselt werden soll, oder gibt ihn zurück.
Index | Gibt den Index des Ordnerfavoriten innerhalb des FolderFavorites-Objekts zurück.
IsFavorite | Gibt an, ob der Eintrag ein Ordnerfavorit ist.
IsSeparator | Gibt an, ob der Eintrag ein Trennzeichen ist.
IsSubMenu | Gibt an, ob der Eintrag ein Untermenü ist.
IsSubMenuEnd | Gibt an, ob der Eintrag der Abschluss eines Untermenüs ist.
Name | Setzt den Anzeigenamen des Ordnerfavoriten oder gibt ihn zurück.

Methoden

Invoke | Aktiviert den Ordnerfavoriten.
Remove | Löscht den Ordnerfavoriten.

FolderFavorites-Objekt


FolderFavorites-Objekt

FolderFavorites-Objekt

Mit Hilfe des FolderFavorites-Objekts erfolgt der Zugriff auf die Ordnerfavoriten.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
Count | Gibt die Anzahl der Ordnerfavoriten-Einträge zurück.

Methoden

Add | Fügt dem Ordnerfavoriten-Menü einen neuen Ordnerfavoriten hinzu.
AddMenu | Fügt dem Ordnerfavoriten-Menü ein neues Untermenü hinzu.
AddSeparator | Fügt dem Ordnerfavoriten-Menü ein Trennzeichen an.
Item | Gibt einen bestimmten Ordnerfavoriten (FolderFavorite-Objekt) innerhalb der Auflistung zurück.
RemoveAll | Entfernt alle Ordnerfavoriten-Einträge.
Save | Speichert die Änderungen an den Ordnerfavoriten.


FolderWindow-Objekt

FolderWindow-Objekt

Das FolderWindow-Objekt ermöglicht den Zugriff auf ein einzelnes Ordnerfenster.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das FolderWindows-Objekt.
BaseFolder | Setzt den Basisordner für das Ordnerfenster oder fragt ihn ab.
FocusedItem | Gibt den fokussierten Eintrag zurück oder legt ihn fest.
Folder | Gibt ein AppFolder-Objekt für den aktuellen Ordner zurück.
GroupView | Aktiviert bzw. deaktiviert die Gruppenansicht oder fragt sie ab.
Index | Gibt den Index des Objekts innerhalb der FolderWindows-Auflistung zurück.
IsVisible | Gibt an, ob das Ordnerfenster sichtbar ist.
Items | Gibt die Objekte im Ordnerfenster in einer ListItems-Aufzählung zurück.
ListView | Setzt den Modus für die Listenansicht oder fragt ihn ab.
Name | Setzt den Namen des Ordnerfensters oder gibt ihn zurück.
SelectedItems | Gibt die ausgewählten Objekte im Ordnerfenster in einer ListItems-Aufzählung zurück.
Selection | Gibt ein ListSelection-Objekt zum Auswählen von Objekten im Ordnerfenster zurück.
Splitter1 | Setzt die Splitterposition zwischen Listenansicht und Baumansicht bzw. fragt sie ab.
Splitter2 | Setzt die Splitterposition zwischen Listenansicht und Statusfenster bzw. fragt sie ab.
StatusWindow | Aktiviert oder deaktiviert das Statusfenster.
TabProperties | Setzt verschiedene Registerkarten-Eigenschaften für das Ordnerfenster oder fragt sie ab.
TreeView | Aktiviert oder deaktiviert die Baumansicht.

Methoden

Activate | Aktiviert das Ordnerfenster.
Close | Schließt das Ordnerfenster.
MoveLeft | Verschiebt das Ordnerfenster in der FolderWindows-Auflistung um eine Position nach links.
MoveRight | Verschiebt das Ordnerfenster in der FolderWindows-Auflistung um eine Position nach rechts.
Refresh | Aktualisiert das Ordnerfenster.

ListItems-Objekt, FolderWindows-Objekt


FolderWindows-Objekt

FolderWindows-Objekt

Das FolderWindows-Objekt ermöglicht den Zugriff auf einzelne Ordnerfenster des linken oder rechten Fensters.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das TabWindow-Objekt.
Active | Gibt ein FolderWindow-Objekt für das aktive Ordnerfenster zurück.
Count | Gibt die Anzahl der Ordnerfenster zurück.
IsVisible | Gibt an, ob die Ordnerfenster sichtbar sind.

Methoden

Activate | Aktiviert die Ordnerfenster.
Add | Erstellt ein neues Ordnerfenster.
CloseAll | Entfernt alle Ordnerfenster bis auf das aktive Ordnerfenster.
Item | Gibt ein bestimmtes Ordnerfenster (FolderWindow-Objekt) innerhalb der Auflistung zurück.

TabWindow-Objekt, FolderWindow-Objekt


ListItem-Objekt

ListItem-Objekt

Das ListItem-Objekt stellt einen einzelnen Eintrag in einem Ordnerfenster oder in einer Dateiablage dar.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das ListItems-Objekt.
Attributes | Gibt die Dateiattribute zurück.
DateCreated | Gibt das Datum zurück, an dem die Datei oder der Ordner erstellt wurde.
DateLastAccessed | Gibt das Datum zurück, an dem auf die Datei oder den Ordner zuletzt zugegriffen wurde.
DateLastModified | Gibt das Datum zurück, an dem die Datei oder der Order zuletzt geändert wurde.
FileName | Gibt den relativen Dateinamen (ohne Pfad) zurück.
Folder | Gibt den Ordner zurück.
PathName | Gibt den vollständigen Dateinamen zurück.
Selected | Setzt den Auswahlzustand eines Eintrags oder gibt ihn zurück.
ShortFileName | Gibt den relativen Dateinamen (ohne Pfad) in 8.3-Konvention zurück.
ShortPathName | Gibt den vollständigen Dateinamen in 8.3-Konvention zurück.
Size | Gibt die Größe der Datei zurück.

Methoden

ListItems-Objekt


ListItems-Objekt

ListItems-Objekt

Das ListItems-Objekt enthält alle Objekte in einem Ordnerfenster oder in einer Dateiablage.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt einen Verweis auf das Elternobjekt zurück.
Count | Gibt die Anzahl der Einträge zurück.

Methoden

Item Gibt einen Eintrag (ListItem-Objekt) innerhalb der Auflistung zurück.

ListItem-Objekt


ListSelection-Objekt

ListSelection-Objekt

Mit Hilfe des ListSelection-Objektes kann die Auswahl in einem Ordnerfenster oder in einer Dateiablage manipuliert werden.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück.

Methoden

Invert | Invertiert die Auswahl.
Restore | Stellt die zuletzt gespeicherte Auswahl wieder her.
Save | Speichert eine Auswahl.
Select | Wählt Dateien und Ordner anhand einer Maske aus.
SelectAll | Wählt alle Dateien und Ordner aus.
SelectAllFiles | Wählt alle Dateien aus.
Unselect | Entfernt die Auswahl für bestimmte Dateien anhand einer Maske.
UnselectAll | Entfernt die Auswahl für alle Dateien und Ordner.
UnselectAllFiles | Entfernt die Auswahl für alle Dateien.

ListItems-Objekt


MainWindow-Objekt

MainWindow-Objekt

Das MainWindow-Objekt repräsentiert das Hauptfenster im SpeedCommander.

Eigenschaften

Eigenschaft | Beschreibung
Application | Gibt einen Verweis auf das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
Caption | Setzt den Fenstertext des Hauptfensters oder gibt diesen zurück.
Height | Gibt die Höhe des Hauptfensters zurück oder legt sie fest.
HWnd | Gibt das Fensterhandle des Hauptfensters zurück.
Left | Gibt den Abstand zwischen dem linken Rand des Bildschirmes und dem linken Rand des Hauptfensters zurück oder legt ihn fest.
Top | Gibt den Abstand zwischen dem oberen Rand des Bildschirmes und dem oberen Rand des Hauptfensters zurück oder legt ihn fest.
Width | Gibt die Breite des Hauptfensters zurück oder legt sie fest.
Visible | Setzt die Sichtbarkeit des Hauptfensters oder gibt diese zurück.

Application-Objekt


MultiRename-Objekt

MultiRename-Objekt

Mit Hilfe des MultiRename-Objekts können Dateien nach bestimmten Kriterien umbenannt werden.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
BaseFolder | Legt den Basisordner fest oder gibt ihn zurück.
CharCase | Legt den Modus für die Groß-/Kleinschreibung fest oder gibt ihn zurück.
DateTime | Legt den Modus für die Datums- und Zeitangaben fest oder gibt ihn zurück.
FileExtToken | Legt das Token für die Dateierweiterung fest oder gibt es zurück.
FileNameToken | Legt das Token für den Dateinamen fest oder gibt es zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
ParentFolder | Legt den Elternordner fest oder gibt ihn zurück.
SearchFor | Legt den zu suchenden Text fest oder gibt ihn zurück.
Replace | Legt den Modus für das Ersetzen von Text fest oder gibt ihn zurück.
ReplaceWith | Legt den Text fest, der den zu suchenden Text ersetzen soll oder gibt ihn zurück.

Methoden

Add | Fügt der aktuellen Auswahl einen Dateinamen oder alle Dateinamen eines ListItems-Objekts hinzu.
RemoveAll | Entfernt alle Dateien aus der Liste der umzubenennenden Dateien.
Rename | Benennt alle Dateien, die sich in der Dateiliste befinden, entsprechend den gewählten Einstellungen um.

Application-Objekt


TabWindow-Objekt

TabWindow-Objekt

Das TabWindow-Objekt repräsentiert das linke oder rechte Fenster in der Zweifenster-Ansicht.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Window-Objekt.
FileContainers | Gibt eine Auflistung der Dateicontainer als FileContainers-Objekt zurück.
FolderWindows | Gibt eine Auflistung der Ordnerfenster als FolderWindows-Objekt zurück.
IsActive | Gibt an, ob das Fenster aktiv ist.
ShowFileContainers | Gibt an, ob die Dateiablagen als Registerkarte angezeigt werden sollen.
SynchronizeFolderWindows | Gibt an, ob die Ordnerfenster untereinander abgeglichen werden sollen.

Methoden

Activate Aktiviert das Fenster.

Siehe auch

Window-Objekt, FolderWindow-Objekt, FolderWindows-Objekt, FileContainer-Objekt, FileContainers-Objekt


UserTool-Objekt

UserTool-Objekt

Das UserTool-Objekt stellt einen einzelnen Anwendungsfavoriten dar.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das UserTools-Objekt.
Arguments | Setzt die Argumente, die der Anwendung beim Start übergeben werden, oder gibt sie zurück.
CmdId | Gibt die Befehls-ID des Anwendungsfavoriten zurück.
Command | Setzt den vollständiger Pfadnamen der Anwendung oder gibt ihn zurück.
Index | Gibt den Index des Anwendungsfavoriten innerhalb des UserTools-Objekts zurück.
InitialDir | Setzt den Startordner der Anwendung oder gibt ihn zurück.
IsSeparator | Gibt an, ob der Eintrag ein Trennzeichen ist.
IsSubMenu | Gibt an, ob der Eintrag ein Untermenü ist.
IsSubMenuEnd | Gibt an, ob der Eintrag ein Abschluss eines Untermenüs ist.
IsUserTool | Gibt an, ob der Eintrag ein Anwendungsfavorit ist.
Name | Setzt den Anzeigenamen des Anwendungsfavoriten oder gibt ihn zurück.
ShowCmd | Setzt den Startmodus der Anwendung oder gibt ihn zurück.
ShortPathNames | Legt fest, dass die der Anwendung übergebenen Objekte im 8.3-Format erfolgen soll.

Methoden

Invoke | Startet den Anwendungsfavoriten.
Remove | Löscht den Anwendungsfavoriten.

UserTools-Objekt


UserTools-Objekt

UserTools-Objekt

Mit Hilfe des UserTools-Objekts erfolgt der Zugriff auf die Anwendungsfavoriten.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
Count | Gibt die Anzahl der Anwendungsfavoriten-Einträge zurück.

Methoden

Add | Fügt dem Anwendungsfavoriten-Menü einen neuen Anwendungsfavoriten hinzu.
AddMenu | Fügt dem Anwendungsfavoriten-Menü ein neues Untermenü hinzu.
AddSeparator | Fügt dem Anwendungsfavoriten-Menü ein Trennzeichen an.
Item | Gibt einen bestimmten Anwendungsfavoriten (UserTool-Objekt) innerhalb der Auflistung zurück.
RemoveAll | Entfernt alle Anwendungsfavoriten-Einträge.
Save | Speichert die Änderungen an den Anwendungsfavoriten.

UserTool-Objekt


Workspace-Objekt

Workspace-Objekt

Das Workspace-Objekt ermöglicht den Zugriff auf den Arbeitsbereich in SpeedCommander. Dazu gehören die beiden Fenster der Zweifenster-Ansicht und das Laufwerksfenster.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
ActiveWindow | Gibt ein TabWindow-Objekt für das aktive Fenster zurück.
DosCommandWindow | Gibt an oder legt fest, ob das DOS-Befehlsfenster angezeigt wird.
DosPrompt | Gibt an oder legt fest, ob die DOS-Eingabezeile angezeigt wird.
DriveSymbols | Setzt die Ansicht für das Laufwerksfenster oder gibt sie zurück.
FolderLayout | Gibt an, ob die Ordnerfenster nebeneinander oder übereinander angezeigt werden sollen.
InactiveWindow | Gibt ein TabWindow-Objekt für das inaktive Fenster zurück.
Splitter | Setzt die Splitterposition zwischen den beiden Fenstern bzw. fragt sie ab.
Swapped | Gibt an, ob die beiden Fenster getauscht sind. Im Normalfall ist erste Fenster links bzw. oben und zweite Fenster rechts bzw. unten.
TabWindow1 | Gibt ein TabWindow-Objekt für das erste Fenster zurück.
TabWindow2 | Gibt ein TabWindow-Objekt für das zweite Fenster zurück.

Methoden

TabWindow-Objekt


Active (FileContainers-Objekt)

Active (FileContainers-Objekt)

Gibt ein FileContainer-Objekt für die aktive Dateiablage zurück.

[C++]
HRESULT get_Active(
  /*[out, retval]*/ IFileContainer** ppFileContainer
);
[C#]
FileContainer Active {get;}
[Visual Basic .NET]
Public ReadOnly Property Active() As FileContainer
[Delphi]
property Active: IFileContainer read Get_Active;

FileContainers-Objekt, FileContainer-Objekt


Active (FolderWindows-Objekt)

Active (FolderWindows-Objekt)

Gibt ein FolderWindow-Objekt für das aktive Ordnerfenster zurück.

[C++]
HRESULT get_Active(
  /*[out, retval]*/ IFolderWindow** ppFolderWindow
);
[C#]
FolderWindow Active {get;}
[Visual Basic .NET]
Public ReadOnly Property Active() As FolderWindow
[Delphi]
property Active: IFolderWindow read Get_Active;

FolderWindows-Objekt, FolderWindow-Objekt


ActiveWindow (Workspace-Objekt)

ActiveWindow (Workspace-Objekt)

Gibt ein TabWindow-Objekt für das aktive Fenster zurück.

[C++]
HRESULT get_ActiveWindow(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow ActiveWindow {get;}
[Visual Basic .NET]
Public ReadOnly Property ActiveWindow() As TabWindow
[Delphi]
property ActiveWindow: ITabWindow read Get_ActiveWindow;

Workspace-Objekt, TabWindow-Objekt


AppDataFolder (Application-Objekt)

AppDataFolder (Application-Objekt)

Gibt den Pfad zurück, in dem die Einstellungen gespeichert werden.

[C++]
HRESULT get_AppDataFolder(
  /*[out, retval]*/ BSTR* pAppDataFolder
);
[C#]
public string AppDataFolder {get;}
[Visual Basic .NET]
Public ReadOnly Property AppDataFolder() As String
[Delphi]
property AppDataFolder: WideString read Get_AppDataFolder;

Application-Objekt


Arguments (UserTool-Objekt)

Arguments (UserTool-Objekt)

Setzt die Argumente, die der Anwendung beim Start übergeben werden, oder gibt sie zurück. Mehrere Argumente werden durch ein Leerzeichen getrennt.

[C++]
HRESULT get_Arguments(
  /*[out, retval]*/ BSTR* pbstrArguments
);
HRESULT put_Arguments(
  /*[in]*/ BSTR bstrArguments
);
[C#]
string Arguments {get; set;}
[Visual Basic .NET]
Public Property Arguments() As String
[Delphi]
property Arguments: WideString read Get_Arguments write Set_Arguments;

UserTool-Objekt


Attributes (ListItem-Objekt)

Attributes (ListItem-Objekt)

Gibt die Dateiattribute zurück.

[C++]
HRESULT get_Attributes(
  /*[out, retval]*/ long* pAttributes
);
[C#]
int Attributes {get;}
[Visual Basic .NET]
Public ReadOnly Property Attributes() As Integer
[Delphi]
property Attributes: Integer read Get_Attributes;

ListItem-Objekt


BarID (CommandBar-Objekt)

BarID (CommandBar-Objekt)

Gibt die eindeutige ID der Symbolleiste zurück.

[C++]
HRESULT get_BarID(
  /*[out, retval]*/ long* pBarID
);
[C#]
int BarID {get;}
[Visual Basic .NET]
Public ReadOnly Property BarID() As Integer
[Delphi]
property BarID: Integer read Get_BarID;

CommandBar-Objekt


BarType (CommandBar-Objekt)

BarType (CommandBar-Objekt)

Gibt den Typ der Symbolleiste als scCommandBarType-Konstante zurück.

[C++]
HRESULT get_BarType(
  /*[out, retval]*/ enum scCommandBarType* pBarType
);
[C#]
scCommandBarType BarType {get;}
[Visual Basic .NET]
Public ReadOnly Property BarType() As scCommandBarType
[Delphi]
property BarType: scCommandBarType read Get_BarType;

CommandBar-Objekt, scCommandBarType-Konstanten


BaseFolder (FolderWindow-Objekt)

BaseFolder (FolderWindow-Objekt)

Setzt den Basisordner für das Ordnerfenster oder fragt ihn ab.

[C++]
HRESULT get_BaseFolder(
  /*[out, retval]*/ BSTR* pbstrBaseFolder
);
HRESULT put_BaseFolder(
  /*[in]*/ BSTR bstrBaseFolder
);
[C#]
string BaseFolder {get; set;}
[Visual Basic .NET]
Public Property BaseFolder() As String
[Delphi]
property BaseFolder: WideString read Get_BaseFolder write Set_BaseFolder;

FolderWindow-Objekt


BaseFolder (MultiRename-Objekt)

BaseFolder (MultiRename-Objekt)

Legt den Basisordner fest oder gibt ihn zurück.

[C++]
HRESULT get_BaseFolder(
  /*[out, retval]*/ BSTR* pbstrBaseFolder
);
HRESULT put_BaseFolder(
  /*[in]*/ BSTR bstrBaseFolder
);
[C#]
string BaseFolder {get; set;}
[Visual Basic .NET]
Public Property BaseFolder() As String
[Delphi]
property BaseFolder: WideString read Get_BaseFolder write Set_BaseFolder;

MultiRename-Objekt


BeginGroup (CommandBarControl-Objekt)

BeginGroup (CommandBarControl-Objekt)

Gibt an, ob das Element der Beginn einer neuen Gruppe ist.

[C++]
HRESULT get_BeginGroup(
  /*[out, retval]*/ VARIANT_BOOL* pBeginGroup
);
HRESULT put_BeginGroup(
  /*[in]*/ VARIANT_BOOL fBeginGroup
);
[C#]
bool BeginGroup {get; set;}
[Visual Basic .NET]
Public Property BeginGroup() As Boolean
[Delphi]
property BeginGroup: WordBool read Get_BeginGroup write Set_BeginGroup;

CommandBarControl-Objekt


BuiltIn (CommandBar-Objekt)

BuiltIn (CommandBar-Objekt)

Gibt an, ob die Symbolleiste eine fest eingebaute Symbolleiste ist.

[C++]
HRESULT get_BuiltIn(
  /*[out, retval]*/ VARIANT_BOOL* pBuiltIn
);
[C#]
bool BuiltIn {get;}
[Visual Basic .NET]
Public ReadOnly Property BuiltIn() As Boolean
[Delphi]
property BuiltIn: WordBool read Get_BuiltIn;

CommandBar-Objekt


Caption (CommandBarControl-Objekt)

Caption (CommandBarControl-Objekt)

Setzt den Text für das Element oder gibt ihn zurück.

[C++]
HRESULT get_Caption(
  /*[out, retval]*/ BSTR* pbstrCaption
);
HRESULT put_Caption(
  /*[in]*/ BSTR bstrCaption
);
[C#]
string Caption {get; set;}
[Visual Basic .NET]
Public Property Caption() As String
[Delphi]
property Caption: WideString read Get_Caption write Set_Caption;

CommandBarControl-Objekt, CommandBar-Objekt


Caption (MainWindow-Objekt)

Caption (MainWindow-Objekt)

Setzt den Fenstertext des Hauptfensters oder gibt diesen zurück.

[C++]
HRESULT get_Caption(
  /*[out, retval]*/ BSTR* pbstrCaption
);
HRESULT put_Caption(
  /*[in]*/ BSTR bstrCaption
);
[C#]
string Caption {get; set;}
[Visual Basic .NET]
Public Property Caption() As String
[Delphi]
property Caption: WideString read Get_Caption write Set_Caption;

MainWindow-Objekt


CharCase (MultiRename-Objekt)

CharCase (MultiRename-Objekt)

Legt den Modus für die Groß-/Kleinschreibung fest oder gibt ihn zurück.

[C++]
HRESULT get_CharCase(
  /*[out, retval]*/ scMrtCharCase* eCharCase
);
HRESULT put_CharCase(
  /*[in]*/ scMrtCharCase eCharCase
);
[C#]
scMrtCharCase CharCase {get; set;}
[Visual Basic .NET]
Public Property CharCase() As scMrtCharCase
[Delphi]
property CharCase: scMrtCharCase read Get_CharCase write Set_CharCase;

MultiRename-Objekt, scMrtCharCase-Konstanten


Checked (CommandBarControl-Objekt)

Checked (CommandBarControl-Objekt)

Gibt an, ob das Element gewählt ist.

[C++]
HRESULT get_Checked(
  /*[out, retval]*/ VARIANT_BOOL* pChecked
);
HRESULT put_Checked(
  /*[in]*/ VARIANT_BOOL fChecked
);
[C#]
bool Checked {get; set;}
[Visual Basic .NET]
Public Property Checked() As Boolean
[Delphi]
property Checked: WordBool read Get_Checked write Set_Checked;

CommandBarControl-Objekt, CommandBar-Objekt


CmdId (CommandBarControl-Objekt)

CmdId (CommandBarControl-Objekt)

Gibt die Befehls-ID des Elements zurück.

[C++]
HRESULT get_CmdId(
  /*[out, retval]*/ long* pCmdId
);
[C#]
int CmdId {get;}
[Visual Basic .NET]
Public ReadOnly Property CmdId() As Integer
[Delphi]
property CmdId: Integer read Get_CmdId write Set_CmdId;

CommandBarControl-Objekt, CommandBar-Objekt


CmdId (FolderFavorite-Objekt)

CmdId (FolderFavorite-Objekt)

Gibt die Befehls-ID des Ordnerfavoriten zurück.

[C++]
HRESULT get_CmdId(
  /*[out, retval]*/ long* pCmdId
);
[C#]
int CmdId {get;}
[Visual Basic .NET]
Public ReadOnly Property CmdId() As Integer
[Delphi]
property CmdId: Integer read Get_CmdId;

FolderFavorite-Objekt


CmdId (UserTool-Objekt)

CmdId (UserTool-Objekt)

Gibt die Befehls-ID des Anwendungsfavoriten zurück.

[C++]
HRESULT get_CmdId(
  /*[out, retval]*/ long* pCmdId
);
[C#]
int CmdId {get;}
[Visual Basic .NET]
Public ReadOnly Property CmdId() As Integer
[Delphi]
property CmdId: Integer read Get_CmdId;

UserTool-Objekt


Command (UserTool-Objekt)

Command (UserTool-Objekt)

Setzt den vollständiger Pfadnamen der Anwendung oder gibt ihn zurück.

[C++]
HRESULT get_Command(
  /*[out, retval]*/ BSTR* pbstrCommand
);
HRESULT put_Command(
  /*[in]*/ BSTR bstrCommand
);
[C#]
string Command {get; set;}
[Visual Basic .NET]
Public Property Command() As String
[Delphi]
property Command: WideString read Get_Command write Set_Command;

UserTool-Objekt


CommandBar (CommandBarControl-Objekt)

CommandBar (CommandBarControl-Objekt)

Gibt das CommandBar-Objekt für untergeordnete Elemente zurück.

[C++]
HRESULT get_CommandBar(
  /*[out, retval]*/ ICommandBar** ppCommandBar
);
[C#]
CommandBar CommandBar {get;}
[Visual Basic .NET]
Public ReadOnly Property CommandBar() As CommandBar
[Delphi]
property CommandBar: ICommandBar read Get_CommandBar;

CommandBarControl-Objekt, CommandBar-Objekt


CommandID (AddInCommand-Objekt)

CommandID (AddInCommand-Objekt)

Gibt die Befehls-ID zurück.

[C++]
HRESULT get_CommandID(
  /*[out, retval]*/ long* pCommandID
);
[C#]
int CommandID {get;}
[Visual Basic .NET]
Public ReadOnly Property CommandID() As Integer
[Delphi]
property CommandID: Integer read Get_CommandID;

AddInCommand-Objekt


Commands (AddIns-Objekt)

Commands (AddIns-Objekt)

Gibt ein AddInCommands-Objekt zurück, welches die Befehle der AddIns enthält.

[C++]
HRESULT get_Commands(
  /*[out, retval]*/ IAddInCommands** ppAddInCommands
);
[C#]
AddInCommands Commands {get;}
[Visual Basic .NET]
Public ReadOnly Property Commands() As AddInCommands
[Delphi]
property Commands: IAddInCommands read Get_Commands;

AddIns-Objekt, AddInCommands-Objekt


Connect (AddIn-Objekt)

Connect (AddIn-Objekt)

Gibt den Aktivierungszustand des AddIns an oder legt ihn fest.

[C++]
HRESULT get_Connect(
  /*[out, retval]*/ VARIANT_BOOL* pConnect
);
HRESULT put_Connect(
  /*[in]*/ VARIANT_BOOL fConnect
);
[C#]
bool Connect {get; set;}
[Visual Basic .NET]
Public Property Connect() As Boolean
[Delphi]
property Connect: WordBool read Get_Connect write Set_Connect;

AddIn-Objekt


Controls (CommandBar-Objekt)

Controls (CommandBar-Objekt)

Gibt eine Auflistung von Elementen in der Symbolleiste zurück.

[C++]
HRESULT get_Controls(
  /*[out, retval]*/ ICommandBarControls** ppCommandBarControls
);
[C#]
CommandBarControls Controls {get;}
[Visual Basic .NET]
Public ReadOnly Property Controls() As CommandBarControls
[Delphi]
property Controls: ICommandBarControls read Get_Controls;

CommandBar-Objekt, CommandBarControls-Objekt


Controls (CommandBarControl-Objekt)

Controls (CommandBarControl-Objekt)

Gibt ein CommandBarControls-Objekt zurück, welches die benachbarten Elemente enthält.

[C++]
HRESULT get_Controls(
  /*[out, retval]*/ ICommandBarControls** ppCommandBarControls
);
[C#]
CommandBarControls Controls {get;}
[Visual Basic .NET]
Public ReadOnly Property Controls() As CommandBarControls
[Delphi]
property Controls: ICommandBarControls read Get_Controls;

CommandBarControl-Objekt, CommandBar-Objekt


ControlType (CommandBarControl-Objekt)

ControlType (CommandBarControl-Objekt)

Gibt den Typ des Elements als scCommandBarControlType-Konstante zurück.

[C++]
HRESULT get_ControlType(
  /*[out, retval]*/ enum scCommandBarControlType* pType
);
[C#]
scCommandBarControlType ControlType {get;}
[Visual Basic .NET]
Public ReadOnly Property ControlType() As scCommandBarControlType
[Delphi]
property ControlType: scCommandBarControlType read Get_ControlType;

Siehe auch

CommandBarControl-Objekt, CommandBar-Objekt, scCommandBarControlType-Konstanten


Count (AddInCommands-Objekt)

Count (AddInCommands-Objekt)

Gibt die Anzahl der verfügbaren Befehle zurück.

[C++]
HRESULT get_Count(
  /*[out, retval]*/ long* pCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Integer
[Delphi]
property Count: Integer read Get_Count;

AddInCommands-Objekt


Count (AddIns-Objekt)

Count (AddIns-Objekt)

Gibt die Anzahl der installierten AddIns zurück.

[C++]
HRESULT get_Count(
  /*[out, retval]*/ long* pCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Integer
[Delphi]
property Count: Integer read Get_Count;

AddIns-Objekt


Count (CommandBarControls-Objekt)

Count (CommandBarControls-Objekt)

Gibt die Anzahl der vorhandenen Elemente innerhalb der Auflistung zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* plCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Integer
[Delphi]
property Count: Integer read Get_Count;

CommandBarControls-Objekt


Count (CommandBars-Objekt)

Count (CommandBars-Objekt)

Gibt die Anzahl der vorhandenen Symbolleisten innerhalb der CommandBars-Auflistung zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* nCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Long
[Delphi]
property Count: Integer read Get_Count;

CommandBars-Objekt


Count (FileContainers-Objekt)

Count (FileContainers-Objekt)

Gibt die Anzahl der Dateiablagen zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* pnCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Integer
[Delphi]
property Count: Integer read Get_Count;

FileContainers-Objekt


Count (FolderFavorites-Objekt)

Count (FolderFavorites-Objekt)

Gibt die Anzahl der vorhandenen Anwendungsfavoriten innerhalb der FolderFavorites-Auflistung zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* nCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Long
[Delphi]
property Count: Integer read Get_Count;

FolderFavorites-Objekt


Count (FolderWindows-Objekt)

Count (FolderWindows-Objekt)

Gibt die Anzahl der Ordnerfenster zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* pnCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Integer
[Delphi]
property Count: Integer read Get_Count;

FolderWindows-Objekt


Count (ListItems-Objekt)

Count (ListItems-Objekt)

Gibt die Anzahl der Einträge innerhalb der ListItems-Auflistung zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* nCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Long
[Delphi]
property Count: Integer read Get_Count;

ListItems-Objekt


Count (UserTools-Objekt)

Count (UserTools-Objekt)

Gibt die Anzahl der vorhandenen Anwendungsfavoriten innerhalb der UserTools-Auflistung zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* nCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Long
[Delphi]
property Count: Integer read Get_Count;

UserTools-Objekt


DateCreated (ListItem-Objekt)

Attributes (ListItem-Objekt)

Gibt das Datum zurück, an dem die Datei oder der Ordner erstellt wurde.

[C++]
HRESULT get_DateCreated(
  /*[out, retval]*/ DATE* pDateCreated
);
[C#]
DateTime DateCreated {get;}
[Visual Basic .NET]
Public ReadOnly Property DateCreated() As Date
[Delphi]
property DateCreated: TDateTime read Get_DateCreated;

ListItem-Objekt


DateLastAccessed (ListItem-Objekt)

DateLastAccessed (ListItem-Objekt)

Gibt das Datum zurück, an dem auf die Datei oder den Ordner zuletzt zugegriffen wurde.

[C++]
HRESULT get_DateLastAccessed(
  /*[out, retval]*/ DATE* pDateLastAccessed
);
[C#]
DateTime DateLastAccessed {get;}
[Visual Basic .NET]
Public ReadOnly Property DateLastAccessed() As Date
[Delphi]
property DateLastAccessed: TDateTime read Get_DateLastAccessed;

ListItem-Objekt


DateLastModified (ListItem-Objekt)

DateLastModified (ListItem-Objekt)

Gibt das Datum zurück, an dem die Datei oder der Order zuletzt geändert wurde.

[C++]
HRESULT get_DateLastModified(
  /*[out, retval]*/ DATE* pDateLastModified
);
[C#]
DateTime DateLastModified {get;}
[Visual Basic .NET]
Public ReadOnly Property DateLastModified() As Date
[Delphi]
property DateLastModified: TDateTime read Get_DateLastModified;

ListItem-Objekt


DateTime (MultiRename-Objekt)

DateTime (MultiRename-Objekt)

Legt den Modus für die Datumsangaben fest oder gibt ihn zurück.

[C++]
HRESULT get_DateTime(
  /*[out, retval]*/ scMrtDateTime* eDateTime
);
HRESULT put_DateTime(
  /*[in]*/ scMrtDateTime eDateTime
);
[C#]
scMrtDateTime DateTime {get; set;}
[Visual Basic .NET]
Public Property DateTime() As scMrtDateTime
[Delphi]
property DateTime: scMrtDateTime read Get_DateTime write Set_DateTime;

MultiRename-Objekt, scMrtDateTime-Konstanten


DefaultItem (CommandBarControl-Objekt)

DefaultItem (CommandBarControl-Objekt)

Gibt an, ob das Element das Standardelement im Menü ist.

[C++]
HRESULT get_DefaultItem(
  /*[out, retval]*/ VARIANT_BOOL* pDefaultItem
);
HRESULT put_DefaultItem(
  /*[in]*/ VARIANT_BOOL* fDefaultItem
);
[C#]
bool DefaultItem {get; set;}
[Visual Basic .NET]
Public Property DefaultItem() As Boolean
[Delphi]
property DefaultItem: WordBool read Get_DefaultItem write Set_DefaultItem;

CommandBarControl-Objekt, CommandBar-Objekt


Description (AddIn-Objekt)

Description (AddIn-Objekt)

Gibt eine Beschreibung für das AddIn zurück.

[C++]
HRESULT get_Description(
  /*[out, retval]*/ BSTR* pbstrDescription
);
[C#]
string Description {get;}
[Visual Basic .NET]
Public ReadOnly Property Description() As String
[Delphi]
property Description: WideString read Get_Description;

AddIn-Objekt, AddIns-Objekt


Description (AddInCommand-Objekt)

Description (AddInCommand-Objekt)

Gibt die Beschreibung des Befehls zurück oder legt sie fest.

[C++]
HRESULT get_Description(
  /*[out, retval]*/ BSTR* pbstrDescription
);
HRESULT put_Description(
  /*[in]*/ BSTR bstrDescription
);
[C#]
string Description {get; set;}
[Visual Basic .NET]
Public Property Description() As String
[Delphi]
property Description: WideString read Get_Description write Set_Description;

AddInCommand-Objekt


Description (CommandBarControl-Objekt)

Description (CommandBarControl-Objekt)

Setzt den Beschreibungstext für das Element oder gibt ihn zurück.

[C++]
HRESULT get_Description(
  /*[out, retval]*/ BSTR* pbstrDescription
);
HRESULT put_Description(
  /*[in]*/ BSTR bstrDescription
);
[C#]
string Description {get; set;}
[Visual Basic .NET]
Public Property Description() As String
[Delphi]
property Description: WideString read Get_Description write Set_Description;

CommandBarControl-Objekt, CommandBar-Objekt


DisplayName (AppFolder-Objekt)

DisplayName (AppFolder-Objekt)

Gibt den Anzeigenamen des Ordners zurück.

[C++]
HRESULT get_DisplayName(
  /*[out, retval]*/ BSTR* pbstrDisplayName
);
[C#]
string DisplayName {get;}
[Visual Basic .NET]
Public ReadOnly Property DisplayName() As String
[Delphi]
property DisplayName: WideString read Get_DisplayName;

AppFolder-Objekt


DosCommandWindow (Workspace-Objekt)

DosCommandWindow (Workspace-Objekt)

Gibt an oder legt fest, ob das DOS-Befehlsfenster angezeigt wird.

[C++]
HRESULT get_DosCommandWindow(
  /*[out, retval]*/ VARIANT_BOOL* pfDosCommandWindow
);
HRESULT put_DosCommandWindow(
  /*[in]*/ VARIANT_BOOL fDosCommandWindow
);
[C#]
bool DosCommandWindow {get; set;}
[Visual Basic .NET]
Public Property DosCommandWindow() As Boolean
[Delphi]
property DosCommandWindow: WordBool read Get_DosCommandWindow write Set_DosCommandWindow;

Workspace-Objekt


DosPrompt (Workspace-Objekt)

DosPrompt (Workspace-Objekt)

Gibt an oder legt fest, ob die DOS-Eingabezeile angezeigt wird.

[C++]
HRESULT get_DosPrompt(
  /*[out, retval]*/ VARIANT_BOOL* pfDosPrompt
);
HRESULT put_DosPrompt(
  /*[in]*/ VARIANT_BOOL fDosPrompt
);
[C#]
bool DosPrompt {get; set;}
[Visual Basic .NET]
Public Property DosPrompt() As Boolean
[Delphi]
property DosPrompt: WordBool read Get_DosPrompt write Set_DosPrompt;

Workspace-Objekt


DriveSymbols (Workspace-Objekt)

DriveSymbols (Workspace-Objekt)

Setzt die Ansicht für das Laufwerksfenster oder gibt sie zurück.

[C++]
HRESULT get_DriveSymbols(
  /*[out, retval]*/ enum scDriveSymbols* peDriveSymbols
);
HRESULT put_DriveSymbols(
  /*[in]*/ enum scDriveSymbols eDriveSymbols
);
[C#]
scDriveSymbols DriveSymbols {get; set;}
[Visual Basic .NET]
Public Property DriveSymbols() As scDriveSymbols
[Delphi]
property DriveSymbols: scDriveSymbols read Get_DriveSymbols write Set_DriveSymbols;

Workspace-Objekt, scDriveSymbols-Konstanten


Enabled (CommandBarControl-Objekt)

Enabled (CommandBarControl-Objekt)

Gibt an, ob das Element aktiv oder deaktiviert ist.

[C++]
HRESULT get_Enabled(
  /*[out, retval]*/ VARIANT_BOOL* pEnabled
);
HRESULT put_Enabled(
  /*[in]*/ VARIANT_BOOL fEnabled
);
[C#]
bool Enabled {get; set;}
[Visual Basic .NET]
Public Property Enabled() As Boolean
[Delphi]
property Enabled: WordBool read Get_Enabled write Set_Enabled;

CommandBarControl-Objekt, CommandBar-Objekt


Extensibility2 (AddIn-Objekt)

Extensibility2 (AddIn-Objekt)

Gibt einen Verweis auf die Basisschnittstelle des AddIns zurück.

[C++]
HRESULT get_Extensibility2(
  /*[out, retval]*/ IDTExtensibility2** ppObject
);
[C#]
IDTExtensibility2 Extensibility2 {get;}
[Visual Basic .NET]
Public ReadOnly Property Extensibility2() As IDTExtensibility2
[Delphi]
property Extensibility2: IDTExtensibility2 read Get_Extensibility2;

AddIn-Objekt, IDTExtensibility2


FileContainers (TabWindow-Objekt)

FileContainers (TabWindow-Objekt)

Gibt eine Auflistung der Dateicontainer als FileContainers-Objekt zurück.

[C++]
HRESULT get_FileContainers(
  /*[out, retval]*/ IFileContainers** ppFileContainers
);
[C#]
FileContainers FileContainers {get;}
[Visual Basic .NET]
Public ReadOnly Property FileContainers() As FileContainers
[Delphi]
property FileContainers: IFileContainers read Get_FileContainers;

TabWindow-Objekt, FileContainers-Objekt


FileExtToken (MultiRename-Objekt)

FileExtToken (MultiRename-Objekt)

Legt das Token für die Dateierweiterung fest oder gibt es zurück.

[C++]
HRESULT get_FileExtToken(
  /*[out, retval]*/ BSTR* pbstFileExtToken
);
HRESULT put_FileExtToken(
  /*[in]*/ BSTR bstrFileExtToken
);
[C#]
string FileExtToken {get; set;}
[Visual Basic .NET]
Public Property FileExtToken() As String
[Delphi]
property FileExtToken: WideString read Get_FileExtToken write Set_FileExtToken;

MultiRename-Objekt


FileName (ListItem-Objekt)

FileName (ListItem-Objekt)

Gibt den relativen Dateinamen (ohne Pfad) zurück.

[C++]
HRESULT get_FileName(
  /*[out, retval]*/ BSTR* pbstrFileName
);
[C#]
string FileName {get;}
[Visual Basic .NET]
Public ReadOnly Property FileName() As String
[Delphi]
property FileName: WideString read Get_FileName;

ListItem-Objekt


FileNameToken (MultiRename-Objekt)

FileNameToken (MultiRename-Objekt)

Legt das Token für den Dateinamen fest oder gibt es zurück.

[C++]
HRESULT get_FileNameToken(
  /*[out, retval]*/ BSTR* pbstrFileNameToken
);
HRESULT put_FileNameToken(
  /*[in]*/ BSTR bstrFileNameToken
);
[C#]
string FileNameToken {get; set;}
[Visual Basic .NET]
Public Property FileNameToken() As String
[Delphi]
property FileNameToken: WideString read Get_FileNameToken write Set_FileNameToken;

MultiRename-Objekt


FocusedItem (FileContainer-Objekt)

FocusedItem (FileContainer-Objekt)

Gibt den fokussierten Eintrag zurück oder legt ihn fest.

[C++]
HRESULT get_FocusedItem(
  /*[out, retval]*/ long* pnFocusedItem
);
HRESULT put_FocusedItem(
  /*[in]*/ long nFocusedItem
);
[C#]
int FocusedItem {get; set;}
[Visual Basic .NET]
Public Property FocusedItem() As Integer
[Delphi]
property FocusedItem: Integer read Get_FocusedItem write Set_FocusedItem;

FileContainer-Objekt


FocusedItem (FolderWindow-Objekt)

FocusedItem (FolderWindow-Objekt)

Gibt den fokussierten Eintrag zurück oder legt ihn fest.

[C++]
HRESULT get_FocusedItem(
  /*[out, retval]*/ long* pnFocusedItem
);
HRESULT put_FocusedItem(
  /*[in]*/ long nFocusedItem
);
[C#]
int FocusedItem {get; set;}
[Visual Basic .NET]
Public Property FocusedItem() As Integer
[Delphi]
property FocusedItem: Integer read Get_FocusedItem write Set_FocusedItem;

FolderWindow-Objekt


Folder (AppFolder-Objekt)

Folder (AppFolder-Objekt)

Gibt den vollständigen Ordnernamen zurück oder setzt ihn.

[C++]
HRESULT get_Folder(
  /*[out, retval]*/ BSTR* pbstrFolder
);
HRESULT put_Folder(
  /*[in]*/ BSTR bstrFolder
);
[C#]
string Folder {get; set;}
[Visual Basic .NET]
Public Property Folder() As String
[Delphi]
property Folder: WideString read Get_Folder write Set_Folder;

AppFolder-Objekt


Folder (FolderFavorite-Objekt)

Folder (FolderFavorite-Objekt)

Setzt den Namen des Ordners, in den im aktiven Fenster gewechselt werden soll, oder gibt ihn zurück.

[C++]
HRESULT get_Folder(
  /*[out, retval]*/ BSTR* pbstrFolder
);
HRESULT put_Folder(
  /*[in]*/ BSTR bstrFolder
);
[C#]
string Folder {get; set;}
[Visual Basic .NET]
Public Property Folder() As String
[Delphi]
property Folder: WideString read Get_Folder write Set_Folder;

FolderFavorite-Objekt


Folder (FolderWindow-Objekt)

Folder (FolderWindow-Objekt)

Gibt ein AppFolder-Objekt für den aktuellen Ordner zurück.

[C++]
HRESULT get_Folder(
  /*[out, retval]*/ IAppFolder** ppAppFolder
);
[C#]
AppFolder Folder {get;}
[Visual Basic .NET]
Public ReadOnly Property Folder() As AppFolder
[Delphi]
property AppFolder: IAppFolder read Get_Folder;

FolderWindow-Objekt, AppFolder-Objekt


Folder (ListItem-Objekt)

Folder (ListItem-Objekt)

Gibt den Ordner zurück.

[C++]
HRESULT get_Folder(
  /*[out, retval]*/ BSTR* pbstrFolder
);
[C#]
string Folder {get;}
[Visual Basic .NET]
Public ReadOnly Property Folder() As String
[Delphi]
property Folder: WideString read Get_Folder;

ListItem-Objekt


Folder2 (FolderFavorite-Objekt)

Folder2 (FolderFavorite-Objekt)

Setzt den Namen des Ordners, in den im inaktiven Fenster gewechselt werden soll, oder gibt ihn zurück.

[C++]
HRESULT get_Folder2(
  /*[out, retval]*/ BSTR* pbstrFolder
);
HRESULT put_Folder2(
  /*[in]*/ BSTR bstrFolder
);
[C#]
string Folder2 {get; set;}
[Visual Basic .NET]
Public Property Folder2() As String
[Delphi]
property Folder2: WideString read Get_Folder2 write Set_Folder2;

FolderFavorite-Objekt


FolderType (AppFolder-Objekt)

FolderType (AppFolder-Objekt)

Gibt den Typ des Ordners als scAppFolder-Konstante zurück.

[C++]
HRESULT get_FolderType(
  /*[out, retval]*/ scAppFolder* peAppFolder
);
[C#]
scAppFolder FolderType {get;}
[Visual Basic .NET]
Public ReadOnly Property FolderType() As scAppFolder
[Delphi]
property FolderType: scAppFolder read Get_FolderType;

AppFolder-Objekt, scAppFolder-Konstanten


FolderLayout (Workspace-Objekt)

FolderLayout (Workspace-Objekt)

Gibt an, ob die Ordnerfenster nebeneinander oder übereinander angezeigt werden sollen.

[C++]
HRESULT get_FolderLayout(
  /*[out, retval]*/ enum scFolderLayout* peFolderLayout
);
HRESULT put_FolderLayout(
  /*[in]*/ enum scFolderLayout eFolderLayout
);
[C#]
scFolderLayout FolderLayout {get; set;}
[Visual Basic .NET]
Public Property FolderLayout() As scFolderLayout
[Delphi]
property FolderLayout: scFolderLayout read Get_FolderLayout write Set_FolderLayout;

Workspace-Objekt, scFolderLayout-Konstanten


FolderWindows (TabWindow-Objekt)

FolderWindows (TabWindow-Objekt)

Gibt eine Auflistung der Ordnerfenster als FolderWindows-Objekt zurück.

[C++]
HRESULT get_FolderWindows(
  /*[out, retval]*/ IFolderWindows** ppFolderWindows
);
[C#]
FolderWindows FolderWindows {get;}
[Visual Basic .NET]
Public ReadOnly Property FolderWindows() As FolderWindows
[Delphi]
property FolderWindows: IFolderWindow2 read Get_FolderWindows;

TabWindow-Objekt, FolderWindows-Objekt


FullName (Application-Objekt)

FullName (Application-Objekt)

Gibt den vollständigen Dateinamen der Anwendung zurück.

[C++]
HRESULT get_FullName(
  /*[out, retval]*/ BSTR* pbstrFullName
);
[C#]
public string FullName {get;}
[Visual Basic .NET]
Public ReadOnly Property FullName() As String
[Delphi]
property FullName: WideString read Get_FullName;

Application-Objekt


GroupView (FolderWindow-Objekt)

GroupView (FolderWindow-Objekt)

Aktiviert bzw. deaktiviert die Gruppenansicht oder fragt sie ab.

[C++]
HRESULT get_GroupView(
  /*[out, retval]*/ VARIANT_BOOL* pfGroupView
);
HRESULT put_Folder(
  /*[in]*/ VARIANT_BOOL fGroupView
);
[C#]
bool GroupView {get; set;}
[Visual Basic .NET]
Public Property GroupView() As Boolean
[Delphi]
property GroupView: WordBool read Get_GroupView write Set_GroupView;

FolderWindow-Objekt


Guid (AddIn-Objekt)

Guid (AddIn-Objekt)

Gibt die Guid (Klassenbezeichnung) des AddIns zurück.

[C++]
HRESULT get_Guid(
  /*[out, retval]*/ BSTR* pbstrGuid
);
[C#]
string Guid {get;}
[Visual Basic .NET]
Public ReadOnly Property Guid() As String
[Delphi]
property Guid: WideString read Get_Guid;

AddIn-Objekt


Height (MainWindow-Objekt)

Height (MainWindow-Objekt)

Gibt die Höhe des Hauptfensters zurück oder legt sie fest.

[C++]
HRESULT get_Height(
  /*[out, retval]*/ long* pHeight
);
HRESULT put_Height(
  /*[in]*/ long nHeight
);
[C#]
int Height {get; set;}
[Visual Basic .NET]
Public Property Height() As Integer
[Delphi]
property Height: Integer read Get_Height write Set_Height;

MainWindow-Objekt


Parent (MainWindow-Objekt)

Parent (MainWindow-Objekt)

Gibt das Fensterhandle des Hauptfensters zurück.

[C++]
HRESULT get_HWnd(
  /*[out, retval]*/ HANDLE_PTR* ppApplication
);
[C#]
IntPtr Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property HWnd() As IntPtr
[Delphi]
property HWnd: LongWord read Get_HWnd;

MainWindow-Objekt


IconId (CommandBarControl-Objekt)

IconId (CommandBarControl-Objekt)

Gibt die ID des Icons zurück, welches für das Element gezeichnet werden soll, oder legt sie fest.

[C++]
HRESULT get_IconId(
  /*[out, retval]*/ long* pIconId
);
HRESULT put_IconId(
  /*[in]*/ long nIconId
);
[C#]
Integer IconId {get; set;}
[Visual Basic .NET]
Public Property IconId() As Integer
[Delphi]
property IconId: Integer read Get_IconId write Set_IconId;

CommandBarControl-Objekt, CommandBar-Objekt


ImageLarge (AddInCommand-Objekt)

ImageLarge (AddInCommand-Objekt)

Legt das große Symbol (24x24) für diesen Befehl fest, welches in der Symbolleiste angezeigt wird.

[C++]
HRESULT put_ImageLarge(
  /*[in]*/ IPictureDisp* pImage
);
[C#]
IPictureDisp ImageLarge {set;}
[Visual Basic .NET]
Public WriteOnly Property ImageLarge() As IPictureDisp
[Delphi]
property ImageLarge: IPictureDisp write Set_ImageLarge;

AddInCommand-Objekt


ImageSmall (AddInCommand-Objekt)

ImageSmall (AddInCommand-Objekt)

Legt das kleine Symbol (16x16) für diesen Befehl fest, welches in der Symbolleiste oder im Menü angezeigt wird.

[C++]
HRESULT put_ImageSmall(
  /*[in]*/ IPictureDisp* pImage
);
[C#]
IPictureDisp ImageSmall {set;}
[Visual Basic .NET]
Public WriteOnly Property ImageSmall() As IPictureDisp
[Delphi]
property ImageSmall: IPictureDisp write Set_ImageSmall;

AddInCommand-Objekt


InactiveWindow (Workspace-Objekt)

InactiveWindow (Workspace-Objekt)

Gibt ein TabWindow-Objekt für das inaktive Fenster zurück.

[C++]
HRESULT get_InactiveWindow(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow InactiveWindow {get;}
[Visual Basic .NET]
Public ReadOnly Property InactiveWindow() As TabWindow
[Delphi]
property InactiveWindow: ITabWindow read Get_InactiveWindow;

Workspace-Objekt, TabWindow-Objekt


Index (CommandBarControl-Objekt)

Index (CommandBarControl-Objekt)

Gibt den Index des Elements in der CommandBarControls-Auflistung zurück.

[C++]
HRESULT get_Index(
  /*[out, retval]*/ long* pIndex
);
[C#]
Integer Index {get;}
[Visual Basic .NET]
Public ReadOnly Property Index() As Integer
[Delphi]
property Index: Integer read Get_Index;

CommandBarControl-Objekt, CommandBar-Objekt


Index (FileContainer-Objekt)

Index (FileContainer-Objekt)

Gibt den Index des Objekts innerhalb der FileContainers-Auflistung zurück.

[C++]
HRESULT get_Index(
  /*[out, retval]*/ long* pnIndex
);
[C#]
int Index {get;}
[Visual Basic .NET]
Public ReadOnly Property Index() As Integer
[Delphi]
property Index: Integer read Get_Index;

FileContainer-Objekt, FileContainers-Objekt


Index (FolderFavorite-Objekt)

Index (FolderFavorite-Objekt)

Gibt den Index des Ordnerfavoriten innerhalb des FolderFavorites-Objekts zurück.

[C++]
HRESULT get_Index(
  /*[out, retval]*/ long* pIndex
);
[C#]
int Index {get;}
[Visual Basic .NET]
Public ReadOnly Property Index() As Integer
[Delphi]
property Index: Integer read Get_Index;

FolderFavorite-Objekt, FolderFavorites-Objekt


Index (FolderWindow-Objekt)

Index (FolderWindow-Objekt)

Gibt den Index des Objekts innerhalb der FolderWindows-Auflistung zurück.

[C++]
HRESULT get_Index(
  /*[out, retval]*/ long* pnIndex
);
[C#]
int Index {get;}
[Visual Basic .NET]
Public ReadOnly Property Index() As Integer
[Delphi]
property Index: Integer read Get_Index;

FolderWindow-Objekt, FolderWindows-Objekt


Index (UserTool-Objekt)

Index (UserTool-Objekt)

Gibt den Index des Anwendungsfavoriten innerhalb des UserTools-Objekts zurück.

[C++]
HRESULT get_Index(
  /*[out, retval]*/ long* pIndex
);
[C#]
int Index {get;}
[Visual Basic .NET]
Public ReadOnly Property Index() As Integer
[Delphi]
property Index: Integer read Get_Index;

UserTool-Objekt, UserTools-Objekt


InitialDir (UserTool-Objekt)

InitialDir (UserTool-Objekt)

Setzt den Startordner der Anwendung oder gibt ihn zurück.

[C++]
HRESULT get_InitialDir(
  /*[out, retval]*/ BSTR* pbstrInitialDir
);
HRESULT put_InitialDir(
  /*[in]*/ BSTR bstrInitialDir
);
[C#]
string InitialDir {get; set;}
[Visual Basic .NET]
Public Property InitialDir() As String
[Delphi]
property InitialDir: WideString read Get_InitialDir write Set_InitialDir;

UserTool-Objekt


IsActive (TabWindow-Objekt)

IsActive (TabWindow-Objekt)

Gibt an, ob das Fenster aktiv ist.

[C++]
HRESULT get_IsActive(
  /*[out, retval]*/ VARIANT_BOOL* pfIsActive
);
[C#]
bool IsActive {get;}
[Visual Basic .NET]
Public ReadOnly Property IsActive() As Boolean
[Delphi]
property IsActive: WordBool read Get_IsActive;

TabWindow-Objekt


IsAddInSite (AppFolder-Objekt)

IsAddInSite (AppFolder-Objekt)

Gibt an, ob der Ordner die oberste Ebene in der AddIn-Dateisystemansicht ist.

[C++]
HRESULT get_IsAddInSite(
  /*[out, retval]*/ VARIANT_BOOL* pfIsAddInSite
);
[C#]
bool IsAddInSite {get;}
[Visual Basic .NET]
Public ReadOnly Property IsAddInSite() As Boolean
[Delphi]
property IsAddInSite: WordBool read Get_IsAddInSite;

AppFolder-Objekt


IsArchive (AppFolder-Objekt)

IsArchive (AppFolder-Objekt)

Gibt an, ob der Ordner ein Archiv ist.

[C++]
HRESULT get_IsArchive(
  /*[out, retval]*/ VARIANT_BOOL* pfIsArchive
);
[C#]
bool IsArchive {get;}
[Visual Basic .NET]
Public ReadOnly Property IsArchive() As Boolean
[Delphi]
property IsArchive: WordBool read Get_IsArchive;

AppFolder-Objekt


IsFavorite (FolderFavorite-Objekt)

IsFavorite (FolderFavorite-Objekt)

Gibt an, ob der Eintrag ein Ordnerfavorit ist.

[C++]
HRESULT get_IsFavorite(
  /*[out, retval]*/ VARIANT_BOOL* pIsFavorite
);
[C#]
bool IsFavorite {get;}
[Visual Basic .NET]
Public ReadOnly Property IsFavorite() As Boolean
[Delphi]
property IsFavorite: WordBool read Get_IsFavorite;

FolderFavorite-Objekt


IsFtpSite (AppFolder-Objekt)

IsFtpSite (AppFolder-Objekt)

Gibt an, ob der Ordner die FTP-Standortansicht ist.

[C++]
HRESULT get_IsFtpSite(
  /*[out, retval]*/ VARIANT_BOOL* pfIsFtpSite
);
[C#]
bool IsFtpSite {get;}
[Visual Basic .NET]
Public ReadOnly Property IsFtpSite() As Boolean
[Delphi]
property IsFtpSite: WordBool read Get_IsFtpSite;

AppFolder-Objekt


IsRoot (AppFolder-Objekt)

IsRoot (AppFolder-Objekt)

Gibt an, ob der Ordner ein Hauptverzeichnis ist.

[C++]
HRESULT get_IsRoot(
  /*[out, retval]*/ VARIANT_BOOL* pfIsRoot
);
[C#]
bool IsRoot {get;}
[Visual Basic .NET]
Public ReadOnly Property IsRoot() As Boolean
[Delphi]
property IsRoot: WordBool read Get_IsRoot;

AppFolder-Objekt


IsSeparator (FolderFavorite-Objekt)

IsSeparator (FolderFavorite-Objekt)

Gibt an, ob der Eintrag ein Trennzeichen ist.

[C++]
HRESULT get_IsSeparator(
  /*[out, retval]*/ VARIANT_BOOL* pIsSeparator
);
[C#]
bool IsSeparator {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSeparator() As Boolean
[Delphi]
property IsSeparator: WordBool read Get_IsSeparator;

FolderFavorite-Objekt


IsSeparator (UserTool-Objekt)

IsSeparator (UserTool-Objekt)

Gibt an, ob der Eintrag ein Trennzeichen ist.

[C++]
HRESULT get_IsSeparator(
  /*[out, retval]*/ VARIANT_BOOL* pIsSeparator
);
[C#]
bool IsSeparator {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSeparator() As Boolean
[Delphi]
property IsSeparator: WordBool read Get_IsSeparator;

UserTool-Objekt


IsSubMenu (FolderFavorite-Objekt)

IsSubMenu (FolderFavorite-Objekt)

Gibt an, ob der Eintrag ein Untermenü ist.

[C++]
HRESULT get_IsSubMenu(
  /*[out, retval]*/ VARIANT_BOOL* pIsSubMenu
);
[C#]
bool IsSubMenu {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSubMenu() As Boolean
[Delphi]
property IsSubMenu: WordBool read Get_IsSubMenu;

FolderFavorite-Objekt


IsSubMenu (UserTool-Objekt)

IsSubMenu (UserTool-Objekt)

Gibt an, ob der Eintrag ein Untermenü ist.

[C++]
HRESULT get_IsSubMenu(
  /*[out, retval]*/ VARIANT_BOOL* pIsSubMenu
);
[C#]
bool IsSubMenu {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSubMenu() As Boolean
[Delphi]
property IsSubMenu: WordBool read Get_IsSubMenu;

UserTool-Objekt


IsSubMenuEnd (FolderFavorite-Objekt)

IsSubMenuEnd (FolderFavorite-Objekt)

Gibt an, ob der Eintrag der Abschluss eines Untermenüs ist.

[C++]
HRESULT get_IsSubMenuEnd(
  /*[out, retval]*/ VARIANT_BOOL* pIsSubMenuEnd
);
[C#]
bool IsSubMenuEnd {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSubMenuEnd() As Boolean
[Delphi]
property IsSubMenuEnd: WordBool read Get_IsSubMenuEnd;

FolderFavorite-Objekt


IsSubMenuEnd (UserTool-Objekt)

IsSubMenuEnd (UserTool-Objekt)

Gibt an, ob der Eintrag der Abschluss eines Untermenüs ist.

[C++]
HRESULT get_IsSubMenuEnd(
  /*[out, retval]*/ VARIANT_BOOL* pIsSubMenuEnd
);
[C#]
bool IsSubMenuEnd {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSubMenuEnd() As Boolean
[Delphi]
property IsSubMenuEnd: WordBool read Get_IsSubMenuEnd;

UserTool-Objekt


IsUserTool (UserTool-Objekt)

IsUserTool (UserTool-Objekt)

Gibt an, ob der Eintrag ein Anwendungsfavorit ist.

[C++]
HRESULT get_IsUserTool(
  /*[out, retval]*/ VARIANT_BOOL* pIsUserTool
);
[C#]
bool IsUserTool {get;}
[Visual Basic .NET]
Public ReadOnly Property IsUserTool() As Boolean
[Delphi]
property IsUserTool: WordBool read Get_IsUserTool;

UserTool-Objekt


IsVisible (FileContainer-Objekt)

IsVisible (FileContainer-Objekt)

Gibt an, ob die Dateiablage sichtbar ist.

[C++]
HRESULT get_IsVisible(
  [out, retval] VARIANT_BOOL* pfIsVisible
);
[C#]
bool IsVisible {get;}
[Visual Basic .NET]
Public ReadOnly Property IsVisible() As Boolean
[Delphi]
property IsVisible: WordBool read Get_IsVisible;

FileContainer-Objekt


IsVisible (FileContainers-Objekt)

IsVisible (FileContainers-Objekt)

Gibt an, ob die Dateiablagen sichtbar sind.

[C++]
HRESULT get_IsVisible(
  [out, retval] VARIANT_BOOL* pfIsVisible
);
[C#]
bool IsVisible {get;}
[Visual Basic .NET]
Public ReadOnly Property IsVisible() As Boolean
[Delphi]
property IsVisible: WordBool read Get_IsVisible;

FileContainers-Objekt


IsVisible (FolderWindow-Objekt)

IsVisible (FolderWindow-Objekt)

Gibt an, ob das Ordnerfenster sichtbar ist.

[C++]
HRESULT get_IsVisible(
  [out, retval] VARIANT_BOOL* pfIsVisible
);
[C#]
bool IsVisible {get;}
[Visual Basic .NET]
Public ReadOnly Property IsVisible() As Boolean
[Delphi]
property IsVisible: WordBool read Get_IsVisible;

FolderWindow-Objekt


IsVisible (FolderWindows-Objekt)

IsVisible (FolderWindows-Objekt)

Gibt an, ob die Ordnerfenster sichtbar sind.

[C++]
HRESULT get_IsVisible(
  [out, retval] VARIANT_BOOL* pfIsVisible
);
[C#]
bool IsVisible {get;}
[Visual Basic .NET]
Public ReadOnly Property IsVisible() As Boolean
[Delphi]
property IsVisible: WordBool read Get_IsVisible;

FolderWindows-Objekt


Items (FileContainer-Objekt)

Items (FileContainer-Objekt)

Gibt die Objekte einer Dateiablage in einer ListItems-Aufzählung zurück.

[C++]
HRESULT get_Items(
  /*[out, retval]*/ IListItems** ppListItems
);
[C#]
ListItems Items {get;}
[Visual Basic .NET]
Public ReadOnly Property Items() As ListItems
[Delphi]
property Items: IListItems read Get_Items;

FileContainer-Objekt, ListItems-Objekt


Items (FolderWindow-Objekt)

Items (FolderWindow-Objekt)

Gibt die Objekte im Ordnerfenster in einer ListItems-Aufzählung zurück.

[C++]
HRESULT get_Items(
  /*[out, retval]*/ IListItems** ppListItems
);
[C#]
ListItems Items {get;}
[Visual Basic .NET]
Public ReadOnly Property Items() As ListItems
[Delphi]
property Items: IListItems read Get_Items;

FolderWindow-Objekt, ListItems-Objekt


Left (MainWindow-Objekt)

Left (MainWindow-Objekt)

Gibt den Abstand zwischen dem linken Rand des Bildschirmes und dem linken Rand des Hauptfensters zurück oder legt ihn fest.

[C++]
HRESULT get_Left(
  /*[out, retval]*/ long* pLeft
);
HRESULT put_Left(
  /*[in]*/ long nLeft
);
[C#]
int Left {get; set;}
[Visual Basic .NET]
Public Property Left() As Integer
[Delphi]
property Left: Integer read Get_Left write Set_Left;

MainWindow-Objekt


ListView (FolderWindow-Objekt)

ListView (FolderWindow-Objekt)

Setzt den Modus für die Listenansicht oder fragt ihn ab.

[C++]
HRESULT get_ListView(
  /*[out, retval]*/ enum scListView* peListView
);
HRESULT put_ListView(
  /*[in]*/ enum scListView eListView
);
[C#]
scListView ListView {get; set;}
[Visual Basic .NET]
Public Property ListView() As scListView
[Delphi]
property ListView: scListView read Get_ListView write Set_ListView;

FolderWindow-Objekt, scListView-Konstanten


LocaleID (Application-Objekt)

LocaleID (Application-Objekt)

Gibt die Sprache der Benutzeroberfläche zurück.

[C++]
HRESULT get_LocaleID(
  /*[out, retval]*/ long* pLocaleID
);
[C#]
public int LocaleID {get;}
[Visual Basic .NET]
Public ReadOnly Property LocaleID() As Integer
[Delphi]
property LocaleID: Integer read Get_LocaleID;

Application-Objekt


LocalOrUncFolder (AppFolder-Objekt)

LocalOrUncFolder (AppFolder-Objekt)

Gibt den vollständigen Ordnernamen zurück, wenn der Ordner ein lokaler Ordner oder ein Netzwerkordner ist.

[C++]
HRESULT get_LocalOrUncFolder(
  /*[out, retval]*/ BSTR* pbstrLocalOrUncFolder
);
[C#]
string LocalOrUncFolder {get;}
[Visual Basic .NET]
Public ReadOnly Property LocalOrUncFolder() As String
[Delphi]
property LocalOrUncFolder: WideString read Get_LocalOrUncFolder;

AppFolder-Objekt


Name (AddInCommand-Objekt)

Name (AddInCommand-Objekt)

Gibt den Namen des Befehls zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
[C#]
string Name {get;}
[Visual Basic .NET]
Public ReadOnly Property Name() As String
[Delphi]
property Name: WideString read Get_Name;

AddInCommand-Objekt


Name (Application-Objekt)

Name (Application-Objekt)

Gibt den Namen der Anwendung zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
[C#]
public string Name {get;}
[Visual Basic .NET]
Public ReadOnly Property Name() As String
[Delphi]
property Name: WideString read Get_Name;

Application-Objekt


Name (FileContainer-Objekt)

Name (FileContainer-Objekt)

Setzt den Namen der Dateiablage oder gibt ihn zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
HRESULT put_Name(
  /*[in]*/ BSTR bstrName
);
[C#]
string Name {get; set;}
[Visual Basic .NET]
Public Property Name() As String
[Delphi]
property Name: WideString read Get_Name write Set_Name;

FileContainer-Objekt


Name (FolderFavorite-Objekt)

Name (FolderFavorite-Objekt)

Setzt den Anzeigenamen des Ordnerfavoriten oder gibt ihn zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
HRESULT put_Name(
  /*[in]*/ BSTR bstrName
);
[C#]
string Name {get; set;}
[Visual Basic .NET]
Public Property Name() As String
[Delphi]
property Name: WideString read Get_Name write Set_Name;

FolderFavorite-Objekt


Name (FolderWindow-Objekt)

Name (FolderWindow-Objekt)

Setzt den Namen des Ordnerfensters oder gibt ihn zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
HRESULT put_Name(
  /*[in]*/ BSTR bstrName
);
[C#]
string Name {get; set;}
[Visual Basic .NET]
Public Property Name() As String
[Delphi]
property Name: WideString read Get_Name write Set_Name;

FolderWindow-Objekt


Name (UserTool-Objekt)

Name (UserTool-Objekt)

Setzt den Anzeigenamen des Anwendungsfavoriten oder gibt ihn zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
HRESULT put_Name(
  /*[in]*/ BSTR bstrName
);
[C#]
string Name {get; set;}
[Visual Basic .NET]
Public Property Name() As String
[Delphi]
property Name: WideString read Get_Name write Set_Name;

UserTool-Objekt


ParentFolder (MultiRename-Objekt)

ParentFolder (MultiRename-Objekt)

Legt den Elternordner fest oder gibt ihn zurück.

[C++]
HRESULT get_ParentFolder(
  /*[out, retval]*/ BSTR* pbstrParentFolder
);
HRESULT put_ParentFolder(
  /*[in]*/ BSTR bstrParentFolder
);
[C#]
string ParentFolder {get; set;}
[Visual Basic .NET]
Public Property ParentFolder() As String
[Delphi]
property ParentFolder: WideString read Get_ParentFolder write Set_ParentFolder;

MultiRename-Objekt


Path (Application-Objekt)

Path (Application-Objekt)

Gibt den Pfad zurück, in dem die Anwendung installiert ist.

[C++]
HRESULT get_Path(
  /*[out, retval]*/ BSTR* pbstrPath
);
[C#]
public string Path {get;}
[Visual Basic .NET]
Public ReadOnly Property Path() As String
[Delphi]
property Path: WideString read Get_Path;

Application-Objekt


PathName (ListItem-Objekt)

PathName (ListItem-Objekt)

Gibt den vollständigen Dateinamen zurück.

[C++]
HRESULT get_PathName(
  /*[out, retval]*/ BSTR* pbstrPathName
);
[C#]
string PathName {get;}
[Visual Basic .NET]
Public ReadOnly Property PathName() As String
[Delphi]
property PathName: WideString read Get_PathName;

ListItem-Objekt


Position (CommandBar-Objekt)

Position (CommandBar-Objekt)

Setzt die Position der Symbolleiste oder gibt diese zurück.

[C++]
HRESULT get_Position(
  /*[out, retval]*/ enum scCommandBarPosition* pPosition
);
HRESULT put_Position(
  /*[in]*/ enum scCommandBarPosition ePosition
);
[C#]
scCommandBarPosition Position {get; set;}
[Visual Basic .NET]
Public Property Position() As scCommandBarPosition
[Delphi]
property Position: scCommandBarPosition read Get_Position write Set_Position;

CommandBar-Objekt, scCommandBarPosition-Konstanten


ProgID (AddIn-Objekt)

ProgID (AddIn-Objekt)

Gibt die ProgID des AddIns zurück.

[C++]
HRESULT get_ProgID(
  /*[out, retval]*/ BSTR* pbstrProgID
);
[C#]
string ProgID {get;}
[Visual Basic .NET]
Public ReadOnly Property ProgID() As String
[Delphi]
property ProgID: WideString read Get_ProgID;

AddIn-Objekt


ProgID (AddInCommand-Objekt)

ProgID (AddInCommand-Objekt)

Gibt die ProgID des AddIns zurück, welches das AddInCommand-Objekt erstellt hat.

[C++]
HRESULT get_ProgID(
  /*[out, retval]*/ BSTR* pbstrProgID
);
[C#]
string ProgID {get;}
[Visual Basic .NET]
Public ReadOnly Property ProgID() As String
[Delphi]
property ProgID: WideString read Get_ProgID;

AddInCommand-Objekt


Replace (MultiRename-Objekt)

Replace (MultiRename-Objekt)

Legt den Modus für das Ersetzen von Text fest oder gibt ihn zurück.

[C++]
HRESULT get_Replace(
  /*[out, retval]*/ scMrtReplace* eReplace
);
HRESULT put_Replace(
  /*[in]*/ scMrtReplace eReplace
);
[C#]
scMrtReplace Replace {get; set;}
[Visual Basic .NET]
Public Property Replace() As scMrtReplace
[Delphi]
property Replace: scMrtReplace read Get_Replace write Set_Replace;

MultiRename-Objekt, scMrtReplace-Konstanten


ReplaceWith (MultiRename-Objekt)

ReplaceWith (MultiRename-Objekt)

Legt den Text fest, der den zu suchenden Text ersetzen soll oder gibt ihn zurück.

[C++]
HRESULT get_ReplaceWith(
  /*[out, retval]*/ BSTR* pbstrReplaceWith
);
HRESULT put_ReplaceWith(
  /*[in]*/ BSTR bstrReplaceWith
);
[C#]
string ReplaceWith {get; set;}
[Visual Basic .NET]
Public Property ReplaceWith() As String
[Delphi]
property ReplaceWith: WideString read Get_ReplaceWith write Set_ReplaceWith;

MultiRename-Objekt


SearchFor (MultiRename-Objekt)

SearchFor (MultiRename-Objekt)

Legt den zu suchenden Text fest oder gibt ihn zurück.

[C++]
HRESULT get_SearchFor(
  /*[out, retval]*/ BSTR* pbstrSearchFor
);
HRESULT put_SearchFor(
  /*[in]*/ BSTR bstrSearchFor
);
[C#]
string SearchFor {get; set;}
[Visual Basic .NET]
Public Property SearchFor() As String
[Delphi]
property SearchFor: WideString read Get_SearchFor write Set_SearchFor;

MultiRename-Objekt


Selected (ListItem-Objekt)

Selected (ListItem-Objekt)

Setzt den Auswahlzustand eines Eintrags oder gibt ihn zurück.

[C++]
HRESULT get_Selected(
  /*[out, retval]*/ VARIANT_BOOL* pSelected
);
HRESULT put_Selected(
  /*[in]*/ VARIANT_BOOL fSelected
);
[C#]
bool Selected {get; set;}
[Visual Basic .NET]
Public Property Selected() As Boolean
[Delphi]
property Selected: WordBool read Get_Selected write Set_Selected;

ListItem-Objekt


SelectedItems (FileContainer-Objekt)

SelectedItems (FileContainer-Objekt)

Gibt die ausgewählten Objekte einer Dateiablage in einer ListItems-Aufzählung zurück.

[C++]
HRESULT get_SelectedItems(
  /*[out, retval]*/ IListItems** ppListItems
);
[C#]
ListItems SelectedItems {get;}
[Visual Basic .NET]
Public ReadOnly Property SelectedItems() As ListItems
[Delphi]
property SelectedItems: IListItems read Get_SelectedItems;

FileContainer-Objekt, ListItems-Objekt


SelectedItems (FolderWindow-Objekt)

SelectedItems (FolderWindow-Objekt)

Gibt die ausgewählten Objekte im Ordnerfenster in einer ListItems-Aufzählung zurück.

[C++]
HRESULT get_SelectedItems(
  /*[out, retval]*/ IListItems** ppListItems
);
[C#]
ListItems SelectedItems {get;}
[Visual Basic .NET]
Public ReadOnly Property SelectedItems() As ListItems
[Delphi]
property SelectedItems: IListItems read Get_SelectedItems;

FolderWindow-Objekt, ListItems-Objekt


Selection (FileContainer-Objekt)

Selection (FileContainer-Objekt)

Gibt ein ListSelection-Objekt zum Auswählen von Objekten in der Dateiablage zurück.

[C++]
HRESULT get_Selection(
  /*[out, retval]*/ IListSelection** ppListSelection
);
[C#]
ListSelection Selection {get;}
[Visual Basic .NET]
Public ReadOnly Property Selection() As ListSelection
[Delphi]
property Selection: IListSelection read Get_Selection;

FileContainer-Objekt, ListSelection-Objekt


Selection (FolderWindow-Objekt)

Selection (FolderWindow-Objekt)

Gibt ein ListSelection-Objekt zum Auswählen von Objekten im Ordnerfenster zurück.

[C++]
HRESULT get_Selection(
  /*[out, retval]*/ IListSelection** ppListSelection
);
[C#]
ListSelection Selection {get;}
[Visual Basic .NET]
Public ReadOnly Property Selection() As ListSelection
[Delphi]
property Selection: IListSelection read Get_Selection;

FolderWindow-Objekt, ListSelection-Objekt


Settings (AddIns-Objekt)

Settings (AddIns-Objekt)

Gibt AddInSettings-Objekt zurück, welches zum Speichern von Einstellungen genutzt werden kann.

[C++]
HRESULT get_Settings(
  /*[out, retval]*/ IAddInSettings** ppAddInSettings
);
[C#]
AddInSettings Settings {get;}
[Visual Basic .NET]
Public ReadOnly Property Settings() As AddInSettings
[Delphi]
property Settings: IAddInSettings read Get_Settings;

AddIns-Objekt, AddInSettings-Objekt


ShortFileName (ListItem-Objekt)

ShortFileName (ListItem-Objekt)

Gibt den relativen Dateinamen (ohne Pfad) in 8.3-Konvention zurück.

[C++]
HRESULT get_ShortFileName(
  /*[out, retval]*/ BSTR* pbstrShortFileName
);
[C#]
string ShortFileName {get;}
[Visual Basic .NET]
Public ReadOnly Property ShortFileName() As String
[Delphi]
property ShortFileName: WideString read Get_ShortFileName;

ListItem-Objekt


ShortPathName (ListItem-Objekt)

ShortPathName (ListItem-Objekt)

Gibt den vollständigen Dateinamen in 8.3-Konvention zurück.

[C++]
HRESULT get_ShortPathName(
  /*[out, retval]*/ BSTR* pbstrShortPathName
);
[C#]
string ShortPathName {get;}
[Visual Basic .NET]
Public ReadOnly Property ShortPathName() As String
[Delphi]
property ShortPathName: WideString read Get_ShortPathName;

ListItem-Objekt


ShortPathNames (UserTool-Objekt)

ShortPathNames (UserTool-Objekt)

Legt fest, dass die der Anwendung übergebenen Objekte im 8.3-Format erfolgen soll.

[C++]
HRESULT get_ShortPathNames(
  /*[out, retval]*/ VARIANT_BOOL* pShortPathNames
);
HRESULT put_ShortPathNames(
  /*[in]*/ VARIANT_BOOL fShortPathNames
);
[C#]
bool ShortPathNames {get; set;}
[Visual Basic .NET]
Public Property ShortPathNames() As Boolean
[Delphi]
property ShortPathNames: WordBool read Get_ShortPathNames write Set_ShortPathNames;

UserTool-Objekt


ShowCmd (UserTool-Objekt)

ShowCmd (UserTool-Objekt)

Setzt den Startmodus der Anwendung oder gibt ihn zurück. Gültige Werte sind SW_SHOWNORMAL (1), SW_SHOWMINIMIZED (2) und SW_SHOWMAXIMIZED (3).

[C++]
HRESULT get_ShowCmd(
  /*[out, retval]*/ long* pShowCmd
);
HRESULT put_ShowCmd(
  /*[in]*/ long iShowCmd
);
[C#]
int ShowCmd {get; set;}
[Visual Basic .NET]
Public Property ShowCmd() As Integer
[Delphi]
property ShowCmd: Integer read Get_ShowCmd write Set_ShowCmd;

UserTool-Objekt


ShowFileContainers (TabWindow-Objekt)

ShowFileContainers (TabWindow-Objekt)

Gibt an, ob die Dateiablagen als Registerkarte angezeigt werden sollen.

[C++]
HRESULT get_ShowFileContainers(
  /*[out, retval]*/ VARIANT_BOOL* pfShowFileContainers
);
HRESULT put_ShowFileContainers(
  /*[in]*/ VARIANT_BOOL fShowFileContainers
);
[C#]
bool ShowFileContainers {get; set;}
[Visual Basic .NET]
Public Property ShowFileContainers() As Boolean
[Delphi]
property ShowFileContainers: WordBool read Get_ShowFileContainers write Set_ShowFileContainers;

TabWindow-Objekt


Size (ListItem-Objekt)

Size (ListItem-Objekt)

Gibt die Größe der Datei zurück.

[C++]
HRESULT get_Attributes(
  /*[out, retval]*/ VARIANT* pvSize
);
[C#]
object Size {get;}
[Visual Basic .NET]
Public ReadOnly Property Size() As Object
[Delphi]
property Size: OleVariant read Get_Size;

ListItem-Objekt


Splitter (Workspace-Objekt)

Splitter (Workspace-Objekt)

Setzt die Splitterposition zwischen den beiden Fenstern bzw. fragt sie ab.

[C++]
HRESULT get_Splitter(
  /*[out, retval]*/ VARIANT_BOOL* pnSplitter
);
HRESULT put_Splitter(
  /*[in]*/ VARIANT_BOOL nSplitter
);
[C#]
int Splitter {get; set;}
[Visual Basic .NET]
Public Property Splitter() As Integer
[Delphi]
property Splitter: Integer read Get_Splitter write Set_Splitter;

Workspace-Objekt


Splitter1 (FolderWindow-Objekt)

Splitter1 (FolderWindow-Objekt)

Setzt die Splitterposition zwischen Listenansicht und Baumansicht bzw. fragt sie ab.

[C++]
HRESULT get_Splitter1(
  /*[out, retval]*/ long* pnSplitter1
);
HRESULT put_Splitter1(
  /*[in]*/ long nSplitter1
);
[C#]
int Splitter1 {get; set;}
[Visual Basic .NET]
Public Property Splitter1() As Integer
[Delphi]
property Splitter1: Integer read Get_Splitter1 write Set_Splitter1;

FolderWindow-Objekt


Splitter2 (FolderWindow-Objekt)

Splitter2 (FolderWindow-Objekt)

Setzt die Splitterposition zwischen Listenansicht und Baumansicht bzw. fragt sie ab.

[C++]
HRESULT get_Splitter2(
  /*[out, retval]*/ long* pnSplitter2
);
HRESULT put_Splitter2(
  /*[in]*/ long nSplitter2
);
[C#]
int Splitter2 {get; set;}
[Visual Basic .NET]
Public Property Splitter2() As Integer
[Delphi]
property Splitter2: Integer read Get_Splitter2 write Set_Splitter2;

FolderWindow-Objekt


StatusWindow (FolderWindow-Objekt)

StatusWindow (FolderWindow-Objekt)

Aktiviert oder deaktiviert das Statusfenster.

[C++]
HRESULT get_StatusWindow(
  /*[out, retval]*/ VARIANT_BOOL* pfStatusWindow
);
HRESULT put_Folder(
  /*[in]*/ VARIANT_BOOL fStatusWindow
);
[C#]
bool StatusWindow {get; set;}
[Visual Basic .NET]
Public Property StatusWindow() As Boolean
[Delphi]
property StatusWindow: WordBool read Get_StatusWindow write Set_StatusWindow;

FolderWindow-Objekt


Swapped (Workspace-Objekt)

Swapped (Workspace-Objekt)

Gibt an, ob die beiden Fenster getauscht sind. Im Normalfall ist erste Fenster links bzw. oben und zweite Fenster rechts bzw. unten.

[C++]
HRESULT get_Swapped(
  /*[out, retval]*/ VARIANT_BOOL* pSwapped
);
HRESULT put_Swapped(
  /*[in]*/ VARIANT_BOOL fSwapped
);
[C#]
bool Swapped {get; set;}
[Visual Basic .NET]
Public Property Swapped() As Boolean
[Delphi]
property Swapped: WordBool read Get_Swapped write Set_Swapped;

Workspace-Objekt


SynchronizeFolderWindows (TabWindow-Objekt)

SynchronizeFolderWindows (TabWindow-Objekt)

Gibt an, ob die Ordnerfenster untereinander abgeglichen werden sollen.

[C++]
HRESULT get_SynchronizeFolderWindows(
  /*[out, retval]*/ VARIANT_BOOL* pfSynchronizeFolderWindows
);
HRESULT put_SynchronizeFolderWindows(
  /*[in]*/ VARIANT_BOOL fSynchronizeFolderWindows
);
[C#]
bool SynchronizeFolderWindows {get; set;}
[Visual Basic .NET]
Public Property SynchronizeFolderWindows() As Boolean
[Delphi]
property SynchronizeFolderWindows: WordBool read Get_SynchronizeFolderWindows write Set_SynchronizeFolderWindows;

TabWindow-Objekt


TabProperties (FolderWindow-Objekt)

TabProperties (FolderWindow-Objekt)

Setzt verschiedene Registerkarten-Eigenschaften für das Ordnerfenster oder fragt sie ab.

[C++]
HRESULT get_TabProperties(
  /*[out, retval]*/ enum scTabProperties* peTabProperties
);
HRESULT put_TabProperties(
  /*[in]*/ enum scTabProperties eTabProperties
);
[C#]
scTabProperties TabProperties {get; set;}
[Visual Basic .NET]
Public Property TabProperties() As scTabProperties
[Delphi]
property TabProperties: scTabProperties read Get_TabProperties write Set_TabProperties;

FolderWindow-Objekt, scTabProperties-Konstanten


Window1 (Workspace-Objekt)

Window1 (Workspace-Objekt)

Gibt ein TabWindow-Objekt für das erste Fenster zurück.

[C++]
HRESULT get_Window1(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow Window1 {get;}
[Visual Basic .NET]
Public ReadOnly Property Window1() As TabWindow
[Delphi]
property Window1: ITabWindow read Get_Window1;

Workspace-Objekt, TabWindow-Objekt


Window2 (Workspace-Objekt)

Window2 (Workspace-Objekt)

Gibt ein TabWindow-Objekt für das zweite Fenster zurück.

[C++]
HRESULT get_Window2(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow Window2 {get;}
[Visual Basic .NET]
Public ReadOnly Property Window2() As TabWindow
[Delphi]
property Window2: ITabWindow read Get_Window2;

Workspace-Objekt, TabWindow-Objekt


Title (CommandBar-Objekt)

Title (CommandBar-Objekt)

Setzt den Titel der Symbolleiste oder gibt diesen zurück.

[C++]
HRESULT get_Title(
  /*[out, retval]*/ BSTR* pbstrTitle
);
HRESULT put_Title(
  /*[in]*/ BSTR bstrTitle
);
[C#]
public string Title {get; set;}
[Visual Basic .NET]
Public Property Title() As String
[Delphi]
property Title: WideString read Get_Title write Set_Title;

CommandBar-Objekt


Top (MainWindow-Objekt)

Top (MainWindow-Objekt)

Gibt den Abstand zwischen dem oberen Rand des Bildschirmes und dem oberen Rand des Hauptfensters zurück oder legt ihn fest.

[C++]
HRESULT get_Top(
  /*[out, retval]*/ long* pTop
);
HRESULT put_Top(
  /*[in]*/ long nTop
);
[C#]
int Top {get; set;}
[Visual Basic .NET]
Public Property Top() As Integer
[Delphi]
property Top: Integer read Get_Top write Set_Top;

MainWindow-Objekt


Tooltip (CommandBarControl-Objekt)

Tooltip (CommandBarControl-Objekt)

Setzt den Text für ein anzuzeigendes InfoTip-Fenster oder gibt ihn zurück.

[C++]
HRESULT get_Tooltip(
  /*[out, retval]*/ BSTR* pbstrTooltip
);
HRESULT put_Tooltip(
  /*[in]*/ BSTR bstrTooltip
);
[C#]
string Tooltip {get; set;}
[Visual Basic .NET]
Public Property Tooltip() As String
[Delphi]
property Tooltip: WideString read Get_Tooltip write Set_Tooltip;

CommandBarControl-Objekt, CommandBar-Objekt


TreeView (FolderWindow-Objekt)

TreeView (FolderWindow-Objekt)

Aktiviert oder deaktiviert die Baumansicht.

[C++]
HRESULT get_TreeView(
  /*[out, retval]*/ VARIANT_BOOL* pfTreeView
);
HRESULT put_Folder(
  /*[in]*/ VARIANT_BOOL fTreeView
);
[C#]
bool TreeView {get; set;}
[Visual Basic .NET]
Public Property TreeView() As Boolean
[Delphi]
property TreeView: WordBool read Get_TreeView write Set_TreeView;

FolderWindow-Objekt


UrlHostName (AppFolder-Objekt)

UrlHostName (AppFolder-Objekt)

Gibt den Namen des Servers zurück, wenn der Ordner eine Internet- oder AddIn-Adresse ist.

[C++]
HRESULT get_UrlHostName(
  /*[out, retval]*/ BSTR* pbstrUrlHostName
);
[C#]
string UrlHostName {get;}
[Visual Basic .NET]
Public ReadOnly Property UrlHostName() As String
[Delphi]
property UrlHostName: WideString read Get_UrlHostName;

AppFolder-Objekt


UrlPath (AppFolder-Objekt)

UrlPath (AppFolder-Objekt)

Gibt den Pfadanteil zurück, wenn der Ordner eine Internet- oder AddIn-Adresse ist.

[C++]
HRESULT get_UrlPath(
  /*[out, retval]*/ BSTR* pbstrUrlPath
);
[C#]
string UrlPath {get;}
[Visual Basic .NET]
Public ReadOnly Property UrlPath() As String
[Delphi]
property UrlPath: WideString read Get_UrlPath;

AppFolder-Objekt


Version (Application-Objekt)

Version (Application-Objekt)

Gibt die Versionsnummer vom SpeedCommander zurück.

[C++]
HRESULT get_Version(
  /*[out, retval]*/ BSTR* pbstrVersion
);
[C#]
public string Version {get;}
[Visual Basic .NET]
Public ReadOnly Property Version() As String
[Delphi]
property Version: WideString read Get_Version;

Application-Objekt


Visible (CommandBar-Objekt)

Visible (CommandBar-Objekt)

Setzt die Sichtbarkeit der Symbolleiste oder gibt diese zurück.

[C++]
HRESULT get_Visible(
  /*[out, retval]*/ VARIANT_BOOL* pVisible
);
HRESULT put_Visible(
  /*[in]*/ VARIANT_BOOL fVisible
);
[C#]
bool Visible {get; set;}
[Visual Basic .NET]
Public Property Visible() As Boolean
[Delphi]
property Visible: WordBool read Get_Visible write Set_Visible;

CommandBar-Objekt


Visible (CommandBarControl-Objekt)

Visible (CommandBarControl-Objekt)

Gibt an oder legt fest, ob das Element sichtbar ist.

[C++]
HRESULT get_Visible(
  /*[out, retval]*/ VARIANT_BOOL* pVisible
);
HRESULT put_Visible(
  /*[in]*/ VARIANT_BOOL fVisible
);
[C#]
bool Visible {get; set;}
[Visual Basic .NET]
Public Property Visible() As Boolean
[Delphi]
property Visible: WordBool read Get_Visible write Set_Visible;

CommandBarControl-Objekt, CommandBar-Objekt


Visible (MainWindow-Objekt)

Visible (MainWindow-Objekt)

Setzt die Sichtbarkeit des Hauptfensters oder gibt diese zurück.

[C++]
HRESULT get_Visible(
  /*[out, retval]*/ VARIANT_BOOL* pVisible
);
HRESULT put_Visible(
  /*[in]*/ VARIANT_BOOL fVisible
);
[C#]
bool Visible {get; set;}
[Visual Basic .NET]
Public Property Visible() As Boolean
[Delphi]
property Visible: WordBool read Get_Visible write Set_Visible;

MainWindow-Objekt


Width (CommandBar-Objekt)

Width (CommandBar-Objekt)

Setzt die Breite der Symbolleiste oder gibt diese zurück.

[C++]
HRESULT get_Width(
  /*[out, retval]*/ long* pWidth
);
HRESULT put_Width(
  /*[in]*/ long nWidth
);
[C#]
int Width {get; set;}
[Visual Basic .NET]
Public Property Width() As Integer
[Delphi]
property Width: Integer read Get_Width write Set_Width;

CommandBar-Objekt


Width (MainWindow-Objekt)

Width (MainWindow-Objekt)

Gibt die Breite des Hauptfensters zurück oder legt sie fest.

[C++]
HRESULT get_Width(
  /*[out, retval]*/ long* pWidth
);
HRESULT put_Width(
  /*[in]*/ long nWidth
);
[C#]
int Width {get; set;}
[Visual Basic .NET]
Public Property Width() As Integer
[Delphi]
property Width: Integer read Get_Width write Set_Width;

MainWindow-Objekt


Activate (FileContainer-Objekt)

Activate (FileContainer-Objekt)
Aktiviviert die Dateiablage.
[C++]
HRESULT __stdcall Activate();
[C#]
public void Activate();
[Visual Basic .NET]
Public Sub Activate()
[Delphi]
procedure Activate(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainer-Objekt


Activate (FileContainers-Objekt)

Activate (FileContainers-Objekt)
Aktiviviert die Dateiablagen.
[C++]
HRESULT __stdcall Activate();
[C#]
public void Activate();
[Visual Basic .NET]
Public Sub Activate()
[Delphi]
procedure Activate(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainers-Objekt


Activate (FolderWindow-Objekt)

Activate (FolderWindow-Objekt)

Aktiviert das Ordnerfenster.

[C++]
HRESULT __stdcall Activate();
[C#]
public void Activate();
[Visual Basic .NET]
Public Sub Activate()
[Delphi]
procedure Activate(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindow-Objekt


Activate (FolderWindows-Objekt)

Activate (FolderWindows-Objekt)

Aktiviert die Ordnerfenster.

[C++]
HRESULT __stdcall Activate();
[C#]
public void Activate();
[Visual Basic .NET]
Public Sub Activate()
[Delphi]
procedure Activate(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindows-Objekt


Activate (TabWindow-Objekt)

Activate (TabWindow-Objekt)
Aktiviert das Fenster.
[C++]
HRESULT __stdcall Activate();
[C#]
public void Activate();
[Visual Basic .NET]
Public Sub Activate()
[Delphi]
procedure Activate(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

TabWindow-Objekt


Add (AddInCommands-Objekt)

Add (AddInCommands-Objekt)

Erstellt einen neuen Befehl. Wenn bereits ein Befehl mit diesem Namen existiert, so wird der Befehl nicht neu erstellt. Stattdessen wird der existierende Befehl zurückgegeben.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ IAddIn* pAddIn,
  /*[in]*/ BSTR bstrCommandName,
  /*[out, retval]*/ IAddInCommand** ppAddInCommand
);
[C#]
public AddInCommand Add(
  AddIn pAddIn,
  string bstrCommandName
);
[Visual Basic .NET]
Public Function Add( _
  ByVal pAddIn As AddIn, _
  ByVal bstrCommandName As String _
) As AddInCommand
[Delphi]
function Add(
  const pAddIn: IAddIn;
  const bstrCommandName: WideString
): IAddInCommand; safecall;

Parameter

pAddIn
Erforderlich. AddIn-Objekt, welches den Befehl erstellt.
bstrCommandName
Erforderlich. Der Name des neuen Befehls. Der Name muss eindeutig sein, empfohlen wird, den Kurznamen des AddIns voranzustellen (z.B. SampleAddIn.NeuerBefehl).

Rückgabewert

Gibt ein AddInCommand-Objekt zurück.

AddInCommands-Objekt


Add (CommandBarControls-Objekt)

Add (CommandBarControls-Objekt)

Erstellt ein neues Objekt und fügt es in die Symbolleiste ein.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ long nId,
  /*[in]*/ BSTR bstrCaption,
  /*[in, optional]*/ VARIANT varType,
  /*[in, optional]*/ VARIANT varBefore,
  /*[in, optional]*/ VARIANT varTemporary,
  /*[out, retval]*/ ICommandBarControl** ppCommandBarControl
);
[C#]
public CommandBarControl Add(
  int nId,
  string bstrCaption,
  object varType,
  object varBefore,
  object varTemporary
);
[Visual Basic .NET]
Public Function Add( _
  ByVal nId As Integer, _
  ByVal bstrCaption As String, _
  Optional ByVal varType As Object, _
  Optional ByVal varBefore As Object, _
  Optional ByVal varTemporary As Object _
) As CommandBarControl
[Delphi]
function Add(
  nId: Integer;
  const bstrCaption: WideString;
  varType: OleVariant;
  varBefore: OleVariant;
  varTemporary: OleVariant
): ICommandBarControl; safecall;

Parameter

nId
Erforderlich. Die ID für das hinzuzufügende Element.
bstrCaption
Erforderlich. Der Name für das hinzuzufügende Element.
varType
Optional. Der Typ für das hinzuzufügende Element (siehe scCommandBarControlType-Konstanten).
varBefore
Optional. Der Index eines existierenden Elements, vor dem das neue Element eingefügt werden soll.
varTemporary
Optional. Legt fest, ob das neue Element nur temporär ist oder beim Beenden von SpeedCommander gespeichert werden soll.

Rückgabewert

Gibt ein CommandBarControl-Objekt zurück.

CommandBarControls-Objekt, CommandBarControl-Objekt


Add (CommandBars-Objekt)

Add (CommandBars-Objekt)

Erstellt eine neue Symbolleiste.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ BSTR bstrTitle,
  /*[out, retval]*/ ICommandBar** ppCommandBar
);
[C#]
public CommandBar Add(
  string bstrTitle
);
[Visual Basic .NET]
Public Function Add( _
  ByVal bstrTitle As String _
) As CommandBar
[Delphi]
function Add(
  const bstrTitle: WideString
): ICommandBar; safecall;

Parameter

bstrTitle
Erforderlich. Der Name für die zu erstellende Symbolleiste.

Rückgabewert

Gibt ein CommandBar-Objekt zurück.

CommandBars-Objekt, CommandBar-Objekt


Add (FileContainers-Objekt)

Add (FileContainers-Objekt)

Erstellt eine neue Dateiablage.

[C++]
HRESULT __stdcall Add(
  /*[out, retval]*/ IFileContainer** ppFileContainer
);
[C#]
public FileContainer Add();
[Visual Basic .NET]
Public Function Add() As FileContainer
[Delphi]
function Add(): IFileContainer; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Gibt ein FileContainer-Objekt zurück.

FileContainers-Objekt, FileContainer-Objekt


Add (FolderFavorites-Objekt)

Add (FolderFavorites-Objekt)

Fügt dem Ordnerfavoriten-Menü einen neuen Ordnerfavoriten hinzu.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ BSTR bstrName,
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IFolderFavorite** ppFolderFavorite
);
[C#]
public FolderFavorite Add(
  string bstrName,
  object iInsertAt
);
[Visual Basic .NET]
Public Function Add( _
  ByVal bstrName As String, _
  ByVal iInsertAt As Object _
) As FolderFavorite
[Delphi]
function Add(
  const bstrName: WideString;
  iInsertAt: OleVariant
): IFolderFavorite; safecall;

Parameter

bstrName
Erforderlich. Der Name des neuen Ordnerfavoriten.
iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein FolderFavorite-Objekt zurück.

FolderFavorites-Objekt, FolderFavorite-Objekt


Add (FolderWindows-Objekt)

Add (FolderWindows-Objekt)

Erstellt ein neues Ordnerfenster.

[C++]
HRESULT __stdcall Add(
  /*[out, retval]*/ IFolderWindow** ppFolderWindow
);
[C#]
public FolderWindow Add();
[Visual Basic .NET]
Public Function Add() As FolderWindow
[Delphi]
function Add(): IFolderWindow; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Gibt ein FolderWindow-Objekt zurück.

FolderWindows-Objekt, FolderWindow-Objekt


Add (MultiRename-Objekt)

Add (MultiRename-Objekt)

Fügt der aktuellen Auswahl einen Dateinamen oder alle Dateinamen eines ListItems-Objekts hinzu.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ VARIANT varFileName
);
[C#]
public void Add(
  object varFileName
);
[Visual Basic .NET]
Public Sub Add( _
  ByVal varFileName As Object _
)
[Delphi]
procedure Add(
  varFileName: OleVariant
); safecall;

Parameter

varName
Erforderlich. Dateiname als String oder ein ListItems-Objekt.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

MultiRename-Objekt, ListItems-Objekt


Add (UserTools-Objekt)

Add (UserTools-Objekt)

Fügt dem Anwendungsfavoriten-Menü einen neuen Anwendungsfavoriten hinzu.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ BSTR bstrName,
  /*[in]*/ BSTR bstrCommand,
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IUserTool** ppUserTool
);
[C#]
public UserTool Add(
  string bstrName,
  string bstrCommand,
  object iInsertAt
);
[Visual Basic .NET]
Public Function Add( _
  ByVal bstrName As String, _
  ByVal bstrCommand As String, _
  ByVal iInsertAt As Object _
) As UserTool
[Delphi]
function Add(
  const bstrName: WideString;
  const bstrCommand: WideString;
  iInsertAt: OleVariant
): IUserTool; safecall;

Parameter

bstrName
Erforderlich. Der Name des neuen Anwendungsfavoriten.
bstrCommand
Erforderlich. Der auszuführende Befehl des neuen Anwendungsfavoriten.
iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein UserTool-Objekt zurück.

UserTools-Objekt, UserTool-Objekt


AddImage (Application-Objekt)

AddImage (Application-Objekt)

Fügt das angegebene Symbol zur Systemimageliste hinzu.

[C++]
HRESULT __stdcall AddImage(
  /*[in]*/ BSTR bstrIconPath,
  /*[in]*/ long iIconIndex,
  /*[in]*/ long dwFlags,
  /*[out, retval] long* pIndex
);
[C#]
public int AddImage(
  string bstrIconPath,
  int iIconIndex,
  int dwFlags
);
[Visual Basic .NET]
Public Function AddImage( _
  ByVal bstrIconPath As String, _
  ByVal iIconIndex As Integer, _
  ByVal dwFlags As Integer _
) As Integer
[Delphi]
procedure AddImage(
  const bstrIconPath: WideString;
  iIconIndex: Integer;
  dwFlags: Integer
): Integer; safecall;

Parameter

bstrIconPath
Erforderlich. Der Name des ausführbaren Moduls, welches das Symbol enthält.
iIconIndex
Erforderlich. Der Index des Symbols im ausführbaren Modul oder der Ressourcenname als negativer Wert.
dwFlags
Erforderlich. Flags für die Funktion Shell_GetCachedImageIndex (GIL_DONTCACHE und/oder GIL_COMPARE).

Rückgabewert

Index des Symbols in der Systemimageliste oder -1 bei einem Fehler.

Application-Objekt


AddMenu (FolderFavorites-Objekt)

AddMenu (FolderFavorites-Objekt)

Erstellt einen neuen Menüeintrag.

[C++]
HRESULT __stdcall AddMenu(
  /*[in]*/ BSTR bstrName,
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IFolderFavorite** ppFolderFavorite
);
[C#]
public FolderFavorite AddMenu(
  string bstrName,
  object iInsertAt
);
[Visual Basic .NET]
Public Function AddMenu( _
  ByVal bstrName As String, _
  ByVal iInsertAt As Object _
) As FolderFavorite
[Delphi]
function AddMenu(
  const bstrName: WideString;
  iInsertAt: OleVariant
): IFolderFavorite; safecall;

Parameter

bstrName
Erforderlich. Der Name des neuen Menüeintrages.
iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein FolderFavorite-Objekt zurück.

FolderFavorites-Objekt, FolderFavorite-Objekt


AddMenu (UserTools-Objekt)

AddMenu (UserTools-Objekt)

Erstellt einen neuen Menüeintrag.

[C++]
HRESULT __stdcall AddMenu(
  /*[in]*/ BSTR bstrName,
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IUserTool** ppUserTool
);
[C#]
public UserTool AddMenu(
  string bstrName,
  object iInsertAt
);
[Visual Basic .NET]
Public Function AddMenu( _
  ByVal bstrName As String, _
  ByVal iInsertAt As Object _
) As UserTool
[Delphi]
function AddMenu(
  const bstrName: WideString;
  iInsertAt: OleVariant
): IUserTool; safecall;

Parameter

bstrName
Erforderlich. Der Name des neuen Menüeintrages.
iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein UserTool-Objekt zurück.

UserTools-Objekt, UserTool-Objekt


AddSeparator (FolderFavorites-Objekt)

AddSeparator (FolderFavorites-Objekt)

Fügt dem Ordnerfavoriten-Menü ein neues Trennzeichen hinzu.

[C++]
HRESULT __stdcall AddSeparator(
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IFolderFavorite** ppFolderFavorite
);
[C#]
public FolderFavorite AddSeparator(
  object iInsertAt
);
[Visual Basic .NET]
Public Function AddSeparator( _
  ByVal iInsertAt As Object _
) As FolderFavorite
[Delphi]
function AddSeparator(
  iInsertAt: OleVariant
): IFolderFavorite; safecall;

Parameter

iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein FolderFavorite-Objekt zurück.

FolderFavorites-Objekt, FolderFavorite-Objekt


AddSeparator (UserTools-Objekt)

AddSeparator (UserTools-Objekt)

Fügt dem Anwendungsfavoriten-Menü ein neues Trennzeichen hinzu.

[C++]
HRESULT __stdcall AddSeparator(
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IUserTool** ppUserTool
);
[C#]
public UserTool AddSeparator(
  object iInsertAt
);
[Visual Basic .NET]
Public Function AddSeparator( _
  ByVal iInsertAt As Object _
) As UserTool
[Delphi]
function AddSeparator(
  iInsertAt: OleVariant
): IUserTool; safecall;

Parameter

iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein UserTool-Objekt zurück.

UserTools-Objekt, UserTool-Objekt


Close (FileContainer-Objekt)

Close (FileContainer-Objekt)

Schließt die Dateiablage.

[C++]
HRESULT __stdcall Close();
[C#]
public void Close();
[Visual Basic .NET]
Public Sub Close()
[Delphi]
procedure Close(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainer-Objekt


Close (FolderWindow-Objekt)

Close (FolderWindow-Objekt)

Schließt das Ordnerfenster.

[C++]
HRESULT __stdcall Close();
[C#]
public void Close();
[Visual Basic .NET]
Public Sub Close()
[Delphi]
procedure Close(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindow-Objekt


CloseAll (FileContainers-Objekt)

CloseAll (FileContainers-Objekt)

Entfernt alle Dateiablagen bis auf die aktive Dateiablage.

[C++]
HRESULT __stdcall CloseAll();
[C#]
public void CloseAll();
[Visual Basic .NET]
Public Sub CloseAll()
[Delphi]
procedure CloseAll(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainers-Objekt


CloseAll (FolderWindows-Objekt)

CloseAll (FolderWindows-Objekt)

Entfernt alle Ordnerfenster bis auf das aktive Ordnerfenster.

[C++]
HRESULT __stdcall CloseAll();
[C#]
public void CloseAll();
[Visual Basic .NET]
Public Sub CloseAll()
[Delphi]
procedure CloseAll(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindows-Objekt


Delete (CommandBar-Objekt)

Delete (CommandBar-Objekt)

Löscht eine Symbolleiste.

[C++]
HRESULT __stdcall Delete();
[C#]
public void Delete();
[Visual Basic .NET]
Public Sub Delete()
[Delphi]
procedure Delete; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

CommandBar-Objekt


Delete (CommandBarControl-Objekt)

Delete (CommandBarControl-Objekt)

Löscht ein Element.

[C++]
HRESULT __stdcall Delete();
[C#]
public void Delete();
[Visual Basic .NET]
Public Sub Delete()
[Delphi]
procedure Delete; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

CommandBarControl-Objekt


EmptySection (AddInSettings-Objekt)

EmptySection (AddInSettings-Objekt)

Löscht eine Sektion aus der XML-Datei von SpeedCommander.

[C++]
HRESULT __stdcall EmptySection(
  /*[in]*/ BSTR bstrProgID,
  /*[in]*/ BSTR bstrSection
);
[C#]
public void EmptySection(
  string bstrProgID,
  string bstrSection
);
[Visual Basic .NET]
Public Sub EmptySection( _
  ByVal bstrProgID As String, _
  ByVal bstrSection As String _
)
[Delphi]
procedure EmptySection(
  const bstrProgID: WideString;
  const bstrSection: WideString
); safecall;

Parameter

bstrProgID
Erforderlich. ProgID des AddIns, für welches die Sektion gelöscht werden soll..
bstrSection
Erforderlich. Die zu löschende Sektion.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

AddInSettings-Objekt


EnableDocking (CommandBar-Objekt)

EnableDocking (CommandBar-Objekt)

Legt fest, ob und wie eine Symbolleiste angedockt werden kann.

[C++]
HRESULT __stdcall EnableDocking(
  /*[in]*/ enum scCommandBarFlags dwFlags
);
[C#]
public void EnableDocking(
  scCommandBarFlags dwFlags
);
[Visual Basic .NET]
Public Sub EnableDocking( _
  ByVal dwFlags As scCommandBarFlags _
)
[Delphi]
procedure EnableDocking(
  dwFlags: scCommandBarFlags
); safecall;

Parameter

dwFlags
Erforderlich. Gibt die Seiten an, an denen die Symbolleiste angedockt werden kann.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

CommandBar-Objekt, scCommandBarFlags-Konstanten


ExecuteCommand (Application-Objekt)

ExecuteCommand (Application-Objekt)

Führt den angegebenen Befehl aus.

[C++]
HRESULT __stdcall ExecuteCommand(
  /*[in]*/ enum scCommand eCommand
);
[C#]
public void ExecuteCommand(
  scCommand eCommand
);
[Visual Basic .NET]
Public Sub ExecuteCommand( _
  ByVal eCommand As scCommand _
)
[Delphi]
procedure ExecuteCommand(
  eCommand: scCommand
); safecall;

Parameter

eCommand
Erforderlich. Gibt den aufzurufenden Befehl an.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

Application-Objekt, scCommand-Konstanten


FindControl (CommandBar-Objekt)

FindControl (CommandBar-Objekt)

Sucht ein Element in der Symbolleiste.

[C++]
HRESULT __stdcall FindControl(
  /*[in]*/ long nId,
  /*[in, optional]*/ VARIANT varType,
  /*[in, optional]*/ VARIANT varVisible,
  /*[in, optional]*/ VARIANT varRecursive,
  /*[out, retval]*/ ICommandBarControl** ppCommandBarControl
);
[C#]
public CommandBarControl FindControl(
  System.Int32 nId,
  System.Object varType,
  System.Object varVisible,
  System.Object varRecursive
);
[Visual Basic .NET]
Public Function FindControl( _
  ByVal nId As Integer, _
  Optional ByVal varType As Object, _
  Optional ByVal varVisible As Object, _
  Optional ByVal varRecursive As Object _
)
[Delphi]
function FindControl(
  nId: Integer;
  varType: OleVariant;
  varVisible: OleVariant;
  varRecursive: OleVariant
): ICommandBarControl; safecall;

Parameter

nID
Erforderlich. Gibt die ID des gesuchten Elements an.
varType
Optional. Gibt den Typ des gesuchten Elements an (siehe scCommandBarControlType-Konstanten).
varVisible
Optional. Gibt an, ob das Element sichtbar sein soll.
varRecursive
Optional. Gibt an, ob auch in den untergeordneten CommandBar-Objekten gesucht werden soll.

Rückgabewert

Gibt ein CommandBarControl-Objekt zurück.

CommandBar-Objekt, CommandBarControl-Objekt


FindControl (CommandBarControls-Objekt)

FindControl (CommandBarControls-Objekt)

Sucht ein Element in der Symbolleiste.

[C++]
HRESULT __stdcall FindControl(
  /*[in]*/ long nId,
  /*[in, optional]*/ VARIANT varType,
  /*[in, optional]*/ VARIANT varVisible,
  /*[in, optional]*/ VARIANT varRecursive,
  /*[out, retval]*/ ICommandBarControl** ppCommandBarControl
);
[C#]
public CommandBarControl FindControl(
  System.Int32 nId,
  System.Object varType,
  System.Object varVisible,
  System.Object varRecursive
);
[Visual Basic .NET]
Public Function FindControl( _
  ByVal nId As Integer, _
  Optional ByVal varType As Object, _
  Optional ByVal varVisible As Object, _
  Optional ByVal varRecursive As Object _
)
[Delphi]
function FindControl(
  nId: Integer;
  varType: OleVariant;
  varVisible: OleVariant;
  varRecursive: OleVariant
): ICommandBarControl; safecall;

Parameter

nID
Erforderlich. Gibt die ID des gesuchten Elements an.
varType
Optional. Gibt den Typ des gesuchten Elements an (siehe scCommandBarControlType-Konstanten).
varVisible
Optional. Gibt an, ob das Element sichtbar sein soll.
varRecursive
Optional. Gibt an, ob auch in den untergeordneten CommandBar-Objekten gesucht werden soll.

Rückgabewert

Gibt ein CommandBarControl-Objekt zurück.

CommandBarControls-Objekt, CommandBarControl-Objekt


GetEvents (Application-Objekt)

GetEvents (Application-Objekt)

Ermöglicht den Zugriff auf alle Ereignisse des Erweiterungsmodells.

[C++]
HRESULT __stdcall GetEvents(
  /*[in]*/ enum scEvents eEvents,
  /*[out, retval] IDispatch** ppInterface
);
[C#]
public object GetEvents(
  scEvents eEvents
);
[Visual Basic .NET]
Public Function GetEvents( _
  ByVal eEvents As scEvents _
) As Object
[Delphi]
function GetEvents(
  eEvents: scEvents
): IDispatch; safecall;

Parameter

eObject
Erforderlich. Gibt das Ereignisobjekt an, welches abgefragt werden soll.

Rückgabewert

Gibt das gewünschte Ereignisobjekt zurück.

Application-Objekt, scEvents-Konstanten


GetObject (Application-Objekt)

GetObject (Application-Objekt)

Gibt ein bestimmtes Anwendungsobjekt zurück.

[C++]
HRESULT __stdcall GetObject(
  /*[in]*/ enum scObject eObject,
  /*[out, retval] IDispatch** ppInterface
);
[C#]
public object GetObject(
  scObject eObject
);
[Visual Basic .NET]
Public Function GetObject( _
  ByVal eObject As scObject _
) As Object
[Delphi]
function GetObject(
  eObject: scObject
): IDispatch; safecall;

Parameter

eObject
Erforderlich. Gibt das Objekt an, welches abgefragt werden soll.

Rückgabewert

Gibt das gewünschte Objekt zurück.

Application-Objekt, scObject-Konstanten


Help (Application-Objekt)

Help (Application-Object)

Ruft die Hilfedatei auf.

[C++]
HRESULT __stdcall Help();
[C#]
public void Help();
[Visual Basic .NET]
Public Sub Help()
[Delphi]
procedure Help; safecall;

Parameter

Diese Methode benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

Application-Objekt


Invert (ListSelection-Objekt)

Invert (ListSelection-Objekt)

Invertiert die Auswahl.

[C++]
HRESULT __stdcall Invert();
[C#]
public void Invert();
[Visual Basic .NET]
Public Sub Invert()
[Delphi]
procedure Invert; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


Invoke (FolderFavorite-Objekt)

Invoke (FolderFavorite-Objekt)

Aktiviert den Ordnerfavoriten. Entsprechend der gesetzten Eigenschaften werden die Ordner im aktiven und/oder inaktiven Ordnerfenster geändert.

[C++]
HRESULT __stdcall Invoke();
[C#]
public void Invoke();
[Visual Basic .NET]
Public Sub Invoke()
[Delphi]
procedure Invoke; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderFavorite-Objekt


Invoke (UserTool-Objekt)

Invoke (UserTool-Objekt)

Startet den Anwendungsfavoriten.

[C++]
HRESULT __stdcall Invoke();
[C#]
public void Invoke();
[Visual Basic .NET]
Public Sub Invoke()
[Delphi]
procedure Invoke; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

UserTool-Objekt


Item (AddInCommands-Objekt)

Item (AddInCommands-Objekt)

Gibt eine bestimmtes Objekt (AddInCommand-Objekt) innerhalb der Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IAddInCommand** ppAddInCommand
);
[C#]
public AddInCommand Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As AddInCommand
[Delphi]
function Item(
  nIndex: Integer
): IAddInCommand; safecall;

Parameter

nIndex
Erforderlich. Der Index des Elements in der Auflistung.

Rückgabewert

Gibt ein AddInCommand-Objekt zurück.

AddInCommands-Objekt


Item (AddIns-Objekt)

Item (AddIns-Objekt)

Gibt eine bestimmtes Objekt (AddIn-Objekt) innerhalb der Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ VARIANT nIndex,
  /*[out, retval]*/ IAddIn** ppAddIn
);
[C#]
public AddIn Item(
  object nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Object _
) As AddIn
[Delphi]
function Item(
  nIndex: OleVariant
): IAddIn; safecall;

Parameter

nIndex
Erforderlich. Die ProgID des AddIns (String) oder der Index innerhalb der AddIn-Liste.

Rückgabewert

Gibt ein AddIn-Objekt zurück.

AddIns-Objekt, AddIn-Objekt


Item (CommandBarControls-Objekt)

Item (CommandBarControls-Objekt)

Gibt ein bestimmtes CommandBarControl-Objekt innerhalb der Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ ICommandBarControl** ppCommandBarControl
);
[C#]
public CommandBarControl Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As CommandBarControl
[Delphi]
function Item(
  nIndex: Integer
): ICommandBarControl; safecall;

Parameter

nIndex
Erforderlich. Der Index des Elements in der Auflistung.

Rückgabewert

Gibt ein CommandBarControl-Objekt zurück.

CommandBarControl-Objekt, CommandBarControls-Objekt


Item (CommandBars-Objekt)

Item (CommandBars-Objekt)

Gibt ein bestimmtes CommandBar-Objekt innerhalb der CommandBars-Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ ICommandBar** ppCommandBar
);
[C#]
public CommandBar Item(
  System.Int32 nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As CommandBar
[Delphi]
function Item(
  nIndex: Integer
): ICommandBar; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index der Symbolleiste.

Rückgabewert

Gibt ein CommandBar-Objekt zurück.

CommandBars-Objekt, CommandBar-Objekt


Item (FileContainers-Objekt)

Item (FileContainers-Objekt)

Gibt eine bestimmte Dateiablage innerhalb der Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IFileContainer** ppFileContainer
);
[C#]
public FileContainer Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As FileContainer
[Delphi]
function Item(
  nIndex: Integer
): IFileContainer; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index der Dateiablage.

Rückgabewert

Gibt ein FileContainer-Objekt zurück.

FileContainers-Objekt, FileContainer-Objekt


Item (FolderFavorites-Objekt)

Item (FolderFavorites-Objekt)

Gibt ein bestimmtes FolderFavorite-Objekt innerhalb der FolderFavorites-Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IFolderFavorite** ppFolderFavorite
);
[C#]
public FolderFavorite Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As FolderFavorite
[Delphi]
function Item(
  nIndex: Integer
): IFolderFavorite; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index des Ordnerfavoriten.

Rückgabewert

Gibt ein FolderFavorit-Objekt zurück.

FolderFavorites-Objekt, FolderFavorit-Objekt


Item (FolderWindows-Objekt)

Item (FolderWindows-Objekt)

Gibt ein bestimmtes Ordnerfenster innerhalb der Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IFolderWindow** ppFolderWindow
);
[C#]
public FolderWindow Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As FolderWindow
[Delphi]
function Item(
  nIndex: Integer
): IFolderWindow; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index des Ordnerfensters.

Rückgabewert

Gibt ein FolderWindow-Objekt zurück.

FolderWindows-Objekt, FolderWindow-Objekt


Item (ListItems-Objekt)

Item (ListItems-Objekt)

Gibt ein bestimmtes ListItem-Objekt innerhalb der ListItems-Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IListItem** ppListItem
);
[C#]
public ListItem Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As ListItem
[Delphi]
function Item(
  nIndex: Integer
): IListItem; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index des Eintrages.

Rückgabewert

Gibt ein ListItem-Objekt zurück.

ListItems-Objekt, ListItem-Objekt


Item (UserTools-Objekt)

Item (UserTools-Objekt)

Gibt ein bestimmtes UserTool-Objekt innerhalb der UserTools-Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IUserTool** ppUserTool
);
[C#]
public UserTool Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As UserTool
[Delphi]
function Item(
  nIndex: Integer
): IUserTool; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index des Anwendungsfavoriten.

Rückgabewert

Gibt ein UserTool-Objekt zurück.

UserTools-Objekt, UserTool-Objekt


MoveLeft (FileContainer-Objekt)

MoveLeft (FileContainer-Objekt)

Verschiebt die Dateiablage in der FileContainers-Auflistung um eine Position nach links.

[C++]
HRESULT __stdcall MoveLeft();
[C#]
public void MoveLeft();
[Visual Basic .NET]
Public Sub MoveLeft()
[Delphi]
procedure MoveLeft(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainer-Objekt , FileContainers-Objekt


MoveLeft (FolderWindow-Objekt)

MoveLeft (FolderWindow-Objekt)

Verschiebt das Ordnerfenster in der FolderWindows-Auflistung um eine Position nach links.

[C++]
HRESULT __stdcall MoveLeft();
[C#]
public void MoveLeft();
[Visual Basic .NET]
Public Sub MoveLeft()
[Delphi]
procedure MoveLeft(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindow-Objekt, FolderWindows-Objekt


MoveRight (FileContainer-Objekt)

MoveRight (FileContainer-Objekt)

Verschiebt die Dateiablage in der FileContainers-Auflistung um eine Position nach rechts.

[C++]
HRESULT __stdcall MoveRight();
[C#]
public void MoveRight();
[Visual Basic .NET]
Public Sub MoveRight()
[Delphi]
procedure MoveRight(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainer-Objekt, FileContainers-Objekt


MoveRight (FolderWindow-Objekt)

MoveRight (FolderWindow-Objekt)

Verschiebt das Ordnerfenster in der FolderWindows-Auflistung um eine Position nach rechts.

[C++]
HRESULT __stdcall MoveRight();
[C#]
public void MoveRight();
[Visual Basic .NET]
Public Sub MoveRight()
[Delphi]
procedure MoveRight(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindow-Objekt, FolderWindows-Objekt


Quit (Application-Objekt)

Quit (Application-Objekt)

Beendet die Anwendung.

[C++]
HRESULT __stdcall Quit();
[C#]
public void Quit();
[Visual Basic .NET]
Public Sub Quit()
[Delphi]
procedure Quit; safecall;

Parameter

Diese Methode benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

Application-Objekt


Read (AddInSettings-Objekt)

Read (AddInSettings-Objekt)

Liest eine AddIn-Einstellung aus der XML-Datei von SpeedCommander.

[C++]
HRESULT __stdcall Read(
  /*[in]*/ BSTR bstrProgID,
  /*[in]*/ BSTR bstrSection,
  /*[in]*/ BSTR bstrProp,
  /*[in]*/ VARTYPE varType,
  /*[out, retval]*/ VARIANT* pData
);
[C#]
public object Read(
  string bstrProgID,
  string bstrSection,
  string bstrProp,
  ushort varData
);
[Visual Basic .NET]
Public Function Read( _
  ByVal bstrProgID As String, _
  ByVal bstrSection As String, _
  ByVal bstrProp As String, _
  ByVal varData As UInt16 _
) As Object
[Delphi]
function Read(
  const bstrProgID: WideString;
  const bstrSection: WideString;
  const bstrProp: WideString;
  varData: Word
): OleVariant; safecall;

Parameter

bstrProgID
Erforderlich. ProgID des AddIns, für welches die Einstellung gelesen werden soll.
bstrSection
Erforderlich. Die Sektion, in welche die Einstellung gespeichert ist. Mehrere Sektionsnamen werden durch einen Backslash getrennt.
bstrProp
Erforderlich. Der Name der Eigenschaft.
varType
Erforderlich. Der Datentyp für die zu lesende Einstellung. Gültige Werte sind VT_BSTR, VT_DATE, VTI4 und VTI8.

Rückgabewert

Gibt eine VARIANT-Struktur zurück.

AddInSettings-Objekt


Refresh (FolderWindow-Objekt)

Refresh (FolderWindow-Objekt)

Aktualisiert das Ordnerfenster.

[C++]
HRESULT __stdcall Refresh();
[C#]
public void Refresh();
[Visual Basic .NET]
Public Sub Refresh()
[Delphi]
procedure Refresh(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindow-Objekt


Remove (AddInCommands-Objekt)

Remove (AddInCommands-Objekt)

Löscht einen Befehl.

[C++]
HRESULT __stdcall Remove(
  /*[in]*/ BSTR bstrCommandName
);
[C#]
public void Remove(
  string bstrCommandName
);
[Visual Basic .NET]
Public Sub Remove( _
  ByVal bstrCommandName As String _
)
[Delphi]
procedure Remove(
  const bstrCommandName: WideString
); safecall;

Parameter

bstrCommandName
Erforderlich. Der Name des Befehls.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

AddInCommands-Objekt


Remove (FolderFavorite-Objekt)

Remove (FolderFavorite-Objekt)

Löscht den Ordnerfavoriten.

[C++]
HRESULT __stdcall Remove();
[C#]
public void Remove();
[Visual Basic .NET]
Public Sub Remove()
[Delphi]
procedure Remove; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderFavorite-Objekt


Remove (UserTool-Objekt)

Remove (UserTool-Objekt)

Löscht den Anwendungsfavoriten.

[C++]
HRESULT __stdcall Remove();
[C#]
public void Remove();
[Visual Basic .NET]
Public Sub Remove()
[Delphi]
procedure Remove; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

UserTool-Objekt


RemoveAll (FolderFavorites-Objekt)

RemoveAll (FolderFavorites-Objekt)

Löscht alle Ordnerfavoriten.

[C++]
HRESULT __stdcall RemoveAll();
[C#]
public void RemoveAll();
[Visual Basic .NET]
Public Sub RemoveAll()
[Delphi]
procedure RemoveAll; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderFavorites-Objekt


RemoveAll (MultiRename-Objekt)

RemoveAll (MultiRename-Objekt)

Entfernt alle Dateien aus der Liste der umzubenennenden Dateien.

[C++]
HRESULT __stdcall RemoveAll();
[C#]
public void RemoveAll();
[Visual Basic .NET]
Public Sub RemoveAll()
[Delphi]
procedure RemoveAll; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

MultiRename-Objekt


RemoveAll (UserTools-Objekt)

RemoveAll (UserTools-Objekt)

Löscht alle Anwendungsfavoriten.

[C++]
HRESULT __stdcall RemoveAll();
[C#]
public void RemoveAll();
[Visual Basic .NET]
Public Sub RemoveAll()
[Delphi]
procedure RemoveAll; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

UserTools-Objekt


Rename (MultiRename-Objekt)

Rename (MultiRename-Objekt)

Benennt alle Dateien, die sich in der Dateiliste befinden, entsprechend den gewählten Einstellungen um.

[C++]
HRESULT __stdcall Rename(
  /*[out, retval]*/ scMrtResult eResult
);
[C#]
public scMrtResult Rename();
[Visual Basic .NET]
Public Function Rename() As scMrtResult
[Delphi]
function Rename: scMrtResult; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Das Ergebnis der Aktion als scMrtResult-Konstante.

MultiRename-Objekt, scMrtResult-Konstanten


Restore (ListSelection-Objekt)

Restore (ListSelection-Objekt)

Stellt die zuletzt gespeicherte Auswahl wieder her.

[C++]
HRESULT __stdcall Restore();
[C#]
public void Restore();
[Visual Basic .NET]
Public Sub Restore()
[Delphi]
procedure Restore; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


Save (FolderFavorites-Objekt)

Save (FolderFavorites-Objekt)

Speichert die Ordnerfavoriten.

[C++]
HRESULT __stdcall Save();
[C#]
public void Save();
[Visual Basic .NET]
Public Sub Save()
[Delphi]
procedure Save; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderFavorites-Objekt


Save (ListSelection-Objekt)

Save (ListSelection-Objekt)

Speichert eine Auswahl.

[C++]
HRESULT __stdcall Save();
[C#]
public void Save();
[Visual Basic .NET]
Public Sub Save()
[Delphi]
procedure Save; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


Save (UserTools-Objekt)

Save (UserTools-Objekt)

Speichert die Anwendungsfavoriten.

[C++]
HRESULT __stdcall Save();
[C#]
public void Save();
[Visual Basic .NET]
Public Sub Save()
[Delphi]
procedure Save; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

UserTools-Objekt


SaveSettings (AddInSettings-Objekt)

SaveSettings (AddInSettings-Objekt)

Schreibt alle gespeicherten Einstellungen in die XML-Datei.

[C++]
HRESULT __stdcall SaveSettings();
[C#]
public void SaveSettings();
[Visual Basic .NET]
Public Sub SaveSettings()
[Delphi]
procedure SaveSettings; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

AddInSettings-Objekt


Select (ListSelection-Objekt)

Select (ListSelection-Objekt)

Wählt Dateien und Ordner anhand einer Maske aus.

[C++]
HRESULT __stdcall Select(
  /*[in]*/ BSTR bstrMask
);
[C#]
public void Select(
  string bstrMask
);
[Visual Basic .NET]
Public Sub Select(
  ByVal bstrMask As String
)
[Delphi]
procedure Select(
  const bstrMask: WideString
); safecall;

Parameter

bstrMask
Erforderlich. Dateimaske, nach welcher die Dateien markiert werden soll. Die Dateimaske kann auch Stellvertreterzeichen enthalten.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


SelectAll (ListSelection-Objekt)

SelectAll (ListSelection-Objekt)

Wählt alle Dateien und Ordner aus.

[C++]
HRESULT __stdcall SelectAll();
[C#]
public void SelectAll();
[Visual Basic .NET]
Public Sub SelectAll()
[Delphi]
procedure SelectAll; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


SelectAllFiles (ListSelection-Objekt)

SelectAllFiles (ListSelection-Objekt)

Wählt alle Dateien aus.

[C++]
HRESULT __stdcall SelectAllFiles();
[C#]
public void SelectAllFiles();
[Visual Basic .NET]
Public Sub SelectAllFiles()
[Delphi]
procedure SelectAllFiles; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


Unselect (ListSelection-Objekt)

Unselect (ListSelection-Objekt)

Entfernt die Auswahl für bestimmte Dateien anhand einer Maske.

[C++]
HRESULT __stdcall Unselect(
  /*[in]*/ BSTR bstrMask
);
[C#]
public void Unselect(
  string bstrMask
);
[Visual Basic .NET]
Public Sub Unselect(
  ByVal bstrMask As String
)
[Delphi]
procedure Unselect(
  const bstrMask: WideString
); safecall;

Parameter

bstrMask
Erforderlich. Dateimaske, nach welcher die Markierung aufgehoben werden soll. Die Dateimaske kann auch Stellvertreterzeichen enthalten.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


UnselectAll (ListSelection-Objekt)

UnselectAll (ListSelection-Objekt)

Entfernt die Auswahl für alle Dateien und Ordner.

[C++]
HRESULT __stdcall UnselectAll();
[C#]
public void UnselectAll();
[Visual Basic .NET]
Public Sub UnselectAll()
[Delphi]
procedure UnselectAll; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


UnselectAllFiles (ListSelection-Objekt)

UnselectAllFiles (ListSelection-Objekt)

Entfernt die Auswahl für alle Dateien.

[C++]
HRESULT __stdcall UnselectAllFiles();
[C#]
public void UnselectAllFiles();
[Visual Basic .NET]
Public Sub UnselectAllFiles()
[Delphi]
procedure UnselectAllFiles; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


Write (AddInSettings-Objekt)

Write (AddInSettings-Objekt)

Speichert eine AddIn-Einstellung.

[C++]
HRESULT __stdcall Write(
  /*[in]*/ BSTR bstrProgID,
  /*[in]*/ BSTR bstrSection,
  /*[in]*/ BSTR bstrProp,
  /*[in]*/ VARIANT varData
);
[C#]
public void Write(
  string bstrProgID,
  string bstrSection,
  string bstrProp,
  object varData
);
[Visual Basic .NET]
Public Sub Write( _
  ByVal bstrProgID As String, _
  ByVal bstrSection As String, _
  ByVal bstrProp As String, _
  ByVal varData As Object _
)
[Delphi]
procedure Write(
  const bstrProgID: WideString;
  const bstrSection: WideString;
  const bstrProp: WideString;
  varData: OleVariant
); safecall;

Parameter

bstrProgID
Erforderlich. ProgID des AddIns, für welches die Einstellung gespeichert werden soll.
bstrSection
Erforderlich. Die Sektion, in welcher die Einstellung gespeichert wird. Mehrere Sektionsnamen werden durch einen Backslash getrennt.
bstrProp
Erforderlich. Der Name der zu speichernden Eigenschaft.
varData
Erforderlich. Der Wert für die zu speichernde Eigenschaft als Variant. Gültige Werte für die Variant-Struktur sind VT_BSTR, VT_DATE, VTI4 und VTI8.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

AddInSettings-Objekt


AfterExecute (CommandEvents-Objekt)

AfterExecute (CommandEvents-Objekt)

Tritt nach der Ausführung eines Befehls ein.

[C++]
HRESULT __stdcall AfterExecute(
  /*[in]*/ enum scCommand eCommand
);
[C#]
public void AfterExecute(
  scCommand eCommand
);
[Visual Basic .NET]
Public Sub AfterExecute( _
  ByVal eCommand As scCommand _
)
[Delphi]
procedure AfterExecute(
  eCommand: scCommand
); safecall;

Parameter

eCommand
Erforderlich. Gibt den aufzurufenden Befehl an.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

CommandEvents-Objekt, scCommand-Konstanten


BeforeExecute (CommandEvents-Objekt)

BeforeExecute (CommandEvents-Objekt)

Tritt vor der Ausführung eines Befehls ein.

[C++]
HRESULT __stdcall BeforeExecute(
  /*[in]*/ enum scCommand eCommand,
  /*[out]*/ VARIANT_BOOL* pfCancelDefault
);
[C#]
public void BeforeExecute(
  scCommand eCommand,
  ref bool pfCancelDefault
);
[Visual Basic .NET]
Public Sub BeforeExecute( _
  ByVal eCommand As scCommand, _
  ByRef pfCancelDefault As Boolean _
)
[Delphi]
procedure BeforeExecute(
  eCommand: scCommand,
  var pfCancelDefault: WordBool
); safecall;

Parameter

eCommand
Erforderlich. Gibt den aufzurufenden Befehl an.
pfCancelDefault
Erforderlich. Gibt VARIANT_FALSE zurück, wenn der Standardbefehl nicht aufgerufen werden soll.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

CommandEvents-Objekt, scCommand-Konstanten


WindowActivated (FileContainerEvents-Objekt)

WindowActivated (FileContainerEvents-Objekt)

Tritt ein, wenn eine Dateiablage den Fokus erhält.

[C++]
HRESULT __stdcall WindowActivated(
  /*[in]*/ IFileContainer* pWndGotFocus,
  /*[in]*/ IFileContainer* pWndLostFocus
);
[C#]
public void WindowActivated(
  FileContainer pWndGotFocus,
  FileContainer pWndLostFocus
);
[Visual Basic .NET]
Public Sub WindowActivated( _
  ByVal pWndGotFocus As FileContainer, _
  ByVal pWndLostFocus As FileContainer _
)
[Delphi]
procedure WindowActivated(
  pWndGotFocus: IFileContainer;
  pWndLostFocus: IFileContainer
); safecall;

Parameter

pWndGotFocus
Erforderlich. Die Dateiablage, welche den Fokus erhalten hat.
pWndLostFocus
Erforderlich. Die Dateiablage, welche zuvor über den Fokus verfügt hat.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainerEvents-Objekt, FileContainer-Objekt


WindowActivated (FolderWindowEvents-Objekt)

WindowActivated (FolderWindowEvents-Objekt)

Tritt ein, wenn ein Ordnerfenster den Fokus erhält.

[C++]
HRESULT __stdcall WindowActivated(
  /*[in]*/ IFolderWindow* pWndGotFocus,
  /*[in]*/ IFolderWindow* pWndLostFocus
);
[C#]
public void WindowActivated(
  FolderWindow pWndGotFocus,
  FolderWindow pWndLostFocus
);
[Visual Basic .NET]
Public Sub WindowActivated( _
  ByVal pWndGotFocus As FolderWindow, _
  ByVal pWndLostFocus As FolderWindow _
)
[Delphi]
procedure WindowActivated(
  pWndGotFocus: IFolderWindow;
  pWndLostFocus: IFolderWindow
); safecall;

Parameter

pWndGotFocus
Erforderlich. Das Ordnerfenster, welches den Fokus erhalten hat.
pWndLostFocus
Erforderlich. Das Ordnerfenster, welches zuvor über den Fokus verfügt hat.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindowEvents-Objekt, FolderWindow-Objekt


WindowActivated (TabWindowEvents-Objekt)

WindowActivated (TabWindowEvents-Objekt)

Tritt ein, wenn ein Fenster den Fokus erhält.

[C++]
HRESULT __stdcall WindowActivated(
  /*[in]*/ ITabWindow* pWndGotFocus,
  /*[in]*/ ITabWindow* pWndLostFocus
);
[C#]
public void WindowActivated(
  TabWindow pWndGotFocus,
  TabWindow pWndLostFocus
);
[Visual Basic .NET]
Public Sub WindowActivated( _
  ByVal pWndGotFocus As TabWindow, _
  ByVal pWndLostFocus As TabWindow _
)
[Delphi]
procedure WindowActivated(
  pWndGotFocus: ITabWindow;
  pWndLostFocus: ITabWindow
); safecall;

Parameter

pWndGotFocus
Erforderlich. Das Fenster, welches den Fokus erhalten hat.
pWndLostFocus
Erforderlich. Das Fenster, welches zuvor über den Fokus verfügt hat.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

TabWindowEvents-Objekt, TabWindow-Objekt


WindowClosing (FileContainerEvents-Objekt)

WindowClosing (FileContainerEvents-Objekt)

Tritt unmittelbar vor dem Schließen einer Dateiablage ein.

[C++]
HRESULT __stdcall WindowClosing(
  /*[in]*/ IFileContainer* pWndClosing
);
[C#]
public void WindowClosing(
  FileContainer pWndClosing
);
[Visual Basic .NET]
Public Sub WindowClosing( _
  ByVal pWndClosing As FileContainer _
)
[Delphi]
procedure WindowClosing(
  pWndClosing: IFileContainer
); safecall;

Parameter

pWndClosing
Erforderlich. Die Dateiablage, welche geschlossen wird.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainerEvents-Objekt, FileContainer-Objekt


WindowClosing (FolderWindowEvents-Objekt)

WindowClosing (FolderWindowEvents-Objekt)

Tritt unmittelbar vor dem Schließen eines Ordnerfensters ein.

[C++]
HRESULT __stdcall WindowClosing(
  /*[in]*/ IFolderWindow* pWndClosing
);
[C#]
public void WindowClosing(
  FolderWindow pWndClosing
);
[Visual Basic .NET]
Public Sub WindowClosing( _
  ByVal pWndClosing As FolderWindow _
)
[Delphi]
procedure WindowClosing(
  pWndClosing: IFolderWindow
); safecall;

Parameter

pWndClosing
Erforderlich. Das Ordnerfenster, welches geschlossen wird.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindowEvents-Objekt, FolderWindow-Objekt


WindowCreated (FileContainerEvents-Objekt)

WindowCreated (FileContainerEvents-Objekt)

Tritt beim Erstellen einer neuen Dateiablage ein.

[C++]
HRESULT __stdcall WindowCreated(
  /*[in]*/ IFileContainer* pWndCreated
);
[C#]
public void WindowCreated(
  FileContainer pWndCreated
);
[Visual Basic .NET]
Public Sub WindowCreated( _
  ByVal pWndCreated As FileContainer _
)
[Delphi]
procedure WindowCreated(
  pWndCreated: IFileContainer
); safecall;

Parameter

pWndCreated
Erforderlich. Die Dateiablage, welche erstellt wurde.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainerEvents-Objekt, FileContainer-Objekt


WindowCreated (FolderWindowEvents-Objekt)

WindowCreated (FolderWindowEvents-Objekt)

Tritt beim Erstellen eines neuen Ordnerfensters ein.

[C++]
HRESULT __stdcall WindowCreated(
  /*[in]*/ IFolderWindow* pWndCreated
);
[C#]
public void WindowCreated(
  FolderWindow pWndCreated
);
[Visual Basic .NET]
Public Sub WindowCreated( _
  ByVal pWndCreated As FolderWindow _
)
[Delphi]
procedure WindowCreated(
  pWndCreated: IFolderWindow
); safecall;

Parameter

pWndCreated
Erforderlich. Das Ordnerfenster, welches erstellt wurde.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindowEvents-Objekt, FolderWindow-Objekt


scAppFolder-Konstanten

scAppFolder-Konstanten

Diese Konstanten stellen den Typ eines Ordners dar.

Eigenschaften

Konstante | Wert | Beschreibung
scAppFolderUnknown | -1 | Der Typ des Ordners ist unbekannt.
scAppFolderLocal | 0 | Der Ordner befindet sich auf einem lokalen Laufwerk oder auf einem gemappten Netzwerklaufwerk.
scAppFolderNetwork | 1 | Der Ordner befindet sich innerhalb der Netzwerkumgebung.
scAppFolderHttp | 2 | Der Ordner stellt eine Web-Adresse dar.
scAppFolderFtp | 3 | Der Ordner befindet sich auf einem FTP-Server.
scAppFolderAddIn | 4 | Der Ordner befindet sich auf einem Dateisystem-AddIn.

AppFolder-Objekt


scCommand-Konstanten

scCommand-Konstanten

Diese Konstanten definieren die Menübefehle.

Eigenschaften

Menü "Datei"
scCommandFileView | 30103 | Startet den Dateibetrachter, um die gewählten Objekte anzuzeigen.
scCommandFileEdit | 30104 | Startet den Editor, um die gewählten Objekte zu editieren.
scCommandFileCopy | 30105 | Kopiert die gewählten Objekte.
scCommandFileMove | 30106 | Verschiebt die gewählten Objekte.
scCommandFileDelete | 30107 | Löscht die markierten Elemente.
scCommandFileDeleteRecycleBin | 30108 | Löscht die markierten Elemente in den Papierkorb.
scCommandFileDeleteSecure | 30109 | Löscht die gewählten Objekte sicher nach Regierungsrichtlinien.
scCommandFileRename | 30110 | Nennt das gewählte Objekt um.
scCommandFileSaveAs | 57604 | Speichert die Internetseite unter neuem Namen.
scCommandFileMultiRename | 30120 | Nennt eine Liste von gewählten Objekten um.
scCommandFileCompress | 30117 | Komprimiert die gewählten Objekte.
scCommandFileExtract | 30118 | Entpackt die gewählten Objekte.
scCommandFileSplit | 30116 | Trennt die gewählte Datei in mehrere Teile.
scCommandFileExecute | 30111 | Führt ein Programm aus.
scCommandFileExecuteDos | 30112 | Startet den DOS-Befehlsinterpreter.
scCommandFileProperties | 30113 | Zeigt die Eigenschaften der gewählten Objekte an.
scCommandFileMoreProperties | 30119 | Zeigt die erweiterten Eigenschaften der gewählten Objekte an.
scCommandFileSearch | 30114 | Startet ein Suchprogramm, um nach Dateien zu suchen.
scCommandFilePrint | 30115 | Druckt das gewählte Dokument.
scCommandFileAppExit | 57665 | Beendet die Anwendung.
Menü "Bearbeiten"
scCommandEditCopy | 57634 | Kopiert die Markierung und überträgt sie in die Zwischenablage.
scCommandEditCut | 57635 | Entfernt die Markierung und überträgt sie in die Zwischenablage.
scCommandEditPaste | 57637 | Fügt den Inhalt der Zwischenablage ein.
scCommandEditPasteAsShortcut | 30201 | Erstellt Verknüpfungen mit Objekten, die an die gewählte Stelle kopiert bzw. an dieser ausgeschnitten wurden.
scCommandEditSelectAll | 57642 | Wählt alle Objekte im Fenster aus.
scCommandEditSelectAllFiles | 30210 | Wählt alle Dateien im Fenster aus.
scCommandEditSelectSome | 30211 | Wählt einige Objekte im Fenster aus.
scCommandEditSelectCurrentExt | 30214 | Wählt alle Dateien, die den gleichen Dateityp haben wie die aktuelle Datei.
scCommandEditUnselectAll | 30215 | Entfernt die gesamte Auswahl.
scCommandEditUnselectAllFiles | 30216 | Entfernt die Auswahl aller Dateien im Fenster.
scCommandEditUnselectSome | 30217 | Entfernt einen Teil der Auswahl.
scCommandEditUnselectCurrentExt | 30218 | Wählt alle Dateien ab, die den gleichen Dateityp haben wie die aktuelle Datei.
scCommandEditSelectInvert | 30212 | Kehrt die Auswahl um.
scCommandEditSelectRestore | 30213 | Stellt die Auswahl wieder her.
scCommandEditIncludeFolders | 30209 | Schließt die Ordner bei der Auswahl ein bzw. aus.
scCommandEditCopyNameAsText | 30202 | Kopiert den Dateinamen als Text in die Zwischenablage.
scCommandEditCopyFullPathAsText | 30204 | Kopiert den vollständigen Dateinamen als Text in die Zwischenablage.
scCommandEditCopyFullNameAsText | 30203 | Kopiert den Ordnernamen als Text in die Zwischenablage.
Menü "Ordner"
scCommandFolderFilterShowAllFiles | 33797 | Zeigt alle Dateien an.
scCommandFolderFilterInclude | 33798 | Zeigt alle Dateien an, die der Maske entsprechen.
scCommandFolderFilterExclude | 33799 | Schließt alle Dateien aus, die der Maske entsprechen.
scCommandFolderFilterFilter1 | 33800 | Aktiviert den ersten benutzerdefinierten Filter.
scCommandFolderFilterFilter100 | 33899 | Aktiviert den letzten benutzerdefinierten Filter.
scCommandFolderFilterSetFilter | 30347 | Setzt Filter, um bestimmte Dateien auszublenden.
scCommandFolderCreateFolder | 30302 | Erstellt einen neuen Ordner.
scCommandFolderCreateShortcut | 30304 | Erstellt eine neue Verknüpfung.
scCommandFolderCompare | 30303 | Prüft zwei Ordner auf Unterschiede.
scCommandFolderSynchronize | 30307 | Synchronisiert zwei Ordner.
scCommandFolderPrint | 30306 | Druckt eine Dateiliste des Ordners aus.
scCommandFolderCalcFolderSize | 30305 | Ermittelt die Größe aller Unterordner.
scCommandFolderFavoritesShowMenu | 30308 | Zeigt ein Menü mit den Ordnerfavoriten.
scCommandFolderFavoritesConfigure | 33999 | Öffnet einen Dialog zur Verwaltung der Ordnerfavoriten.
scCommandFolderFavoritesAddCurrentFolder | 33997 | Fügt den aktuellen Ordner den Ordnerfavoriten hinzu.
scCommandFolderFavoritesRemoveCurrentFolder | 33998 | Entfernt den aktuellen Ordner aus den Ordnerfavoriten.
scCommandFolderFavorites1 | 34000 | Aktiviert den ersten Ordnerfavoriten.
scCommandFolderFavorites200 | 34199 | Aktiviert den letzten Ordnerfavoriten.
scCommandFolderSystemFolderDesktop | 30322 | Wechselt nach 'Desktop'.
scCommandFolderSystemFolderFavorites | 30323 | Wechselt nach 'Favoriten'.
scCommandFolderSystemFolderStartMenu | 30324 | Wechselt nach 'Startmenü'.
scCommandFolderSystemFolderProgramFiles | 30325 | Wechselt nach 'Programme'.
scCommandFolderSystemFolderCommonFiles | 30326 | Wechselt nach 'Gemeinsame Dateien'.
scCommandFolderSystemFolderSendTo | 30327 | Wechselt nach 'Senden an'.
scCommandFolderSystemFolderAppData | 30328 | Wechselt nach 'Anwendungsdaten'.
scCommandFolderSystemFolderLocalAppData | 30329 | Wechselt nach 'Lokale Anwendungsdaten'.
scCommandFolderSystemFolderMyDocuments | 30330 | Wechselt nach 'Eigene Dateien'.
scCommandFolderSystemFolderMyPictures | 30331 | Wechselt nach 'Eigene Bilder'.
scCommandFolderSystemFolderSystem | 30332 | Wechselt nach 'System'.
scCommandFolderSystemFolderWindows | 30333 | Wechselt nach 'Windows'.
scCommandFolderSystemFolderFonts | 30334 | Wechselt nach 'Schriftarten'.
scCommandFolderSystemFolderHistory | 30335 | Wechselt nach 'Verlauf'.
scCommandFolderSystemFolderCookies | 30336 | Wechselt nach 'Cookies'.
scCommandFolderSystemFolderTempInternetFiles | 30337 | Wechselt nach 'Temporäre Internetdateien'.
scCommandFolderGotoBack | 30313 | Öffnet das vorherige Objekt in der Liste der letzten 20 Elemente, die zuletzt angezeigt wurden.
scCommandFolderGotoForward | 30314 | Öffnet das nächste Objekt in der Liste der letzten 20 Elemente, die zuletzt angezeigt wurden.
scCommandFolderGotoHierarchyShowMenu | 30310 | Zeigt ein Menü mit der Ordnerhierarchie an.
scCommandFolderGotoHierarchy1 | 31200 | Wechselt in den obersten Hierarchie-Eintrag.
scCommandFolderGotoHierarchy50 | 31249 | Wechselt in den untersten Hierarchie-Eintrag.
scCommandFolderGotoUpOneLevel | 30315 | Wechselt in den übergeordneten Ordner.
scCommandFolderGotoUpToRoot | 30316 | Wechselt in das Hauptverzeichnis.
scCommandFolderGotoBaseFolder | 30317 | Wechselt in das Basisverzeichnis.
scCommandFolderHistory1 | 31150 | Wechselt zum ersten History-Eintrag.
scCommandFolderHistory50 | 31199 | Wechselt zum letzten History-Eintrag.
Menu "Datenträger"
scCommandDiskFormat | 30401 | Startet das Programm zum Formatieren von Datenträgern.
scCommandDiskCopy | 30402 | Startet das Programm zum Kopieren von Datenträgern.
scCommandDiskMapNetworkDrive | 30403 | Ordnet einem Netzlaufwerk einen Laufwerksbuchstaben zu.
scCommandDiskDisconnectNetworkDrive | 30404 | Trennt ein Netzlaufwerk.
scCommandDiskFtpConnect | 30405 | Stellt eine Verbindung zu einem FTP-Server her.
scCommandDiskFtpDisconnect | 30406 | Trennt die Verbindung zu einem FTP-Server.
scCommandDiskFtpQuickConnect | 30411 | Stellt eine Schnellverbindung zu einem FTP-Server her.
scCommandDiskInternetStart | 30407 | Öffnet die Internet-Startseite.
scCommandDiskInternetSearch | 30408 | Öffnet die Internet-Suchseite.
scCommandDiskInternetProperties | 30409 | Öffnet die Internet-Eigenschaften.
scCommandDiskRefresh | 30410 | Aktualisiert die Laufwerkssymbole.
scCommandDiskSelectLeftDrive | 30421 | Wählt das Laufwerk für das linke Fenster.
scCommandDiskSelectRightDrive | 30422 | Wählt das Laufwerk für das rechte Fenster.
Menü "Ansicht"
scCommandViewAppearanceDrivesCombo | 30515 | Zeigt die Laufwerksfenster als Kombinationsfeld über jedem Ordnerfenster an.
scCommandViewAppearanceDrivesList | 30516 | Stellt das Laufwerksfenster als Leiste über jedem Ordnerfenster dar.
scCommandViewAppearanceDrivesDual | 30517 | Stellt das Laufwerksfenster als gemeinsame Leiste über beiden Ordnerfenstern dar.
scCommandViewAppearanceTileHorizontally | 30510 | Ordnet die Dateifenster untereinander an.
scCommandViewAppearanceDosPrompt | 30518 | Blendet die DOS-Eingabezeile ein bzw. aus.
scCommandViewAppearanceDosCommandWindow | 30520 | Blendet das integrierte DOS-Ausgabefenster ein bzw. aus.
scCommandViewAppearanceQuickDropSymbols | 30519 | Blendet die QuickDrop-Symbole ein bzw. aus.
scCommandViewAppearanceSwap | 30522 | Tauscht die beiden Ordnerfenster.
scCommandViewAppearanceAdjust | 30523 | Gleicht die beiden Fenster aneinander an.
scCommandViewAppearanceStop | 30501 | Bricht die Seitenanzeige ab.
scCommandViewAppearanceAlwaysOnTop | 30502 | Stellt den SpeedCommander so dar, daß er nicht durch andere Anwendungen überlagert wird.
scCommandViewFolderWindowVolumeInfo | 30530 | Schaltet den Laufwerksstatus an bzw. aus.
scCommandViewFolderWindowQuickView | 30531 | Schaltet die integrierte Schnellansicht an bzw. aus.
scCommandViewFolderWindowFolderInfo | 30532 | Schaltet die Ordnerinformationen an bzw. aus.
scCommandViewFolderWindowTreeView | 30538 | Aktiviert bzw. deaktiviert die Baumansicht.
scCommandViewFolderWindowStatusView | 30539 | Aktiviert bzw. deaktiviert das Statusfenster.
scCommandViewFolderWindowTabNew | 30540 | Erstellt ein neues Ordnerfenster.
scCommandViewFolderWindowTabProperties | 30548 | Zeigt die Eigenschaften der Registerkarte an.
scCommandViewFolderWindowTabSynchronize | 30547 | Schaltet die Synchronisation der Ordnerfenster ein oder aus.
scCommandViewFolderWindowFileContainerNew | 30541 | Erstellt eine neue Dateiablage.
scCommandViewFolderWindowFileContainerShow | 30555 | Zeigt die Dateiablage als Registerkarte an.
scCommandViewFolderWindowFileContainerLoadSel | 30556 | Lädt eine zuvor gespeicherte Auswahl.
scCommandViewFolderWindowFileContainerSaveSel | 30557 | Speichert eine Auswahl.
scCommandViewFolderWindowTabRename | 30546 | Benennt die aktuelle Ansicht um.
scCommandViewFolderWindowTabShiftLeft | 30545 | Verschiebt die aktuelle Ansicht nach links.
scCommandViewFolderWindowTabShiftRight | 30544 | Verschiebt die aktuelle Ansicht nach rechts.
scCommandViewFolderWindowTabClose | 30542 | Schließt die aktuelle Ansicht.
scCommandViewFolderWindowTabCloseAll | 30542 | Schließt alle Ansichten bis auf die aktuelle Ansicht.
scCommandViewLayoutShowMenu | 30580 | Zeigt ein Menü mit den gespeicherten Layouts.
scCommandViewLayoutSave | 33598 | Speichert das aktuelle Layout.
scCommandViewLayoutRemove | 33599 | Entfernt ein gespeichertes Layout.
scCommandViewLayout1 | 33600 | Aktiviert das erste benutzerdefinierte Layout.
scCommandViewLayout100 | 33699 | Aktiviert das letzte benutzerdefinierte Layout.
scCommandViewSplitter0 | 30595 | Versteckt das linke Fenster.
scCommandViewSplitter25 | 30596 | Vergrößert das rechte Fenster.
scCommandViewSplitter50 | 30597 | Stellt das linke und rechte Fenster auf gleiche Größe.
scCommandViewSplitter75 | 30598 | Vergrößert das linke Fenster.
scCommandViewSplitter100 | 30599 | Versteckt das rechte Fenster.
scCommandViewIcons | 19950 | Zeigt Elemente mit großen Symbolen an.
scCommandViewList | 19953 | Zeigt Elemente in Listenform an.
scCommandViewDetails | 19951 | Zeigt Informationen über die Elemente im Fenster an.
scCommandViewTiles | 19954 | Zeigt Informationen über jedes Fensterelement im Kachelformat an.
scCommandViewThumbnails | 19955 | Zeigt Elemente in der Miniaturansicht an.
scCommandViewArrangeShowInGroups | 19959 | Gruppiert die Elemente im Fenster nach der Sortiereigenschaft.
scCommandViewArrangeAuto | 19956 | Ordnet die Symbole automatisch an.
scCommandViewArrangeAlignToGrid | 19957 | Richtet die Symbole am Raster aus.
scCommandViewRefresh | 30503 | Aktualisiert den Inhalt des aktuellen Fensters.
scCommandViewSortName | 19000 | Sortiert alle Elemente nach Name.
scCommandViewSortType | 19001 | Sortiert alle Elemente nach Typ.
scCommandViewSortModified | 19002 | Sortiert alle Elemente nach dem Datum der letzten Änderung.
scCommandViewSortSize | 19003 | Sortiert alle Elemente nach Größe.
scCommandViewSortAttributes | 19004 | Sortiert alle Elemente nach Attribute.
scCommandViewSortExtension | 19005 | Sortiert alle Elemente nach Erweiterung.
scCommandViewSortLastAccess | 19006 | Sortiert alle Elemente nach dem Datum des letzten Zugriffs.
scCommandViewSortCreated | 19007 | Sortiert alle Elemente nach dem Erstelldatum.
scCommandViewSortRatio | 19008 | Sortiert alle Elemente nach Einsparung.
scCommandViewSortCompressed | 19009 | Sortiert alle Elemente nach komprimierter Größe.
scCommandViewSortComment | 19010 | Sortiert alle Elemente nach Kommentar.
scCommandViewSortCRC | 19011 | Sortiert alle Elemente nach CRC.
scCommandViewSortSystem | 19012 | Sortiert alle Elemente nach System.
scCommandViewSortMethod | 19013 | Sortiert alle Elemente nach Komprimiermethode.
scCommandViewSortFolder | 19014 | Sortiert alle Elemente nach Ordner.
scCommandViewSortServer | 19015 | Sortiert alle Elemente nach Server.
scCommandViewSortLastVisit | 19016 | Sortiert alle Elemente nach letztem Besuch.
scCommandViewSort83Name | 19017 | Sortiert alle Elemente nach 8.3-Name.
scCommandscCommandViewSortColumnHandler1 | 19030 | Sortiert alle Elemente nach der ersten Shell-Spaltenerweiterung.
scCommandscCommandViewSortColumnHandler50 | 19079 | Sortiert alle Elemente nach der letzten Shell-Spaltenerweiterung.
scCommandscCommandViewSortAddInColumn1 | 19080 | Sortiert alle Elemente nach der ersten zusätzlichen AddIn-Spalte.
scCommandscCommandViewSortAddInColumn20 | 19099 | Sortiert alle Elemente nach der letzten zusätzlichen AddIn-Spalte.
Menü "Extras"
scCommandExtraSettings | 30601 | Ändert die Einstellungen.
scCommandExtraCustomize | 35001 | Ermöglicht das Anpassen von Symbolleisten, Menüs und Tastenkürzel.
scCommandExtraFont | 30603 | Ändert die Schriftart.
scCommandExtraFontIncrease | 30604 | Vergrößert die Schriftart.
scCommandExtraFontDecrease | 30605 | Verkleinert die Schriftart.
scCommandExtraFileTypes | 30619 | Zeigt einen Dialog zur Bearbeitung der Dateiverknüpfungen an.
scCommandExtraArchiveMainComment | 30623 | Ändert den Hauptkommentar des Archivs.
scCommandExtraArchiveFileComment | 30624 | Ändert den Dateikommentar für die gewählten Objekte im Archiv.
scCommandExtraArchiveAddRecoveryData | 30621 | Fügt einem Archiv Reparaturdaten hinzu.
scCommandExtraArchiveStripRecoveryData | 30622 | Entfernt die Reparaturdaten aus einem Archiv.
scCommandExtraArchiveRepair | 30620 | Repariert ein defektes Archiv.
scCommandExtraArchiveTest | 30625 | Testet das Archiv auf Fehler.
scCommandExtraArchiveCreateSfx | 30626 | Erzeugt aus dem Archiv ein selbstentpackendes Archiv.
scCommandExtraSpecialEmptyRecycleBin | 30640 | Löscht alle Objekte im Papierkorb.
scCommandExtraMacrosEditor | 23928 | Öffnet den Makroeditor.
scCommandExtraMacros1 | 34600 | Startet das erste Makro.
scCommandExtraMacros200 | 34799 | Startet das letzte Makro.
scCommandExtraUserToolsShowMenu | 30608 | Zeigt ein Menü mit den Anwendungsfavoriten.
scCommandExtraUserToolsConfig | 34299 | Öffnet einen Dialog zur Verwaltung der Anwendungsfavoriten.
scCommandExtraUserTools1 | 34300 | Startet den ersten Anwendungsfavoriten.
scCommandExtraUserTools300 | 34599 | Startet den letzten Anwendungsfavoriten.
scCommandExtraSaveSetup | 30606 | Speichert die aktuellen Einstellungen.
Menü "Hilfe"
scCommandHelpTopics | 57667 | Listet die Hilfethemen auf.
scCommandHelpKeyboardMap | 30701 | Zeigt alle Tastaturbefehle an.
scCommandHelpWebHomepage | 19921 | Wechselt zur SpeedProject-Homepage.
scCommandHelpWebSupport | 19922 | Wechselt zur Support- und Updateseite.
scCommandHelpWebForum | 19923 | Wechselt zum Anwenderforum.
scCommandHelpWebFeedback | 19924 | Sendet ein Feedback an das SpeedProject-Team.
scCommandHelpInfoAbout | 57664 | Zeigt Programminformationen, Versionsnummer und Copyright an.

Application-Objekt


scCommandBarControlType-Konstanten

scCommandBarControlType-Konstanten

Diese Konstanten stellen den Typ eines Kontrollelements in einer Symbolleiste dar.

Eigenschaften

Konstante | Wert | Beschreibung
scCommandBarControlTypeAny | 0 | Wird bei der Suche verwendet, um Elemente unabhängig vom Typ zu finden.
scCommandBarControlTypeButton | 1 | Normale Schaltfläche.
scCommandBarControlTypePopup | 2 | Popup-Fenster mit Text ohne Symbol.
scCommandBarControlTypeButtonPopup | 3 | Popup-Fenster mit Symbol ohne Text.
scCommandBarControlTypeSplitButtonPopup | 4 | Popup-Fenster mit Symbol ohne Text und einem Pfeil rechts.
scCommandBarControlTypeComboBox | 5 | Kombinationsfeld.
scCommandBarControlTypeEdit | 6 | Eingabefeld.
scCommandBarControlTypeCustom | 7 | Benutzerdefiniertes Element.
scCommandBarControlTypeLabel | 8 | Einfaches Textfeld zur Informationsanzeige.

CommandBarControl-Objekt


scCommandBarFlags-Konstanten

scCommandBarFlags-Konstanten

Diese Konstanten stellen die verschiedenen Möglichkeiten für das Andocken von Symbolleisten dar.

Eigenschaften

Konstante | Wert | Beschreibung
scCommandBarFlagAlignTop | 1 | Die Symbolleiste kann am oberen Rand angedockt werden.
scCommandBarFlagAlignBottom | 2 | Die Symbolleiste kann am unteren Rand angedockt werden.
scCommandBarFlagAlignLeft | 4 | Die Symbolleiste kann am linken Rand angedockt werden.
scCommandBarFlagAlignRight | 8 | Die Symbolleiste kann am rechten Rand angedockt werden.
scCommandBarFlagAlignAny | 15 | Die Symbolleiste kann an jedem Rand angedockt werden.
scCommandBarFlagFloating | 16 | Die Symbolleiste kann freischwebend angezeigt werden.
scCommandBarFlagHideWrap | 32 | Elemente, für die kein Platz mehr ist, können ausgeblendet werden.
scCommandBarFlagStretched | 64 | Die Symbolleiste nimmt die ganze zur Verfügung stehende Breite/Höhe ein.

CommandBar-Objekt


scCommandBarPosition-Konstanten

scCommandBarPosition-Konstanten

Diese Konstanten stellen die aktuelle Position einer Symbolleiste dar.

Eigenschaften

Konstante | Wert | Beschreibung
scCommandBarPositionTop | 0 | Die Symbolleiste ist am oberen Rand angedockt.
scCommandBarPositionBottom | 1 | Die Symbolleiste ist am unteren Rand angedockt.
scCommandBarPositionLeft | 2 | Die Symbolleiste ist am linken Rand angedockt.
scCommandBarPositionRight | 3 | Die Symbolleiste ist am rechten Rand angedockt.
scCommandBarPositionFloating | 4 | Die Symbolleiste ist freischwebend.
scCommandBarPositionPopup | 5 | Die Symbolleiste ist ein Popup-Fenster innerhalb einer anderen Symbolleiste.
scCommandBarPositionListBox | 6 | Nicht benutzt.
scCommandBarPositionNone | 7 | Nicht benutzt.

CommandBar-Objekt


scCommandBarType-Konstanten

scCommandBarType-Konstanten

Diese Konstanten stellen den Typ einer Symbolleiste dar.

Eigenschaften

Konstante | Wert | Beschreibung
scCommandBarTypeMenuBar | 0 | Die Symbolleiste ist eine Menüleiste.
scCommandBarTypeNormal | 1 | Die Symbolleiste ist eine Toolbar.
scCommandBarTypePopup | 2 | Die Symbolleiste ist ein Popup-Fenster.

CommandBar-Objekt


scDriveSymbols-Konstanten

scDriveSymbols-Konstanten

Diese Konstanten legen fest, wie die Laufwerkssymbole angezeigt werden sollen.

Eigenschaften

Konstante | Wert | Beschreibung
scDriveSymbolsCombo | 0 | Die Anzeige der Laufwerkssymbole erfolgt in zwei Kombinationsfeldern.
scDriveSymbolsSingleList | 1 | Die Anzeige der Laufwerkssymbole erfolgt als Liste gemeinsam für beide Ordnerfenster.
scDriveSymbolsDualList | 2 | Die Anzeige der Laufwerkssymbole erfolgt als Liste getrennt für beide Ordnerfenster.

Window-Objekt


scEvents-Konstanten

scEvents-Konstanten

Diese Konstanten legen das Ereignisobjekt fest, das abgefragt werden soll.

Eigenschaften

Konstante | Wert | Beschreibung
scEventsCommand | 0 | Gibt ein CommandEvents-Objekt zurück, über welches auf Befehlsereignisse reagiert werden kann.
scEventsTabWindow | 1 | Gibt ein TabWindowEvents-Objekt zurück, über welches auf Ereignisse für die Zweifenster-Ansicht reagiert werden kann.
scEventsFolderWindow | 2 | Gibt ein FolderWindowEvents-Objekt zurück, über welches auf Ereignisse für Ordnerfenster reagiert werden kann.
scEventsFileContainer | 3 | Gibt ein FileContainerEvents-Objekt zurück, über welches auf Ereignisse für Dateiablagen reagiert werden kann.

Application-Objekt


scFolderLayout-Konstanten

scFolderLayout-Konstanten

Diese Konstanten legen fest, wie die Ordnerfenster angezeigt werden sollen.

Eigenschaften

Konstante | Wert | Beschreibung
scFolderLayoutVertical | 0 | Die Anzeige der Ordnerfenster erfolgt nebeneinander.
scFolderLayoutHorizontal | 1 | Die Anzeige der Ordnerfenster erfolgt untereinander.

Window-Objekt


scListView-Konstanten

scListView-Konstanten

Diese Konstanten legen fest, wie die Dateien und Ordner innerhalb der Listenansicht angezeigt werden.

Eigenschaften

Konstante | Wert | Beschreibung
scListViewIcon | 0 | Dateien und Ordner werden mit großen Symbolen angezeigt.
scListViewDetails | 1 | Dateien und Ordner werden mit Detailinformationen angezeigt.
scListViewSmallIcon | 2 | Dateien und Ordner werden mit kleinen Symbolen angezeigt.
scListViewList | 3 | Dateien und Ordner werden mit kleinen Symbolen als Liste angezeigt.
scListViewTile | 4 | Dateien und Ordner werden mit sehr großen Symbolen angezeigt.
scListViewThumbnails | 5 | Dateien und Ordner werden mit Vorschaubildern angezeigt.

FolderWindow-Objekt


scMrtCharCase-Konstanten

scMrtCharCase-Konstanten

Diese Konstanten legen den Modus für die Groß-/Kleinschreibung für das MultiRename-Objekt fest.

Eigenschaften

Konstante | Wert | Beschreibung
scMrtCharCaseUnchanged | 0 | Es erfolgt keine Änderung der Groß-/Kleinschreibung.
scMrtCharCaseAllUpper | 1 | Alle Zeichen werden in Großbuchstaben umgewandelt.
scMrtCharCaseAllLower | 2 | Alle Zeichen werden in Kleinbuchstaben umgewandelt.
scMrtCharCaseWordUpper | 3 | Jeder Wortanfang wird in Großbuchstaben umgewandelt.
scMrtCharCaseFirstNameUpper | 4 | Der erste Buchstabe wird in Großbuchstaben umgewandelt.
scMrtCharCaseFirstWordUpper | 5 | Das jeweils erste Wort (Dateiname und -erweiterung) wird in Großbuchstaben umgewandelt.

MultiRename-Objekt


scMrtDateTime-Konstanten

scMrtDateTime-Konstanten

Diese Konstanten legen den Modus für die Datums- und Zeitangaben für das MultiRename-Objekt fest.

Eigenschaften

Konstante | Wert | Beschreibung
scMrtDateTimeFile | 0 | Für Datums- und Zeitangaben wird die Zeit der letzten Änderung der jeweiligen Datei verwendet.
scMrtDateTimeSystem | 1 | Für Datums- und Zeitangaben wird die aktuelle Systemzeit verwendet.

MultiRename-Objekt


scMrtReplace-Konstanten

scMrtReplace-Konstanten

Diese Konstanten legen den Suchen- und Ersetzen-Modus für das MultiRename-Objekt fest.

Eigenschaften

Konstante | Wert | Beschreibung
scMrtReplaceFirstMatch | 0 | Es wird nur das erste Vorkommen ersetzt.
scMrtReplaceAllMatches | 1 | Es werden alle Vorkommen ersetzt.

MultiRename-Objekt


scMrtResult-Konstanten

scMrtResult-Konstanten

Diese Konstanten geben das Ergebnis einer Umbenennen-Aktion zurück.

Eigenschaften

Konstante | Wert | Beschreibung
scMrtResultOk | 0 | Die Dateien wurden mit Erfolg umbenannt.
scMrtResultSyntaxError | 1 | Die Parameter können nicht ausgewertet werden.
scMrtResultDoublesPresent | 2 | Das Umbenennen hätte zu doppelten Dateinamen geführt.

MultiRename-Objekt


scObject-Konstanten

scObject-Konstanten

Diese Konstanten legen das Anwendungsobjekt fest, das abgefragt werden soll.

Eigenschaften

Konstante | Wert | Beschreibung
scObjectMainWindow | 0 | Gibt ein MainWindow-Objekt zurück, über welches auf das Hauptfenster zugegriffen werden kann.
scObjectCommandBars | 1 | Gibt ein CommandBars-Objekt zurück, über welches auf die Symbolleisten und das Menü zugegriffen werden kann.
scObjectWorkspace | 2 | Gibt ein Workspace-Objekt zurück, über welches auf den Arbeitsbereich zugegriffen werden kann.
scObjectAddIns | 3 | Gibt ein AddIns-Objekt zurück, über welches auf die installierten AddIns zugegriffen werden kann.
scObjectUserTools | 4 | Gibt ein UserTools-Objekt zurück, über welches auf die Anwendungsfavoriten zugegriffen werden kann.
scObjectFolderFavorites | 5 | Gibt ein FolderFavorites-Objekt zurück, über welches auf die Ordnerfavoriten zugegriffen werden kann.
scObjectMultiRename | 6 | Gibt ein MultiRename-Objekt zurück, über welches Mehrfachumbenennungen erfolgen können.

Application-Objekt


scTabProperties-Konstanten

scTabProperties-Konstanten

Diese Konstanten stellen verschiedene Eigenschaften für Ordnerfenster dar.

Eigenschaften

Konstante | Wert | Beschreibung
scTabPropertiesUseBaseFolder | 1 | Das Ordnerfenster besitzt einen gültigen Basisordner, der beim Start von SpeedCommander automatisch angezeigt wird.
scTabPropertiesLockDrives | 2 | Der Wechsel auf andere Laufwerke ist gesperrt.
scTabPropertiesLockChilds | 4 | Der Wechsel in untergeordnete Verzeichnisse ist gesperrt.
scTabPropertiesLockParent | 8 | Der Wechsel in übergeordnete Verzeichnisse ist gesperrt.
scTabPropertiesBaseFolderOnActivate | 16 | Bei jeder Aktivierung des Ordnerfensters wird in den Basisordner gewechselt.
scTabPropertiesRefreshOnActivate | 256 | Bei jeder Aktivierung des Ordnerfensters wird der aktuelle Ordner neu eingelesen.
scTabPropertiesAutoRename | 512 | Der Name des Ordnerfensters wird automatisch aus dem jeweils aktuellen Ordner ermittelt.
scTabPropertiesTempArchive | 65536 | Das Ordnerfenster ist ein temporäres Archiv und wird bei einem Wechsel automatisch geschlossen.

FolderWindow-Objekt


Exec (IDTCommandTarget)

Exec (IDTCommandTarget)

Führt den angegebenen Befehl aus.

[C++]
HRESULT __stdcall Exec(
  /*[in]*/ BSTR bstrCmdName,
  /*[in]*/ vsCommandExecOption eExecuteOption,
  /*[in]*/ VARIANT* pVariantIn,
  /*[out]*/ VARIANT* pVariantOut,
  /*[out]*/ VARIANT_BOOL* pfHandled
);
[C#]
public void Exec(
  string bstrCmdName,
  vsCommandExecOption eExecuteOption,
  ref object pVariantIn,
  out object pVariantOut,
  out bool pfHandled
);
[Visual Basic .NET]
Public Sub Exec( _
  ByVal bstrCmdName As String, _
  ByVal eExecuteOption As vsCommandExecOption, _
  ByRef pVariantIn As Object, _
  ByRef pVariantOut As Object, _
  ByRef pfHandled As Boolean _
)
[Delphi]
procedure Exec(
  const bstrCmdName: WideString;
  eExecuteOption: vsCommandExecOption;
  var pVariantIn: OleVariant;
  out pVariantOut: OleVariant;
  out pfHandled: WordBool
); safecall;

Parameter

bstrCmdName
[in] Name des auszuführenden Befehls (z.B. SampleAddIn.Befehl1).
eExecuteOption
[in] Legt die Ausführungsoptionen fest und ist einer der folgenden Werte:
Ausführung | Wert | Bedeutung
vsCommandExecOptionDoDefault | 0 | Führt den Befehl aus (mit oder ohne Benutzereingabe).
vsCommandExecOptionPromptUser | 1 | Führt den Befehl nach Benutzereingabe aus.
vsCommandExecOptionDoPromptUser | 2 | Führt den Befehl aus, ohne den Benutzer zur Eingabe aufzufordern.
vsCommandExecOptionShowHelp | 3 | Zeigt eine Hilfe zum Befehl an, ohne ihn auszuführen.
pVariantIn
[in] Benutzerdefinierter Wert, der an einen Befehl übergeben wird.
pVariantOut
[out] Wert, der nach dem Ausführen des Befehls an den Aufrufer zurückgegeben wird.
pfHandled
[out] Gibt zurück, ob der Befehl ausgeführt wurde (VARIANT_TRUE) oder nicht (VARIANT_FALSE).

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTCommandTarget


QueryStatus (IDTCommandTarget)

QueryStatus (IDTCommandTarget)

Mit QueryStatus wird geprüft, ob der jeweilige Befehl verfügbar oder deaktiviert ist.

[C++]
HRESULT __stdcall QueryStatus(
  /*[in]*/ BSTR bstrCmdName,
  /*[in]*/ vsCommandStatusTextWanted eNeededText,
  /*[out]*/ vsCommandStatus* pStatusOption,
  /*[out]*/ VARIANT* pCommandText
);
[C#]
public void QueryStatus(
  string bstrCmdName,
  vsCommandStatusTextWanted eNeededText,
  ref vsCommandStatus pStatusOption,
  out object pCommandText
);
[Visual Basic .NET]
public Sub QueryStatus( _
  ByVal bstrCmdName As String, _
  ByVal eNeededText As vsCommandStatusTextWanted, _
  ByRef pStatusOption As vsCommandStatus, _
  ByRef pCommandText As Object _
)
[Delphi]
procedure QueryStatus(
  const bstrCmdName: WideString;
  eNeededText: vsCommandStatusTextWanted;
  var pStatusOption: vsCommandStatus;
  out pCommandText: OleVariant
); safecall;

Parameter

bstrCmdName
[in] Name des auszuführenden Befehls (z.B. SampleAddIn.Befehl1).
eNeededText
[in] Gibt an, ob die Überprüfung Informationen zurückgeben soll und ist einer der folgenden Werte:
Status | Wert | Bedeutung
vsCommandStatusTextWantedNone | 0 | Es werden keine Informationen zurückgegeben.
vsCommandStatusTextWantedName | 1 | Der Name des Befehls wird zurückgegeben.
vsCommandStatusTextWantedStatus | 2 | Der Status des Befehls wird zurückgebeben.
pStatusOption
[out] Legt den aktuellen Status des Befehls fest und ist eine Kombination der folgenden Werte:
Status | Wert | Bedeutung
vsCommandStatusUnsupported | 0 | Der Befehl wird momentan nicht unterstützt.
vsCommandStatusSupported | 1 | Der Befehl wird momentan unterstützt.
vsCommandStatusEnabled | 2 | Der Befehl ist momentan aktiviert.
vsCommandStatusLatched | 4 | Derzeit nicht implementiert.
vsCommandStatusNinched | 8 | Derzeit nicht implementiert.
vsCommandStatusInvisible | 16 | Der Befehl ist momentan ausgeblendet.
pCommandText
[out] Gibt den Befehlstext zurück, wenn vsCommandStatusTextWantedName angegeben wurde.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTCommandTarget


ShowConfigDialog (IDTConfigDialog)

ShowConfigDialog (IDTConfigDialog)

Zeigt den Einstellungsdialog des AddIns an.

[C++]
HRESULT __stdcall ShowConfigDialog(
  /*[in]*/ HANDLE_PTR hWndOwner
);
[C#]
public void ShowConfigDialog(
  uint hWndOwner
);
[Visual Basic .NET]
Public Sub ShowConfigDialog( _
  ByVal hWndOwner As System.UInt32 _
)
[Delphi]
function ShowConfigDialog(
  hWndOwner: LongWord
): HResult; stdcall;

Parameter

hWndOwner
[in] Handle (HWND) des aktuellen Fensters, welches als Elternfenster für den Dialog genutzt werden kann.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTConfigDialog


OnAddInsUpdate (IDTExtensibility2)

OnAddInsUpdate (IDTExtensibility2)

OnAddInsUpdate wird aufgerufen, wenn sich der Zustand eines AddIns (aktiviert oder deaktiviert) geändert hat.

[C++]
HRESULT __stdcall OnAddInsUpdate(
  /*[in, out]*/ SAFEARRAY** ppCustom
);
[C#]
public void OnAddInsUpdate(
  ref System.Array ppCustom
);
[Visual Basic .NET]
public Sub OnAddInsUpdate( _
  ByRef ppCustom As System.Array _
)
[Delphi]
procedure OnAddInsUpdate(
  var ppCustom: PSafeArray
); safecall;

Parameter

ppCustom
[in, out] Array von Variants für benutzerdefinierte Daten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTExtensibility2


OnBeginShutdown (IDTExtensibility2)

OnBeginShutdown (IDTExtensibility2)

OnBeginShutdown wird aufgerufen, bevor SpeedCommander beendet wird. Das AddIn kann hier seine Einstellungen sichern, bevor die Benutzeroberfläche von SpeedCommander geschlossen wird.

[C++]
HRESULT __stdcall OnBeginShutdown(
  /*[in]*/ SAFEARRAY** ppCustom
);
[C#]
public void OnBeginShutdown(
  ref System.Array ppCustom
);
[Visual Basic .NET]
public Sub OnBeginShutdown( _
  By Ref ppCustom As System.Array _
)
[Delphi]
procedure OnBeginShutdown(
  var ppCustom: PSafeArray
); safecall;

Parameter

ppCustom
[in] Array von Variants für benutzerdefinierte Daten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTExtensibility2


OnConnection (IDTExtensibility2)

OnConnection (IDTExtensibility2)

OnConnection wird aufgerufen, wenn das AddIn mit SpeedCommander verbunden wird. Dies kann zum einen beim Start von SpeedCommander erfolgen als auch zu einem späteren Zeitpunkt durch den Anwender. Ein Rückgabewert von NOERROR zeigt an, dass das AddIn geladen werden kann. Jeder andere Rückgabewert lässt SpeedCommander das AddIn wieder freigeben.

[C++]
HRESULT __stdcall OnConnection(
  /*[in]*/ IDispatch* pApplication,
  /*[in]*/ ext_ConnectMode eConnectMode,
  /*[in]*/ IDispatch* pAddInInst,
  /*[in]*/ SAFEARRAY** ppCustom
);
[C#]
public void OnConnection(
  object pApplication,
  ext_ConnectMode eConnectMode,
  object pAddInInst,
  ref System.Array ppCustom
);
[Visual Basic .NET]
public Sub OnConnection( _
  ByVal pApplication As Object, _
  ByVal eConnectMode As ext_ConnectMode, _
  ByVal pAddInInst As Object, _
  ByRef ppCustom As System.Array _
)
[Delphi]
procedure OnConnection(
  const pApplication: IDispatch;
  eConnectMode: ext_ConnectMode;
  const pAddInInst: IDispatch;
  var ppCustom: PSafeArray
); safecall;

Parameter

pApplication
[in] Verweis auf das Application-Objekt von SpeedCommander.
ConnectMode
[in] Gibt an, wie das AddIn geladen wurde und ist einer der folgenden Werte:
Status | Wert | Bedeutung
ext_cm_AfterStartup | 0 | Das AddIn wurde zu einem späteren Zeitpunkt geladen.
ext_cm_Startup | 1 | Das AddIn wurde beim Start von SpeedCommander geladen.
ext_cm_External | 2 | Das AddIn wurde durch ein anderes AddIn geladen.
pAddInInst
[in] Verweis auf ein AddIn-Objekt, welches das AddIn innerhalb der AddIns-Liste präsentiert.
ppCustom
[in] Array von Variants für benutzerdefinierte Daten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTExtensibility2


OnDisconnection (IDTExtensibility2)

OnDisconnection (IDTExtensibility2)

OnDisconnection wird aufgerufen, bevor die Verbindung zu SpeedCommander getrennt wird. Mit dem Parameter DisconnectMode kann das AddIn ermitteln, ob es durch den Anwender entladen wird. In diesem Fall sollte es alle seine Befehle und Einstellungen entfernen. Im anderen Fall sollten alle Anpassungen erhalten bleiben, so dass mögliche Befehle beim nächsten Start wieder zur Verfügung stehen.

[C++]
HRESULT __stdcall OnDisconnection(
  /*[in]*/ ext_DisconnectMode eDisconnectMode,
  /*[in]*/ SAFEARRAY** ppCustom
);
[C#]
public void OnDisconnection(
  ext_DisconnectMode eDisconnectMode,
  ref System.Array ppCustom
);
[Visual Basic .NET]
public Sub OnDisconnection( _
  ByVal eDisconnectMode As ext_DisconnectMode, _
  ByRef ppCustom As System.Array _
)
[Delphi]
procedure OnDisconnection(
  eDisconnectMode: ext_DisconnectMode;
  var ppCustom: PSafeArray
); safecall;

Parameter

eDisconnectMode
[in] Gibt an, wie das AddIn entladen wurde und ist einer der folgenden Werte:
Ausführung | Wert | Bedeutung
ext_dm_HostShutdown | 0 | Das AddIn wurde entladen, weil SpeedCommander beendet wurde.
ext_dm_UserClosed | 1 | Das AddIn wurde vom Anwender entfernt.
ppCustom
[in] Benutzerdefinierter Wert für zusätzliche Daten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTExtensibility2


OnStartupComplete (IDTExtensibility2)

OnStartupComplete (IDTExtensibility2)

OnStartupComplete wird aufgerufen, wenn der Startvorgang von SpeedCommander abgeschlossen wurde und die Benutzeroberfläche einsatzbereit ist. Das AddIn kann dieses Ereignis z.B. auch dazu nutzen, um zu überprüfen, ob andere AddIns geladen sind.

[C++]
HRESULT __stdcall OnStartupComplete(
  /*[in, out]*/ SAFEARRAY** ppCustom
);
[C#]
public void OnStartupComplete(
  ref System.Array ppCustom
);
[Visual Basic .NET]
public Sub OnStartupComplete( _
  ByRef ppCustom As System.Array _
)
[Delphi]
procedure OnStartupComplete(
  var ppCustom: PSafeArray
); safecall;

Parameter

ppCustom
[in, out] Array von Variants für benutzerdefinierte Daten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTExtensibility2


FileOpProgress-Objekt

FileOpProgress-Objekt

Mit Hilfe des FileOpProgress-Objektes kann die Fortschrittsanzeige für die aktuelle Operation beeinflusst werden. Für bestimmte Aktionen vor oder nach einer Dateioperation kann das AddIn auch eigene Aktionen (z.B. Konvertieren von Dateien) definieren.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Cancelled | Ermittelt, ob die aktuelle Operation durch den Anwender abgebrochen wurde.

Methoden

SetProgress | Setzt den Fortschritt für die aktuelle Operation.
StartJob | Startet einen neuen Job.
EndJob | Beendet den aktuellen Job.
SetJobProgress | Setzt den Fortschritt für den aktuellen Job.

IDTFileSystemSite


Application (FileOpProgress-Objekt)

Application (FileOpProgress-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FileOpProgress-Objekt, Application-Objekt


Cancelled (FileOpProgress-Objekt)

Cancelled (FileOpProgress-Objekt)

Ermittelt, ob die aktuelle Operation durch den Anwender abgebrochen wurde.

[C++]
HRESULT get_Cancelled(
  /*[out, retval]*/ VARIANT_BOOL* pCancelled
);
[C#]
bool Cancelled {get;}
[Visual Basic .NET]
Public ReadOnly Property Cancelled() As Boolean
[Delphi]
property Cancelled: WordBool read Get_Cancelled;

FileOpProgress-Objekt


EndJob (FileProgress-Objekt)

EndJob (FileProgress-Objekt)

Beendet eine Aktion.

[C++]
HRESULT __stdcall EndJob();
[C#]
public void EndJob();
[Visual Basic .NET]
Public Sub EndJob()
[Delphi]
procedure EndJob; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileOpProgress-Objekt


SetJobProgress (FileOpProgress-Objekt)

SetJobProgress (FileOpProgress-Objekt)

Setzt den Fortschritt für die aktuelle Aktion.

[C++]
HRESULT __stdcall SetJobProgress(
  /*[in]*/ long nPercentDone
);
[C#]
public void SetJobProgress(
  int nPercentDone
);
[Visual Basic .NET]
Public Sub SetJobProgress( _
  ByVal nPercentDone As Integer _
)
[Delphi]
procedure SetJobProgress(
  nPercentDone: Integer
); safecall;

Parameter

nPercentDone
Erforderlich. Fortschritt in Prozent (von 0 bis 100).

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileOpProgress-Objekt


SetProgress (FileOpProgress-Objekt)

SetProgress (FileOpProgress-Objekt)

Setzt eine Fortschritt für die aktuelle Dateioperation.

[C++]
HRESULT __stdcall SetProgress(
  /*[in]*/ long nPercentDone
);
[C#]
public void SetProgress(
  int nPercentDone
);
[Visual Basic .NET]
Public Sub SetProgress( _
  ByVal nPercentDone As Integer _
)
[Delphi]
procedure SetProgress(
  nPercentDone: Integer
); safecall;

Parameter

nPercentDone
Erforderlich. Fortschritt in Prozent (von 0 bis 100).

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileOpProgress-Objekt


StartJob (FileOpProgress-Objekt)

StartJob (FileOpProgress-Objekt)

Startet eine neue Aktion.

[C++]
HRESULT __stdcall StartJob(
  /*[in]*/ BSTR bstrJobName
);
[C#]
public void StartJob(
  string bstrJobName
);
[Visual Basic .NET]
Public Sub StartJob( _
  ByVal bstrJobName As String _
)
[Delphi]
procedure StartJob(
  const bstrJobName: WideString
); safecall;

Parameter

bstrJobName
Erforderlich. Aktionsname, der in der Titelzeile des Fortschrittdialogs angezeigt wird.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileOpProgress-Objekt


DTINVOKECOMMANDINFO (IDTContextMenu)

DTINVOKECOMMANDINFO (IDTContextMenu)

Enthält Informationen zum auszuführenden Befehl.

[C++]
typedef struct tagDTINVOKECOMMANDINFO {
  DWORD cbSize;
  HWND hWndOwner;
  DWORD dwFlags;
  UINT nCommand;
  UINT nExtendedCommand;
} DTINVOKECOMMANDINFO, *LPDTINVOKECOMMANDINFO;
[Delphi]
DTINVOKECOMMANDINFO = packed record
  cbSize: LongWord;
  hWndOwner: HWnd;
  dwFlags: LongWord;
  nCommand: LongWord;
  nExtendedCommand: LongWord;
end;

Strukturwerte

cbSize
Gibt die Größe der Struktur an.
hWndOwner
Handle des aktuellen Fensters, das für Bildschirmausgaben (z.B. eine Dialogbox) genutzt werden kann.
dwFlags
Legt erweiterte Informationen fest und ist eine Kombination von:
Flag | Wert | Bedeutung
DTICIFLAG_EXTENDEDCOMMAND | 1 | Es wird ein vordefinierter Befehl in nExtendedCommand angegeben.
nCommand
Gibt den auszuführenden Befehl an.
nExtendedCommand
Gibt einen vordefinierten Befehl an. Mögliche Werte sind:
Flag | Wert | Bedeutung
DTICIEXTENDED_OPEN | 1 | Die gewählten Objekte sollen geöffnet werden.
DTICIEXTENDED_PROPERTIES | 2 | Die Eigenschaften der gewählten Objekte sollen angezeigt werden.

IDTContextMenu


InvokeCommand (IDTContextMenu)

InvokeCommand (IDTContextMenu)

Führt einen ausgewählten Befehl aus.

[C++]
HRESULT InvokeCommand(
  LPCDTINVOKECOMMANDINFO pInvokeCommandInfo
);
[C#]
public void InvokeCommand(
  ref DTINVOKECOMMANDINFO pInvokeCommandInfo
);
[Visual Basic .NET]
public Sub InvokeCommand( _
  ByRef pInvokeCommandInfo As DTINVOKECOMMANDINFO _
)
[Delphi]
function InvokeCommand(
  var pInvokeCommandInfo: DTINVOKECOMMANDINFO
): HResult; stdcall;

Parameter

pInvokeCommandInfo
[in] Zeigt auf eine DTINVOKECOMMANDINFO-Struktur mit Informationen zum auszuführenden Befehl.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_NOTIMPL, E_OUTOFMEMORY sowie:

S_OK
Der Befehl wurde erfolgreich ausgeführt.

IDTContextMenu


QueryContextMenu (IDTContextMenu)

QueryContextMenu (IDTContextMenu)

Fügt einem Kontextmenü Befehle für Dateisystemobjekte hinzu.

[C++]
HRESULT QueryContextMenu(
  HMENU hMenu,
  UINT nIndexMenu,
  UINT nCmdFirst,
  UINT nCmdLast,
  DWORD dwFlags
);
[C#]
public void QueryContextMenu(
  ref RemotableHandle hMenu,
  uint nIndexMenu,
  uint nCmdFirst,
  uint nCmdLast,
  uint dwFlags
);
[Visual Basic .NET]
public Sub QueryContextMenu( _
  ByRef hMenu As RemotableHandle, _
  ByVal nIndexMenu As System.UInt32, _
  ByVal nCmdFirst As System.UInt32, _
  ByVal nCmdLast As System.UInt32, _
  ByVal dwFlags As System.UInt32 _
)
[Delphi]
function QueryContextMenu(
  var hMenu: RemotableHandle;
  nIndexMenu: LongWord;
  nCmdFirst: LongWord;
  dwFlags: LongWord
): HResult; stdcall;

Parameter

hMenu
[in] Menü, welches erweitert werden soll.
nIndexMenu
[in] Index, an welchem der erste Befehl in das Menü eingefügt werden kann.
nCmdFirst
[in] Befehls-ID für den ersten Befehl.
nCmdLast
[in] Befehls-ID für den letzten Befehl.
dwFlags
[in] Momentan nicht genutzt.

Rückgabewert

Gibt bei Erfolg die Anzahl der eingefügten Menüpunkte zurück oder E_FAIL bei einem Fehler.

IDTContextMenu


GetFileSystemSites (IDTFileSystemSites)

GetFileSystemSites (IDTFileSystemSites)

GetFileSystemSites wird aufgerufen, um die vom AddIn angebotenen Dateisystemobjekte abzufragen.

[C++]
HRESULT GetFileSystemSites(
  /*[out]*/ SAFEARRAY(IDTFileSystemSite*)* ppFileSystemSites
);
[C#]
public void GetFileSystemSites(
  out Array ppFileSystemSites
);
[Visual Basic .NET]
public Sub GetFileSystemSites( _
  ByRef ppFileSystemSites As Array _
)
[Delphi]
function GetFileSystemSites(
  out ppFileSystemSites: PSafeArray
): HResult; stdcall;

Parameter

ppFileSystemSites
[out] Zeiger auf ein Array mit IDTFileSystemSite-Objekten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystem


Attributes (IDTFileSystemItem)

Attributes (IDTFileSystemItem)

Gibt die Attribute für den Dateisystemeintrag zurück.

[C++]
HRESULT __stdcall get_Attributes(
  /*[out, retval]*/ long* pAttributes
);
[C#]
public int Attributes {get;}
[Visual Basic .NET]
Public ReadOnly Property Attributes() As Integer
[Delphi]
function Get_Attributes(
  out pAttributes: Integer
): HResult; stdcall;

Parameter

pAttributes
[out] Attribute des Dateisystemeintrages. Der Wert ist eine Kombination von:
Attribut | Wert | Bedeutung
FILE_ATTRIBUTE_READONLY | 0x0001 (1) | Der Dateisystemeintrag ist schreibgeschützt.
FILE_ATTRIBUTE_HIDDEN | 0x0002 (2) | Der Dateisystemeintrag ist versteckt.
FILE_ATTRIBUTE_SYSTEM | 0x0004 (4) | Der Dateisystemeintrag ist Teil des Betriebssystems.
FILE_ATTRIBUTE_DIRECTORY | 0x0010 (16) | Der Dateisystemeintrag ist ein Ordner.
FILE_ATTRIBUTE_ARCHIVE | 0x0020 (32) | Der Dateisystemeintrag muss gesichert werden.
FILE_ATTRIBUTE_COMPRESSED | 0x1000 (4096) | Der Dateisystemeintrag ist komprimiert.
FILE_ATTRIBUTE_ENCRYPTED | 0x4000 (16384) | Der Dateisystemeintrag ist verschlüsselt.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


DateCreated (IDTFileSystemItem)

DateCreated (IDTFileSystemItem)

Gibt den Zeitpunkt der Erstellung für den Dateisystemeintrag zurück.

[C++]
HRESULT __stdcall get_DateCreated(
  /*[out, retval]*/ DATE* pDateCreated
);
[C#]
public DateTime DateCreated {get;}
[Visual Basic .NET]
Public ReadOnly Property DateCreated() As Date
[Delphi]
function Get_DateCreated(
  out pDateCreated: TDateTime
): HResult; stdcall;

Parameter

pDateCreated
[out] Zeitpunkt der Erstellung.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


DateLastAccessed (IDTFileSystemItem)

DateLastAccessed (IDTFileSystemItem)

Gibt den Zeitpunkt des letzten Zugriffs für den Dateisystemeintrag zurück.

[C++]
HRESULT __stdcall get_DateLastAccessed(
  /*[out, retval]*/ DATE* pDateLastAccessed
);
[C#]
public DateTime DateLastAccessed {get;}
[Visual Basic .NET]
Public ReadOnly Property DateLastAccessed() As Date
[Delphi]
function Get_DateLastAccessed(
  out pDateLastAccessed: TDateTime
): HResult; stdcall;

Parameter

pDateLastAccessed
[out] Zeitpunkt des letzten Zugriffs.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


DateLastModified (IDTFileSystemItem)

DateLastModified (IDTFileSystemItem)

Gibt den Zeitpunkt der letzten Änderung für den Dateisystemeintrag zurück.

[C++]
HRESULT __stdcall get_DateLastModified(
  /*[out, retval]*/ DATE* pDateLastModified
);
[C#]
public DateTime DateLastModified {get;}
[Visual Basic .NET]
Public ReadOnly Property DateLastModified() As Date
[Delphi]
function Get_DateLastModified(
  out pDateLastModified: TDateTime
): HResult; stdcall;

Parameter

pDateLastModified
[out] Zeitpunkt der letzten Änderung.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


GetItemData (IDTFileSystemItem)

GetItemData (IDTFileSystemItem)

Gibt die Daten für eine erweiterte Spalte zurück.

[C++]
HRESULT __stdcall GetItemData(
  /*[in]*/ LPSHCOLUMNID pColumnID,
  /*[out]*/ VARIANT* pVarData
);
[C#]
public void GetItemData(
  ref SHCOLUMNID pColumnID,
  out object pVarData
);
[Visual Basic .NET]
public Sub GetItemData( _
  ByRef pColumnID As SHCOLUMNID, _
  ByRef pVarData As Object_
)
[Delphi]
function GetItemData(
  var pColumnID: SHCOLUMNID;
  out pVarData: OleVariant
): HResult; stdcall;

Parameter

pColumnID
[in] Eindeutige Spaltenkennung.
pVarData
[out] Zeigt auf eine VARIANT-Struktur und enthält die angeforderten Daten für die Spalte.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


Image (IDTFileSystemItem)

Image (IDTFileSystemItem)

Gibt den Index des Symbols in der Systemimageliste zurück, welches SpeedCommander zur Anzeige des Eintrages verwenden soll. Das AddIn kann der Systemimageliste mit Hilfe der Funktion IApplication::AddImage eigene Symbole hinzufügen.

[C++]
HRESULT __stdcall get_Image(
  /*[out, retval]*/ long* pImage
);
[C#]
public int Image {get;}
[Visual Basic .NET]
Public ReadOnly Property Image() As Integer
[Delphi]
function Get_Image(
  out pImage: Integer
): HResult; stdcall;

Parameter

pImage
[out] Index des Symbols in der Systemimageliste oder -1, wenn SpeedCommander das Symbol über die Dateierweiterung selbst bestimmen soll.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


Name (IDTFileSystemItem)

Name (IDTFileSystemItem)

Gibt den Namen des Dateisystemeintrages zurück.

[C++]
HRESULT __stdcall get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
[C#]
public string Name {get;}
[Visual Basic .NET]
Public ReadOnly Property Name() As String
[Delphi]
function Get_Name(
  out pbstrName: WideString
): HResult; stdcall;

Parameter

pbstrName
[out] Name des Eintrages.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


Size (IDTFileSystemItem)

Size (IDTFileSystemItem)

Gibt die Größe des Dateisystemeintrages zurück.

[C++]
HRESULT __stdcall get_Size(
  /*[out, retval]*/ VARIANT* pSize
);
[C#]
public object Size {get;}
[Visual Basic .NET]
Public ReadOnly Property Size() As Object
[Delphi]
function Get_Size(
  out pSize: OleVariant
): HResult; stdcall;

Parameter

pSize
[out] Größe des Dateisystemeintrages.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


Capabilities (IDTFileSystemSite)

Capabilities (IDTFileSystemSite)

Gibt die Eigenschaften des AddIn-Dateisystemobjekts zurück.

[C++]
HRESULT __stdcall get_Capabilities(
  /*[out, retval]*/ long* pCapabilities
);
[C#]
public int Capabilities {get;}
[Visual Basic .NET]
public ReadOnly Property Capabilities() As Integer
[Delphi]
function Get_Capabilities(
  out pCapabilities: Integer
): HResult; stdcall;

Parameter

pCapabilities
[out] Gibt die Eigenschaften des Dateisystemobjekts zurück. Der Wert ist 0 oder eine Kombination folgender Eigenschaften:
Flag | Wert | Bedeutung
FSSCAP_FILEOP_BACKGROUND | 0x001 (1) | Die Dateioperationen können im Hintergrund ablaufen, die Schnittstelle ist multithreadfähig.
FSSCAP_FILEOP_SUSPEND | 0x0002 (2) | Die Dateioperationen können angehalten/fortgesetzt werden.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL sowie:

S_OK
Die Eigenschaften wurden erfolgreich zurückgegeben.

IDTFileSystemSite


Comment (IDTFileSystemSite)

Comment (IDTFileSystemSite)

Gibt einen Kommentar für das Dateisystem-Objekt zurück. Der Kommentar wird in der Dateisystem-AddIn-Ansicht angezeigt.

[C++]
HRESULT __stdcall get_Comment(
  /*[out, retval]*/ BSTR* pbstrComment
);
[C#]
public string Comment {get;}
[Visual Basic .NET]
Public ReadOnly Property Comment() As String
[Delphi]
function Get_Comment(
  out pbstrComment: WideString
): HResult; stdcall;

Parameter

pbstrComment
[out] Gibt den Kommentar für das Dateisystemobjekt zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_OUTOFMEMORY sowie:

S_OK
Der Kommentar wurde erfolgreich zurückgegeben.
E_NOTIMPL
Die Funktion ist nicht implementiert.

IDTFileSystemSite


CreateDirectory (IDTFileSystemSite)

CreateDirectory (IDTFileSystemSite)

Erstellt einen neuen Ordner.

[C++]
HRESULT __stdcall CreateDirectory(
  /*[in]*/ BSTR bstrFolder,
  /*[out]*/ IFileSystemItem** pFileSystemItem
);
[C#]
public void CreateDirectory(
  string bstrFolder,
  out IFileSystemItem pFileSystemItem
);
[Visual Basic .NET]
public Sub CreateDirectory( _
  ByVal bstrFolder As String, _
  ByRef pFileSystemItem As IFileSystemItem _
)
[Delphi]
function CreateDirectory(
  const bstrFolder: WideString;
  out pFileSystemItem: IFileSystemItem
): HResult; stdcall;

Parameter

bstrFolder
[in] Ordner, der erstellt werden soll.
pFileSystemItem
[out] Adresse eines Zeigers, der ein IDTFileSystemItem-Objekt für den neuerstellten Ordner empfängt.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der Ordner wurde erfolgreich erstellt.

IDTFileSystemSite


DeleteFile (IDTFileSystemSite)

DeleteFile (IDTFileSystemSite)

Löscht eine Datei.

[C++]
HRESULT __stdcall DeleteFile(
  /*[in]*/ BSTR bstrPathName
);
[C#]
public void DeleteFile(
  string bstrPathName
);
[Visual Basic .NET]
public Sub DeleteFile( _
  ByVal bstrPathName As String _
)
[Delphi]
function DeleteFile(
  const bstrPathName: WideString
): HResult; stdcall;

Parameter

bstrPathName
[in] Datei, die gelöscht werden soll.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Datei wurde erfolgreich gelöscht.

IDTFileSystemSite


DownloadFile (IDTFileSystemSite)

DownloadFile (IDTFileSystemSite)

Kopiert eine Datei vom AddIn-Dateisystem in einen lokalen Ordner oder UNC-Pfad.

[C++]
HRESULT __stdcall DownloadFile(
  /*[in]*/ BSTR bstrRemoteFileName,
  /*[in]*/ BSTR bstrLocalFileName,
  /*[in]*/ DWORD dwFlags,
  /*[in]*/ IFileOpProgress* pFileOpProgress
);
[C#]
public void DownloadFile(
  string bstrRemoteFileName,
  string bstrLocalFileName,
  uint dwFlags,
  IFileOpProgress pFileOpProgress
);
[Visual Basic .NET]
public Sub DownloadFile( _
  ByVal bstrRemoteFileName As String, _
  ByVal bstrLocalFileName As String, _
  ByVal dwFlags As System.UInt32, _
  ByVal pFileOpProgress As IFileOpProgress _
)
[Delphi]
function DownloadFile(
  const bstrRemoteFileName: WideString;
  const bstrLocalFileName: WideString;
  dwFlags: LongWord;
  const pFileOpProgress: IFileOpProgress
): HResult; stdcall;

Parameter

bstrRemoteFileName
[in] Quelldateiname für die zu kopierende Datei.
bstrLocalFileName
[in] Zieldateiname für die zu kopierende Datei.
dwFlags
[in] Momentan nicht benutzt.
pFileOpProgress
[in] Schnittstelle zu IFileOpProgress zum Setzen des Fortschritts.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Datei wurde erfolgreich kopiert.
STG_E_FILENOTFOUND
Die Quelldatei wurde nicht gefunden.
STG_E_READFAULT
Fehler beim Lesen.
STG_E_WRITEFAULT
Fehler beim Schreiben.
STG_E_ACCESSDENIED
Zugriff verweigert.
E_ABORT
Die Aktion wurde abgebrochen.

IDTFileSystemSite


DTCOLUMNINFO (IDTFileSystemSite)

DTCOLUMNINFO (IDTFileSystemSite)

Enthält Eigenschaften für eine Spalte.

[C++]
typedef struct tagDTCOLUMNINFO {
  SHCOLUMNID scid;
  DWORD dwFormat;
  UINT cChars;
  DTCOLSTATEF dwFlags;
  BSTR bstrTitle;
} DTCOLUMNINFO, *LPDTCOLUMNINFO;
[Delphi]
DTCOLUMNINFO = packed record
  scid: SHCOLUMNID;
  dwFormat: LongWord;
  cChars: SYSUINT;
  dwFlags: LongWord;
  bstrTitle: WideString;
end;

Strukturwerte

scid
Legt die eindeutige Spaltenkennung mit der Struktur SHCOLUMNID fest.
dwFormat
Legt die Ausrichtung der Spalte fest. Mögliche Wert sind:
Ausrichtung | Wert | Bedeutung
LVCFMT_LEFT | 0 | Die Werte in der Spalte sind nach links ausgerichtet.
LVCFMT_RIGHT | 1 | Die Werte in der Spalte sind nach rechts ausgerichtet.
LVCFMT_CENTER | 2 | Die Werte in der Spalte sind zentriert ausgerichtet.
cChars
Breite der Spalte in Zeichen.
dwFlags
Legt bestimmte Eigenschaften für die Spalte fest.
Flag | Wert | Bedeutung
DTCOLSTATE_TYPE_STR | 1 | Die Werte in der Spalte sind Strings.
DTCOLSTATE_TYPE_INT | 2 | Die Werte in der Spalte sind Zahlen.
DTCOLSTATE_TYPE_DATE | 3 | Die Werte in der Spalte sind Datumsangaben.
DTCOLSTATE_SLOW | 16 | Die Abfrage der Spaltenwerte für die einzelen Dateieinträge erfolgt asynchron im Hintergrund.
DTCOLSTATE_HIDDEN | 32 | Die Spalte ist versteckt und nicht aktivierbar.
DTCOLSTATE_PREFER_VARCMP | 64 | SpeedCommander soll bei einer Sortierung die Werte dieser Spalte direkt vergleichen und nicht den Spaltentext (String) verwenden.
bstrTitle
Legt den Spaltentitel fest.

IDTFileSystemSite


DTVOLUMEINFORMATION (IDTFileSystemSite)

DTVOLUMEINFORMATION (IDTFileSystemSite)

Enthält Informationen zum Laufwerksstatus.

[C++]
typedef struct tagDTVOLUMEINFORMATION {
  BSTR bstrVolumeName;
  BSTR bstrVolumeSerial;
  BSTR bstrFileSystemName;
  VARIANT varBytesTotal;
  VARIANT varBytesFree;
  DWORD dwTotalClusters;
  DWORD dwFreeClusters;
  DWORD dwSectorsPerCluster;
  DWORD dwBytesPerSector;
  DTVOLINFOF dwFlags;
} DTVOLUMEINFORMATION, *LPDTVOLUMEINFORMATION;
[Delphi]
DTCOLUMNINFO = packed record
  bstrVolumeName: WideString;
  bstrVolumeSerial: WideString;
  bstrFileSystemName: WideString;
  varBytesTotal: OleVariant;
  varBytesFree: OleVariant;
  dwTotalClusters: LongWord;
  dwFreeClusters: LongWord;
  dwSectorsPerCluster: LongWord;
  dwBytesPerSector: LongWord;
  dwFlags: LongWord;
end;

Strukturwerte

bstrVolumeName
Gibt den Namen des Datenträgers an.
bstrVolumeSerial
Gibt die Seriennummer des Laufwerks an.
bstrFileSystemName
Gibt den Namen des Dateisystems an.
varBytesTotal
Gibt den insgesamt zur Verfügung stehenden Speicherplatz an.
varBytesFree
Gibt den freien Speicherplatz an.
dwTotalClusters
Gibt die insgesamt zur Verfügung stehenden Cluster an.
dwFreeClusters
Gibt die freien Cluster an.
dwSectorsPerCluster
Gibt an, wieviel Sektoren zu einem Cluster gehören.
dwBytesPerSector
Gibt an, wieviele Bytes ein Sektor umfasst.
dwFlags
Gibt zusätzliche Eigenschaften des Datenträgers an und ist eine Kombination von:
Flag | Wert | Bedeutung
DTVOLINFO_CASE_PRESERVEDNAMES | 0x0001 (1) | Speicherung von Dateinamen mit Groß- und Kleinschreibung.
DTVOLINFO_CASE_SENSITIVESEARCH | 0x0002 (2) | Unterscheidung von Dateinamen mit Groß- und Kleinschreibung.
DTVOLINFO_SUPPORTS_UNICODE | 0x0004 (4) | Unterstützung von Dateinamen in Unicode.
DTVOLINFO_SUPPORTS_PERSISTENTACLS | 0x0008 (8) | Unterstützung von Zugriffskontroll-Listen (ACLs).
DTVOLINFO_SUPPORTS_COMPRESSION | 0x0010 (16) | Unterstützung von dateibasierter Kompression.
DTVOLINFO_SUPPORTS_ENCRYPTION | 0x0020 (32) | Unterstützung von Verschlüsselung (EFS).
DTVOLINFO_SUPPORTS_QUOTAS | 0x0040 (64) | Unterstützung von Disk-Quotas.
DTVOLINFO_SUPPORTS_REPARSEPOINTS | 0x0080 (128) | Unterstützung von Reparse-Points.
DTVOLINFO_SUPPORTS_SPARSEFILES | 0x0100 (256) | Unterstützung von Sparse-Streams.
DTVOLINFO_SUPPORTS_OBJECTIDS | 0x0200 (512) | Unterstützung von Objekt-Identifiers.

IDTFileSystemSite


EnumObjects (IDTFileSystemSite)

EnumObjects (IDTFileSystemSite)

Ermittelt alle Elemente in einem Ordner. Für jedes Element erstellt EnumObjects ein IDTFileSystemItem-Objekt und fügt es der Kollektion hinzu.

[C++]
HRESULT __stdcall EnumObjects(
  /*[in]*/ BSTR bstrFolder,
  /*[out]*/ SAFEARRAY** ppFileSystemItems
);
[C#]
public void EnumObjects(
  string bstrFolder,
  out System.Array ppFileSystemItems
);
[Visual Basic .NET]
public Sub EnumObjects( _
  ByVal bstrFolder As String, _
  ByRef ppFileSystemItems As System.Array _
)
[Delphi]
function EnumObjects(
  const bstrFolder: WideString;
  out ppFileSystemItems: PSafeArray
): HResult; stdcall;

Parameter

bstrFolder
[in] Gibt den Ordner an, für welchen die Elemente abgerufen werden sollen.
ppFileSystemItems
[out] Zeiger auf ein Array mit IDTFileSystemItem-Objekten.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Auflistung war erfolgreich.

IDTFileSystemSite


ExecCommand (IDTFileSystemSite)

ExecCommand (IDTFileSystemSite)

Führt einen Befehl aus, den der Anwender in der Kommandozeile eingegeben hat.

[C++]
HRESULT __stdcall ExecCommand(
  /*[in]*/ BSTR bstrCommand
);
[C#]
public void ExecCommand(
  string bstrCommand
);
[Visual Basic .NET]
public Sub ExecCommand( _
  ByVal bstrCommand As String _
)
[Delphi]
function ExecCommand(
  const bstrCommand: WideString
): HResult; stdcall;

Parameter

bstrCommand
[in] Auszuführender Befehl.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der Befehl wurde erfolgreich ausgeführt .
S_FALSE
Der Befehl wurde erfolgreich ausgeführt und das aktuell angezeigte Verzeichnis soll aktualisiert werden.

IDTFileSystemSite


FileOpStatusInfo (IDTFileSystemSite)

FileOpStatusInfo (IDTFileSystemSite)

Wird aufgerufen, wenn eine Dateioperation gestartet oder beendet wird.

[C++]
HRESULT __stdcall FileOpStatusInfo(
  /*[in]*/ BSTR bstrRemotePath,
  /*[in]*/ enum scFileOpStatus eStatus,
  /*[in]*/ enum scFileOpAction eAction
);
[C#]
public void FileOpStatusInfo(
  string bstrRemotePath,
  scFileOpStatus eStatus,
  scFileOpAction eAction
);
[Visual Basic .NET]
public Sub FileOpStatusInfo( _
  ByVal bstrRemotePath As String, _
  ByVal eStatus As scFileOpStatus, _
  ByVal eAction As scFileOpAction _
)
[Delphi]
function FileOpStatusInfo(
  const bstrRemotePath: WideString;
  eStatus: scFileOpStatus;
  eAction: scFileOpAction
): HResult; stdcall;

Parameter

bstrRemotePath
[in] Ordner, in dem die Aktion durchgeführt wird.
scFileOpStatus
[in] Gibt an, ob die Aktion gestartet wird oder beendet wurde.
Konstante | Wert | Bedeutung
scFileOpStatusStart | 0 | Die Aktion wird gestartet.
scFileOpStatusEnd | 1 | Die Aktion wurde beendet.
scFileOpAction
[in] Legt die Aktion fest.
Konstante | Wert | Bedeutung
scFileOpActionList | 1 | Ein Ordner wird aufgelistet.
scFileOpActionDownload | 2 | Eine oder mehrere Dateien werden vom AddIn-Dateisystem in einen lokalen Ordner oder UNC-Pfad kopiert.
scFileOpActionDownloadSingle | 3 | Eine einzelne Datei wird vom AddIn-Dateisystem in einen lokalen Ordner oder UNC-Pfad kopiert.
scFileOpActionUpload | 4 | Eine oder mehrere Dateien werden von einem lokalen Ordner oder einem UNC-Pfad in das AddIn-Dateisystem kopiert.
scFileOpActionUploadSingle | 5 | Eine einzelne Datei wird von einem lokalen Ordner oder einem UNC-Pfad in das AddIn-Dateisystem kopiert.
scFileOpActionDelete | 6 | Dateien oder Ordner werden gelöscht.
scFileOpActionCreateDirectory | 7 | Ein neuer Ordner wird erstellt.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

IDTFileSystemSite


GetColumnID (IDTFileSystemSite)

GetColumnID (IDTFileSystemSite)

Ermittelt die Spalten-ID für einen bestimmten Ordner und ermöglicht damit dem AddIn, verschiedene Spaltenlayouts für unterschiedliche Ordner anzubieten. Vor jeder Anzeige eines Ordners fragt SpeedCommander die Spalten-ID ab und benutzt diese dann, um das jeweilige gespeicherte Layout wiederherzustellen. Das AddIn sollte als Spalten-ID 0 zurückgeben, wenn es für alle Ordner ein und dieselbe Spaltenanordnung anbietet.

[C++]
HRESULT __stdcall GetColumnID(
  /*[in]*/ BSTR bstrFolder,
  /*[out]*/ long* plColumnID
);
[C#]
public void GetColumnID(
  string bstrFolder,
  out int plColumnID
);
[Visual Basic .NET]
public Sub GetColumnID( _
  ByVal bstrFolder As String, _
  ByRef plColumnID As Integer, _
)
[Delphi]
function GetColumnID(
  const bstrFolder: WideString;
  out plColumnID: Integer
): HResult; stdcall;

Parameter

bstrFolder
[in] Gibt den Ordner an, für welchen die Spalten-ID abgefragt werden soll.
plColumnID
[out] Gibt die Spalten-ID zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Spalten-ID wurde erfolgreich zurückgegeben.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


GetColumnInfo (IDTFileSystemSite)

GetColumnInfo (IDTFileSystemSite)

Fragt Informationen zu verfügbaren Spalten ab. SpeedCommander ruft GetColumnInfo solange auf, bis GetColumnInfo entweder einen Fehlercode oder S_FALSE zurückgibt.

[C++]
HRESULT __stdcall GetColumnInfo(
  /*[in]*/ DWORD dwIndex,
  /*[in]*/ BSTR bstrFolder,
  /*[out]*/ LPDTCOLUMNINFO pColumnInfo
);
[C#]
public void GetColumnInfo(
  uint dwIndex,
  string bstrFolder,
  ref DTCOLUMNINFO pColumnInfo
);
[Visual Basic .NET]
public Sub GetColumnInfo( _
  ByVal dwIndex As System.UInt32, _
  ByVal bstrFolder As String, _
  ByRef pColumnInfo As DTCOLUMNINFO _
)
[Delphi]
function GetColumnInfo(
  dwIndex: LongWord;
  const bstrFolder: WideString;
  out pColumnInfo: DTCOLUMNINFO
): HResult; stdcall;

Parameter

dwIndex
[in] Null-basierter Zähler, der von SpeedCommander zur Auflistung genutzt wird. Mit jedem Aufruf wird der Zähler um eins erhöht.
bstrFolder
[in] Gibt den Ordner an, für welchen die Spalteninformationen abgerufen werden.
pColumnInfo
[out] Gibt die Spalteninformationen in einer DTCOLUMNINFO-Struktur zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Spalten-ID wurde erfolgreich zurückgegeben.
S_FALSE
Es sind keine weiteren Spalten verfügbar.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


GetCurrentDirectory (IDTFileSystemSite)

GetCurrentDirectory (IDTFileSystemSite)

Fragt den aktuell gesetzten Ordner im AddIn-Dateisystem ab.

[C++]
HRESULT __stdcall GetCurrentDirectory(
  /*[out]*/ BSTR* pbstrFolder
);
[C#]
public void GetCurrentDirectory(
  out string pbstrFolder
);
[Visual Basic .NET]
public Sub GetCurrentDirectory( _
  ByRef pbstrFolder As String _
)
[Delphi]
function GetCurrentDirectory(
  out pbstrFolder: WideString
): HResult; stdcall;

Parameter

pbstrFolder
[out] Gibt den aktuell gesetzten Ordner zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der Ordner wurde erfolgreich ermittelt.

IDTFileSystemSite


GetDefaultColumns (IDTFileSystemSite)

GetDefaultColumns (IDTFileSystemSite)

Gibt an, welche Spalten bei der ersten Initialisierung einer Ansicht aktiviert werden sollen.

[C++]
HRESULT __stdcall GetDefaultColumns(
  /*[in]*/ long nColumnID,
  /*[out]*/ DWORD* pdwDefaultColumns
);
[C#]
public void GetDefaultColumns(
  int nColumnID,
  out uint pdwDefaultColumns
);
[Visual Basic .NET]
public Sub GetDefaultColumns( _
  ByVal nColumnID As Integer, _
  ByRef pdwDefaultColums As System.UInt32 _
)
[Delphi]
function GetDefaultColumns(
  nColumnID: Integer;
  out pdwDefaultColumns: LongWord
): HResult; stdcall;

Parameter

nColumnID
[in] Spalten-ID, für welche die Standardinitialisierung abgefragt wird.
pdwDefaultColumns
[out] Gibt zurück, welche Spalten bei der ersten Initialisierung angezeigt werden sollen und ist eine Kombination von:
Konstante | Wert | Beschreibung
scDefaultColumnSize | 1 | Die Spalte Größe soll angezeigt werden.
scDefaultColumnType | 2 | Die Spalte Typ soll angezeigt werden.
scDefaultColumnModified | 4 | Die Spalte Geändert am soll angezeigt werden.
scDefaultColumnAttributes | 8 | Die Spalte Attribute soll angezeigt werden.
scDefaultColumnExtension | 16 | Die Spalte Erweiterung soll angezeigt werden.
scDefaultColumnAddIn1 | 32 | Die erste selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn2 | 64 | Die zweite selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn3 | 128 | Die dritte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn4 | 256 | Die vierte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn5 | 512 | Die fünfte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn6 | 1024 | Die sechste selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn7 | 2048 | Die siebte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn8 | 4096 | Die achte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn9 | 8192 | Die neunte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn10 | 16384 | Die zehnte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn11 | 32768 | Die elfte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn12 | 65536 | Die zwölfte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn13 | 131072 | Die dreizehnte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn14 | 262144 | Die vierzehnte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn15 | 524288 | Die fünfzehnte selbstdefinierte Spalte des AddIns soll angezeigt werden.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die anzuzeigenden Spalten wurden erfolgreich zurückgegeben.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


GetTargetFileName (IDTFileSystemSite)

GetTargetFileName (IDTFileSystemSite)

Vor jeder Kopieroperation (IDTFileSystemSite::DownloadFile und IDTFileSystemSite::UploadFile) fragt SpeedCommander nach dem Zieldateinamen. SpeedCommander setzt den Zieldateinamen anhand der vom Anwender festgelegten Optionen selbst zusammen. In einigen Fällen kann es aber vorkommen, dass sich der Zieldateiname durch Konvertierungen (z.B. beim Konvertieren von Dokumenten zwischen PDA und PC) ändert. Das AddIn darf hier aber nur den Dateinamen selbst anpassen, der Pfadbestandteil muss unverändert bleiben!

[C++]
HRESULT __stdcall GetTargetFileName(
  /*[in]*/ DWORD dwFlags,
  /*[in]*/ BSTR bstrSourceFileName,
  /*[in, out]*/ BSTR* pbstrTargetFileName
);
[C#]
public void GetTargetFileName(
  uint dwFlags,
  string bstrSourceFileName,
  ref string pbstrTargetFileName
);
[Visual Basic .NET]
public Sub GetTargetFileName( _
  ByVal dwFlags As System.UInt32, _
  ByVal bstrSourceFileName As String _
  ByRef pbstrTargetFileName As String _
)
[Delphi]
function GetTargetFileName(
  dwFlags: LongWord;
  const bstrSourceFileName: WideString;
  var pbstrTargetFileName: WideString
): HResult; stdcall;

Parameter

dwFlags
[in] Flags für die Bestimmung des Zieldateinamens. Mögliche Werte sind:
Flag | Wert | Bedeutung
FSSGTFN_DOWNLOAD | 1 | Die Datei wird vom AddIn-Dateisystem in einen lokalen Ordner oder UNC-Pfad kopiert.
FSSGTFN_UPLOAD | 2 | Die Datei wird von einem lokalen Ordner oder UNC-Pfad in das AddIn-Dateisystem kopiert.
bstrSourceFileName
[in] Datei, die kopiert werden soll.
pbstrTargetFileName
[in, out] Gibt den Zieldateinamen zurück. Bei einer Änderung des Zieldateinamens muss der von SpeedCommander vorgeschlagene Zieldateiname vorher mit SysFreeString freigegeben werden.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der Zieldateiname wurde geändert.
E_NOTIMPL
Die Funktion ist nicht implementiert.

IDTFileSystemSite


GetUIObjectOf (IDTFileSystemSite)

GetUIObjectOf (IDTFileSystemSite)

Erstellt ein UI-Objekt für die angegebenen Dateien und Ordner. Mögliche UI-Objekte sind

  • IDTContextMenu
[C++]
HRESULT __stdcall GetUIObjectOf(
  /*[in]*/ HANDLE_PTR hWndOwner,
  /*[in]*/ UINT nItems,
  /*[in]*/ VARIANT varItems,
  /*[in]*/ REFIID riid,
  /*[out]*/ void** ppInterface
);
[C#]
public void GetUIObjectOf(
  uint hWndOwner,
  uint nItems,
  object varItems,
  System.Guid riid,
  System.IntPtr ppInterface
);
[Visual Basic .NET]
public Sub GetUIObjectOf( _
  ByVal hWndOwner As System.UInt32, _
  ByVal nItems As System.UInt32, _
  ByVal varItems As Object, _
  ByRef riid As System.Guid, _
  ByRef ppInterface As System.IntPtr _
)
[Delphi]
function GetUIObjectOf(
  hWndOwner: LongWord;
  nItems: LongWord;
  varItems: OleVariant;
  var riid: TGuid;
  out ppInterface: Pointer
): HResult; stdcall;

Parameter

hWndOwner
[in] Handle (HWND) des aktuellen Fensters, das für Bildschirmausgaben (z.B. eine Dialogbox) genutzt werden kann.
nItems
[in] Anzahl der Einträge im Array oder null, wenn das UI-Objekt für oberste Ebene (Root) des Dateisystems angefordert wird.
varItems
[in] Array aus IDTFileSystemItem-Objekten, für die das UI-Objekt erstellt werden soll.
riid
[in] GUID für das zu erstellende UI-Objekt:
GUID | Bedeutung
IID_IDTContextMenu | Ein IDTContextMenu-Objekt soll erstellt werden.
ppInterface
[out] Zeiger auf das erstellte UI-Objekt.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_NOTIMPL, E_OUTOFMEMORY sowie:

S_OK
Das UI-Objekt wurde erfolgreich erstellt.
E_NOINTERFACE
Das Interface wird nicht unterstützt.

IDTFileSystemSite, IDTContextMenu


GetVolumeInformation (IDTFileSystemSite)

GetVolumeInformation (IDTFileSystemSite)

Gibt Informationen zum Laufwerksstatus (u.a. Name des Laufwerks, Gesamtspeicherplatz, freier Speicher) zurück.

[C++]
HRESULT __stdcall GetVolumeInformation(
  /*[in]*/ BSTR bstrPathName,
  /*[out]*/ LPDTVOLUMEINFORMATION pVolumeInformation
);
[C#]
public void GetVolumeInformation(
  string bstrPathName,
  ref DTVOLUMEINFORMATION pVolumeInformation
);
[Visual Basic .NET]
public Sub GetVolumeInformation( _
  ByVal bstrPathName As String, _
  ByRef pVolumeInformation As DTVOLUMEINFORMATION _
)
[Delphi]
function GetVolumeInformation(
  const bstrPathName: WideString;
  out pVolumeInformation: DTVOLUMEINFORMATION
): HResult; stdcall;

Parameter

bstrPathName
[in] Ordner, für den die Laufwerksinformationen ermittelt werden sollen.
pVolumeInformation
[out] Gibt die Laufwerksinformationen in einer DTVOLUMEINFORMATION-Struktur zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Laufwerksinformationen wurden erfolgreich zurückgegeben.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


Guid (IDTFileSystemSite)

Guid (IDTFileSystemSite)

Gibt die GUID für das AddIn-Dateisystemobjekt zurück. Die GUID wird von SpeedCommander u.a. bei der Speicherung der Spaltenlayouts benutzt.

[C++]
HRESULT __stdcall get_Guid(
  /*[out, retval]*/ BSTR* pbstrGuid
);
[C++]
public string Guid {get;}
[Visual Basic .NET]
Public ReadOnly Property Guid() As String
[Delphi]
function Get_Guid(
  out pbstrGuid: WideString
): HResult; stdcall;

Parameter

pbstrGuid
[out] Gibt die GUID für das Dateisystemobjekt zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_OUTOFMEMORY sowie:

S_OK
Die GUID wurde erfolgreich zurückgegeben.

IDTFileSystemSite


HostName (IDTFileSystemSite)

HostName (IDTFileSystemSite)

Gibt den Namen für das AddIn-Dateisystemobjekt zurück. Die Navigation in SpeedCommander innerhalb der AddIn-Dateisysteme erfolgt durch eine URL in der Form AddIn://HostName/Ordner1/Datei. Der Name für das Dateisystemobjekt sollte daher gut gewählt und recht eindeutig sein.

[C++]
HRESULT __stdcall get_HostName(
  /*[out, retval]*/ BSTR* pbstrHostName
);
[C#]
public string HostName {get;}
[Visual Basic .NET]
Public ReadOnly Property HostName() As String
[Delphi]
function Get_HostName(
  out pbstrHostName: WideString
): HResult; stdcall;

Parameter

pbstrHostName
[out] Gibt den Namen für das Dateisystemobjekt zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_OUTOFMEMORY sowie:

S_OK
Der Name wurde erfolgreich zurückgegeben.

IDTFileSystemSite


Image (IDTFileSystemSite)

Image (IDTFileSystemSite)

Gibt das Symbol an, welches SpeedCommander für das Dateisystem-Objekt anzeigen soll. Das AddIn kann über die Funktion IApplication::AddImage eigene Symbole definieren. Das Dateisystemobjekt sollte -1 zurückgeben, wenn es kein eigenes Symbol verwendet. In diesem Fall zeigt SpeedCommander ein Standardsymbol an.

[C++]
HRESULT __stdcall get_Image(
  /*[out, retval]*/ long* pImage
);
[C#]
public int Image {get;}
[Visual Basic .NET]
Public ReadOnly Property Image() As Integer
[Delphi]
function Get_Image(
  out pImage: Integer
): HResult; stdcall;

Parameter

pImage
[out] Gibt den Index für das anzuzeigende Symbol zurück oder -1, wenn das AddIn kein eigenes Symbol verwendet.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL sowie:

S_OK
Das Symbol wurde erfolgreich zurückgegeben.

IDTFileSystemSite


MoveFile (IDTFileSystemSite)

MoveFile (IDTFileSystemSite)

Verschiebt eine Datei oder einen Ordner bzw. benennt eine Datei oder einen Ordner um.

[C++]
HRESULT __stdcall MoveFile(
  /*[in]*/ BSTR bstrExistingFileName,
  /*[in]*/ BSTR bstrNewFileName
);
[C#]
public void MoveFile(
  string bstrExistingFileName,
  string bstrNewFileName
);
[Visual Basic .NET]
public Sub MoveFile( _
  ByVal bstrExistingFileName As String, _
  ByVal bstrNewFileName As String _
)
[Delphi]
function MoveFile(
  const bstrExistingFileName: WideString;
  const bstrNewFileName: WideString
): HResult; stdcall;

Parameter

bstrExistingFileName
[in] Datei oder Ordner, die/der verschoben oder umbenannt werden soll.
bstrNewFileName
[in] Neuer Name für die Datei oder den Ordner.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Datei oder der Ordner wurde erfolgreich umbenannt bzw. verschoben.

IDTFileSystemSite


RemoveDirectory (IDTFileSystemSite)

RemoveDirectory (IDTFileSystemSite)

Löscht einen Ordner.

[C++]
HRESULT __stdcall RemoveDirectory(
  /*[in]*/ BSTR bstrFolder
);
[C#]
public void RemoveDirectory(
  string bstrFolder
);
[Visual Basic .NET]
public Sub RemoveDirectory( _
  ByVal bstrFolder As String _
)
[Delphi]
function RemoveDirectory(
  const bstrFolder: WideString
): HResult: stdcall;

Parameter

bstrFolder
[in] Ordner, der gelöscht werden soll.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der Ordner wurde erfolgreich gelöscht.

IDTFileSystemSite


SetCurrentDirectory (IDTFileSystemSite)

SetCurrentDirectory (IDTFileSystemSite)

Setzt den aktuellen Ordner im AddIn-Dateisystem.

[C++]
HRESULT __stdcall SetCurrentDirectory(
  /*[in]*/ BSTR bstrFolder
);
[C#]
public void SetCurrentDirectory(
  string bstrFolder
);
[Visual Basic .NET]
public Sub SetCurrentDirectory( _
  ByVal bstrFolder As String _
)
[Delphi]
function SetCurrentDirectory(
  const bstrFolder: WideString
): HResult; stdcall;

Parameter

bstrFolder
[in] Ordner, der gesetzt werden soll.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der aktuelle Ordner wurde erfolgreich gesetzt.
STG_E_PATHNOTFOUND
Der Ordner ist ungültig und kann nicht gesetzt werden.

IDTFileSystemSite


SetFileAttributes (IDTFileSystemSite)

SetFileAttributes (IDTFileSystemSite)

Setzt die Attribute für eine Datei oder einen Ordner.

[C++]
HRESULT __stdcall SetFileAttributes(
  /*[in]*/ BSTR bstrPathName,
  /*[in]*/ DWORD dwFileAttributes
);
[C#]
public void SetFileAttributes(
  string bstrPathName,
  uint dwFileAttributes
);
[Visual Basic .NET]
public Sub SetFileAttributes( _
  ByVal bstrPathName As String, _
  ByVal dwFileAttributes As System.UInt32 _
)
[Delphi]
function SetFileAttributes(
  const bstrPathName: WideString;
  dwFileAttributes: LongWord
): HResult; stdcall;

Parameter

bstrPathName
[in] Datei oder Ordner, für die/den die Attribute geändert werden sollen.
dwFileAttributes
[in] Attribute des Dateisystemeintrages. Der Wert ist eine Kombination von:
Attribut | Wert | Bedeutung
FILE_ATTRIBUTE_READONLY | 1 | Der Dateisystemeintrag ist schreibgeschützt.
FILE_ATTRIBUTE_HIDDEN | 2 | Der Dateisystemeintrag ist versteckt.
FILE_ATTRIBUTE_SYSTEM | 4 | Der Dateisystemeintrag ist Teil des Betriebssystems.
FILE_ATTRIBUTE_ARCHIVE | 32 | Der Dateisystemeintrag muss gesichert werden.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Dateiattribute wurden erfolgreich gesetzt.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


SetFileTime (IDTFileSystemSite)

SetFileTime (IDTFileSystemSite)

Setzt die Erstellungszeit, die Zeit des letzten Zugriffs sowie die Zeit der letzten Änderung für eine Datei oder einen Ordner. Wenn für eine Zeit der Wert 0 übergeben wird, dann wird diese Zeit nicht geändert.

[C++]
HRESULT __stdcall SetFileTime(
  /*[in]*/ BSTR bstrPathName,
  /*[in]*/ DATE dateCreated,
  /*[in]*/ DATE dateLastAccessed,
  /*[in]*/ DATE dateLastModified
);
[C#]
public void SetFileTime(
  string bstrPathName,
  DateTime dateCreated,
  DateTime dateLastAccessed,
  DateTime dateLastModified
);
[Visual Basic .NET]
public Sub SetFileTime( _
  ByVal bstrPathName As String, _
  ByVal dateCreated As Date, _
  ByVal dateLastAccessed As Date, _
  ByVal dateLastModified As Date _
)
[Delphi]
function SetFileTime(
  const bstrPathName: WideString;
  dateCreated: TDateTime;
  dateLastAccessed: TDateTime;
  dateLastModified: TDateTime
): HResult; stdcall;

Parameter

bstrPathName
[in] Datei oder Ordner, für die/den die Zeit geändert werden soll.
dateCreated
[in] Erstellungszeit.
dateLastAccessed
[in] Zeit des letzten Zugriffs.
dateLastModified
[in] Zeit der letzten Änderung.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Zeit wurde erfolgreich gesetzt.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


SHCOLUMNID (IDTFileSystemSite)

SHCOLUMNID (IDTFileSystemSite)

Legt die eindeutige Spaltenkennzeichnung in der Form FMTID/PID fest. SpeedCommander verwendet diese Informationen, um die verschiedenen Spalten eindeutig unterscheiden zu können.

In der Regel verwenden AddIns als FMTID immer die GUID des AddIns. Die PID kann frei gewählt werden, normalerweise erhält die erste Spalte 1, die zweite Spalte 2 usw.

[C++]
typedef struct tagSHCOLUMNID {
  GUID fmtid;
  DWORD pid;
} SHCOLUMNID, *LPSHCOLUMNID;
[Delphi]
SHCOLUMNID = packed record
  fmtid: TGUID;
  pid: LongWord;
end;
fmtid
Legt die GUID für die Spalte fest.
pid
Legt die Spaltenbezeichnung fest.

IDTFileSystemSite


UploadFile (IDTFileSystemSite)

UploadFile (IDTFileSystemSite)

Kopiert eine Datei von einem lokalen Ordner oder einem UNC-Pfad in das AddIn-Dateisystem.

[C++]
HRESULT __stdcall UploadFile(
  /*[in]*/ BSTR bstrLocalFileName,
  /*[in]*/ BSTR bstrRemoteFileName,
  /*[in]*/ DWORD dwFlags,
  /*[in]*/ IFileOpProgress* pFileOpProgress
);
[C#]
public void UploadFile(
  string bstrLocalFileName,
  string bstrRemoteFileName,
  uint dwFlags,
  IFileOpProgress pFileOpProgress
);
[Visual Basic .NET]
public Sub UploadFile( _
  ByVal bstrLocalFileName As String, _
  ByVal bstrRemoteFileName As String, _
  ByVal dwFlags As System.UInt32, _
  ByVal pFileOpProgress As IFileOpProgress _
)
[Delphi]
function UploadFile(
  const bstrLocalFileName: WideString;
  const bstrRemoteFileName: WideString;
  dwFlags: LongWord;
  const pFileOpProgress: IFileOpProgress
): HResult; stdcall;

Parameter

bstrLocalFileName
[in] Quelldateiname für die zu kopierende Datei.
bstrRemoteFileName
[in] Zieldateiname für die zu kopierende Datei.
dwFlags
[in] Momentan nicht benutzt.
pFileOpProgress
[in] Schnittstelle zu IFileOpProgress zum Setzen des Fortschritts.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Datei wurde erfolgreich kopiert.
STG_E_FILENOTFOUND
Die Quelldatei wurde nicht gefunden.
STG_E_READFAULT
Fehler beim Lesen.
STG_E_WRITEFAULT
Fehler beim Schreiben.
STG_E_ACCESSDENIED
Zugriff verweigert.
E_ABORT
Die Aktion wurde abgebrochen.

IDTFileSystemSite


Application (AddIn-Objekt)

Application (AddIn-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AddIn-Objekt, Application-Objekt


Parent (AddIn-Objekt)

Parent (AddIn-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das AddIns-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IAddIns** ppAddIns
);
[C#]
AddIns Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As AddIns
[Delphi]
property Parent: IAddIns read Get_Parent;

AddIn-Objekt, AddIns-Objekt


Application (AddInCommand-Objekt)

Application (AddInCommand-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AddInCommand-Objekt, Application-Objekt


Parent (AddInCommand-Objekt)

Parent (AddInCommand-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das AddInCommands-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IAddCommands** ppAddInCommands
);
[C#]
AddInCommands Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As AddInCommands
[Delphi]
property Parent: IAddInCommands read Get_Parent;

AddInCommand-Objekt, AddInCommands-Objekt


Application (AddInCommands-Objekt)

Application (AddInCommands-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AddInCommands-Objekt, Application-Objekt


Parent (AddInCommands-Objekt)

Parent (AddInCommands-Objekt)

Gibt das Elternobjekt zurück, in diesem Falle das AddIns-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IAddIns** ppAddIns
);
[C#]
AddIns Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As AddIns
[Delphi]
property Parent: IAddIns read Get_Parent;

AddInCommands-Objekt, AddIns-Objekt


Application (AddIns-Objekt)

Application (AddIns-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AddIns-Objekt, Application-Objekt


Parent (AddIns-Objekt)

Parent (AddIns-Objekt)

Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: Application read Get_Parent;

AddIns-Objekt, Application-Objekt


Update (AddIns-Objekt)

Update (AddIns-Objekt)

Aktualisiert die AddIn-Liste.

[C++]
HRESULT __stdcall Update();
[C#]
public void Update();
[Visual Basic .NET]
Public Sub Update()
[Delphi]
procedure Update; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

AddIns-Objekt


Application (AddInSettings-Objekt)

Application (AddInSettings-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AddInSettings-Objekt, Application-Objekt


Parent (AddInSettings-Objekt)

Parent (AddInSettings-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das AddIns-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IAddIns** ppAddIns
);
[C#]
AddIns Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As AddIns
[Delphi]
property Parent: IAddIns read Get_Parent;

AddInSettings-Objekt, AddIns-Objekt


Application (MainWindow-Objekt)

Application (MainWindow-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

MainWindow-Objekt, Application-Objekt


Parent (MainWindow-Objekt)

Parent (MainWindow-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

MainWindow-Objekt, Application-Objekt


Application (CommandBar-Objekt)

Application (CommandBar-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

CommandBar-Objekt, Application-Objekt


Parent (CommandBar-Objekt)

Parent (CommandBar-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das CommandBars-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ ICommandBars** ppCommandBars
);
[C#]
CommandBars Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As CommandBars
[Delphi]
property Parent: ICommandBars read Get_Parent;

CommandBar-Objekt, CommandBars-Objekt


Application (CommandBarControl-Objekt)

Application (CommandBarControl-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

CommandBarControl-Objekt, Application-Objekt


Parent (CommandBarControl-Objekt)

Parent (CommandBarControl-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das CommandBar-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ ICommandBar** ppCommandBar
);
[C#]
CommandBar Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As CommandBar
[Delphi]
property Parent: ICommandBar read Get_Parent;

CommandBarControl-Objekt, CommandBar-Objekt


Application (CommandBarControls-Objekt)

Application (CommandBarControls-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

CommandBarControls-Objekt, Application-Objekt


Parent (CommandBarControls-Objekt)

Parent (CommandBarControls-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das CommandBar-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ ICommandBar** ppCommandBar
);
[C#]
CommandBar Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As CommandBar
[Delphi]
property Parent: ICommandBar read Get_Parent;

CommandBarControls-Objekt, CommandBar-Objekt


Application (CommandBars-Objekt)

Application (CommandBars-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

CommandBars-Objekt, Application-Objekt


Parent (CommandBars-Objekt)

Parent (CommandBars-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

CommandBars-Objekt, Application-Objekt


CommandEvents-Objekt

CommandEvents-Objekt

Das CommandEvents-Objekt stellt Befehlsereignisse für Automatisierungsclients bereit.

Ereignisse

AfterExecute | Tritt nach der Ausführung eines Befehls ein.
BeforeExecute | Tritt vor der Ausführung eines Befehls ein.

Application-Objekt


FileContainerEvents-Objekt

FileContainerEvents-Objekt

Das FileContainerEvents-Objekt stellt Ereignisse für Änderungen an Dateiablagen bereit.

Ereignisse

WindowActivated | Tritt ein, wenn eine Dateiablage den Fokus erhält.
WindowClosing | Tritt unmittelbar vor dem Schließen einer Dateiablage ein.
WindowCreated | Tritt beim Erstellen einer neuen Dateiablage ein.

Application-Objekt


FolderWindowEvents-Objekt

FolderWindowEvents-Objekt

Das FolderWindowEvents-Objekt stellt Ereignisse für Änderungen an Ordnerfenstern bereit.

Ereignisse

WindowActivated | Tritt ein, wenn ein Ordnerfenster den Fokus erhält.
WindowClosing | Tritt unmittelbar vor dem Schließen eines Ordnerfensters ein.
WindowCreated | Tritt beim Erstellen eines neuen Ordnerfensters ein.

Application-Objekt


TabWindowEvents-Objekt

TabWindowEvents-Objekt

Das TabWindowEvents-Objekt stellt Ereignisse für Änderungen an der Zweifenster-Ansicht bereit.

Ereignisse

WindowActivated Tritt ein, wenn ein Fenster den Fokus erhält.

Application-Objekt


Application (FileContainer-Objekt)

Application (FileContainer-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FileContainer-Objekt, Application-Objekt


Parent (FileContainer-Objekt)

Parent (FileContainer-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das FileContainers-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IFileContainers** ppFileContainers
);
[C#]
FileContainers Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As FileContainers
[Delphi]
property Parent: IFileContainers read Get_Parent;

FileContainer-Objekt, FileContainers-Objekt


Application (FileContainers-Objekt)

Application (FileContainers-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FileContainers-Objekt, Application-Objekt


Parent (FileContainers-Objekt)

Parent (FileContainers-Objekt)

Gibt das Elternobjekt zurück, in diesem Falle das TabWindow-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As TabWindow
[Delphi]
property Parent: ITabWindow read Get_Parent;

FileContainers-Objekt, TabWindow-Objekt


Application (FolderFavorite-Objekt)

Application (FolderFavorite-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FolderFavorite-Objekt, Application-Objekt


Parent (FolderFavorite-Objekt)

Parent (FolderFavorite-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das FolderFavorites-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IFolderFavorites** ppFolderFavorites
);
[C#]
FolderFavorites Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As FolderFavorites
[Delphi]
property Parent: IFolderFavorites read Get_Parent;

FolderFavorite-Objekt, FolderFavorites-Objekt


Application (FolderFavorites-Objekt)

Application (FolderFavorites-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FolderFavorites-Objekt, Application-Objekt


Parent (FolderFavorites-Objekt)

Parent (FolderFavorites-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

FolderFavorites-Objekt, Application-Objekt


Application (AppFolder-Objekt)

Application (AppFolder-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AppFolder-Objekt, Application-Objekt


Parent (AppFolder-Objekt)

Parent (AppFolder-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das FolderWindow-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IFolderWindow** ppFolderWindow
);
[C#]
FolderWindow Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As FolderWindow
[Delphi]
property Parent: IFolderWindow read Get_Parent;

AppFolder-Objekt, FolderWindow-Objekt


Application (FolderWindow-Objekt)

Application (FolderWindow-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FolderWindow-Objekt, Application-Objekt


Parent (FolderWindow-Objekt)

Parent (FolderWindow-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das FolderWindows-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IFolderWindows** ppFolderWindows
);
[C#]
FolderWindows Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As FolderWindows
[Delphi]
property Parent: IFolderWindows read Get_Parent;

FolderWindow-Objekt, FolderWindows-Objekt


Application (FolderWindows-Objekt)

Application (FolderWindows-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FolderWindows-Objekt, Application-Objekt


Parent (FolderWindows-Objekt)

Parent (FolderWindows-Objekt)

Gibt das Elternobjekt zurück, in diesem Falle das TabWindow-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As TabWindow
[Delphi]
property Parent: ITabWindow read Get_Parent;

FolderWindows-Objekt, TabWindow-Objekt


Application (ListItem-Objekt)

Application (ListItem-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

ListItem-Objekt, Application-Objekt


Parent (ListItem-Objekt)

Parent (ListItem-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das ListItems-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IListItems** ppListItems
);
[C#]
ListItems Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As ListItems
[Delphi]
property Parent: IListItems read Get_Parent;

ListItem-Objekt, ListItems-Objekt


Application (ListItems-Objekt)

Application (ListItems-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

ListItems-Objekt, Application-Objekt


Parent (ListItems-Objekt)

Parent (ListItems-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IUnknown** ppParent
);
[C#]
object Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Object
[Delphi]
property Parent: IUnknown read Get_Parent;

ListItems-Objekt


Application (ListSelection-Objekt)

Application (ListSelection-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

ListSelection-Objekt, Application-Objekt


Parent (ListSelection-Objekt)

Parent (ListSelection-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IUnknown** ppParent
);
[C#]
object Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Object
[Delphi]
property Parent: IUnknown read Get_Parent;

ListSelection-Objekt


Application (MultiRename-Objekt)

Application (MultiRename-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

MultiRename-Objekt, Application-Objekt


Parent (MultiRename-Objekt)

Parent (MultiRename-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

MultiRename-Objekt, Application-Objekt


Application (TabWindow-Objekt)

Application (TabWindow-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

TabWindow-Objekt, Application-Objekt


Parent (TabWindow-Objekt)

Parent (TabWindow-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Window-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IWindow** ppWindow
);
[C#]
Window Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Window
[Delphi]
property Parent: IWindow read Get_Parent;

TabWindow-Objekt, Window-Objekt


Application (UserTool-Objekt)

Application (UserTool-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

UserTool-Objekt, Application-Objekt


Parent (UserTool-Objekt)

Parent (UserTool-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das UserTools-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IUserTools** ppUserTools
);
[C#]
UserTools Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As UserTools
[Delphi]
property Parent: IUserTools read Get_Parent;

UserTool-Objekt, UserTools-Objekt


Application (UserTools-Objekt)

Application (UserTools-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

UserTools-Objekt, Application-Objekt


Parent (UserTools-Objekt)

Parent (UserTools-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

UserTools-Objekt, Application-Objekt


Application (Workspace-Objekt)

Application (Workspace-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

Workspace-Objekt, Application-Objekt


Parent (Workspace-Objekt)

Parent (Workspace-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

Workspace-Objekt, Application-Objekt